Nowe posty

xx Fatal error: cannot connect to database! LMS (0)
Wczoraj o 21:53:02
xx Z wielu dystrybucji linuxa działają tylko dwie. Proszę o wsparcie (17)
2018-09-13, 22:00:57
xx Szukasz pracy? (1)
2018-09-11, 20:56:19
xx Dzielenie sieci, nadawanie masek (11)
2018-09-10, 23:07:05
xx konfiguracja dhcp server na ubuntu (1)
2018-09-07, 13:05:48
xx Jak zainstalować GIMPa? (16)
2018-09-05, 08:50:05
xx Odpowiednik Windowsowego Notepad++ (2)
2018-09-03, 08:05:23
xx JS w gulpie (0)
2018-09-01, 21:02:49
xx Błąd przy uruchamianiu make menuconfig (6)
2018-09-01, 18:14:55
xx [ Gra Za Darmo przez okreslony czas ] Warhammer 40,000: Space Marine (0)
2018-08-31, 17:28:45

Autor Wątek: Laptop się nie wyłącza  (Przeczytany 1011 razy)

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 1980
  • 1709
    • Zobacz profil
Odp: Laptop się nie wyłącza
« Odpowiedź #30 dnia: 2018-06-17, 22:36:01 »
Jak znalesc plik ?
locate systemd-halt.service
locate nalezy do pakietu mlocate , gdybys nie mial zainstalowane.
Jesli dopiero co zainstalowales to dobrze jest wykonac updatedb  z konta root by stworzylo baze danych z nazwami plikow.

lub ostatecznie ( ale nie polecam bo zbyt wolne )
find / -name "systemd-halt.service"
« Ostatnia zmiana: 2018-06-17, 22:38:31 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline pavbaranov

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 170
    • Zobacz profil
Odp: Laptop się nie wyłącza
« Odpowiedź #31 dnia: 2018-06-18, 14:07:21 »
@pixel70 - Tak, poszukując jeszcze rozwiązania, zauważyłem, że są następujące tropy:
1. Prezentowane tu głównie przez @1709 - kwestia ACPI. Coś mogłoby być na rzeczy ze względu na lekką poprawę związaną z jego wyłączeniem.
2. Kwestie związane z systemd (to się okaże), bo to on w Twoich systemach przekazuje komputerowi sygnał do wyłączenia. Niekiedy domyślne ustawienia są "zbyt delikatne" dla niektórych komputerów.
3. BIOS/UEFI - To wniosek płynący z innego systemu, a w zasadzie z udzielanych odpowiedzi i reakcji na forach Lenovo. Lekko wychodzi na to, że producent dał ciała i po prostu nie jest tam najlepszy firmware. Były dla niego jakiegś aktualizacje, ale ich dostępność, możliwość instalacji - jak widzę - spod Windows.
4. Zakładając, że to kwestia związana jednak z linuksem (choć te same objawy na Windows raczej to wykluczają, jednakże skoro tam naprawiono to software'owo, to być może i tutaj można), spróbowałbym sprawdzić:
- inny kernel (i wcale niekoniecznie nowszy niż ten, który masz); powinieneś znaleźć jakiś z linii 4.4, 4.9 bądź 4.14 (wszystkie to LTS) lub 4.16/17 (uwaga, 4.16 miał z niektórymi Lenovo problem) - raczej nie miałbym problemów z sięgnięciem po rozwiązania z Ubuntu w przypadku Minta (wszak tu jest niezmieniony kernel Ubuntu), a dla Sparky - z Debiana,
- inny/nowszy tzw. firmware (nie mam Minta i nie wiem, czy i gdzie jest dostępna dla niego stosowna paczka; pewnie jednak na jakimś PPA będzie),
- może również jakieś nowsze ACPI.

Generalnie masz dwie dystrybucje oddebianowe, z którymi masz problem. Sprawdź po prostu na jakiejś innej, nawet w trybie livecd. Z tych, które oferują nowszy software niż ten, który masz w Mint/Sparky choćby OpenSUSE Leap 15, Fedora 28, Manjaro 17.1.10 (ale raczej był brał któreś "główne" wydanie, a nie z community). I po prostu sprawdzić możliwość zamykania w sesji livecd. To samo sprawdź też na livecd obu dystrybucji (i w tej samej wersji), które masz zainstalowane. Przynajmniej dowiemy się, czy jest to kwestia instalacji, czy nie.