Nowe posty

xx Bezpieczne usunięcie ubuntu 18.10 (4)
2018-10-22, 16:51:49
xx GMail w KDE (20)
2018-10-21, 13:49:48
xx Zmiana Nazwy użytkownika (1)
2018-10-18, 23:39:05
xx Dostęp zewnętrzny do sprzętu. (4)
2018-10-18, 22:29:25
xx Modem komórkowy z GPS - komendy AT (5)
2018-10-17, 17:58:39
xx Jak pobierać dodatki do kde? (6)
2018-10-17, 14:06:19
xx [ROZWIĄZANY] LO Writer - jak rozsunąć tekst do lewa i prawa w jednym wierszu (4)
2018-10-17, 11:57:05
xx skrypty wykonywane w crontab-ie [SElinux] (2)
2018-10-17, 10:33:12
xx Jak zmienić domyślny emulator terminala ? (4)
2018-10-14, 20:51:52
xx Javascript pasjans (1)
2018-10-14, 13:10:22

Autor Wątek: [solved]brak liblz4.so.1  (Przeczytany 1307 razy)

Offline Tomasz Rozalski

  • Users
  • Użytkownik
  • **
  • Wiadomości: 71
    • Zobacz profil
[solved]brak liblz4.so.1
« dnia: 2017-11-15, 20:47:44 »
Coś stukło, coś hukło i system padł. Odpaliłem z pendriva i naprawiłem fsck dysk systemowy. Pytał czy usuwać, dodawać do pliku lost i czy zmieniać liczbę powiązań i poprawiać. Tak, tak, tak, tak. System wstał ale nie działa np. synaptic bo brakuje liblz4.so.1. W ogóle to słabo bo:
Cytuj
vangoche@VanTv:~$ sudo synaptic
synaptic: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory
vangoche@VanTv:~$ sudo apt-get install aptitude
apt-get: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory
vangoche@VanTv:~$
Da się to załatać czy reinstall? Kopii nie mam.
« Ostatnia zmiana: 2017-11-19, 06:54:23 wysłana przez Tomasz Rozalski »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2411
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: brak liblz4.so.1
« Odpowiedź #1 dnia: 2017-11-15, 22:56:48 »
Odpal jeszcze raz z pendrive'a, i skopiuj "na wydrę" to liblz4.so.1 .

Poprawność możesz sprawdzić robiąc chroot z pendrive'a do naprawianego systemu (wystarczy, że będziesz miał zamontowane /, /boot, /dev, /proc i /sys). Jak już poprawnie zainstalujesz aptitude'a, robisz z jego poziomu
aptitude reinstall '~i'
i powinien wszystko naprawić.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Tomasz Rozalski

  • Users
  • Użytkownik
  • **
  • Wiadomości: 71
    • Zobacz profil
Odp: [solved]brak liblz4.so.1
« Odpowiedź #2 dnia: 2017-11-19, 06:57:15 »
Po aptitude reinstall, które trwało jakieś ćwierć sekundy wywaliło komunikat, że nie może utworzyć list do pobrania czegoś tam. System jednak działa w pełni. Zamykamy.