Nowe posty

xx Ubuntu 17.04 spowolnienie (3)
Dzisiaj o 00:26:36
xx D (3)
Dzisiaj o 00:13:34
xx Po włączeniu instalacji linuxa nie ma obrazu. (2)
Dzisiaj o 00:09:37
xx Jaki tani laptop do linuxa ? (5)
Wczoraj o 23:35:14
xx Czy nakladka na system nie skopie mi juz zainstalowanego systemu (3)
Wczoraj o 22:53:46
xx Linux hardware error (3)
Wczoraj o 18:00:25
xx Jakim poleceniem zainstalować Pythona 3? (2)
Wczoraj o 00:12:54
xx Przesiadka z Minta 18.3 na Debiana (22)
2018-01-21, 20:11:17
xx SAMBA i oplocks - bardzo wolne działanie (0)
2018-01-21, 18:35:06
xx preloadowane biblioteki do obsługi kamery w skype (1)
2018-01-21, 13:49:36

Autor Wątek: [solved]brak liblz4.so.1  (Przeczytany 901 razy)

Offline Tomasz Rozalski

  • Users
  • Użytkownik
  • **
  • Wiadomości: 56
    • Zobacz profil
[solved]brak liblz4.so.1
« dnia: 2017-11-15, 20:47:44 »
Coś stukło, coś hukło i system padł. Odpaliłem z pendriva i naprawiłem fsck dysk systemowy. Pytał czy usuwać, dodawać do pliku lost i czy zmieniać liczbę powiązań i poprawiać. Tak, tak, tak, tak. System wstał ale nie działa np. synaptic bo brakuje liblz4.so.1. W ogóle to słabo bo:
Cytuj
vangoche@VanTv:~$ sudo synaptic
synaptic: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory
vangoche@VanTv:~$ sudo apt-get install aptitude
apt-get: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory
vangoche@VanTv:~$
Da się to załatać czy reinstall? Kopii nie mam.
« Ostatnia zmiana: 2017-11-19, 06:54:23 wysłana przez Tomasz Rozalski »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2311
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: brak liblz4.so.1
« Odpowiedź #1 dnia: 2017-11-15, 22:56:48 »
Odpal jeszcze raz z pendrive'a, i skopiuj "na wydrę" to liblz4.so.1 .

Poprawność możesz sprawdzić robiąc chroot z pendrive'a do naprawianego systemu (wystarczy, że będziesz miał zamontowane /, /boot, /dev, /proc i /sys). Jak już poprawnie zainstalujesz aptitude'a, robisz z jego poziomu
aptitude reinstall '~i'
i powinien wszystko naprawić.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy
Jeżeli uważasz, że warto: 1AfKbLX6nZSqv5DNhXMNLivc9fXwaHMd4Z

Offline Tomasz Rozalski

  • Users
  • Użytkownik
  • **
  • Wiadomości: 56
    • Zobacz profil
Odp: [solved]brak liblz4.so.1
« Odpowiedź #2 dnia: 2017-11-19, 06:57:15 »
Po aptitude reinstall, które trwało jakieś ćwierć sekundy wywaliło komunikat, że nie może utworzyć list do pobrania czegoś tam. System jednak działa w pełni. Zamykamy.