Nowe posty

xx Brak kursora myszy (1)
Wczoraj o 18:03:17
xx Routing pomiedzy dwoma interfejsami (1)
Wczoraj o 16:22:33
clip Jaki Linux do przywracania partycji systemowej w Android ? (13)
Wczoraj o 15:59:56
xx VmUbuntu - Sieć ta sama, ale nie widzi innych hostow. (5)
Wczoraj o 00:19:09
xx dbeaver ubuntu 18.04 (4)
2019-01-17, 22:30:48
xx Program do nauki słówek z angielskiego (8)
2019-01-17, 18:22:54
xx skrypt osoba .sh (1)
2019-01-17, 17:47:53
xx dns, nslookup (4)
2019-01-17, 15:56:25
xx Nie widać drukarki podłączonej do routera (8)
2019-01-13, 19:51:20
xx Aplikacja Rufus - Najnowsza wersja - ISO x64 z Hiren's Boot. (14)
2019-01-09, 22:22:48

Autor Wątek: [solved]brak liblz4.so.1  (Przeczytany 1381 razy)

Offline Tomasz Rozalski

  • Users
  • Użytkownik
  • **
  • Wiadomości: 98
    • Zobacz profil
[solved]brak liblz4.so.1
« dnia: 2017-11-15, 20:47:44 »
Coś stukło, coś hukło i system padł. Odpaliłem z pendriva i naprawiłem fsck dysk systemowy. Pytał czy usuwać, dodawać do pliku lost i czy zmieniać liczbę powiązań i poprawiać. Tak, tak, tak, tak. System wstał ale nie działa np. synaptic bo brakuje liblz4.so.1. W ogóle to słabo bo:
Cytuj
vangoche@VanTv:~$ sudo synaptic
synaptic: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory
vangoche@VanTv:~$ sudo apt-get install aptitude
apt-get: error while loading shared libraries: liblz4.so.1: cannot open shared object file: No such file or directory
vangoche@VanTv:~$
Da się to załatać czy reinstall? Kopii nie mam.
« Ostatnia zmiana: 2017-11-19, 06:54:23 wysłana przez Tomasz Rozalski »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2450
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: brak liblz4.so.1
« Odpowiedź #1 dnia: 2017-11-15, 22:56:48 »
Odpal jeszcze raz z pendrive'a, i skopiuj "na wydrę" to liblz4.so.1 .

Poprawność możesz sprawdzić robiąc chroot z pendrive'a do naprawianego systemu (wystarczy, że będziesz miał zamontowane /, /boot, /dev, /proc i /sys). Jak już poprawnie zainstalujesz aptitude'a, robisz z jego poziomu
aptitude reinstall '~i'
i powinien wszystko naprawić.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Tomasz Rozalski

  • Users
  • Użytkownik
  • **
  • Wiadomości: 98
    • Zobacz profil
Odp: [solved]brak liblz4.so.1
« Odpowiedź #2 dnia: 2017-11-19, 06:57:15 »
Po aptitude reinstall, które trwało jakieś ćwierć sekundy wywaliło komunikat, że nie może utworzyć list do pobrania czegoś tam. System jednak działa w pełni. Zamykamy.