Nowe posty

xx Debian https w apt (1)
Dzisiaj o 19:26:33
xx Kopiowanie uprawnień do struktury folderów i plików (1)
Dzisiaj o 18:24:50
xx Jak usunąć kilka dowiązań twardych jednym poleceniem. (3)
2019-06-14, 12:12:10
xx Skrypt sprawdzający miejsce na dysku (1)
2019-06-13, 13:55:00
xx Samba server (3)
2019-06-10, 17:01:44
xx Skrypt tworzący użytkownika (3)
2019-06-07, 17:11:55
xx Jaki serwis komp. we Wrocławiu (0)
2019-06-06, 12:39:23
xx serwer wydruku (1)
2019-06-04, 13:57:58
xx mod_security i roundcube (0)
2019-05-27, 14:27:03
xx Touchpad po pewnym losowym czasie przestaje reagować (33)
2019-05-27, 10:14:21

Autor Wątek: Konfiguracja dźwięku Kubuntu HDA NVidia  (Przeczytany 3363 razy)

Offline Kamil

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 5
    • Zobacz profil
Konfiguracja dźwięku Kubuntu HDA NVidia
« dnia: 2017-11-07, 13:16:40 »
Witam.
Ostatnio instalując sobie ZynAddSubFX, musiałem sobie zainstalować JACK.
ZynAddSubFX ma dwie wersja dla Alsa która nie działała od początku i wersja dla Jack, która (bez tego elementu wyrzucała błąd) wymagała doinstalowania owego menadżera dźwięku.

Zatem przystąpiłem do działania:
sudo apt-get install jack-tools fftw3 qjackctl
sudo jack -r -d alsa -r 44100 -P
sudo apt-get install pulseaudio-module-jack
sudo vim /etc/pulse/default.pa
z dodaniem linijek:
load-module module-jack-sink
load-module module-jack-source

I teraz moje pytanie jest takie, bo mam kłopot z dźwiękiem z innych aplikacji, plus słaba konfiguracja mikrofonu i dodatkowo domyślny menadżer dźwięku w zasobniku nie wyświetla mi żadnych suwaków i kontrolek. Jak przywrócić wszystko do stanu fabrycznego bez reinstalacji systemu (zawsze jak coś zwaliłem, kończyło się to na reinstalacji Linuxa). Jaki w Kubuntu 16.04 - 17.10 (17.04) jest domyślny menadżer dźwięku żeby najwyżej jego przeinstalować i skonfigurować na nowo.
(Że też w Linuksie nie ma czegoś takiego jak punkty przywracania systemu jakie ma Windows)

Po usunięciu wszystkiego mam pustkę:
sudo apt-get autoremove jack-tools qjackctl pulseaudio-module-jack
Nie mam ani kontrolek dźwięku w pasku powiadomień od jack audio ani od poprzedniego domyślnego menadżera dźwięku i tym samym dźwięku brak.
« Ostatnia zmiana: 2017-11-07, 13:52:43 wysłana przez Kamil »

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2156
  • 1709
    • Zobacz profil
Odp: Konfiguracja dźwięku Kubuntu HDA NVidia
« Odpowiedź #1 dnia: 2017-11-07, 13:55:21 »
Cytuj
ZynAddSubFX ma dwie wersja dla Alsa która nie działała od początku
Nie znam tego, ale może nie odistalowałeś pulse audio ?

Cytuj
wersja dla Jack, która (bez tego elementu wyrzucała błąd) wymagała doinstalowania owego menadżera dźwięku.
No raczej i zgaduję że jeszcze skonfigurowania, jest on polecany dla "profesjonalistów",
to nie jest on prosty w użytkowaniu i trochę problematyczny.
- https://pclinuxoshelp.com/index.php/Jack_audio
- https://translate.google.pl/?hl=pl
( proponuje sie zapoznac z dokumentacja w celu uzywania tego  http://www.jackaudio.org/   )

Cytuj
Jak przywrócić wszystko do stanu fabrycznego bez reinstalacji systemu
A mogę tak po chłopsku na swój sposób ?
- Otwiersz sobie w virtualboxie live-cd ( albo korzystasz z historii instalowanych pakietow przez Synaptic na swoim systemie  )
i otwierasz menadzer pakietów Synaptic lub
patrzysz z terminala jakie pakiety pulse są zainstalowane 
https://help.ubuntu.com/lts/serverguide/dpkg.html

Przykład z Debiana
$ dpkg -l | grep pulse
ii  gstreamer1.0-pulseaudio:amd64         1.10.4-1                                    amd64        GStreamer plugin for PulseAudio
ii  libcanberra-pulse:amd64               0.30-3                                      amd64        PulseAudio backend for libcanberra
ii  libpulse-mainloop-glib0:amd64         10.0-1+deb9u1                               amd64        PulseAudio client libraries (glib support)
ii  libpulse0:amd64                       10.0-1+deb9u1                               amd64        PulseAudio client libraries
ii  libpulse0:i386                        10.0-1+deb9u1                               i386         PulseAudio client libraries
ii  libpulsedsp:amd64                     10.0-1+deb9u1                               amd64        PulseAudio OSS pre-load library
rc  mate-media-pulse                      1.8.0+dfsg1-3                               amd64        MATE media utilities (PulseAudio backend)
rc  mate-settings-daemon-pulse            1.8.2-4                                     amd64        MATE session settings daemon (PulseAudio version)
ii  pulseaudio                            10.0-1+deb9u1                               amd64        PulseAudio sound server
ii  pulseaudio-utils                      10.0-1+deb9u1                               amd64        Command line tools for the PulseAudio sound server
ii  xfce4-pulseaudio-plugin:amd64         0.2.4-1                                     amd64        Xfce4 panel plugin to control pulseaudio

Na swoim systemie usuwasz, wszystkie inne które doinstalowałeś.
( Jeśli używasz Synaptic to tez jest tam historia, która pokaze jakie i kiedy pakiety instalowałeś. )
A potem reinstalujesz z pulse audio i doinstalowujesz te z pulse które usunąłeś.
Restartujesz komputer i sie cieszysz dzwiekiem.
Jesli nie pomogło, zakładasz nowe konto użytkownika.
Jesli wszystko działa jak powinno na nowym koncie uzytkownika, to spróbuj usunąć stare pliki konfiguracyjne na starym końcie z $HOME/
 ( po restarcie system stworzy nowe pliki i dzwiek powinien działać )
Wyszukasz je np. w ten sposób
 locate pulse | grep home | grep -v Pulpit | grep -v Pobrane | grep -v Steam
« Ostatnia zmiana: 2017-11-07, 14:02:11 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122