Nowe posty

xx Debian 9 Stretch, linuxcnc i restart przy uruchamianiu (1)
Dzisiaj o 11:09:50
xx Zakup sprzętu bez preinstalowanego windowsa (8)
Wczoraj o 16:50:51
xx Problem z pocztą Dovecot+Postfix+MySQL (3)
2019-10-16, 14:43:41
xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
2019-10-15, 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36
xx Problem z instalacją sterowników TL-WN821N (4)
2019-10-11, 23:15:00
xx Sprzet z Linuxem (1)
2019-10-11, 10:06:24
xx nadpisanie partycji domowej (6)
2019-10-03, 03:27:28
xx Screen flickering Deepin (4)
2019-10-02, 20:32:56

Autor Wątek: Debian Buster 64 bit i instalacja pakietów 32 bit.  (Przeczytany 1556 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 226
    • Zobacz profil
Debian Buster 64 bit i instalacja pakietów 32 bit.
« dnia: 2017-10-29, 12:30:56 »
Witam!
Dopiero od kilku dni używam systemu 64bitowego ponieważ wcześniej korzystałem tylko z 32bitowego.
Chciałem zainstalować klika bibliotek 32bitowych niestety w synapticu pokazuje się komunikat:
E: /tmp/apt-dpkg-install-dh5b8I/02-zlib1g_1%3a1.2.8.dfsg-5_i386.deb: próba nadpisania dzielonego "/usr/share/doc/zlib1g/changelog.Debian.gz", który różni się od innych kopii pakietu zlib1g:i386
Nie wiem w czym problem ponieważ po raz pierwszy widzę taki problem.
W terminalu:
Wybieranie wcześniej niewybranego pakietu libblkid1:i386.
(Odczytywanie bazy danych ... 135127 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../00-libblkid1_2.30.2-0.1_i386.deb ...
Rozpakowywanie pakietu libblkid1:i386 (2.30.2-0.1) ...
Wybieranie wcześniej niewybranego pakietu libmount1:i386.
Przygotowywanie do rozpakowania pakietu .../01-libmount1_2.30.2-0.1_i386.deb ...
Rozpakowywanie pakietu libmount1:i386 (2.30.2-0.1) ...
Wybieranie wcześniej niewybranego pakietu zlib1g:i386.
Przygotowywanie do rozpakowania pakietu .../02-zlib1g_1%3a1.2.8.dfsg-5_i386.deb ...
Rozpakowywanie pakietu zlib1g:i386 (1:1.2.8.dfsg-5) ...
dpkg: błąd przetwarzania archiwum /tmp/apt-dpkg-install-dh5b8I/02-zlib1g_1%3a1.2.8.dfsg-5_i386.deb (--unpack):
 próba nadpisania dzielonego "/usr/share/doc/zlib1g/changelog.Debian.gz", który różni się od innych kopii pakietu zlib1g:i386
Wybieranie wcześniej niewybranego pakietu libxt6:i386.
Przygotowywanie do rozpakowania pakietu .../03-libxt6_1%3a1.1.5-1_i386.deb ...
Rozpakowywanie pakietu libxt6:i386 (1:1.1.5-1) ...
Wybieranie wcześniej niewybranego pakietu libaudio2:i386.
Przygotowywanie do rozpakowania pakietu .../04-libaudio2_1.9.4-6_i386.deb ...
Rozpakowywanie pakietu libaudio2:i386 (1.9.4-6) ...
Wybieranie wcześniej niewybranego pakietu libegl-mesa0:i386.
Przygotowywanie do rozpakowania pakietu .../05-libegl-mesa0_17.2.3-1_i386.deb ...
Rozpakowywanie pakietu libegl-mesa0:i386 (17.2.3-1) ...
Wybieranie wcześniej niewybranego pakietu libpng16-16:i386.
Przygotowywanie do rozpakowania pakietu .../06-libpng16-16_1.6.34-1_i386.deb ...
Rozpakowywanie pakietu libpng16-16:i386 (1.6.34-1) ...
Wybieranie wcześniej niewybranego pakietu libfreetype6:i386.
Przygotowywanie do rozpakowania pakietu .../07-libfreetype6_2.8.1-0.1_i386.deb ...
Rozpakowywanie pakietu libfreetype6:i386 (2.8.1-0.1) ...
Wybieranie wcześniej niewybranego pakietu libglib2.0-0:i386.
Przygotowywanie do rozpakowania pakietu .../08-libglib2.0-0_2.54.1-1_i386.deb ...
Rozpakowywanie pakietu libglib2.0-0:i386 (2.54.1-1) ...
Wybieranie wcześniej niewybranego pakietu libegl1:i386.
Przygotowywanie do rozpakowania pakietu .../09-libegl1_0.2.999+git20170802-5_i386.deb ...
Rozpakowywanie pakietu libegl1:i386 (0.2.999+git20170802-5) ...
Wybieranie wcześniej niewybranego pakietu libwayland-egl1-mesa:i386.
Przygotowywanie do rozpakowania pakietu .../10-libwayland-egl1-mesa_17.2.3-1_i386.deb ...
Rozpakowywanie pakietu libwayland-egl1-mesa:i386 (17.2.3-1) ...
Wybieranie wcześniej niewybranego pakietu libsdl2-2.0-0:i386.
Przygotowywanie do rozpakowania pakietu .../11-libsdl2-2.0-0_2.0.6+dfsg1-4_i386.deb ...
Rozpakowywanie pakietu libsdl2-2.0-0:i386 (2.0.6+dfsg1-4) ...
Wystąpiły błędy podczas przetwarzania:
 /tmp/apt-dpkg-install-dh5b8I/02-zlib1g_1%3a1.2.8.dfsg-5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Nie udało się zainstalować pakietu. Próba powrócenia do poprzedniego stanu:
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libpng16-16:i386:
 libpng16-16:i386 zależy od zlib1g (>= 1:1.2.3.4); jednakże:
  Pakiet zlib1g:i386 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu libpng16-16:i386 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu libglib2.0-0:amd64 (2.54.1-1)...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libglib2.0-0:i386:
 libglib2.0-0:i386 zależy od zlib1g (>= 1:1.2.2); jednakże:
  Pakiet zlib1g:i386 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu libglib2.0-0:i386 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu libblkid1:i386 (2.30.2-0.1) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libfreetype6:i386:
 libfreetype6:i386 zależy od libpng16-16 (>= 1.6.2-1); jednakże:
  Pakiet libpng16-16:i386 nie jest jeszcze skonfigurowany.
 libfreetype6:i386 zależy od zlib1g (>= 1:1.1.4); jednakże:
  Pakiet zlib1g:i386 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu libfreetype6:i386 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu libc-bin (2.24-17)...
Konfigurowanie pakietu libxt6:i386 (1:1.1.5-1) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libegl-mesa0:i386:
 libegl-mesa0:i386 zależy od zlib1g (>= 1:1.1.4); jednakże:
  Pakiet zlib1g:i386 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu libegl-mesa0:i386 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu libmount1:i386 (2.30.2-0.1) ...
Konfigurowanie pakietu libaudio2:i386 (1.9.4-6) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libegl1:i386:
 libegl1:i386 zależy od libegl-mesa0 | libegl-vendor; jednakże:
  Pakiet libegl-mesa0:i386 nie jest jeszcze skonfigurowany.
  Pakiet libegl-mesa0:i386 dostarcza libegl-vendor, ale nie został jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libegl1:i386 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libwayland-egl1-mesa:i386:
 libwayland-egl1-mesa:i386 zależy od libegl1; jednakże:
  Pakiet libegl1:i386 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libwayland-egl1-mesa:i386 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libsdl2-2.0-0:i386:
 libsdl2-2.0-0:i386 zależy od libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1; jednakże:
  Pakiet libwayland-egl1-mesa:i386 nie jest jeszcze skonfigurowany.
  Pakiet libwayland-egl1-mesa:i386 dostarcza libwayland-egl1, ale nie został jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libsdl2-2.0-0:i386 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu libc-bin (2.24-17)...
Wystąpiły błędy podczas przetwarzania:
 libpng16-16:i386
 libglib2.0-0:i386
 libfreetype6:i386
 libegl-mesa0:i386
 libegl1:i386
 libwayland-egl1-mesa:i386
 libsdl2-2.0-0:i386
W czym konkretnie jest problem i jak temu zaradzić?
Z tego co czytałem na forach to pakiety 32 bitowe powinny instalować na systemie 64 bitowym.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2211
  • 1709
    • Zobacz profil
Odp: Debian Buster 64 bit i instalacja pakietów 32 bit.
« Odpowiedź #1 dnia: 2017-10-29, 15:30:58 »
Tu masz przykład:
https://wiki.debian.org/Steam#A64-bit_systems_.28amd64.29

Cytuj
Enable Multi-Arch and update the list of available packages:
# dpkg --add-architecture i386
# aptitude update

...

# aptitude install libgl1-nvidia-glx:i386
Gdzie końcówka :i386 oznacz aże chodzi o pakiet 32bit

Jeśli używasz Steam i Ci działa, to napisz jakiego sterownika używasz i jakie 32bit biblioteki masz zainstalowane, (pakiety )
bo coś odinstalowałem kiedyś i od tamtej pory grać nie mogę.
« Ostatnia zmiana: 2017-10-29, 15:32:36 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 226
    • Zobacz profil
Odp: Debian Buster 64 bit i instalacja pakietów 32 bit.
« Odpowiedź #2 dnia: 2017-10-30, 12:47:06 »
Dodałem architekturę:
# dpkg --add-architecture i386
Nie używam aptitude, który domyślnie nie jest zainstalowany lecz apt.
Co ciekawe apt nie chce mi instalować pakietów *:386, tylko sugeruje mi instalację pakietów 64bitowych, dlatego muszę posługiwać się synaptic.
Akurat mój komputer to nie AMD lecz Intel Celeron, więc sterowniki grafiki są raczej już zainstalowane bo Debian zawsze instaluje mi stery dla Intela.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2211
  • 1709
    • Zobacz profil
Odp: Debian Buster 64 bit i instalacja pakietów 32 bit.
« Odpowiedź #3 dnia: 2017-10-30, 13:24:36 »
Cytuj
Nie używam aptitude, który domyślnie nie jest zainstalowany lecz apt.
Ja też nie, to był tylko przykład i działa
np.
# apt-get install zlibc:i386
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
  apg brasero-common cdrdao dleyna-renderer dleyna-server dvdauthor freeglut3
  genisoimage gir1.2-gdata-0.0 gir1.2-gepub-0.4 gir1.2-mediaart-2.0
  gir1.2-tracker-1.0 gir1.2-zpj-0.0 gnome-control-center-data
  gnome-online-accounts growisofs libburn4 libcg libcoverart1 libcoverartcc1v5
  libcublas8.0 libcudart8.0 libcue1 libcufft8.0 libcufftw8.0 libcuinj64-8.0
  libcurand8.0 libcusolver8.0 libcusparse8.0 libdiscid0
  libdleyna-connector-dbus-1.0-1 libdleyna-core-1.0-3 libdmapsharing-3.0-2
  libdumb1 libgadu3 libgepub0 libgexiv2-2 libgoa-backend-1.0-1 libgom-1.0-0
  libgom-1.0-common libgpod-common libgpod4 libgsf-bin libhiredis0.13
  libhtp-0.5.23-1 libhyperscan4 libisofs6 libjte1 liblua5.3-0 libluajit-5.1-2
  libluajit-5.1-common libmeanwhile1 libmikmod3 libnetfilter-log1 libnppc8.0
  libnppi8.0 libnppial8.0 libnppicc8.0 libnppicom8.0 libnppidei8.0 libnppif8.0
  libnppig8.0 libnppim8.0 libnppist8.0 libnppisu8.0 libnppitc8.0 libnpps8.0
  libnss-myhostname libnvblas8.0 libnvcuvid1 libnvgraph8.0 libnvrtc8.0
  libnvtoolsext1 libnvvm3 libportmidi0 libprelude2 libprotobuf-c1
  libquvi-0.9-0.9.3 libquvi-scripts-0.9 libsdl-mixer1.2 libsdl-net1.2
  libsgutils2-2 libthrust-dev libtracker-miner-1.0-0 libvdpau-dev libvulkan1
  libzapojit-0.0-0 libzephyr4 linux-image-3.16.0-4-amd64 lua-bitop lua-expat
  lua-json lua-lpeg lua-socket mousetweaks opencl-c-headers
  opencl-clhpp-headers opencl-headers prboom-plus python3-mako
  python3-markupsafe realmd rhythmbox-data unoconv wodim
Aby je usunąć należy użyć "apt autoremove".
Następujące pakiety zostaną USUNIĘTE:
  zlibc
Zostaną zainstalowane następujące NOWE pakiety:
  zlibc:i386
0 aktualizowanych, 1 nowo instalowanych, 1 usuwanych i 2 nieaktualizowanych.
Konieczne pobranie 67,2 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
Kontynuować? [T/n]

Cytuj
Co ciekawe apt nie chce mi instalować pakietów *:386, tylko sugeruje mi instalację pakietów 64bitowych, dlatego muszę posługiwać się synaptic.
Mój synaptic nie widzi pakietów 32bit, prócz tych zainstalowanych.

Cytuj
Akurat mój komputer to nie AMD lecz Intel Celeron, więc sterowniki grafiki są raczej już zainstalowane bo Debian zawsze instaluje mi stery dla Intela.
Trudno, dzięki.

PS:
Fragment co u Ciebie pisze
Cytuj
problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libpng16-16:i386:
 libpng16-16:i386 zależy od zlib1g (>= 1:1.2.3.4); jednakże:
  Pakiet zlib1g:i386 nie jest zainstalowany.
Twierdzi że masz jakieś pakiety uszkodzone w systemie, napraw je pierw.
Radze to zrobić ostrożnie z Synaptic, ale tak żeby Ci pół systemu nie odinstalowało

Poradnik bardzo stary, ale mniej więcej pokazuje gdzie szukać uszkodzonych pakietów
http://qla.internetdsl.pl/000/Synaptic/korekta/korekta.html

Edytowane:
Co do uszkodzonych pakietów nie jestem pewien, ale sprawdzić zawsze możesz
Ja wkazdym razie te pakiety mam zainstalowane z jakiegoś działu main
# dpkg -l  | grep zlib1g:i386
ii  zlib1g:i386                           1:1.2.8.dfsg-5                              i386         compression library - runtime
# dpkg -l  | grep libpng16-16:i386
ii  libpng16-16:i386                      1.6.28-1                                    i386         PNG library - runtime (version 1.6)

Edytowane:
Dodawałeś jakieś nowe repozytoria do systemu ? Zastanawiam się czy to moze być przyczyna problemu z zaleznosciami pakietów.
Próbowałeś aktualizować system ?
« Ostatnia zmiana: 2017-10-30, 14:04:26 wysłana przez 1709 »
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 226
    • Zobacz profil
Odp: Debian Buster 64 bit i instalacja pakietów 32 bit.
« Odpowiedź #4 dnia: 2017-10-30, 15:28:39 »
Dzięki.
Dostosowałem się do Twoich porad i teraz wszystko jest w porządku.