Nowe posty

Autor Wątek: /dev - brak uprawnien  (Przeczytany 4565 razy)

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 337
    • Zobacz profil
/dev - brak uprawnien
« dnia: 2005-05-17, 00:28:32 »
Witam

Piszę tutaj do tych którzy próbowali coś napisać w Anjuta pod Ubuntu. Jak się Wam udało rozwiązać problem kompilacji?

Normalnie nie sposób znaleść rozwiązania w sieci na ten problem. Wszystkie pakiety mam do kompilowania i wsystkie potrzebne biblioteki, a okazuje się, że jakaś tam biblioteja nie zna jakiejść tam funkcji. Wszystko obraca się wokół bibliotek dla gtk i gtk2.

Fakt. Kompiluje ale tylko C. Lub proste hello world C++. Jak dodam nowe biblioteki do korzystania z glide, czy nowe kontrolki, to sie zaczynają sypać pliki nagłówkowe.

Jak to rozwiązaliście?

Pozdrawiam

Offline tomek ----

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
/dev - brak uprawnien
« Odpowiedź #1 dnia: 2005-06-28, 20:55:27 »
Ja też miałem z Anjutą wiele kłopotów (najwiecej z gettextem, wystarczyło doinstalować CVS?!). odpuściłem sobie konfiguratory Anjuty i korzystam tylko z fuckcji importowania projektów, a wszystko (configure, makefile) pisze sobie sam, przyznam troche to trwalo zanim sie nauczylem, ale bylo warto! ;-)

Offline Krzysztof Tulidowicz

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 446
    • Zobacz profil
/dev - brak uprawnien
« Odpowiedź #2 dnia: 2005-05-16, 23:36:02 »
Witam. Ostatnio mnie system przywitał tak, że sie nie chcial uruchomic.(tzn. nie sam system, tylko managery, kde, gnome... -fluxbox dzialal :-) ) Po kilkunastu minutach doszedlem, ze kilka urzadzen ( /dev/null, /dev/dsp ... ) ma ustawione uprawnienia na 770 , wiec zwykli uzytkownicy nie maja do nich dostepu (na koncie roota wszystko dziala).

Nie wiem dlaczego tak sie stało, nic nie grzebałem, podejrzewam, ze stalo sie to po emerge -uD world , choc nie jestem pewien bo komp pracowal tydzien bez przerwy.

Nie potrafie zlokalizowac wszystkich urzadzen ktore sie tak zachowują, więc jako tymczasowy srodek zaradczy robi chmod -R 777 /dev. Nie jest to ani dobre ani bezpieczne, ale nic innego mi do glowy nie przychodzi. Po kazdym restarcie musze wpisywac to od nowa.

(google i forum przeszukane, choc nie wiedzialem dobrze jak sformulowac pytanie...)

moje distro to Gentoo

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
/dev - brak uprawnien
« Odpowiedź #3 dnia: 2005-05-17, 07:26:04 »
konfiguracja udev'a (to on zarzadza urzadzeniami w /dev) jest w /etc/udev/ zdajsie :-) o ile dobrze pamietam...

Offline Krzysztof Tulidowicz

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 446
    • Zobacz profil
/dev - brak uprawnien
« Odpowiedź #4 dnia: 2005-05-17, 11:05:29 »
2005-05-17 07:26:04 chmooreck napisał:

> konfiguracja udev'a (to on zarzadza urzadzeniami w /dev) jest w /etc/udev/ zdajsie :-) o ile
 > dobrze pamietam...
dzieki wielkie, to mnie naprowadzilo na dobry trop :-)

rozwiazanie:
po update zainstalowal sie nowy udev, a konfiguracja caly czas byla stara, bo gentoo ma taka polityke ochrony configów :-) trzeba bylo przerzucic nowe pliki konfiguracyjne w miejsce starych i zaczelo grac :-)