Nowe posty

Autor Wątek: Caffeine Debian 9 Stretch  (Przeczytany 1238 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 226
    • Zobacz profil
Caffeine Debian 9 Stretch
« dnia: 2017-06-25, 10:36:59 »
Podczas uruchamiana caffeine:
$ caffeine
/usr/bin/caffeine:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, Gtk, GLib
Co można z tym zrobić?

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 1918
  • 1709
    • Zobacz profil
Odp: Caffeine Debian 9 Stretch
« Odpowiedź #1 dnia: 2017-06-25, 14:45:20 »
Na początek sprawdz czy
1. masz nowe aktualizacje w systemie które mogłyby naprawić problem
2. czy problem występuje na nowym końcie użytkownika, jeśli tak to zgłoś problem.

Przy zgłaszaniu błędu weź pod uwagę także repozytoria.
Zauważyłem że np. mieszanie repozytorium stable i backports potrafi psuć niektóre aplikacje poprzez różnice w łatkach lub w wersji  programu.
Kolega mi podpowiedział że istnieje coś takiego https://debgen.simplylinux.ch/
Jeśli dobrze zrozumiałem, różnica w linkach jest taka że Debian 8.0 sam się nie zaktualizuje do Debian 9.0 ( " jessie " ---" stretch " ),
natomiast " stable " zawsze będzie dostawać aktualizacje do nowych wersji Debiana.  ( " stable "  --> " stable "  )

Jeśli caffeine jest z repozytorium Debiana,
to zgłosić problem paczkującemu ( opiekunowi paczki )
porzez
A.) reportbug program
B.)  " Debian user mailing list "    debian-user@lists.debian.org
poczytaj na spokojnie   https://www.debian.org/Bugs/Reporting

Tu maszcze inne  wskazówki
- https://raphaelhertzog.com/2011/07/11/7-tips-to-file-useful-debian-bug-reports-and-get-your-problem-solved/
- https://itsfoss.com/bug-report-debian/


W ostateczności
1. 
apt-cache show nazwa_paczki 
i wyciagasz maila piszesz facetowi lub babie lub kimkolwiek jest.

Przykład
Cytuj
$ apt-cache show caffeine
Package: caffeine
Version: 2.8.3-3
Installed-Size: 314
Maintainer: Andrew Shadura  XXXX@XXXX.xxx
Architecture: all
Depends: python3.5:any, python3:any (>= 3.3.2-2~), perl, gir1.2-gtk-3.0, gir1.2-appindicator3-0.1, python3-xlib, python3-pkg-resources, python3-gi, libnet-dbus-perl
Description-en: prevent the desktop becoming idle in full-screen mode
 Caffeine prevents the desktop from becoming idle when an application
 is running full-screen. A desktop indicator ‘caffeine-indicator’
 supplies a manual toggle, and the command ‘caffeinate’ can be used
 to prevent idleness for the duration of any command.
Description-md5: 4c9c48fcec88e1f3a34205595604515d
Homepage: https://launchpad.net/caffeine
Section: misc
Priority: optional
Filename: pool/main/c/caffeine/caffeine_2.8.3-3_all.deb
Size: 57380
MD5sum: d605f9c8349417ebbdf3b0da7a7cf974
SHA256: a6400c66be8f1a394873a6e151a14f9d5306b05345dc3baa0c4f10368e39a3f6

Jeśli Ci wywali błąd przy wysłaniu email to może oznaczać że email jest zabezpieczony lub wymyślony i nie istnieje, lub nie aktualny i nie wyślesz.
Edytowane:   własciwy email został zakrylem znakami XXXX@XXXX.xxx aby spam bot tam nie buszował, emal trzeba sobie samemu z paczki wyszukac wskazanym wyzej przykladem.
W przypadku listy mailingowej tego nie zrobilem, bo i tak jest dostepny na stronie www.

2. Forum gdzie większość będzie miała w nosie że jakieś błędy istnieją.  ( Może sie mylę )
- http://forums.debian.net/
- http://www.debianuserforums.org/



I jeśli moge się wypowiedzieć to Debian ma jeden z gorszych systemów raportowania błędów jaki widziałem.   >:(
1. Moze to tylko błąd po aktalizacji stable, ale po cofnięciu wstecz w "report bug" wszystko się wyszarza i nic nie moge zrobić, to to można pominąć.
2. W "report bug" nie mozna zglosic błędu, jesli jestem nowy i nie wiem jak zlokalizować przyczyne, nazwe paczki.
3. I jeśli musze to konfigurować bo " SMTP send failure: (550, b'No valid sender found in the From:, Sender: and Reply-to: headers')
4. " mailing list  " działa, ale jeśli to prawda że tam publicznie widać email to jest to dodatkowa informacja o tobie dla hakerów, podszywaczy i złodziei ( pomijając shakowane fora i inne treści )



A  Jesli problem dotyczy programu z poza repozytorium Debiana,
 to zgłoś problem developerowi ktory ją stworzył.


Edytowane.

Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 226
    • Zobacz profil
Odp: Caffeine Debian 9 Stretch
« Odpowiedź #2 dnia: 2017-06-26, 14:49:25 »
Już widziałem podobne wpisy o caffeine...
Cóż, oby wyszła aktualizacja do wersji 9.1 i z poprawkami.