Nowe posty

Autor Wątek: openSuse maszyna wirtualna brak dostępu do internetu  (Przeczytany 1030 razy)

Offline pld

  • Users
  • Użytkownik
  • **
  • Wiadomości: 51
    • Zobacz profil
Witam,
utworzyłem maszynę wirtualną na opensuse (tryb tylko konsolowy) maszyna wirtualna to takze opensuse
Nie ma ona dostępu do internetu

Kod hosta
dlp:~ # zypper -n install qemu-kvm libvirt virt-install bridge-utils
# verify modules are loaded
dlp:~ # lsmod | grep kvm
kvm_intel       147785  0
kvm             464964  1 kvm_intel

dlp:~ # systemctl start libvirtd
dlp:~ # systemctl enable libvirtd
[2] Configure Bridge networking for KVM virtual machine.
dlp:~ # mv /etc/sysconfig/network/ifcfg-eth0 /etc/sysconfig/network/ifcfg-br0
dlp:~ # vi /etc/sysconfig/network/ifcfg-br0
# add follows to the end
BRIDGE='yes'
BRIDGE_FORWARDDELAY='0'
BRIDGE_PORTS='eth0'
BRIDGE_STP='off'
dlp:~ # vi /etc/sysconfig/network/routes
# add gateway for br0 to the end
default 10.0.0.254 - br0
dlp:~ # systemctl restart wickedd wicked
dlp:~ # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br0 state UP group default qlen 1000
    link/ether 00:0c:29:93:c2:e0 brd ff:ff:ff:ff:ff:ff
3: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether 00:0c:29:93:c2:e0 brd ff:ff:ff:ff:ff:ff
    inet 10.0.1.22/16 brd 10.0.255.255 scope global br0
       valid_lft forever preferred_lft forever
    inet6 fe80::20c:29ff:fe93:c2e0/64 scope link
       valid_lft forever preferred_lft forever
# create a Storage Pool
dlp:~ # mkdir -p /var/kvm/images
dlp:~ # virt-install \
--name sles12 \
--ram 4096 \
--disk path=/var/kvm/images/sles12.img,size=30 \
--vcpus 2 \
--os-type linux \
--os-variant sles12 \
--network bridge=br0 \
--graphics none \
--console pty,target_type=serial \
--location /tmp/SLE-12-Server-DVD-x86_64-GM-DVD1.iso \
--extra-args 'console=ttyS0,115200n8 serial'
Starting install...     # installation starts



Proszę o pomoc

Offline roobal

  • Users
  • Guru
  • *****
  • Wiadomości: 2052
    • Zobacz profil
Odp: openSuse maszyna wirtualna brak dostępu do internetu
« Odpowiedź #1 dnia: 2017-02-06, 23:51:36 »
Nie wiem jak to się robi w OpenSUSE, ale w systemd robi się to tak:

/etc/systemd/network/br0.netdev

[NetDev]
Name=br0
Kind=bridge

/etc/systemd/network/br0.network

[Match]
Name=br0

[Network]
DHCP=v4

/etc/systemd/network/eth0.network

[Match]
Name=eth0

[Network]
Bridge=br0

Po tym robisz.
systemctl enbale systemd-networkd
systemctl stop NetworkManager
systemct disable NetworkManager
systemctl start systemd-networkd

Jeśli przeładowanie usług nie zadziała to restartujesz system. Jeśli Twój interfejs nazywa się inaczej, niż eth0 to podajesz właściwą nazwę w nazwie pliku i w Name. Następnie w Virt Manager wskazujesz interfejs br0 jako interfejs sieciowy.

W podanym przez Ciebie sposobie konfiguracji sieci, prawdopodobnie nie przeładowałeś usługi sieciowej (nie wiem jak to się robi w SUSE, być może też systemct restart systemd-networkd lub NetworkManager). Zawsze po takiej zmianie możesz zrestartować system.
« Ostatnia zmiana: 2017-02-06, 23:54:45 wysłana przez roobal »