Nowe posty

xx Zlecę skrypt w bashu (0)
2020-02-19, 14:07:39
xx Nadawanie praw katalogom takich, jak nazwa usera (4)
2020-02-17, 14:15:18
xx Fedora na laptopie HP 15-bs152nw brak wifi (44)
2020-02-16, 12:17:18
xx Komputer do nauki linuxa (10)
2020-02-15, 07:03:28
xx Patronat serwisow internetowych. (1)
2020-02-13, 00:13:24
xx Xfce-terminal v 0.8.7.4 - jak ustawić wklejanie skopiowanego tekstu? (3)
2020-02-12, 18:59:24
xx HD ISO, jak odzyskać starsze pliki (6)
2020-02-12, 10:54:31
xx QEMU KVM gpu passthrough brak obrazu (4)
2020-02-11, 17:05:06
xx i7-9700 + Intel H370 (0)
2020-02-11, 12:36:55
xx Co to jest .xsession-errors.old ? (1)
2020-02-09, 22:55:09

Autor Wątek: nie mogę zainstalować żadnego programu - xubuntu 16.04  (Przeczytany 1570 razy)

Offline czjekes

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
po aktualizacji zniknęło mi Centrum Oprogramowania. Chciałem je zainstalować lecz pojawia się komunikat:

ulikii@ulikii-Lenovo-G50-30:~$ sudo apt-get install software-center
[sudo] hasło użytkownika ulikii:
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt-get -f install", aby naprawić poniższe problemy:
Następujące pakiety mają niespełnione zależności:
 cpp-5 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 g++-5 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 gcc-5 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libasan2 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libatomic1 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libcc1-0 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libcilkrts5 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libgcc-5-dev : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libgomp1 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libitm1 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libmpx0 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libquadmath0 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libstdc++-5-dev : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
                   Wymaga: libstdc++6 (>= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 libubsan0 : Wymaga: gcc-5-base (= 5.4.0-6ubuntu1~16.04.4) ale 5.4.0-6ubuntu1~16.04.2 ma zostać zainstalowany
 software-center : Wymaga: software-center-aptdaemon-plugins ale nie zostanie zainstalowany
                   Wymaga: python-xapian
                   Wymaga: python-apt (>= 0.8.3ubuntu4) ale nie zostanie zainstalowany
                   Wymaga: python-aptdaemon (>= 0.40) ale nie zostanie zainstalowany
                   Wymaga: python-aptdaemon.gtk3widgets ale nie zostanie zainstalowany
                   Wymaga: python-dbus ale nie zostanie zainstalowany
                   Wymaga: python-defer ale nie zostanie zainstalowany
                   Wymaga: python-lxml ale nie zostanie zainstalowany
                   Wymaga: python-xdg ale nie zostanie zainstalowany
                   Wymaga: ubuntu-sso-client ale nie zostanie zainstalowany
                   Wymaga: python-piston-mini-client (>= 0.1+bzr29) ale nie zostanie zainstalowany
                   Wymaga: oneconf (>= 0.2.6) ale nie zostanie zainstalowany
                   Wymaga: python-oneconf (>= 0.3) ale nie zostanie zainstalowany lub
                           oneconf (< 0.3) ale nie zostanie zainstalowany
                   Wymaga: python-debtagshw ale nie zostanie zainstalowany
                   Poleca: apt-xapian-index (>= 0.38ubuntu1) ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt-get -f install" bez pakietów (lub podać rozwiązanie).
ulikii@ulikii-Lenovo-G50-30:~$



wpisując apt-get -f install pojawia się:

ulikii@ulikii-Lenovo-G50-30:~$ apt-get -f install
E: Nie udało się otworzyć pliku blokady /var/lib/dpkg/lock - open (13: Brak dostępu)
E: Nie udało się zablokować katalogu administracyjnego (/var/lib/dpkg/), czy użyto uprawnień administratora?



nie wiem co dalej robić, dotyczy to każdego programu - nie tylko centrum oprogramowania
proszę o pomoc

Offline Kãa Esanæan'eveôse

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 40
    • Zobacz profil
Odp: nie mogę zainstalować żadnego programu - xubuntu 16.04
« Odpowiedź #1 dnia: 2016-11-24, 00:15:40 »
Dlatego "apt-get -f install" nie podziałało, bo tam również trzeba wpisać "sudo" przed komendą.
Dotyczy każdego programu, ponieważ niemożliwe będą wszelkie operacje na pakietach tak długo, dopóki będą jakieś niespełnione zależności. Najpierw trzeba to naprawić, na początek spróbować przez "apt-get -f install" - rozwiązuje to część problemów, chociaż nie zawsze. Najpierw zrób to i zobacz, co się stanie.
#562166  ||  UG9kcGlzdWrEmSBzacSZIGtyd2nEhSAtIG5pZSBwb3TEmXBpYWpjaWUgbW5pZSB6YSB0byE=