Nowe posty

Autor Wątek: Problem z instalacja WIne  (Przeczytany 3271 razy)

Offline Oubountou

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
Problem z instalacja WIne
« dnia: 2016-10-29, 13:33:27 »
Witam, Probuje zainstalowac srodowisko Wine przez centrum oprogramowania na ubuntu 14.04 i wyskakuje:

Cytuj
Zależności dla następujących pakietów, nie zostały spełnione:

unity-control-center: Depends: libpulse-mainloop-glib0 (>= 1:0.99.1) ale 1:4.0-0ubuntu11.1 zostanie zainstalowany
Depends: libpulse0 (>= 1:0.99.1) ale 1:4.0-0ubuntu11.1 zostanie zainstalowany
Depends: libxi6 (>= 2:1.2.99.4) ale 2:1.7.1.901-1ubuntu1.1 zostanie zainstalowany
wine:

Co dalej?  :o
« Ostatnia zmiana: 2016-10-29, 14:25:39 wysłana przez Oubountou »

Offline Kãa Esanæan'eveôse

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 40
    • Zobacz profil
Odp: Problem z instalacja WIne
« Odpowiedź #1 dnia: 2016-10-29, 17:18:05 »
To oznacza, że wersje pakietów w repozytoriach były nierównomiernie aktualizowane. Są "zbyt nowe" dla tej wersji Wine, która jest dostępna. Chyba w tym wypadku powinno się poszukać, np. na stronie Wine, jakiejś nowszej wersji. Z tego źródła raczej się już nie ściągnie.
#562166   ||   Nie śpię, bo aktualizuję Archa...

Offline Oubountou

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
Odp: Problem z instalacja WIne
« Odpowiedź #2 dnia: 2016-10-29, 18:07:17 »
Probuje usuwac wine pisząc:

Cytuj
sudo add-apt-repository --remove ppa:wine/wine-builds
Cytuj
sudo add-apt-repository --remove ppa:wine/winetricks

A pozniej od nowa:

Cytuj
sudo add-apt-repository ppa:ubuntu-wine/ppa

sudo apt-get update

sudo apt-get install wine1.8 winetricks


I nadal nie dziala

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2427
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: Problem z instalacja WIne
« Odpowiedź #3 dnia: 2016-10-29, 23:53:52 »
W PPA ppa:wine/wine-builds nie ma pakietu wine1.8... Jest wine-devel (wersja 1.9.21).

Nie ma też takiego PPA jak ppa:wine/winetricks.

Musisz mieć jeszcze dodane jakieś inne PPA albo repozytoria i stamtąd próbuje zaciągnąć się wine1.8, bo standardowe repo do 14.04 ma wersję maksymalnie wine1.6.

Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline Oubountou

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 3
    • Zobacz profil
Odp: Problem z instalacja WIne
« Odpowiedź #4 dnia: 2016-10-30, 18:59:17 »
A moge jakos sprawdzic jakie repozytoria mam dodane albo jakos inaczej to ogarnac?
Moze np. sprobowac pousuwac rozne mozliwe...

Po wpisaniu "apt-cache show wine" :

Cytuj
Package: wine
Source: wine1.8
Priority: extra
Section: metapackages
Installed-Size: 21
Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Architecture: amd64
Version: 1:1.8.0-0ubuntu1
Depends: wine1.6 | wine1.8
Filename: pool/main/w/wine1.8/wine_1.8.0-0ubuntu1_amd64.deb
Size: 978
MD5sum: 5162190cd8f2075a40f8c5c31aaf8531
SHA1: 47dd283bfb8ced8212d27a30cc61bfecb5f3baa0
SHA256: bd6346aaa21102d57317b4b7518e6d023cc5c5031121a4696003ef3b997e6951
Description-en: Microsoft Windows Compatibility Layer (meta-package)
 Wine is a compatibility layer for running Windows applications on Linux.
 Applications are run at full speed without the need of cpu emulation. Wine
 does not require Microsoft Windows, however it can use native system dll
 files in place of its own if they are available.
 .
 This meta-package always depends on the latest stable version of Wine.
Description-md5: 7ca999b13ee007110685ad22b3ecb3b6
Multi-Arch: foreign

Package: wine
Priority: extra
Section: universe/otherosfs
Installed-Size: 21
Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Architecture: amd64
Source: wine1.6
Version: 1:1.6.2-0ubuntu4
Depends: wine1.6
Filename: pool/universe/w/wine1.6/wine_1.6.2-0ubuntu4_amd64.deb
Size: 968
MD5sum: fa532a90c316e7679d2281985748e093
SHA1: 558c2b93b3d5feb5b077939e4d51db8fbe28fc95
SHA256: d3e711eeefb2d921fd486b8a5f20c1e333f090b254be322fcabf35f3cf23c728
Description-en: Microsoft Windows Compatibility Layer (meta-package)
 Wine is a compatibility layer for running Windows applications on Linux.
 Applications are run at full speed without the need of cpu emulation. Wine
 does not require Microsoft Windows, however it can use native system dll
 files in place of its own if they are available.
 .
 This meta-package always depends on the default version of Wine.
Description-md5: 6474b3e541944944e61aec502ceb28f2
Multi-Arch: foreign
Homepage: http://www.winehq.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu




//edit

Cos sie udalo usunac, zostalo tylko to:

Cytuj
Package: wine
Priority: extra
Section: universe/otherosfs
Installed-Size: 21
Maintainer: Scott Ritchie <scottritchie@ubuntu.com>
Architecture: amd64
Source: wine1.6
Version: 1:1.6.2-0ubuntu4
Depends: wine1.6
Filename: pool/universe/w/wine1.6/wine_1.6.2-0ubuntu4_amd64.deb
Size: 968
MD5sum: fa532a90c316e7679d2281985748e093
SHA1: 558c2b93b3d5feb5b077939e4d51db8fbe28fc95
SHA256: d3e711eeefb2d921fd486b8a5f20c1e333f090b254be322fcabf35f3cf23c728
Description-en: Microsoft Windows Compatibility Layer (meta-package)
 Wine is a compatibility layer for running Windows applications on Linux.
 Applications are run at full speed without the need of cpu emulation. Wine
 does not require Microsoft Windows, however it can use native system dll
 files in place of its own if they are available.
 .
 This meta-package always depends on the default version of Wine.
Description-md5: 6474b3e541944944e61aec502ceb28f2
Multi-Arch: foreign
Homepage: http://www.winehq.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
« Ostatnia zmiana: 2016-10-30, 19:43:17 wysłana przez Oubountou »