Nowe posty

xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (1)
2019-04-19, 11:11:08
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50
xx Xubuntu i VirtualBox (2)
2019-04-11, 23:24:54
xx problem konfiguracji sieci (3)
2019-04-10, 17:19:19
xx Wykonam strone internetowa. Tworzenie i projektowanie stron www (0)
2019-04-10, 12:37:26
xx Read- only SD (7)
2019-04-10, 08:28:22

Autor Wątek: Panasonic KX-MB1530 - jak skonfigurować skaner - w innych distro działa  (Przeczytany 6910 razy)

Offline Paweł Owczarek

  • Users
  • Użytkownik
  • **
  • Wiadomości: 52
    • Zobacz profil
Witam.

Zainstalowałem niedawno OpenSUSE Tumbleweed i mam problem z konfiguracją skanera, który w innych dystrybucjach, których używałem (Ubuntu, Debian, Manjaro, Fedora i kilka innych), dało się uruchomić. Jako, że OpenSUSE różni się dla mnie dość mocno od innych distro, opiszę po kolei, jakie kroki wykonałem i może ktoś z Użytkowników będzie w stanie mi pomóc. A więc:

1. Zainstalowałem najpierw sterownik skanera w najnowszej wersji, dostępny na stronie producenta. W innych distro nie miałem z tym problemów, ale tutaj w terminalu wypluło komunikat:

ln: nie udało się utworzyć dowiązania symbolicznego „/etc/rc2.d/S80panasoniclpd-init”: Nie ma takiego pliku ani katalogu
ln: nie udało się utworzyć dowiązania symbolicznego „/etc/rc3.d/S80panasoniclpd-init”: Nie ma takiego pliku ani katalogu
ln: nie udało się utworzyć dowiązania symbolicznego „/etc/rc4.d/S80panasoniclpd-init”: Nie ma takiego pliku ani katalogu
ln: nie udało się utworzyć dowiązania symbolicznego „/etc/rc5.d/S80panasoniclpd-init”: Nie ma takiego pliku ani katalogu

2. Mimo tego spróbowałem wykonać krok kolejny, czyli dodać do pliku 55-libsane.rules wpis, jak w instrukcji wydanej przez producenta:

# Panasonic MFS scanners
ATTRS{idVendor}=="04da", ENV{libsane_matched}="yes"

3. Potem zrestartowałem komputer i w innych dystrybucjach skanera dało się normalnie używać, ale tutaj xsane w ogóle go nie widzi. Uruchomiłem YaST-a i wszedłem w konfigurację skanerów. Po chwili, kiedy próbował wykryć skanery, w oknie pokazał się wpis:

panamfs Brak skanerów obsługiwanych przez ten program obsługi

Kiedy kliknąłem "Dodaj", wyświetliła się długa lista urządzeń, w tym Panasonica, ale mojego urządzenia na niej nie ma.

OpenSUSE to dla mnie zupełnie nowy system, poza krótkim podejściem kilka lat temu. Zakładam jednak, że skoro na wszystkich innych dystrybucjach skaner dało się skonfigurować, to tutaj też musi się jakoś dać, jednak działanie tej dystrybucji i administrowanie nią jest jakieś inne, niż w innych dystrybucjach, których używałem i w których konfiguracja była krótka i bezproblemowa.

Dodam, że w tej chwili nie mam Tumbleweeed na dysku, bo musiałem dużo skanować, a nie mogłem i zainstalowałem więc z powrotem Debiana, więc nie mogę tak od razu podać więcej szczegółów, ale mam teraz 2 dni wolne i chcę spróbować rozwiązać problem i dziś wieczorem instaluję Tumbleweed ponownie i będę w stanie podać więcej szczegółów, typu co wypluwają jakieś komendy itp. jak będzie to potrzebne.

Będę ogromnie wdzięczny za pomoc, bo Tumbleweed to najlepsze distro, jakiego używałem, tylko ten skaner...

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2138
  • 1709
    • Zobacz profil
Cytuj
ln: nie udało się utworzyć dowiązania symbolicznego „/etc/rc2.d/S80panasoniclpd-init”: Nie ma takiego pliku ani katalogu
Po za tym ze nie masz pliku lub katalogu do którego chcesz stworzyc link,
to nie wiele to mowi.
Mozesz podac linka do  OpenSUSE Tumbleweed oraz do sterowników ?
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Paweł Owczarek

  • Users
  • Użytkownik
  • **
  • Wiadomości: 52
    • Zobacz profil
Link do sterów:

http://panasonic.net/pcc/support/fax/common/table/linuxdriver.html

W innych dystrybucjach ten komunikat o braku dowiązania symbolicznego nie występował, a na bardzo wielu ten skaner z powodzeniem uruchamiałem: Ubuntu, Debian, Fedora, Manjaro, PCLOS i kilkunastu innych (mam to urządzenie już koło dwóch lat). Nigdy nie było problemu i nie wiem, o co w ogóle chodzi z tym dowiązaniem symbolicznym. 

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 283
    • Zobacz profil
Sterowniki obsługują starszy demon inicjalizacji - sysvinit:
https://www.centos.org/docs/5/html/Installation_Guide-en-US/s1-boot-init-shutdown-sysv.html

W OpenSUSE jest systemd. Trzeba sprawdzić, czy masz tam pakiet systedm-sysvinit - być może on obsłuży to, czego wymagają sterowniki.

Ręczne utworzenie struktury katalogów /etc/rc.d itd. nic nie da, bo system nie będzie wiedział o ich istnieniu itd.

W ostateczności można też napisać do producenta ... :D
« Ostatnia zmiana: 2015-11-26, 22:49:30 wysłana przez marcin'82 »
marcin82

Offline Paweł Owczarek

  • Users
  • Użytkownik
  • **
  • Wiadomości: 52
    • Zobacz profil
Aha. To wypróbuję, jak tylko zrobię nową instalację - waśnie wróciłem z pracy. Co do systemd, to wszystkie dystrybucje, pod którymi uruchamiałem skaner, też mają systemd, a problemu nie było. Zrobię instalację Tumbleweed i próbuję, a na wszelki wypadek zainstaluję na jakiejś małej ilości miejscana dysku innego Linuksa, aby spod niego skanować, zanim problem uda się (lub nie) rozwiązać. Na co dzień takie rozwiązanie mi nie pasuje, ale mam nadzieję, że coś się uda zdziałać. Jeszcze dziś napiszę, czy udało się coś osiągnąć, instalując ten pakiet i tworząc katalog. Dziękuję za zainteresowanie :)

Offline marcin'82

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 283
    • Zobacz profil
Najpierw może zainstaluj pakiet - poszukaj czy w ogóle jest. On powinien dostarczać tych katalogów - struktury systemu init.
marcin82

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2138
  • 1709
    • Zobacz profil
Linux jest za darmo, dyski sa w miare tanie,
postawiłbys sobie 2 systemy, 1 malutki 6GB awaryjny
i drugi do uzytku codziennego.
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Paweł Owczarek

  • Users
  • Użytkownik
  • **
  • Wiadomości: 52
    • Zobacz profil
Zainstalowałem Tumbleweed ponownie. Akurat wyszedł nowy obraz iso do pobrania - ja próbowałem konfigurować skaner na poprzednim snapshocie. Tym razem udało się zainstalować sterownik bez komunikatu o braku dowiązania symbolicznego i po dodaniu wpisu skanera do pliku 55-libsane.rules xsane widzi skaner bez żadnych kombinacji. Myślę, że po prostu na poprzednim obrazie mogło nie być pakietu systemd-sysvinit, ponieważ z każdym nowym obrazem dorzucane lub usuwane są jakieś pakiety i poprawiane błędy. Sprawdziłem przed instalacją sterownika i ten pakiet był teraz zainstalowany i wszystko teraz działa.

Dziękuję za zainteresowanie i rady.

Offline Paweł Owczarek

  • Users
  • Użytkownik
  • **
  • Wiadomości: 52
    • Zobacz profil
Odnawiam temat.

Po pewnym czasie okazało się, że ten sam problem mam na Antergosie. Tumbleweed poszedł w odstawkę, bo były ostatnio spore problemy ze stabilnością i aktualizacjami.

Dostaję dokładnie ten sam komunikat i nie mogę skanować. Żeby było ciekawiej, na laptopie mam Sabayona i pomimo takich samych komunikatów o tym, że niemożna utworzyć plików i dowiązań, xsane widzi skaner i normalnie mogę skanować, czyli przypuszczam, że skanowanienie nie jest uniemożliwione przez te problemy, które widoczne są w komunikatach, a przez coś innego. Nie znam działania (x)sane. Może program po prostu nie widzi skanera i da się to zmienić??? 

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2138
  • 1709
    • Zobacz profil
- sprawdz czy wersje xsane sa te same,
  jesli tam gdzie nie działa , sasugeruj dystrybucji aktualizacje xsane,
  jesli wersje sa identyczne, jesli wersja jest najnowsza, to mozesz recznie skompilowac,
  choc moze to byc trudne, potrzebujesz poradnika, moze tylko plik README wystarczy z paczki xsane lub dokumentacje ze strony xsane...
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Paweł Owczarek

  • Users
  • Użytkownik
  • **
  • Wiadomości: 52
    • Zobacz profil
Problem rozwiązany ostatecznie.

Zainstalowałem inną wersję sane z Arch User Repository i ponownie zainstalowałem sterownik. Komunikaty błędów przy instalacji były, ale mogę teraz normalnie skanować i wszystko działa, jak powinno. Teraz wiem, że w przypadku pojawienia się problemu na innych dystrybucjach, wystarczy zainstalować inną wersję sane. Akurat teraz mam najnowszą, ale używałem tego skanera na dystrybucjach, które miały dość starą wersję sane, bo w ogóle wszystkie pakiety w nich były nie za świeże i skaner działał poprawnie....