Nowe posty

Autor Wątek: ubuntu 16.04 vps  (Przeczytany 3032 razy)

ampul

  • Gość
ubuntu 16.04 vps
« dnia: 2016-08-10, 20:37:36 »
witam,

mam takowa wersje w 32bit,

wszystko dobrze gdyby nie to ze uruchomienie wielu programow napisanych w javie (jar) powoduje samo zamkniecie i niemam zielonego pojecia dlaczego,

podpowiecie co tu mozna wykombinowac ?


dziekuje

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2562
  • 1709
    • Zobacz profil
Odp: ubuntu 16.04 vps
« Odpowiedź #1 dnia: 2016-08-10, 23:35:21 »
1. Uruchomom z terminala cokolwiek to jest ( pierwsza myśl zawsze )
powinien wyskoczyć jakiś bląd, jeśli nie to trzeba zdebugować program by się  dowiedzieć.
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

ampul

  • Gość
Odp: ubuntu 16.04 vps
« Odpowiedź #2 dnia: 2016-08-11, 06:19:04 »
http://screenshot.sh/m7ymd5L7BTIwP

fakt terminal, no i takie cos wylazi

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2562
  • 1709
    • Zobacz profil
Odp: ubuntu 16.04 vps
« Odpowiedź #3 dnia: 2016-08-11, 14:09:39 »
No i na podstawie błedu mozna spróbować poszukać ,
czy ktoś już miał taki problem
https://www.google.pl/search?q=unable+to+remove+unistalled++invalition+notifier&ie=utf-8&oe=utf-8&gws_rd=cr&ei=cWasV5aiIsSVsgHU6Jb4AQ

Żeby być pewnym ze problem dotyczy akurat tego błędu,
musisz albo poczekać aż ktoś mądrzejszy napisze , albo samemu spróbować zgłębić tajniki javy i debugowania i procesów,
ewentualnie spytac na forum supportu javy.

Dlaczego javy ?
 - Bo tobie się wykrzaczyły wszystkie naraz programy, więc wspólnym mianownikiem jest jakiś proces javy
 (  ja zwykle mam tylko 1 proces programu który sprawdzam, więc nie możliwe żeby mi coś jeszcze padło )

Dlaczego debugowania ?
 - bo żeby zobaczyć więcej musisz użyć programów zewnetrznych, np. strace, gdb lub czegos innego
strace nazwa_programu
http://www.thegeekstuff.com/2011/11/strace-examples/

Dlaczego procesów?
 - Żeby być pewnym, że twoj program nie uruchamia jakiegoś pierw "servera" i to on się wykrzacza.
( tu pstree sie moze przydac )
https://pl.wikibooks.org/wiki/Linux/Procesy

Bo tak zeby wiecej coś napisac to
- ja sie nie znam za bardzo
- nie podales co to za programy, wiec nie przetestuje u siebie.
- oraz jak uruchamiasz  " java jar nazwa " czy inaczej ...

Edytowane:
Warto też sprawdzić czasami ... może będzie tam informacja jakać o programie  która się wykrzacza.
dmesg | egrep -i 'failed|warning|error'
egrep -i 'failed|warning|error' ~/.xsession-errors
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2840
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: ubuntu 16.04 vps
« Odpowiedź #4 dnia: 2016-08-11, 15:01:06 »
Przeredaguj pytanie, bo nie do końca wiadomo o co chodzi...

1. VPS, to... Masz wykupionego gdzieś VPSa i na nim zainstalowane Ubuntu? Czy palce się omskły i masz Ubuntu 16.04 LTS zainstalowane na "normalnym" komputerze?

2. Która wersja Javy, jak i skąd instalowana? Dodatkowo,  niektóre programy napisane w Javie nie zadowalają się samym JRE i wymagają zainstalowanego pełnego JDK.

3. "wielu programow napisanych w javie" - przykłady, please

4. "powoduje samo zamkniecie" - o_O Chodzi o samoczynne zamknięcie? Czego? Programu? Systemu?

5. Co do przysłanego logu: przydatne byłyby linijki tuż po uruchomieniu aplikacji.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

ampul

  • Gość
Odp: ubuntu 16.04 vps
« Odpowiedź #5 dnia: 2016-08-11, 17:41:42 »
witam,

a wiec chcialbym od poczatku,

stoi czysty tym razem 14.04, bez javy, chcialbym zainstalowac jni

no ale

root@defaultvps:~# apt-get install libswt-gtk-3-jni
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  libswt-gnome-gtk-3-jni
The following NEW packages will be installed:
  libswt-gtk-3-jni
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
13 not fully installed or removed.
Need to get 163 kB of archives.
After this operation, 667 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ trusty/universe libswt-gtk-3-jni i386 3.8.2-3 [163 kB]
Fetched 163 kB in 0s (578 kB/s)
Selecting previously unselected package libswt-gtk-3-jni.
(Reading database ... 149653 files and directories currently installed.)
Preparing to unpack .../libswt-gtk-3-jni_3.8.2-3_i386.deb ...
Unpacking libswt-gtk-3-jni (3.8.2-3) ...
Setting up bluez (4.101-0ubuntu13.1) ...
start: Job failed to start
invoke-rc.d: initscript bluetooth, action "start" failed.
dpkg: error processing package bluez (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of bluez-alsa:i386:
 bluez-alsa:i386 depends on bluez; however:
  Package bluez is not configured yet.

dpkg: error processing package bluez-alsa:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-bluetooth:
 gnome-bluetooth depends on bluez (>= 4.36); however:
  Package bluez is not configured yet.

dpkg: error processing package gnome-bluetooth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indicator-bluetooth:
 indicator-bluetooth depends on bluez (>= 4.36); however:
  Package bluez is not configured yet.
 indicator-bluetooth depends on gnome-bluetooth | ubuntu-system-settings; however:
  Package gnome-bluetooth is not configurNo apport report written because the error message indicates its a followup error from a previous failure.
                                               No apport report written because the error message indicates its a followup error from a previous failure.
                                                     No apport report written because MaxReports is reached already
               No apport report written because MaxReports is reached already
                                                                             No apport report written because MaxReports is reached already
                                       No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
                                                               No apport report written because MaxReports is reached already
                         ed yet.
  Package ubuntu-system-settings is not installed.

dpkg: error processing package indicator-bluetooth (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-control-center:
 unity-control-center depends on indicator-bluetooth; however:
  Package indicator-bluetooth is not configured yet.

dpkg: error processing package unity-control-center (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-shell:
 gnome-shell depends on gnome-bluetooth (>= 3.0.0); however:
  Package gnome-bluetooth is not configured yet.

dpkg: error processing package gnome-shell (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gdm:
 gdm depends on gnome-shell; however:
  Package gnome-shell is not configured yet.

dpkg: error processing package gdm (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency prNo apport report written because MaxReports is reached already
                                                                                 No apport report written because MaxReports is reached already
                                           No apport report written because MaxReports is reached already
     No apport report written because MaxReports is reached already
                                                                   oblems prevent configuration of gnome-user-share:
 gnome-user-share depends on gnome-bluetooth; however:
  Package gnome-bluetooth is not configured yet.

dpkg: error processing package gnome-user-share (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-core:
 gnome-core depends on gdm (>= 3.4); however:
  Package gdm is not configured yet.
 gnome-core depends on gnome-bluetooth (>= 3.4); however:
  Package gnome-bluetooth is not configured yet.
 gnome-core depends on gnome-shell (>= 3.4); however:
  Package gnome-shell is not configured yet.
 gnome-core depends on gnome-user-share (>= 3.0); however:
  Package gnome-user-share is not configured yet.

dpkg: error processing package gnome-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-desktop:
 ubuntu-desktop depends on unity-control-center; however:
  Package unity-control-center is not configured yet.

dpkg: error processing package ubuntu-desktop (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unity-control-center-signon:
 unity-control-center-signon depends on unity-control-center; however:
  Package unity-control-center is not configured yet.

dpkg: error processing package unity-control-center-signon (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of webaccounts-extension-common:
 webaccounts-extension-common depends on unity-control-center-signon | gnome-control-center-signon; however:
  Package unity-control-center-signon is not configured yet.
  Package gnome-control-center-signon is not installed.

dpkg: error processing package webaccounts-extension-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xul-ext-webaccounts:
 xul-ext-webaccounts depends on webaccounts-extension-common (= 0.5-0ubuntu2.14.04.1); however:
  Package webaccounts-extension-common is not configured yet.

dpkg: error processing package xul-ext-webaccounts (--configure):
 dependency problems - leaving unconfigured
Setting up libswt-gtk-3-jni (3.8.2-3) ...
Errors were encountered while processing:
 bluez
 bluez-alsa:i386
 gnome-bluetooth
 indicator-bluetooth
 unity-control-center
 gnome-shell
 gdm
 gnome-user-share
 gnome-core
 ubuntu-desktop
 unity-control-center-signon
 webaccounts-extension-common
 xul-ext-webaccounts
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Ostatnia zmiana: 2016-08-11, 18:15:47 wysłana przez bartek »

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2840
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Odp: ubuntu 16.04 vps
« Odpowiedź #6 dnia: 2016-08-12, 07:39:26 »
Czysty i na dzień dobry skopane pakiety?
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

ampul

  • Gość
Odp: ubuntu 16.04 vps
« Odpowiedź #7 dnia: 2016-08-12, 09:25:50 »
no czysty znaczy sie to co na wykupionym vpsie,  ale uporalem sie z tym, wlasnie testujemy czy wsio ok,

niemam az takowej wiedzy zeby sprawdzic i przetestowac, chyba ze ktos ma ochote pomoc to chetnie uzycze dostep

a tutaj koncowka terminala kiedy aplikacja sie zamyka.
http://screenshot.sh/ofi6xyl0jvsD3
« Ostatnia zmiana: 2016-08-12, 10:16:37 wysłana przez bartek »