Nowe posty

Autor Wątek: Problem z Publicznym IP PILNE!!!!  (Przeczytany 3475 razy)

Offline Hacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Problem z Publicznym IP PILNE!!!!
« dnia: 2016-06-29, 13:42:51 »
Witam, mam pewien problem. Kupiłem raspberry pi z myślą o serwerze www i ftp. Więc go wykonałem. Wszystko chodzi tylko jest pewien problem. Chciałbym aby inny też mogli go odpalać z publicznego ip. Niewiem jak ustawić porty. Mam router TP Linka. Pomocy!!!!!

Offline marcin'82

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 239
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #1 dnia: 2016-06-29, 18:26:39 »
Pomoc znajdziesz w instrukcji obsługi routera.
marcin82

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2025
  • 1709
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #2 dnia: 2016-06-29, 23:41:36 »
- Tutaj też możesz znaleść instrukcje do routera
http://portforward.com/english/routers/port_forwarding/routerindex.htm

- Jakie porty ?
Jesli nie wiesz to musisz się zapoznać z programem jakiego użyłeś do postawienia servera ftp.
Server może używać np. dwa porty 20 i 21 plus losowe porty pasywne.
Żeby nie trzeba było przekierować  wszystkie (  dowolny port --> dowolny port  )
 to porty pasywne mozna spróbować zdefiniować w pliku konfiguracyjnym ftp którego używasz a potem tylko te odblokowujesz w routerze
( dowolny --> zakres portu ) i przypisujesz je IP wewnętrznemu. Na youtubie masz tez pokazane co i jak.
Ale co i jak zalezy od routera i ftp.
https://www.youtube.com/watch?v=bgdsWzMN68o&feature=youtu.be&t=56

netstat -tan
Moze sie przydać do badania co się dzieje w sieci, jeśli masz costakiego na malince.
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Hacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #3 dnia: 2016-06-30, 07:57:46 »
Witam, przejrzałem odcinek oraz poszperałem w internecie i doszedłem do tego stanu:

Dalej jak wchodzę na serwer www poprzez ip zewnętrzne wzięty ze strony twojeip.wp.pl (wiem sprawdzałem malinka ma takie same) i nic nie wyskakuje jest błąd. Teraz niewiem co mam robić. Pomóżcie!

Offline Hacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #4 dnia: 2016-06-30, 08:04:57 »
Witam, dorzucam jeszcze screena z konsoli raspberry pi po wpisaniu komendy
netsat -tan
  Może się przyda  :D   :
https://www.dropbox.com/s/tyduly3fq1nuke5/konsola.png?dl=0

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2025
  • 1709
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #5 dnia: 2016-06-30, 09:12:08 »
- Staraj się chować wrazliwe dane jak IP  (np. abc , kolorami), tak aby było wiadomo ze to te samo IP  (nikt nie chce nieproszonych gości)

- Zgaduje ze adres wewnętrzny wpisałeś  prawidłowo, bo pisze że to lokalny (wewnętrzny) w netstat.
- Nie wiem tylko czy "usługa" www jest uruchomiona i na jakich portach to twoje działa.
1. Działa Ci strona po wpisaniu IP lokalnego ? (192.168.X.X)
2.
Cytuj
wchodzę na serwer www poprzez ip zewnętrzne wzięty ze strony twojeip.wp.pl (wiem sprawdzałem malinka ma takie same)
Tego raczej nie zrozumiałem, nie wiem po czym to stwierdziłeś,
ale wydaje mi się że używasz na malince IP wewnętrznego (lokalnego) 192.168.X.X, a na stronie twojeip.wp.pl pewnie masz już inne.
(inaczej nie widze sensu używania routera, chyba ze masz modem-router w jednym i opcja router jest wyłączona, aczkolwiek i tak to wygląda jak lokalne)
https://www.youtube.com/watch?v=Z4-CZj195JQ&feature=youtu.be&t=477
3. A i jeszcze coś ... jak się polaczysz ze stroną lokalnie, np. na malince (192.168.X.X),  to w netstat zobaczysz te IP i porty na których trwa połączenie.
( aktualnie w twoim netstat nie widze portu 80 i nie wiem, czy akurat wtedy trwało połączenie z twoją stroną www )
4. I jeszcze coś. Czyść ciastecza w przeglądarce przed sprawdzeniem strony internetowej. (czasami moze być pomocne)

Przykład:
192.168.0.1 to twoja malinka
192.168.0.2 to twoj komputer
- wpisałeś netstat -tan  i patrzysz co masz
- uruchomiłeś serwer www, wpisałeś na swoim kompuetrze IP malinki i uruchomiła Ci się strona www ( super  ;D )
- patrzysz ponownie w terminal wpisując netstat -tan  i zauwazasz nowy wpis
tcp        0    0    192.168.0.2:8080       192.168.0.1:8080          ESTABLISHED
protokół  ...    ...     komputer:port         malinka:port        połączone
- i wtedy podobnie ustawiasz w routerze
8080      8080      192.168.0.1    TCP

Tylko sprawdz czy napewno, po obu stronach masz zawsze identyczny port, jeśli na komputerze jest zmienny, wtedy port  chyba "Internal Port" powinien być dowolny.
Przetestuj w praktyce, z tym samym portem i zmieniając na dowolny a się dowiesz.
( Jesli oba działają, to numer portu )

Tu masz przykład jak gościu sobie przekierował
http://www.mamkomputer.info/jak-przekierowac-porty-konfiguracja-routera-port-forwarding/


Edytowane
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Hacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #6 dnia: 2016-06-30, 11:43:23 »
Witam, odpowiadam na pytania:
1. Tak
2. Tak na stronie mam już inne ip. Odnośnie poradnika mogę mieć tak że tam gościu mówił że u nas samych ip publiczne nie zadziała. Idę zaraz to sprawdzę ;)
3. Zdjęcie komendy
netstat -tan
już kiedy byłem podłączony:
https://www.dropbox.com/s/anhi4sl6w3jrzm7/konsola1.png?dl=0
4. Przed testem wyczyściłem wszystkie ciasteczka.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2025
  • 1709
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #7 dnia: 2016-06-30, 11:51:04 »
Czyli uzywa portu 80, to dobrze wpisałeś, to w routerze zmień któryś z portów na dowolny , (dowolne, bo na komputerze masz użyty inny port )
( Internal port lub Service port nie wiem który , w instrukcji powinno pisać dokładniej )  i strona powinna działać po wpisaniu zewnętrznego IP.
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Hacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #8 dnia: 2016-06-30, 12:15:58 »
Witam kolejny raz. Niestety robiłem co mogłem testowałem na internecie w komórce w routerze zmieniałem porty na dowolne (np.8080) ja i na normalne (80) a nic nie działało. Niewiem czy coś robię źle.  :-[

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2025
  • 1709
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #9 dnia: 2016-06-30, 13:01:34 »
To spróbuj ( tylko na chwile )dla tego IP przekierować cały zakres portów -->  cały zakres portów,
jak masz opcję "dowolny port" to "dowolny port  --> dowolny port"   
Ja zadziała, to źle miałeś podane porty, trzeba bedzie to poprawić.
Jak nie zadziała, to popatrz w ustawieniach jeszcze routera, może coś jest poblokowane.
( W ostatecznosci mozesz spróbować z DMZ, ale to nie jest bezpieczne )
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline Hacper

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #10 dnia: 2016-06-30, 13:14:48 »
Słuchaj, ponieważ jestem zielony w tym temacie mógłbyś mi podać jakiś link do poradnika czy coś w tym stylu jak to zrobić, ponieważ ja robię tak jak na poradniku zawsze a nie wychodzi w praktyce.  :-[

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2025
  • 1709
    • Zobacz profil
Odp: Problem z Publicznym IP PILNE!!!!
« Odpowiedź #11 dnia: 2016-06-30, 23:51:51 »
- Jak mi podasz dokładniej jaki model TP-Linka posiadasz to poszukam instrukcji i zerkne do niej, bo dokładnego poradnika to nie znalazłem.
- Możesz także po skonfigurowaniu routera spróbować go wyłączyć i włączyć ( może trzyma stare ustawienia )
- Ogłądajac filmiki na youtube nie widze opcji "dowolny port" , ale pisze w ustawieniach że jeden z portów może być pusty. Próbowałeś ?
- Jakiego programu użyłeś do stworzenia servera www ?  Apache ?
Z tego linku np. wynika ze oprócz 80 musisz jeszcze przekierować 443  ( jeśli używasz Apache i nie wiem, na ile poradnik jest aktualny )
http://portforward.com/english/routers/port_forwarding/TP-Link/TD-W8901G/Apache.htm
- Możesz także na próbe  zmienić port na któryś od 49152 do 65535 ( w pliku konfiguracyjnym, zrestartować server, i przekierować port w routerze )
Jeśli posiadasz zapore na malince to owy port na malince oczywiscie także musisz odblokować na tą chwilę.
( W przegladarce wpisujesz wtedy    IP:numer_portu )
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122