Nowe posty

Autor Wątek: Problem z NVIDIA GeForce GT 220  (Przeczytany 4983 razy)

Offline lopogo59

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
Problem z NVIDIA GeForce GT 220
« dnia: 2016-03-27, 18:31:01 »
Mam problem z uruchomieniem jakiejkolwiek dystrybucji na komputerze z płytą główną ASUS P5VD2-MX i kartą graficzną Nvidia Geforce GT 220. Ubuntu 15.10 w trybie nomodeset uruchamia się bez problemu, ale próba normalnego uruchomienia Ubuntu kończy się na "do_IRQ: 0.163 No irq handler for vector". Również dodanie
pci="nomsi,noaer"
nie pomogło a co najwyżej spowodowało, że błąd no irq handler for vector już się nie wyświetla, ale nadal nie mogę uruchomić w pełni systemu. Korzystając z karty zintegrowanej na płycie głównej każda dystrybucja uruchamiała się i instalowała bez żadnego problemu, ale chciałbym jednak korzystać z zewnętrznej karty.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2420
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #1 dnia: 2016-03-27, 21:41:53 »
Czy w BIOSie masz włączone przyznanie przerwania dla VGA?
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline lopogo59

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #2 dnia: 2016-03-28, 12:14:23 »
Czy w BIOSie masz włączone przyznanie przerwania dla VGA?
Mam ten sam błąd przy włączonej, jak i wyłączonej opcji "Assign IRQ for VGA".

Offline Rafi X

  • Users
  • Guru
  • *****
  • Wiadomości: 758
  • Nie ufaj nikomu w internecie. Nawet mi..
    • Zobacz profil
    • Google+ / Tech
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #3 dnia: 2016-03-31, 00:03:12 »
Cytuj
Korzystając z karty zintegrowanej na płycie głównej każda dystrybucja uruchamiała się i instalowała bez żadnego problemu
A może po prostu wyłączyć integrę?

Jeśli pojawiał się jakiś problem z uruchomieniem trybu graficznego, to kombinowałem z poniższymi opcjami w GRUB
> noapic
> acpi=off
> vga=0x314 (lub 0x317)
> nomodeset
> usunąć "quiet"
Potem wystarczyło zainstalować sterowniki NVidia ze strony producenta jakąkolwiek metodą, nawet hardcore'owo z terminala i było ok.
PC: AsRock, AMD FX-6300, 8GB DDR3, Palit GTX 680, SanDisk Ultra II 240GB, Seagate 500GB, openSUSE 42.1
Laptop: C2D T7300, 4GB DDR2, GeForce 8600 GS, Samsung 500 GB, openSUSE 42.1
Mobilnie: Moto G 1gen (Android 5.1), Lumia 625 (Windows 10), iPhone 4 (iOS 7.1.2), Nokia 6310i

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2032
  • 1709
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #4 dnia: 2016-03-31, 07:53:23 »
A mogę się spytać po co się tak męczyć skoro z nomodeset działa ?
   Jak chcesz naprawić, to pisz z developerami Ubuntu i kernela.
http://ubuntuforums.org/showthread.php?t=1613132

Cytuj
ale chciałbym jednak korzystać z zewnętrznej karty.
od tego są opcje w Biosie / UEFI zazwyczaj, u mnie to są ...
 IDG - zintegrowana ,  PEG - zewnętrzna.
   Po tym trzeba pamiętać żeby przepiąć kabel do właściwej karty graficznej.
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline lopogo59

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #5 dnia: 2016-03-31, 20:16:09 »
Cytuj
Korzystając z karty zintegrowanej na płycie głównej każda dystrybucja uruchamiała się i instalowała bez żadnego problemu
A może po prostu wyłączyć integrę?

Jeśli pojawiał się jakiś problem z uruchomieniem trybu graficznego, to kombinowałem z poniższymi opcjami w GRUB
> noapic
> acpi=off
> vga=0x314 (lub 0x317)
> nomodeset
> usunąć "quiet"
Potem wystarczyło zainstalować sterowniki NVidia ze strony producenta jakąkolwiek metodą, nawet hardcore'owo z terminala i było ok.

1. Jak korzystałem ze zintegrowanej to po prostu wyjmowałem zewnętrzną i przełączałem kable, i nie mam możliwości wyłączenia wyłączenia zintegrowanej w ustawieniach BIOSu
2. Żadne z dodatkowych poleceń do GRUBa nic nie zmienia, tylko nomodeset działa, ale system uruchamia się w rozdzielczości 1024x768 i nie wykrywa poprawnie mojego ekranu który ma rozdzielczość 1600x1200. Może zainstalowanie sterowników Nvidii to zmieni?

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2032
  • 1709
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #6 dnia: 2016-03-31, 20:56:43 »
Sterowniki raczej nie służą do przełączania karty (bynajmniej nie Nvidii), sprawdz/ upewnij się co do ustawień Biosiu / Uefi.

Edytowane:
Przeanalizuj  co to znaczy VGA w instrukcji twojego Biosu, strona: 10 i opcje na stronie 71
Cytuj
VGA Share Memory Size [64M]
Configuration options: [Disabled] [16M] [32M] [64M]
http://dlcdnet.asus.com/pub/ASUS/mb/socket775/P5VD2-MX/e2505_p5vd2-mx_update.pdf
I jak zadziała to nie zapomnij przepiąć kabla od karty do monitora.  :P

Cytuj
nie wykrywa poprawnie mojego ekranu który ma rozdzielczość 1600x1200
To może też być problem samego Ekranu Monitora, w ekranie siedzi układ który odpowiada za informacje o monitorze. (albo sterowników)
http://pclinuxoshelp.com/index.php/EDID
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline lopogo59

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #7 dnia: 2016-04-01, 17:02:42 »
Jak jest włożona zewnętrzna karta to pamięci RAM dzielonej ze zintegrowaną grafiką nie da się zmienić, spróbuję ustawić na "Disabled" zapisać i później zobaczyć co się stanie. A co do ekranu to jest w 100% w porządku, podłączałem do innego komputera i jest bez problemu wykrywany.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2032
  • 1709
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #8 dnia: 2016-04-01, 17:40:27 »
Cytuj
Jak jest włożona zewnętrzna karta to pamięci RAM dzielonej
Kart się raczej nie wkłada do RAM  ???
   Może chodziło Ci o slot jakiś na płycie głównej, np. PCI-E ?

      W każdym razie ja nic nie pisałem o zmianie kart, tylko o sprawdzeniu/zmianie opcji w Biosie i przepięciu kabli
          np. jak twój monitor korzysta z kabla VGA , to przepinasz z płyty głównej na karte zewnętrzną.
             Uruchamiasz ponownie komputer i sie cieszysz.  ;D
                      Jeśli Ci nie wykryje nowej karty i system się wysypie wtedy instalujesz system na nowo i wykryje już nowy sprzęt.
                       ( ze sterownikami Mesa powinno działać bez problemowo, bez konieczności ponownej instalacji )
                            To są podstawowe rzeczy  ;D Może weź zaproś do pomocy jakiegoś kolege bardziej obeznanego na sprzęcie ?
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline lopogo59

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #9 dnia: 2016-04-01, 19:42:27 »
Cytat:  link=topic=24453.msg132114#msg132114 date=1459525227
Cytuj
Jak jest włożona zewnętrzna karta to pamięci RAM dzielonej
Kart się raczej nie wkłada do RAM  ???
   Może chodziło Ci o slot jakiś na płycie głównej, np. PCI-E ?

      W każdym razie ja nic nie pisałem o zmianie kart, tylko o sprawdzeniu/zmianie opcji w Biosie i przepięciu kabli
          np. jak twój monitor korzysta z kabla VGA , to przepinasz z płyty głównej na karte zewnętrzną.
             Uruchamiasz ponownie komputer i sie cieszysz.  ;D
                      Jeśli Ci nie wykryje nowej karty i system się wysypie wtedy instalujesz system na nowo i wykryje już nowy sprzęt.
                       ( ze sterownikami Mesa powinno działać bez problemowo, bez konieczności ponownej instalacji )
                            To są podstawowe rzeczy  ;D Może weź zaproś do pomocy jakiegoś kolege bardziej obeznanego na sprzęcie ?

Źle się zrozumieliśmy. Napisałem "Jak jest włożona zewnętrzna karta to pamięci RAM dzielonej ze zintegrowaną grafiką nie da się zmienić", chodziło mi o to, że opcja VGA Share Memory czyli chyba pamięć ram współdzielona ze zintegrowaną grafiką jest niedostępna po podłączeniu zewnętrznej karty. Aż taki głupi nie jestem żeby podłączenie kabli pomylić i miejsca na RAM z PCI-E ;). Po prostu linux nie uruchamia się z włożoną zewnętrzną kartą graficzną (w poprzednich postach napisałem jakie to błędy miałem przy uruchamianiu), a jak korzystam z integry (z wyjętą kartą Nvidii) to działa normalnie.

Offline lopogo59

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #10 dnia: 2016-04-01, 19:55:50 »
Opiszę wszystko jeszcze raz dokładnie:
1. Przy wyjętej karcie NVIDIA GEFORCE GT 220 i podłączeniu ekranu do portu DVI na płycie głównej (ASUS P5VD2-MX ma zintegrowaną grafikę) linux odpalał bez problemu.
2. Z włożoną kartą Nvidii uruchamianie jakiejkolwiek dystrybucji kończy się na "No irq handler for vector" a w trybie nomodeset uruchamia się, ale w niskiej rozdzielczości i wykrywa ekran jako wbudowany (Built-in display) i nie mogę zmienić rozdzielczości na wyższą niż 1024x768. A co do
Cytuj
Sterowniki raczej nie służą do przełączania karty (bynajmniej nie Nvidii), sprawdz/ upewnij się co do ustawień Biosiu / Uefi.
chodziło o to czy po zainstalowaniu sterowników Nvidii ekran zostanie poprawnie wykryty i w końcu będę mógł ustawić normalną rozdzielczość.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2032
  • 1709
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #11 dnia: 2016-04-02, 12:25:52 »
Cytuj
Po prostu linux nie uruchamia się z włożoną zewnętrzną kartą graficzną
- To wkońcu testowałeś z opcją  VGA Share Memory Size [Disabled]  ?

     
Cytuj
   w trybie nomodeset uruchamia się, ale w niskiej rozdzielczości
  Z tego co czytałem opcja nomodest jest tylko dla GRUBa,
      czyli że bez  nomodest uruchamiają się sterowniki (jakieś, może 3D) i masz boot splash
             i login screen w wysokiej rozdzielczości,
                bez  nomodest jest użyty sterownik VESA o małej rozdzielości.
                       A właściwy sterownik 3D powinien się uruchomić po zalogowaniu się do systemu
        Ale koniec końców, bez tej czy z tą opcją, maksymalne rozdzielczości powinno Ci normalnie wykrywać.
    ( Nie wiem czy rozdzielczości by się nie dało naprawić rozdzielczości bez opcji nomodest instalując
           bardzo starego gruba z super-boot-manager,
              Plymouth Manager, albo coś zmieniając ale nie pamiętam i mogę się mylić )
            - sprawdz jaki Ci wykrywa sterownik
                   http://pclinuxoshelp.com/index.php/Glxinfo
            - sprawdz czy ci wykrywa monitor komendą
monitor-edid
                        jeśli masz taką aplikację dostępną w Ubuntu,
                           sprawdz czy xrandr Ci wykryje prawidłową rozdzielczość monitora
                                https://wiki.ubuntu.com/X/Config/Resolution
                                    Jak chcesz to możesz nawet spróbować zmienić rozdzielczość przy pomocy tego jak chcesz.

Cytuj
chodziło o to czy po zainstalowaniu sterowników Nvidii ekran zostanie poprawnie wykryty
   - To powinno wyglądać tak, zmmieniasz w Biosie karty , lub wyłączasz zintegrowaną, przepinasz kabel
        i jako że pewnie używasz Mesy system powinien wykryć że masz nową kartę i załadować odpowiedni sterownik z Mesy
         ( bo są raczej wszystkie instalowane wraz z Mesą, upewnij się w menadzerze czy tak jest na pewno )
              System powinien działać normalnie,
            jeśli dalej miałbyś problem z rozdzielczością to możesz zainstalować sterownik Nvidia i zobaczyć czy coś się zmieni.
              Ze sterownikami Nvidia powinno Ci wykryć rozdzielczość tak samo dobrze jak z Mesą.

       To że Ci nie wykrywa pełnej rozdzielczości z opcją nomodest możesz zgłosić developerom Ubuntu,
          może coś zaradzą na to.
           Google translator może Ci pomóc z angielskim jak coś  https://translate.google.pl/

Możesz też zmienić rozdzielczość splasha w GRUBie i zobaczyć czy to coś zmieni.
http://netbit73.blogspot.com/2010/09/zabawy-splashem.html

  Edytowane:
   I sparwdz log systemowy Xorg
         np. wten sposób z terminala
       
grep "(EE)\|(WW)\|(NI)\|(??)" /var/log/Xorg.0.log
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline lopogo59

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #12 dnia: 2016-04-02, 17:18:21 »
Cytuj
To wkońcu testowałeś z opcją  VGA Share Memory Size [Disabled]  ?
Tak i wtedy nawet komputer się nie włącza i musiałem ustawienia BIOSu resetować. Nie mam zainstalowanej monitor-edid i dlatego nie mogę też z tej komendy skorzystać, a xrandr przy próbie zmiany rozdzielczości daje tylko "Can't open display". Zainstalowałem również sterowniki Nvidii, które również nie działają (tutaj log xorga http://pastebin.com/XqTt3HG7). Zmiana rozdzielczości splasha w GRUBie też nic nie zmieniła... Jakieś pomysły co może być nie tak?
« Ostatnia zmiana: 2016-04-02, 17:30:00 wysłana przez lopogo59 »

Offline sgleg61

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 5
    • Zobacz profil
Odp: Problem z NVIDIA GeForce GT 220
« Odpowiedź #13 dnia: 2017-02-08, 19:02:30 »
Miałem podobny problem z Nvidia GT 710. Używam Pclinuxos, po zamotowaniu karty załączyłem komputer, wystartował jak przed zamontowaniem karty. Z repozytorium zainstalowałem sterowniki nvidia-current, następnie przez konfiguracja komputera > ustawienia serwera grafiki wybrałem kartę nvidii wyskoczyło pytanie czy stosowac sterowniki nvidii, potwierdziłem. Sprawdziłem xorg.config faktycznie zapisało jako pierwszą kartę nvidia sterownik nvidia i drugą intel sterownik nvidia. Restartowałem, w BIOSie wybrałem preferowaną kartę nvidii PEG karta zintegrowana w moim BIOSie nazywa sie IGFX przestawiłem na auto, pamięć dzielona [shared memory] dotyczy ile pamięci ma być zarezerwowane dla IGFX, zapisalem ustawienia. Na starcie systemu zauważylem nową opcję bootowania 'nokmsboot'  po splash, przed uuid  i system wystartował.
« Ostatnia zmiana: 2018-02-20, 07:48:40 wysłana przez sgleg61 »