Nowe posty

Autor Wątek: Problem z konfiguracją Knoppix-a do sieci  (Przeczytany 370 razy)

  • Gość
Problem z konfiguracją Knoppix-a do sieci
« dnia: 2005-12-29, 17:42:52 »
Zainstalowałam Azureus, ale jest problem z NAT i \\"problem z mapowaniem portów rozproszonej bazy danych\\". Miałam komunikat, żeby(jeśli używam routera) ustawić port na 6883. Zrobiłam tak i używając system-config-securitylevel odblokowałam ten port. Ale dalej jest to samo i nie mogę ściągać. Co robić? Używam Fedory 4.

  • Gość
Problem z konfiguracją Knoppix-a do sieci
« Odpowiedź #1 dnia: 2005-12-29, 20:58:04 »
Przepraszam za zawracanie głowy... Jeśli ktoś ma taki problem z NATem jak ja to należy otworzyć ten port na routerze. Dla routera Asmax jest to przystępnie opisane na www.asmax.com/forum. Dalej jednak mam komunikat o problemie z mapowaniem rozproszonej bazy danych :-(. Co z tym zrobić?

Maciek_Rutecki

  • Gość
Problem z konfiguracją Knoppix-a do sieci
« Odpowiedź #2 dnia: 2005-12-29, 21:10:09 »
2005-12-29 20:58:04 Shaer napisał:


 > Dalej jednak mam komunikat o problemie z mapowaniem rozproszonej bazy danych :-(. Co z tym
 > zrobić?

Mam ten sam problem i go... ignoruje, jakoś działa :-)

--
Maciek

bluedevil275

  • Gość
Problem z konfiguracją Knoppix-a do sieci
« Odpowiedź #3 dnia: 2006-09-23, 00:24:19 »
2005-12-29 21:10:09 Maciek_Rutecki napisał:

> 2005-12-29 20:58:04 Shaer napisał:
 >
 >
 >  > Dalej jednak mam komunikat o problemie z mapowaniem rozproszonej bazy danych :-(. Co z
 > tym
 >  > zrobić?
 >
 > Mam ten sam problem i go... ignoruje, jakoś działa :-)
 >
 > --
 > Maciek

u mnie jest identycznie (mandriva 2006). moje rozwiazanie: otwieram ogniomurek i wszystko gra. po skonczonym ssaniu zamykam go znowu. moj azu-port:6881.

  • Gość
Problem z konfiguracją Knoppix-a do sieci
« Odpowiedź #4 dnia: 2005-12-29, 14:51:19 »
Witam

Mam chyba konflikt sprzętowy. Ponieważ pojawia się komunikat:
SIOCSIFFLAGS: Devise or resourse busy (źródło są zajęte).

Zastanaiam się czy nie kupić drugą kartę sieciową dla Linux-sa.
Jeżeli muszę kupić drugą kartę sieciową to muszę mieć zgodę firmy Hyperion. Nie wiem jaką kartę sieciową wybrać.

Mam Knoppix 3.2 i Red Had 9. Nie pomagają automatyczne ani ręczne ustawienie konfiguracji bo ciągle pojawia się komunikat "źródło lub zasoby są zajęte".

Mam karte sieciową Realtek RTL8139 Family PCI Fast Ethernet NIC. Dokładny opis karty: "10/100Mbps PCI Fast Ethernet Adapter Driver Program Rev:1.0".

Podaję swój dokładny adres IP (pokazuje to w Windows):
Adres fizyczny: 00-E0-15-04-D9
Adres IP: 10.60.50.167
Maska podsieci: 255.255.255.0
Brama domyślna: 10.60.50.1
Serwer DHCP: 10.60.50.1
Serwer DNS: 194.204.152.34 lub 194.204.152.1
Serwer WINS - Brak

Podam przykład mojej konfiguracji (może zauważy pan jakiś błąd):

 Knoppix 3.2 (uruchamiam tylko cd czyli bootowanie)
 K->Knoppix->Network/Internet->Network Card Configuration
 Komunikat: W oknie->Xdialog: "No supported network cards
                               found".
 K->Knoppix->Network/Internet->Root Shell
 # lsmod (brakuje go na liście więc wpisuje modprobe... )
 # modprobe 8139too
 # netconf lub netconfig (nie wykonuje polecenia)

 Po wpisaniu "modprobe 8139too"
 (to zmienia komunikat w netcardconfig)

 # netcardconfig
 Pokazuje komunikat: Sending DHCP broadcast from device eth0
 Operation failed. Failed. Hit return to exit.

 # ifconfig eth0 10.60.50.167 netmask 255.255.255.0 broadcast  
    10.60.50.1 up
 Pokazuje komunikat: SIOCSIFFLAGS: Device or resource busy                                          
                     SIOCSIFFLAGS: Device or resource busy      
                     
 Mimo ze zrodlo sa zajete ale podajac polecenie: ifconfig eth0
 Pokazuje komunikat:

 # ifconfig eth0
 # eth0 Link encap:Ethernet HWaddr 00:E0:4D:15:04:D9                
 inet addr:10.60.50.167 Bcast:10.60.50.1 Mask:255.255.255.0     
 BROADCAST MULTICAST MTU:1500 Metric:1      
 RX packets:0 errors:0 dropped:0 overruns:0 frame:0      
 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0      
 collisions:0 txqueuelen:100      
 RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)      
 Base address:0xd000

 # /etc/network/interfaces 10.60.50.167
 Pokazuje komunikat: bash: /etc/network/interfaces: Permission
 denied

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
 Pokazuje komunikat: bash: syntax error near unexpected token
 '('

 # /etc/init.d/network restart
 Pokazuje komunikat: Reconfiguring network interfaces... done
 Nie wiem co dalej robi. Nie laczy Mozilla przez internet
 
 Jesli dam netcardconfig to Use DHCP broadcast ? YES

 To wymazuje zpamięci adresy IP.

 # iface eth0 inet static 10.60.50.167
   address 10.60.50.167
   netmask 255.255.255.0
   gateway 10.60.50.1

  # iface eth0 inet dhtp 10.60.50.167

 Pokazuje komunikat: bash: iface: Permission denied

 Bardzo proszę o radę.