Nowe posty

xx Strona o testach penetracyjnych, hackingu (20)
2021-11-28, 20:39:47
xx Przydatne Linki (11)
2021-11-18, 01:50:23
xx Lekka przeglądarki (4)
2021-11-13, 10:58:18
xx Przejście z iptables na nftables. Serwer z DNS i VPN... (0)
2021-11-12, 11:20:40
xx SSH (5)
2021-11-11, 09:11:41
xx audio debian problem (12)
2021-11-09, 12:01:43
xx czyszczenie systemu (31)
2021-11-07, 14:41:26
xx Jak przekierować port (1)
2021-11-06, 09:52:44
xx kdenlive nie chce się uruchomić (14)
2021-10-29, 08:38:52
xx Aktualizacja Ubuntu 20.4 do 21.10. Kmail nie zapisuje haseł (10)
2021-10-28, 16:48:20

Autor Wątek: PROBLEM LAIKA  (Przeczytany 7334 razy)

joca

  • Gość
PROBLEM LAIKA
« dnia: 2005-11-20, 16:23:59 »
Mam problem z podniesieniem ver. glib-config . Obecnie mam glib-1.2.1 a potrzebuję mieć przynajmniej glib-1.2.2. Instaluję ze żródeł glib-1.2.2 przy (./configure) na koniec otrzymuję
creating config.h
config.h is unchanged
creating glibconfig.h
glibconfig.h is unchanged
podobnie jest przy glib-1.2.3
na końcu ./configure otrzymuję
glibconfig.h is unchanged
mimo błędów próbowałem instalować bez rezultatu dalej sprawdzając ver. jest 1.2.1
co jest nie tak czy powinienem odinstalować glib-1.2.1 najpierw  (jak? bo make uninstall - nie odinstalowuje) Mój linux Mandrake 10.0
Proszę o helpa możliwie łopatologicznego


jk33

  • Gość
PROBLEM LAIKA
« Odpowiedź #1 dnia: 2005-11-20, 17:03:25 »
2005-11-20 16:23:59 joca napisał:

> Mam problem z podniesieniem ver. glib-config . Obecnie mam glib-1.2.1 a potrzebuję mieć
 > przynajmniej glib-1.2.2. Instaluję ze żródeł glib-1.2.2 przy (./configure) na koniec otrzymuję
 >
 > creating config.h
 > config.h is unchanged
 > creating glibconfig.h
 > glibconfig.h is unchanged
 > podobnie jest przy glib-1.2.3
 > na końcu ./configure otrzymuję
 > glibconfig.h is unchanged
 > mimo błędów próbowałem instalować bez rezultatu

Jakie błędy? Nie widzę tu żadnych.

dalej sprawdzając ver. jest 1.2.1
 > co jest nie tak czy powinienem odinstalować glib-1.2.1 najpierw  (jak? bo make uninstall - nie
 > odinstalowuje) Mój linux Mandrake 10.0
 > Proszę o helpa możliwie łopatologicznego
 >

Najlepiej byloby poszukać rpmów
z glibem. A jak koniecznie chcesz ze źródeł to:
rpm -e --nodeps glib glib-devel
Odinstalujesz wersję z dystrybucji
i później ./configure --prefix=/usr
make
make install

pozdrawiam

joca

  • Gość
PROBLEM LAIKA
« Odpowiedź #2 dnia: 2005-11-21, 16:24:18 »
2005-11-20 17:03:25 jk33 napisał:

> 2005-11-20 16:23:59 joca napisał:
 >
 > > Mam problem z podniesieniem ver. glib-config . Obecnie mam glib-1.2.1 a potrzebuję mieć
 >  > przynajmniej glib-1.2.2. Instaluję ze żródeł glib-1.2.2 przy (./configure) na koniec
 > otrzymuję
 >  >
 >  > creating config.h
 >  > config.h is unchanged
 >  > creating glibconfig.h
 >  > glibconfig.h is unchanged
 >  > podobnie jest przy glib-1.2.3
 >  > na końcu ./configure otrzymuję
 >  > glibconfig.h is unchanged
 >  > mimo błędów próbowałem instalować bez rezultatu
 >
 > Jakie błędy? Nie widzę tu żadnych.
 >
 > dalej sprawdzając ver. jest 1.2.1
 >  > co jest nie tak czy powinienem odinstalować glib-1.2.1 najpierw  (jak? bo make uninstall
 > - nie
 >  > odinstalowuje) Mój linux Mandrake 10.0
 >  > Proszę o helpa możliwie łopatologicznego
 >  >
 >
 > Najlepiej byloby poszukać rpmów
 > z glibem. A jak koniecznie chcesz ze źródeł to:
 > rpm -e --nodeps glib glib-devel
 > Odinstalujesz wersję z dystrybucji
 > i później ./configure --prefix=/usr
 > make
 > make install
 >
 > pozdrawiam

joca

  • Gość
PROBLEM LAIKA
« Odpowiedź #3 dnia: 2005-11-21, 16:37:37 »
znalazłem rpm-a obecnie mam glib-config ver. 1.2.10 bez odinstalowania 1.2.1.
dzięki za sugestie
Ale teraz mam problem bo instalując XMMs 1.2.10 (wpisując ./configure) wywala mi błędy:
checking for pthread.h... yes
checking for glib-config... /usr/bin/glib-config
checking for GLIB - version >= 1.2.2...
*** \\'glib-config --version\\' returned 1.2.10, but GLIB (1.2.2)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

czy powinienem instalować glib 1.2.2 i nic wyżej?
próbowałem już odinstalować glib (rpm -e --nodeps glib glib-devel ) dostaję informacje  (błąd: pakiet glib nie jest zainstalowany) kiedy wpisuję glib-config --version dostaję odpowiedz 1.2.10
a może ktoś poda mi linka skad ściągnąć xmm w rpm-e pod Mandrake 10.0
dzięki za ewentualne zainteresowanie moim problemem pozdrawiam wszystkich

jk33

  • Gość
PROBLEM LAIKA
« Odpowiedź #4 dnia: 2005-11-21, 16:46:15 »
spróbój rpm -e --nodeps libglib1.2 libglib1.2-devel

I później jeszcze raz make install gliba ze źródeł.



joca

  • Gość
PROBLEM LAIKA
« Odpowiedź #5 dnia: 2005-11-21, 20:09:30 »
2005-11-21 16:46:15 jk33 napisał:

> spróbój rpm -e --nodeps libglib1.2 libglib1.2-devel
 >
 > I później jeszcze raz make install gliba ze źródeł.
 >
 >
 > jeśli chodzi o odinstalowanie glib działa dzięki
muszę teraz poszukać glib1.2.2 bo 1.2.10 dalej wywalał ten sam błąd i zobaczymy.
jak zainstaluję napiszę jak i zamknę wątek albo będę pytał dalej. POZDRAWIAM

joca

  • Gość
PROBLEM LAIKA
« Odpowiedź #6 dnia: 2005-11-23, 21:03:13 »
po zainstalowaniu gtk+1.2.10 i glib1.2.10 pojawiał się dalej błąd przy ./configure
checking for GLIB - version >= 1.2.2...
*** \\'glib-config --version\\' returned 1.2.10, but GLIB (1.2.2)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

mimo błędu zainstalowałem xmms-a
i działa

krzychu.qn

  • Gość
PROBLEM LAIKA
« Odpowiedź #7 dnia: 2005-11-20, 14:06:33 »
posiadam aurox linux wersje 9.3.1 i wszystko było dobrze do czasu kiedy zaktualizowałem linuxa do wersji 10.1, teraz iksy mi nie wchodzą system wyświetla następującą informacje:

INIT: Id "x" respawning to fast : disabled for 5 minutes

komunikat się powtarza co 5 minut...

sprawdzałem konfiguracje XF86 ale wszystko wygląda tak samo jak przed akutalizacją i nie wiem co mam zrobić żeby iksy włączyć

jk33

  • Gość
PROBLEM LAIKA
« Odpowiedź #8 dnia: 2005-11-20, 14:16:43 »
2005-11-20 14:06:33 krzychu.qn napisał:

> posiadam aurox linux wersje 9.3.1 i wszystko było dobrze do czasu kiedy zaktualizowałem linuxa
 > do wersji 10.1, teraz iksy mi nie wchodzą system wyświetla następującą informacje:
 >
 > INIT: Id "x" respawning to fast : disabled for 5 minutes
 >
 > komunikat się powtarza co 5 minut...
 >
 > sprawdzałem konfiguracje XF86 ale wszystko wygląda tak samo jak przed akutalizacją i nie wiem
 > co mam zrobić żeby iksy włączyć

1) Spróbuj ustawić sterownik karty graficznej na vesa
i zobacz czy pójdzie.

2) zaloguj się na konsoli i wklep startx.
Zobacz jakie będą komunikaty o błędach.

3) Jaką masz kartę graficzną.
Czy instalowałeś sterownik do niej?

4) W auroksie 9.3 było XFree,
ale czy w 10 nie jest już xorg?
Może musisz skopiować plik konfiguracyjny
(/etc/X11/XF86Config-4 na /etc/X11/xorg.conf).

pozdrawiam

krzychu.qn

  • Gość
PROBLEM LAIKA
« Odpowiedź #9 dnia: 2005-11-20, 17:25:25 »
2005-11-20 14:16:43 jk33 napisał:

> 2005-11-20 14:06:33 krzychu.qn napisał:
 >
 > > posiadam aurox linux wersje 9.3.1 i wszystko było dobrze do czasu kiedy zaktualizowałem
 > linuxa
 >  > do wersji 10.1, teraz iksy mi nie wchodzą system wyświetla następującą informacje:
 >  >
 >  > INIT: Id "x" respawning to fast : disabled for 5 minutes
 >  >
 >  > komunikat się powtarza co 5 minut...
 >  >
 >  > sprawdzałem konfiguracje XF86 ale wszystko wygląda tak samo jak przed akutalizacją i nie
 > wiem
 >  > co mam zrobić żeby iksy włączyć
 >
 > 1) Spróbuj ustawić sterownik karty graficznej na vesa
 > i zobacz czy pójdzie.
 >
 > 2) zaloguj się na konsoli i wklep startx.
 > Zobacz jakie będą komunikaty o błędach.
 >
 > 3) Jaką masz kartę graficzną.
 > Czy instalowałeś sterownik do niej?
 >
 > 4) W auroksie 9.3 było XFree,
 > ale czy w 10 nie jest już xorg?
 > Może musisz skopiować plik konfiguracyjny
 > (/etc/X11/XF86Config-4 na /etc/X11/xorg.conf).
 >
 > pozdrawiam
 >
niestety problem jest poważniejszy, wpisałem startx i wyskoczyło kilka błędów... ogólnie wszystkie dotyczyły "Input Device" nie chce mi ładować myszki ani klawiatury czasami wyświetla mi też no screen found pisze też o jakimś błędzie core pointer nie wiem jak mam to rozwiązać

chmooreck

  • Gość
PROBLEM LAIKA
« Odpowiedź #10 dnia: 2005-11-20, 17:33:25 »
2005-11-20 17:25:25 krzychu.qn napisał:

 > niestety problem jest poważniejszy, wpisałem startx i wyskoczyło kilka błędów... ogólnie
 > wszystkie dotyczyły "Input Device" nie chce mi ładować myszki ani klawiatury czasami
 > wyświetla mi też no screen found pisze też o jakimś błędzie core pointer nie wiem jak mam to
 > rozwiązać

dopoki nie napiszesz jakie to dokladnie bledy, bedzie bardzo trudno ci pomoc ;-)

poczytaj sobie http://rtfm.killfile.pl

krzychu.qn

  • Gość
PROBLEM LAIKA
« Odpowiedź #11 dnia: 2005-11-20, 17:57:14 »
2005-11-20 17:33:25 chmooreck napisał:

> 2005-11-20 17:25:25 krzychu.qn napisał:
 >
 >  > niestety problem jest poważniejszy, wpisałem startx i wyskoczyło kilka błędów... ogólnie
 >  > wszystkie dotyczyły "Input Device" nie chce mi ładować myszki ani klawiatury
 > czasami
 >  > wyświetla mi też no screen found pisze też o jakimś błędzie core pointer nie wiem jak mam
 > to
 >  > rozwiązać
 >
 > dopoki nie napiszesz jakie to dokladnie bledy, bedzie bardzo trudno ci pomoc ;-)
 >
 > poczytaj sobie http://rtfm.killfile.pl

oto te błędy:
(EE) xf86OpenSerial: Cannot open device /dev/psaux
   No such file or directory.
(EE) Mouse0: cannot open input device
(EE) PreInit failed for input device "Mouse0"

No core pointer

Fatal server error:
failed to initialize core devices

z góry dziękuje za pomoc

jk33

  • Gość
PROBLEM LAIKA
« Odpowiedź #12 dnia: 2005-11-20, 18:26:53 »
2005-11-20 17:57:14 krzychu.qn napisał:
 > oto te błędy:
 > (EE) xf86OpenSerial: Cannot open device /dev/psaux
 >    No such file or directory.
 > (EE) Mouse0: cannot open input device
 > (EE) PreInit failed for input device "Mouse0"
 >

Spróbuj w pliku konfiguracyjnym
zamienić /dev/psaux na
/dev/input/mouse albo /dev/mouse


krzychu.qn

  • Gość
PROBLEM LAIKA
« Odpowiedź #13 dnia: 2005-11-20, 19:14:37 »
2005-11-20 18:26:53 jk33 napisał:

> 2005-11-20 17:57:14 krzychu.qn napisał:
 >  > oto te błędy:
 >  > (EE) xf86OpenSerial: Cannot open device /dev/psaux
 >  >    No such file or directory.
 >  > (EE) Mouse0: cannot open input device
 >  > (EE) PreInit failed for input device "Mouse0"
 >  >
 >
 > Spróbuj w pliku konfiguracyjnym
 > zamienić /dev/psaux na
 > /dev/input/mouse albo /dev/mouse
 >
 >

to niestety nic nie daje...

chmooreck

  • Gość
PROBLEM LAIKA
« Odpowiedź #14 dnia: 2005-11-20, 19:42:33 »
2005-11-20 19:14:37 krzychu.qn napisał:

> 2005-11-20 18:26:53 jk33 napisał:
 >
 > > 2005-11-20 17:57:14 krzychu.qn napisał:
 >  >  > oto te błędy:
 >  >  > (EE) xf86OpenSerial: Cannot open device /dev/psaux
 >  >  >    No such file or directory.
 >  >  > (EE) Mouse0: cannot open input device
 >  >  > (EE) PreInit failed for input device "Mouse0"
 >  >  >
 >  >
 >  > Spróbuj w pliku konfiguracyjnym
 >  > zamienić /dev/psaux na
 >  > /dev/input/mouse albo /dev/mouse
 >  >
 >  >
 >
 > to niestety nic nie daje...
 >

przed zmieniaem sprwadz jakie masz urzadzenia w /dev , ktore moga odpowiadac myszce... tak chyba bedzie lepiej, niz zgadywac ;-)