Nowe posty

Autor Wątek: nie poprawnie mycha labteca  (Przeczytany 688 razy)

Nevi

  • Gość
nie poprawnie mycha labteca
« dnia: 2005-07-19, 12:22:20 »
Zainstalowa?em sobie gentoo 2005.0, w komputerze mia?em ju? jednego linuxa Mandrak\\'a, wi?c spod mandrak\\'a doda?em wpisy do LILO. Gdy próbuje w??czy? Gentoo wy?wietla mi si? b??d  \\"Kernel panic - not syncing: VFS: Unable to mount root\\". Dlaczego kernel panikuje ;0? :)
PS : Mandrake wykrywa mi dysk jako hda i tak go dodaje w LILO, natomist Gentoo sda mo?e to przez to? W takim razie jak zrobi? bym móg? wreszcie uruchomi? GENTOO?

michalk

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #1 dnia: 2005-07-19, 12:51:56 »
2005-07-19 12:22:20 Nevi napisa?:

> Zainstalowa?em sobie gentoo 2005.0, w komputerze mia?em ju? jednego linuxa Mandrak\\'a, wi?c spod
 > mandrak\\'a doda?em wpisy do LILO. Gdy próbuje w??czy? Gentoo wy?wietla mi si? b??d  \\"Kernel
 > panic - not syncing: VFS: Unable to mount root\\". Dlaczego kernel panikuje ;0? :)
 > PS : Mandrake wykrywa mi dysk jako hda i tak go dodaje w LILO, natomist Gentoo sda mo?e to
 > przez to? W takim razie jak zrobi? bym móg? wreszcie uruchomi? GENTOO?

jaki masz dysk - sata czy ata?

Nevi

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #2 dnia: 2005-07-19, 12:58:36 »
sata

chmooreck

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #3 dnia: 2005-07-19, 13:05:09 »
musisz miec:

a) obsluge swojego kontrolera wkompilowana w jadro

LUB

b) modul obslugi swojego kontrolera zaladowany w initrd

inaczej kernel nie bedzie widzial ci tego dysku

Nevi

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #4 dnia: 2005-07-19, 13:14:08 »
2005-07-19 13:05:09 chmooreck napisa?:

> musisz miec:
 >
 > a) obsluge swojego kontrolera wkompilowana w jadro
 >
 > LUB
 >
 > b) modul obslugi swojego kontrolera zaladowany w initrd
 >
 > inaczej kernel nie bedzie widzial ci tego dysku

dobra, które prostsze i jak to zrobi? :)?

individual

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #5 dnia: 2005-07-19, 13:20:56 »
Najlepiej sterowniki do obs?ugi dysku twardego i systemu plików mie? wkomplilowane na sta?e.
Musisz si? chrootwa? na gentoo, ponownie zrobi? make menuconfig i w??czy? na sta?e te elementy które u?ywasz przy ka?dym uruchomieniu systemu (np sata - ale to z poziomu SCSI jest jeszcze rozwi?zanie starsze w dyskach IDE ale tego nie w??czaj) reiserfs (je?li u?ywasz) czy inny system plkiów. To samo dotyczy USB. Obs?ug? wkompliluj na sta?e, ale sterowniki do poszczególnych u??dze? jako modu?y.

Aha przy chrootowaniu nie zapomnij o pod??czeniu proc, zrobieniu env-update i source /etc/profile

95% b??dów przy uruchamianiu Gentoo po raz pierwsz to albo b??dy kernela albo gruba (tak naprawd? z?a konfiguracja w/w)

Nevi

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #6 dnia: 2005-07-19, 13:45:00 »
2005-07-19 13:20:56 individual napisa?:

> Najlepiej sterowniki do obs?ugi dysku twardego i systemu plików mie? wkomplilowane na sta?e.
 > Musisz si? chrootwa? na gentoo, ponownie zrobi? make menuconfig i w??czy? na sta?e te elementy
 > które u?ywasz przy ka?dym uruchomieniu systemu (np sata - ale to z poziomu SCSI jest jeszcze
 > rozwi?zanie starsze w dyskach IDE ale tego nie w??czaj) reiserfs (je?li u?ywasz) czy inny
 > system plkiów. To samo dotyczy USB. Obs?ug? wkompliluj na sta?e, ale sterowniki do
 > poszczególnych u??dze? jako modu?y.
 >
 > Aha przy chrootowaniu nie zapomnij o pod??czeniu proc, zrobieniu env-update i source
 > /etc/profile
 >
 > 95% b??dów przy uruchamianiu Gentoo po raz pierwsz to albo b??dy kernela albo gruba (tak
 > naprawd? z?a konfiguracja w/w)
Jak sobie przegl?dam configa jajka to tam ju? jest  zaznaczone wszystko, obs?uga SATA, wszystkie typy partycji których u?ywam :(.

chmooreck

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #7 dnia: 2005-07-19, 14:24:54 »
 > Jak sobie przegl?dam configa jajka to tam ju? jest  zaznaczone wszystko, obs?uga SATA,
 > wszystkie typy partycji których u?ywam :(.

nie moze byc.. jaki masz chipset ?

na 100% modul twojego kontrolera jest jako modul :-)

no chyba, ze faktycznie nie masz wkompilowanej obslugi systemu plikow, ktory jest na partycji /

jaki masz fs na / ?

bojleros

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #8 dnia: 2005-07-19, 14:28:46 »
mam kontroler silicon image 3112 na p?ycie asusa , uzywam sterownika do siliconimage z ga?ezi scsi , który rozpoznaje mój dysk jako sdai sdb  . jest jeszcze drugi sterownik , starszy który rozpoznaje dyski jako hde i hdf. jezeli moge to polecam tego na scsi , wkompiluj go w j?dro bo po co szczypa? si? w modu?y z czym? czego i tak musisz uzywa?.

przed chrootowaniem zbinduj sobie /proc do miejsca gdzie jest proc ?rodowiska gdzie sie bedziesz chroot....

jakby? mia? problem z lilo to zawsze pamietaj jak kernel który chcesz zabootowa? bedzie widzia? twój dysk a jak go widzi obecnie zabootowany kernel i w zalezno?ci od tego edytuj lilo.conf i updatuj bootrecord przez wpisanie lilo

jezeli nie bedizesz mia? odpowiednich urzadzen w /dev to zawsze mozesz je zmajstrowa? przez MAKEDEV


Nevi

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #9 dnia: 2005-07-19, 14:50:45 »
2005-07-19 14:24:54 chmooreck napisa?:

>
 >  > Jak sobie przegl?dam configa jajka to tam ju? jest  zaznaczone wszystko, obs?uga SATA,
 >  > wszystkie typy partycji których u?ywam :(.
 >
 > nie moze byc.. jaki masz chipset ?
 >
 > na 100% modul twojego kontrolera jest jako modul :-)
 >
 > no chyba, ze faktycznie nie masz wkompilowanej obslugi systemu plikow, ktory jest na partycji /
 >
 >
 > jaki masz fs na / ?
fs na / jest ext3
chipset VIA  (zaznaczony w configu dla SATA)

haves

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #10 dnia: 2006-01-23, 08:32:31 »
ja tez mialem z tym problem
sprawdz sobie czy twój system plikow jest wkompilowany w jajki jak tak to skopiuj bzImage dodaj go do lilo i przejdz do /usr/src/linux-2.6.x
i wydaj komende make install
Nie wiem cemu ale to dziala tak w manualu do kernela pisze wszystkie inne metody zawodza

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #11 dnia: 2006-01-23, 15:56:37 »
2005-07-19 14:50:45 Nevi napisał:

 >  > jaki masz fs na / ?
 > fs na / jest ext3
 > chipset VIA  (zaznaczony w configu dla SATA)

 > No to dorzucę swoje trzy grosze :)
 > Po pierwsze: jaki masz procesor ?
  \\"Ważne: LILO może być użyte tylko dla architektury x86!\\"
 > Po drugie:
  \\"Następnie przechodzimy do File Systems i wybieramy obsługę systemów plików, z których zamierzamy używać. Jeśli pominiemy ten krok, to Gentoo nie będzie w stanie zamontować niektórych partycji lub nawet się nie uruchomi. Sterowniki te również powinny być wkompilowane w jądro na stałe, nie należy ich dodawać w modułach. Oprócz tego zaznaczamy opcje Virtual memory i /proc file system. Użytkownicy jąder 2.4 wciąż muszą korzystać z /dev file system, ponieważ jądra te nie obsługują udev.\\"
  Jestem pewny że to jest to. Jeśli masz kernela 2.6 i wkompilowałes \\"/dev file system support\\" to na pewno Gentoo sie nie uruchomi.
Cytaty zaczerpnięte z: http://www.gentoo.org/doc/pl/list.xml
 > Po trzecie:jakie mazs ustawione kodowanie? Zamiast polskich liter to  widzę krzaki :(
 > Po czwarte: jak uruchomisz Gentoo to wywal Mandarynę :)
 > Po piąte: powodzenia


przemsi

  • Gość
nie poprawnie mycha labteca
« Odpowiedź #12 dnia: 2005-07-19, 08:56:54 »
mam problem zakupilem klaw i myche labteca ultra flat wirlless,klaw dziala,mycha pod konsola dziala na prot imps/2 i ps2 chociaz warjuje na imps/2 problem jest taki wskakuje na x i dupa raz dziala raz nie ?? wylaczylem juz rolke , mysle moze ona ?? ale nic to wylaczylem gpm i to samo ,a wiem ze labtec to logitech a logitach ma inny protokol(nie zawsze ale moze w tym przpadku) bo czytalem mana , niech mi ktos cos podpowie nie zalaczam xorg.conf poniewaz mialem kulke radiowa dexxy i chodzila i samsung opto na kablu tez chodzil a w xorg.conf jest # ChordMiddle is an option for some 3-button Logitech mice

# Option "ChordMiddle"

to tez probowalem, pomocy bo chcialbym zeby mi to dzialalo bede wdzieczny(nie wszystko mozna wiedziec od razu)