Nowe posty

Autor Wątek: Pytania o biblioteki.  (Przeczytany 754 razy)

MichaUeQ

  • Gość
Pytania o biblioteki.
« dnia: 2005-05-22, 23:43:31 »
mam Mandriva LE 2005, kiedy chce zainstalować Xmms,wyskakuje błąd: error: *** GLIB >= 1.2.2 not installed - please install first ***.czyli trzeba zainstalować GLIB w wersji 1.2.2 lub nowszy.Ja zainstalowałem wersje 2.6.4 (w tej chwili najnowsza),ale to nie pomogło,nadal wypisuje error: *** GLIB >= 1.2.2 not installed - please install first ***.Wie ktoś dlaczego tak jest? Przecież 2.6.4 jest nowsze od 1.2.2.Moze chodzi o to ze jest \\"za nowe\\".Może ktoś mi doradzić? Dziekuję.

mandylion

  • Gość
Pytania o biblioteki.
« Odpowiedź #1 dnia: 2005-05-23, 01:21:51 »
2005-05-22 23:43:31 MichaUeQ napisał:

> mam Mandriva LE 2005, kiedy chce zainstalować Xmms,wyskakuje błąd: error: *** GLIB >= 1.2.2
 > not installed - please install first ***.czyli trzeba zainstalować GLIB w wersji 1.2.2 lub
 > nowszy.Ja zainstalowałem wersje 2.6.4 (w tej chwili najnowsza),ale to nie pomogło,nadal
 > wypisuje error: *** GLIB >= 1.2.2 not installed - please install first ***.Wie ktoś dlaczego
 > tak jest? Przecież 2.6.4 jest nowsze od 1.2.2.Moze chodzi o to ze jest \\"za nowe\\".Może
 > ktoś mi doradzić? Dziekuję.

Witam
xmms uzywa gtk w wersji 1 czyli musisz zainstalowac wersje 1.... glib gtk
spobuj moze BMP czyli beep-media-player oparty jest na gtk 2  
pozdrawiam

MichaUeQ

  • Gość
Pytania o biblioteki.
« Odpowiedź #2 dnia: 2005-05-23, 23:36:06 »
2005-05-23 01:21:51 mandylion napisał:

> 2005-05-22 23:43:31 MichaUeQ napisał:
 >
 > > mam Mandriva LE 2005, kiedy chce zainstalować Xmms,wyskakuje błąd: error: *** GLIB >=
 > 1.2.2
 >  > not installed - please install first ***.czyli trzeba zainstalować GLIB w wersji 1.2.2
 > lub
 >  > nowszy.Ja zainstalowałem wersje 2.6.4 (w tej chwili najnowsza),ale to nie pomogło,nadal
 >  > wypisuje error: *** GLIB >= 1.2.2 not installed - please install first ***.Wie ktoś
 > dlaczego
 >  > tak jest? Przecież 2.6.4 jest nowsze od 1.2.2.Moze chodzi o to ze jest \\"za
 > nowe\\".Może
 >  > ktoś mi doradzić? Dziekuję.
 >
 > Witam
 > xmms uzywa gtk w wersji 1 czyli musisz zainstalowac wersje 1.... glib gtk
 > spobuj moze BMP czyli beep-media-player oparty jest na gtk 2  
 > pozdrawiam

ale w błędzie nic nie pisze o GTK,tylko jest wspomniane o GLIB. GTK tez trzeba będzie zainstalować?

xis

  • Gość
Pytania o biblioteki.
« Odpowiedź #3 dnia: 2005-05-23, 23:56:23 »
Nie mylisz przypadkiem Glib i GlibC?
To są zupełnie różne pakiety.

Co do gliba, to nie jestem pewny, ale z gtk jest tak, że gtk i gtk2 to zupełnie inne linie pakietów.

MichaUeQ

  • Gość
Pytania o biblioteki.
« Odpowiedź #4 dnia: 2005-05-24, 00:07:15 »
2005-05-23 23:56:23 xis napisał:

> Nie mylisz przypadkiem Glib i GlibC?
 > To są zupełnie różne pakiety.
 >
 > Co do gliba, to nie jestem pewny, ale z gtk jest tak, że gtk i gtk2 to zupełnie inne linie
 > pakietów.
 >

CHyba nie myle,raczej chodzi o GLIB.A co do GTK to nic nie bylo mowy o tym ze rowniez musi byc zainstalowany aby Xmms dzialal.

xis

  • Gość
Pytania o biblioteki.
« Odpowiedź #5 dnia: 2005-05-24, 10:52:43 »
Mam dla Ciebie doskonałą radę:
Przeszukaj to forum (albo dział Artykuły i FAQ) pod kątem słowa \\'urpmi\\'. Skonfiguruj urpmi i zainstaluj po prostu xmms. Ten program sam zadba o zależności i nic Cię nie będzie obchodziło :)

smard

  • Gość
Pytania o biblioteki.
« Odpowiedź #6 dnia: 2005-05-28, 13:23:34 »
2005-05-24 10:52:43 xis napisał:

> Mam dla Ciebie doskonałą radę:
 > Przeszukaj to forum (albo dział Artykuły i FAQ) pod kątem słowa \\'urpmi\\'. Skonfiguruj urpmi i
 > zainstaluj po prostu xmms. Ten program sam zadba o zależności i nic Cię nie będzie obchodziło
 > :)
 >
czy moze ten blad byc spowodowany tym ze wlasnie baza danych URPMI jest zablokowana?:>??

ika

  • Gość
Pytania o biblioteki.
« Odpowiedź #7 dnia: 2005-08-01, 01:38:30 »
2005-05-22 23:43:31 MichaUeQ napisał:

> mam Mandriva LE 2005, kiedy chce zainstalować Xmms,wyskakuje błąd: error: *** GLIB >= 1.2.2
 > not installed - please install first ***.czyli trzeba zainstalować GLIB w wersji 1.2.2 lub
 > nowszy.Ja zainstalowałem wersje 2.6.4 (w tej chwili najnowsza),ale to nie pomogło,nadal
 > wypisuje error: *** GLIB >= 1.2.2 not installed - please install first ***.Wie ktoś dlaczego
 > tak jest? Przecież 2.6.4 jest nowsze od 1.2.2.Moze chodzi o to ze jest \\"za nowe\\".Może
 > ktoś mi doradzić? Dziekuję.


Witam. Ja też mam problem z Glib przy instalowaniu Xmms (pod Mandrake 10.0) - wypisuje coś takiego:

checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.2...
*** \\'glib-config --version\\' returned 1.2.2, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

Mam zainstalowane GLIB-1.2.2, natomiast żadnej wersji 1.2.10 nie instalowałam. Próbowałam już ustawiać wartość zmiennej GLIB_CONFIG na /usr/local/bin/glib-config (chyba o to chodziło w tym \\"set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config\\"?) ale bez efektów, nadal to samo. Nie bardzo wiem co dalej z tym zrobić. Czy ktoś może mi pomóc? Z góry dziękuję.

coldfire

  • Gość
Pytania o biblioteki.
« Odpowiedź #8 dnia: 2005-05-22, 21:53:14 »
Witam. Już wcześniej prosiłem o odpowiedź bardziej "elegancko"-co nie znaczy, że teraz poproszę o chamsku, jednak teraz proszę o odpowiedź jak dla 5 latka.
W czasie kompilacji super karamby .36 pojawia mi się:
"checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!
"
w czasie kompilacji kadu pojawia się:
"checking if libpng is in system directories... no
checking if libpng is in specified directories:     /usr/lib /usr/local/lib /sw/lib... not found
libpng not found - checking for zlib first
checking if libz is in system directories... no
checking if libz is in specified directories:       /usr/lib /usr/local/lib /sw/lib... not found
configure: error: libz not found - please install zlib-devel
Instalacja nie powiodła się (na etapie ./configure)"
Używam Mepisa. Skąd mogę wziąć biblioteki (i dokładnie jakie)- na płycie ich nie ma. Jeśli z repozytorium debiana, to dla woodiego czy sargea?? Przepraszam, że proszę o odpowiedź daną na tacy, ale jestem już zdesperowany- sam próbowałem b. długo i wysiada mi cierpliwość....