Nowe posty

xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
Wczoraj o 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36
xx Problem z instalacją sterowników TL-WN821N (4)
2019-10-11, 23:15:00
xx Sprzet z Linuxem (1)
2019-10-11, 10:06:24
xx nadpisanie partycji domowej (6)
2019-10-03, 03:27:28
xx Screen flickering Deepin (4)
2019-10-02, 20:32:56
xx Pisanie bezpiecznych skryptow. (0)
2019-10-01, 19:42:01
xx Ciągle pojawiają się nowe wpisy w auth.log (1)
2019-09-27, 21:09:45
xx Pblem z montowaniem dysku sieciowego (3)
2019-09-22, 22:05:08

Autor Wątek: Problem po instalacji sterownikow  (Przeczytany 4209 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 24
    • Zobacz profil
Problem po instalacji sterownikow
« dnia: 2015-08-09, 16:29:41 »
Probowalem zainstalowac sterowniki do karty graficznej i mam przez to problem. Nie dziala srodowisko graficzne.
 Instalowalem na podstawie https://wiki.debian.org/ATIProprietary zrobilem wszystko tak samo a po restarcie mam tylko tryb tekstowy.
debian 8.1jessie kde
 Po poleceniu startx wyeala bledy. Prosze o pomoc


Moja karta to msi radeon HD 7770

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2205
  • 1709
    • Zobacz profil
Problem po instalacji sterownikow
« Odpowiedź #1 dnia: 2015-08-09, 18:30:09 »
Możesz spróbować reinstalować pakiety mesa i powinno wróćić do starego sterownika
niżej w linku masz opisane, choć weź pod uwagę że z pliku .bak pliku nie przywrócisz
bo takiego nie robiłeś
https://takasobiestrona.wordpress.com/linux/sterowniki-dla-kart-ati/sterowniki-otwarte-radeon-dla-kart-z-ati/

Przykładd dla Ubuntu jest podobny
http://www.ubuntu-pomoc.org/powrot-do-standardowych-sterownikow-i-uruchomienie-komputera-po-nieudanej-zabawie-z-catalyst-ati/

Tu też świetne nieoficjalne wiki dla Debiana
http://wiki.cchtml.com/index.php/Debian#Removing_Catalyst.2Ffglrx

Edytowane
To moze skorzystaj z ostatniego linku :D
Tylko nie wiem czy sudo masz, jesli nie to zastąp     sudo   -->   su
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 24
    • Zobacz profil
Problem po instalacji sterownikow
« Odpowiedź #2 dnia: 2015-08-09, 19:06:42 »
Przetestowalem wszystkie 3 poradniki, ale nadal nie ma GUI. Czy powinno byc po wykonaniu tych komend czy kusze jeszcze cos zainstalowac?

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2205
  • 1709
    • Zobacz profil
Problem po instalacji sterownikow
« Odpowiedź #3 dnia: 2015-08-09, 19:41:49 »
Raczej powinno, powinno zamienić sterownik radeon na mesa.
W jednym poradniku pisalo ze pierw musisz odistalowac pierw sterowniki radeona,
robiles to ?
miałes błedy przy instalacji ?

mozesz zerknac czy masz plik oraz błędy z trybu tekstowego ?

zobaczysz czy plik istnieje
ls /var/log/Xorg.0.log
wyswietli plik, moze bedzie pisac ktory sterownik startuje.
cat /var/log/Xorg.0.log
Shift+Page Up lub Page Down   powinienes miec mozliwosc poruszania sie do góry i na dół.

PS: Szukaj lini zawierajacych EE , to oznacza error.
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 24
    • Zobacz profil
Problem po instalacji sterownikow
« Odpowiedź #4 dnia: 2015-08-09, 20:51:13 »
Mam zdjecia logow bledow pozniej wrzuce, a dodam jeszcze ze prawie przy kazdej instalacji z tych poradnikow pytalo czy zainstalowac z zaleznosciami czy cos takiego i nie bylem pewien czy wybrac y lub N

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2205
  • 1709
    • Zobacz profil
Problem po instalacji sterownikow
« Odpowiedź #5 dnia: 2015-08-09, 21:42:07 »
lepiej wybierać y.
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 24
    • Zobacz profil
Odp: Problem po instalacji sterownikow
« Odpowiedź #6 dnia: 2015-08-10, 12:23:11 »
Chyba nie ma polaczenia z internetem ponieważ po np ping onet.pl dostaje
unknown host
. Dlaczego on nie dziala gdy wszystko podlaczone i dzialal na GUI?? Jesli nie da sie tego naprawic w jakis prosty sposob to robie formata, bo juz mnie te problemy denerwuja.

Zdjecia z bledami
http://imgur.com/BfjOjZx,4z02aPn,zUnrQjV,g3EUaiF,jKHXLEG,HLMt2s1,e0QmqBD,0UhuXMg,XPt9pUA

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2205
  • 1709
    • Zobacz profil
Odp: Problem po instalacji sterownikow
« Odpowiedź #7 dnia: 2015-08-10, 14:44:14 »
Faktycznie net Ci nie startuje ( bynajmniej tak wygląda )
po drugie dalej Ci próbuje startować fglrx i w tym problem,
powinieneś go usunąć.

Generalnie powiem tak, bez neta to chyba nie wiele zdziałasz,
a ja nie wiem jak Ci pomóc z netem.
z live-cd sobie skopiuj co potrzebujesz na bezpieczną partycję
i postaw system na nowo.
A jak chcesz się jeszcze pobawić to zobacz czy w poradnikach coś nie pisze żeby w jakimś pliku nie zmienić nazwy sterownika i powinien wystartować inny,
kiedyś to było w /etc/X11/xorg.conf
teraz w nowszych systemach jak debian to moze być w /etc/X11/xorg.conf.d/
ale nie gwarantuje ze sie uda.
https://wiki.archlinux.org/index.php/Xorg_%28Polski%29

do edycji plikow uzywa sie kilku edytorow, jednym z nich jest np. nano
nano nazwa_pliku
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 24
    • Zobacz profil
Odp: Problem po instalacji sterownikow
« Odpowiedź #8 dnia: 2015-08-10, 15:38:29 »
System przeinstalowany. Zacznijmy od nowa. Jak zainstalować sterowniki do MSI Radeon HD 7770 + AMD Catalyst™, aby wszystko dzialało poprawnie?

Przy ostatniej instalacji sterownika z https://wiki.debian.org/ATIProprietary#Debian_8_.22Jessie.22 się nie udalo. Według mnie problem był w tym, że nie wiedzialem jak skonfigurować Xorg'a zrobilem to po prostu przez wpisanie
# mkdir /etc/X11/xorg.conf.d
# echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf
, a chyba powinienem cos zmienić w tym poleceniu?

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2205
  • 1709
    • Zobacz profil
Odp: Problem po instalacji sterownikow
« Odpowiedź #9 dnia: 2015-08-10, 16:07:37 »
Najbezpieczniej jest zainstalować pakiet fglrx i catalyst, z repozytorium.
Jak nie zadziała, to powinien wystartować otwarty sterownik.

Sęk w tym że czasdami nie będzie działał na starszych kartach,
bo AMD wspiera tylko nowe karty, potem sterowniki przechodzą do otwartych sterowników,
które aktualnie posiadasz i tu z wydajnością jest różnie,
czasami gorzej ( brak ulepszeń ze względu na patenty ) ,
czasami coś psują jedne by inne lepiej działały, bo sterowniki są paczkowane razem
a czasami lepiej ponieważ są wprowadzane ulepszenia.

Najwięcej o sterownikach zamkniętych AMD się dowiesz ze strony
Powinno tam pisać jaka wersja sterownika wspiera twoją karte i co powinieneś zainstalować
najpierw przed sterownikami ( na stronie debiana tez )
zwóć też uwagę na wersję kernela.
http://wiki.cchtml.com/index.php/Debian#Removing_Catalyst.2Ffglrx

oraz w plikach
http://support.amd.com/en-us/download
W dokumentacji powinno także pisać jakie Linuxy firma wspiera i powinna Ci udzielić
mniejszej lub większej pomocy.

W razie jakiś problemów ze sterownikami możesz przetestować jeszcze OpenSuse i PCLinuxOS,
w obu tych dystrybujach insalujesz sterowniki z paczek bez strachu ze zobaczysz czarny ekran i ( W przypadku PCLinuxa , gdyby coś poszlo nie tak powinien załączyć się teksty jakiś DrakX w którym ponownie możesz wybrać sterownik, bez reinstalacji czego kolwiek ).

Google translator do pomocy
https://translate.google.pl/
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 24
    • Zobacz profil
Odp: Problem po instalacji sterownikow
« Odpowiedź #10 dnia: 2015-08-10, 16:27:56 »
Teraz będe wszystko testował na VM aby nic nie zepsuć.