Nowe posty

Autor Wątek: Problem na Ubuntu 14.10 z kartą Qualcome  (Przeczytany 5827 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 9
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« dnia: 2015-04-23, 16:35:43 »
Cześć

Na komputerze na którym bez problemu działała sieć pod windowsem zainstalowałem ubuntu 14.10 i od startu miałem problemu z ethernetową kartą Qualcom QCA8171 (laptop Lenovo Ideapad Y510P). Bezprzewodówka działa poprawnie ale gdy ją wyłączę nie mam żadnego połączenia z siecią mimo wpiętego kabla (jeszcze raz zanzaczam, że nie było najmniejszych kłopotów pod windowsem 7 więc to nie jest wada sprzętowa). Konfiguracja wygląda tak:

srd@ubuntu:~/Downloads$ ifconfig
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:3487 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3487 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:621148 (621.1 KB)  TX bytes:621148 (621.1 KB)

    p3p1      Link encap:Ethernet  HWaddr 28:d2:44:2a:7d:5c  
              inet6 addr: fe80::2ad2:44ff:fe2a:7d5c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:16351 errors:0 dropped:87 overruns:0 frame:0
              TX packets:206 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:98346
srd@ubuntu:~/sudo lshw -C network
  *-network              
       description: Ethernet interface
       product: QCA8171 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: p3p1
       version: 10
       serial: 28:d2:44:2a:7d:5c
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx duplex=full latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:50 memory:c2500000-c253ffff ioport:3000(size=128)
  *-network
srd@ubuntu:~$ modinfo alx
filename:       /lib/modules/3.16.0-34-generic/kernel/drivers/net/ethernet/atheros/alx/alx.ko
license:        GPL
description:    Qualcomm Atheros(R) AR816x/AR817x PCI-E Ethernet Network Driver
author:         Qualcomm Corporation,
author:         Johannes Berg
srcversion:     A8A24DC0B21D72803977AB3
alias:          pci:v00001969d000010A0sv*sd*bc*sc*i*
alias:          pci:v00001969d000010A1sv*sd*bc*sc*i*
alias:          pci:v00001969d00001090sv*sd*bc*sc*i*
alias:          pci:v00001969d0000E091sv*sd*bc*sc*i*
alias:          pci:v00001969d00001091sv*sd*bc*sc*i*
depends:        mdio
intree:         Y
vermagic:       3.16.0-34-generic SMP mod_unload modversions
srd@ubuntu:~$ lsmod |grep alx
alx                    36680  0
mdio                   13561  1 alx
srd@ubuntu:~$ cat /etc/network/interfaces
# The loopback network interface
auto lo
auto p3p1
allow-hotplug p3p1
#iface p3p1 inet dhcp
iface lo inet loopback
Moim zdaniem sterownik rozpoznaje urządzenie, mimo wszystko wyczytałem że może potrzeba zainstalować paczki compat-drivers (chociaż powinny być w sumie w kernelu). Wiele paczek nie udało mi się skompilować aż w końcu odniosłem sukces z instalacją backports.3.10.19, ale to i tak nic nie zmieniło. Linijka iface p3p1 inet dhcp jest zakomentowana bo tylko w ten sposob wstaje network menager i mam dostep do bezprzewodowki. Czy ktoś ma pomysł jak można temu zaradzić?

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2475
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #1 dnia: 2015-04-23, 20:38:47 »
1/ Upewniam się tylko, bo strasznie zakręciłeś: wyłączenie karty WiFi równocześnie jakoś wyłącza kartę miedzianą? WiFi wyłączasz w NetworkManagerze, jakąś kombinacją klawiszy czy fizycznym pstrykiem gdzieś na laptopie?

2/ Czy mógłbyś wrzucić na listę wynik polecenia dmesg | tail -n 50 tak ze 5-6 sekund po wyłączeniu sieci i to samo z 5-6 sekund po włączeniu sieci?
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 9
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #2 dnia: 2015-04-24, 01:25:16 »
Polecenie dnesg, najpierw proba polaczenia:

srd@ubuntu:~$ sudo dmesg | tail -n 50
[    4.550452] vga_switcheroo: enabled
[    4.550633] [TTM] Zone  kernel: Available graphics memory: 8074722 kiB
[    4.550634] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[    4.550635] [TTM] Initializing pool allocator
[    4.550649] [TTM] Initializing DMA pool allocator
[    4.550657] nouveau  [     DRM] VRAM: 2048 MiB
[    4.550657] nouveau  [     DRM] GART: 1048576 MiB
[    4.550660] nouveau W[     DRM] Pointer to TMDS table invalid
[    4.550661] nouveau  [     DRM] DCB version 4.0
[    4.550662] nouveau W[     DRM] Pointer to flat panel table invalid
[    4.556674] nouveau  [     DRM] MM: using COPY for buffer copies
[    4.556679] [drm] Initialized nouveau 1.1.2 20120801 for 0000:01:00.0 on minor 1
[    5.461905] scsi 4:0:0:0: Direct-Access     ST1000LM 014-1EJ164            PQ: 0 ANSI: 0
[    5.462169] sd 4:0:0:0: Attached scsi generic sg2 type 0
[    5.462309] sd 4:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[    5.462559] sd 4:0:0:0: [sdb] Write Protect is off
[    5.462563] sd 4:0:0:0: [sdb] Mode Sense: 03 00 00 00
[    5.462807] sd 4:0:0:0: [sdb] No Caching mode page found
[    5.462811] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[    5.463965]  sdb: sdb1 sdb2
[    5.464769] sd 4:0:0:0: [sdb] Attached SCSI disk
[    6.235407] systemd-logind[958]: Failed to start unit user@104.service: Unknown unit: user@104.service
[    6.235412] systemd-logind[958]: Failed to start user service: Unknown unit: user@104.service
[    6.238271] systemd-logind[958]: New session c1 of user lightdm.
[    6.238284] systemd-logind[958]: Linked /tmp/.X11-unix/X0 to /run/user/104/X11-display.
[   11.846754] ACPI Warning: \\_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   11.846862] ACPI: \\_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
[   11.846866] ACPI Warning: \\_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   30.498305] systemd-logind[958]: Failed to start unit user@1000.service: Unknown unit: user@1000.service
[   30.498309] systemd-logind[958]: Failed to start user service: Unknown unit: user@1000.service
[   30.501028] systemd-logind[958]: New session c2 of user srd.
[   30.501039] systemd-logind[958]: Linked /tmp/.X11-unix/X0 to /run/user/1000/X11-display.
[   33.072841] audit_printk_skb: 57 callbacks suppressed
[   33.072843] audit: type=1400 audit(1429831003.015:30): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2735 comm="apparmor_parser"
[   33.072848] audit: type=1400 audit(1429831003.015:31): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2735 comm="apparmor_parser"
[   33.090009] audit: type=1400 audit(1429831003.035:32): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="third_party" pid=2735 comm="apparmor_parser"
[  241.117018] wlan0: deauthenticating from c0:25:5c:23:d5:60 by local choice (Reason: 3=DEAUTH_LEAVING)
[  241.137550] cfg80211: Calling CRDA to update world regulatory domain
[  241.155916] cfg80211: World regulatory domain updated:
[  241.155919] cfg80211:  DFS Master region: unset
[  241.155920] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  241.155922] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155924] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155925] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155926] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155928] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  270.709215] alx 0000:08:00.0 p3p1: Link Down
[  273.483091] alx 0000:08:00.0 p3p1: NIC Up: 100 Mbps Full
[  328.630074] alx 0000:08:00.0 p3p1: Link Down
[  340.449809] alx 0000:08:00.0 p3p1: NIC Up: 100 Mbps Full
teraz po wylaczeniu networkingu w network menagerze:
srd@ubuntu:~$ sudo dmesg | tail -n 50
[    4.550452] vga_switcheroo: enabled
[    4.550633] [TTM] Zone  kernel: Available graphics memory: 8074722 kiB
[    4.550634] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[    4.550635] [TTM] Initializing pool allocator
[    4.550649] [TTM] Initializing DMA pool allocator
[    4.550657] nouveau  [     DRM] VRAM: 2048 MiB
[    4.550657] nouveau  [     DRM] GART: 1048576 MiB
[    4.550660] nouveau W[     DRM] Pointer to TMDS table invalid
[    4.550661] nouveau  [     DRM] DCB version 4.0
[    4.550662] nouveau W[     DRM] Pointer to flat panel table invalid
[    4.556674] nouveau  [     DRM] MM: using COPY for buffer copies
[    4.556679] [drm] Initialized nouveau 1.1.2 20120801 for 0000:01:00.0 on minor 1
[    5.461905] scsi 4:0:0:0: Direct-Access     ST1000LM 014-1EJ164            PQ: 0 ANSI: 0
[    5.462169] sd 4:0:0:0: Attached scsi generic sg2 type 0
[    5.462309] sd 4:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[    5.462559] sd 4:0:0:0: [sdb] Write Protect is off
[    5.462563] sd 4:0:0:0: [sdb] Mode Sense: 03 00 00 00
[    5.462807] sd 4:0:0:0: [sdb] No Caching mode page found
[    5.462811] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[    5.463965]  sdb: sdb1 sdb2
[    5.464769] sd 4:0:0:0: [sdb] Attached SCSI disk
[    6.235407] systemd-logind[958]: Failed to start unit user@104.service: Unknown unit: user@104.service
[    6.235412] systemd-logind[958]: Failed to start user service: Unknown unit: user@104.service
[    6.238271] systemd-logind[958]: New session c1 of user lightdm.
[    6.238284] systemd-logind[958]: Linked /tmp/.X11-unix/X0 to /run/user/104/X11-display.
[   11.846754] ACPI Warning: \\_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   11.846862] ACPI: \\_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
[   11.846866] ACPI Warning: \\_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   30.498305] systemd-logind[958]: Failed to start unit user@1000.service: Unknown unit: user@1000.service
[   30.498309] systemd-logind[958]: Failed to start user service: Unknown unit: user@1000.service
[   30.501028] systemd-logind[958]: New session c2 of user srd.
[   30.501039] systemd-logind[958]: Linked /tmp/.X11-unix/X0 to /run/user/1000/X11-display.
[   33.072841] audit_printk_skb: 57 callbacks suppressed
[   33.072843] audit: type=1400 audit(1429831003.015:30): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2735 comm="apparmor_parser"
[   33.072848] audit: type=1400 audit(1429831003.015:31): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2735 comm="apparmor_parser"
[   33.090009] audit: type=1400 audit(1429831003.035:32): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="third_party" pid=2735 comm="apparmor_parser"
[  241.117018] wlan0: deauthenticating from c0:25:5c:23:d5:60 by local choice (Reason: 3=DEAUTH_LEAVING)
[  241.137550] cfg80211: Calling CRDA to update world regulatory domain
[  241.155916] cfg80211: World regulatory domain updated:
[  241.155919] cfg80211:  DFS Master region: unset
[  241.155920] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  241.155922] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155924] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155925] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155926] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155928] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  270.709215] alx 0000:08:00.0 p3p1: Link Down
[  273.483091] alx 0000:08:00.0 p3p1: NIC Up: 100 Mbps Full
[  328.630074] alx 0000:08:00.0 p3p1: Link Down
[  340.449809] alx 0000:08:00.0 p3p1: NIC Up: 100 Mbps Full
srd@ubuntu:~$ sudo dmesg | tail -n 50
[    4.550452] vga_switcheroo: enabled
[    4.550633] [TTM] Zone  kernel: Available graphics memory: 8074722 kiB
[    4.550634] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[    4.550635] [TTM] Initializing pool allocator
[    4.550649] [TTM] Initializing DMA pool allocator
[    4.550657] nouveau  [     DRM] VRAM: 2048 MiB
[    4.550657] nouveau  [     DRM] GART: 1048576 MiB
[    4.550660] nouveau W[     DRM] Pointer to TMDS table invalid
[    4.550661] nouveau  [     DRM] DCB version 4.0
[    4.550662] nouveau W[     DRM] Pointer to flat panel table invalid
[    4.556674] nouveau  [     DRM] MM: using COPY for buffer copies
[    4.556679] [drm] Initialized nouveau 1.1.2 20120801 for 0000:01:00.0 on minor 1
[    5.461905] scsi 4:0:0:0: Direct-Access     ST1000LM 014-1EJ164            PQ: 0 ANSI: 0
[    5.462169] sd 4:0:0:0: Attached scsi generic sg2 type 0
[    5.462309] sd 4:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[    5.462559] sd 4:0:0:0: [sdb] Write Protect is off
[    5.462563] sd 4:0:0:0: [sdb] Mode Sense: 03 00 00 00
[    5.462807] sd 4:0:0:0: [sdb] No Caching mode page found
[    5.462811] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[    5.463965]  sdb: sdb1 sdb2
[    5.464769] sd 4:0:0:0: [sdb] Attached SCSI disk
[    6.235407] systemd-logind[958]: Failed to start unit user@104.service: Unknown unit: user@104.service
[    6.235412] systemd-logind[958]: Failed to start user service: Unknown unit: user@104.service
[    6.238271] systemd-logind[958]: New session c1 of user lightdm.
[    6.238284] systemd-logind[958]: Linked /tmp/.X11-unix/X0 to /run/user/104/X11-display.
[   11.846754] ACPI Warning: \\_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   11.846862] ACPI: \\_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
[   11.846866] ACPI Warning: \\_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   30.498305] systemd-logind[958]: Failed to start unit user@1000.service: Unknown unit: user@1000.service
[   30.498309] systemd-logind[958]: Failed to start user service: Unknown unit: user@1000.service
[   30.501028] systemd-logind[958]: New session c2 of user srd.
[   30.501039] systemd-logind[958]: Linked /tmp/.X11-unix/X0 to /run/user/1000/X11-display.
[   33.072841] audit_printk_skb: 57 callbacks suppressed
[   33.072843] audit: type=1400 audit(1429831003.015:30): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2735 comm="apparmor_parser"
[   33.072848] audit: type=1400 audit(1429831003.015:31): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2735 comm="apparmor_parser"
[   33.090009] audit: type=1400 audit(1429831003.035:32): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="third_party" pid=2735 comm="apparmor_parser"
[  241.117018] wlan0: deauthenticating from c0:25:5c:23:d5:60 by local choice (Reason: 3=DEAUTH_LEAVING)
[  241.137550] cfg80211: Calling CRDA to update world regulatory domain
[  241.155916] cfg80211: World regulatory domain updated:
[  241.155919] cfg80211:  DFS Master region: unset
[  241.155920] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  241.155922] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155924] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155925] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155926] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  241.155928] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[  270.709215] alx 0000:08:00.0 p3p1: Link Down
[  273.483091] alx 0000:08:00.0 p3p1: NIC Up: 100 Mbps Full
[  328.630074] alx 0000:08:00.0 p3p1: Link Down
[  340.449809] alx 0000:08:00.0 p3p1: NIC Up: 100 Mbps Full
Oczywiscie wszystko z wylaczonym wifi. Wifi wylaczam w network menagerze natomiast pod windowsem nie mialem zadnych problemow by oba urzadzenia chodzili rownolegle gdyz uzywalem czasem laptopa do stawiania wifi hotspot.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2475
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #3 dnia: 2015-04-24, 10:09:45 »
Facepalm... Problemem jest włączanie i wyłączanie wifi, więc logicznym jest, że chodziło mi o logi po włączeniu i po wyłączeniu wifi, nawet jeżeli mają one docelowo dotyczyć miedzi.

Nie odpowiedziałeś też na pytanie 1/ .

Jest też prośba 3/:

* Wyłącz i włącz laptopa z podpiętym ethernetem.
* Połącz się z WiFi, zaczekaj 10 sekund.
* Wklej wynik polecenia route -n i ifconfig -a
* Wyłącz wifi, zaczekaj 10 sekund.
* Wklej wynik polecenia route -n i ifconfig -a
* Z wyłączonym WiFi wyjmij i włóż kabel ethernetowy, zaczekaj 10 sekund.
* Wklej wynik polecenia route -n i ifconfig -a
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 9
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #4 dnia: 2015-04-25, 15:37:34 »
Cytat: pkraszewski
Facepalm... Problemem jest włączanie i wyłączanie wifi, więc logicznym jest, że chodziło mi o logi po włączeniu i po wyłączeniu wifi, nawet jeżeli mają one docelowo dotyczyć miedzi.
Nie, problemem jest to że karta ethernet nie działa w ogóle nie zależnie od stanu wifi (które działa bez problemu). Jak już oisałem wcześniej w laptopie karty te działają bez problemu równocześnie i włączenie jednej nie wyłącza drugiej - dzięki temu na Windowsie sharowałem internet z kabla przez wifi. Więc odpowiadając na pytanie 1. wyłączenie/włączenie karty wifi nie wpływa w żaden sposób na stan sprzętowy ethernetu. Może trochę zakręciłem w 1 poscie ale chodziło mi po prostu o to, że wylączając Wifi tracę jaką kolwiek komunikacje (wifi wyłączam w network menagerze bo laptop nie ma takiego guzika sprzętowego). Mam nadzieje, że już to dobrze wyjaśniłem, więc logi z pytania 3 chyba nie będą już potrzebne (a jeśli się myle to daj proszę znać to wykonam procedurę i wkleje)

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2475
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #5 dnia: 2015-04-25, 18:03:28 »
Nie napisałeś, że w ogóle nie działa. Pisałeś że nie masz netu po wyłączeniu bezprzewodówki, więc zakładałem, że skoro wspominasz o tym konkretnie objawie, to miedź działa jeżeli wifi jest włączone (ale na przykład nie połączone z żadnym AP) a przestaje po wyłączeniu WiFi. Założyłem, że w jakiś sposób driver WiFi zabija równocześnie Eth.

To tyle w kwestii moich pytań "nie na temat".

A teraz, skoro nie chodzi o żaden związek z WiFi: Ethernet działa, wysyła i odbiera pakiety. Liczniki pakietów w obie strony są niezerowe, liczniki błędów są zerowe. Z jakiegoś powodu albo laptop nie wysyła zapytań DHCP, albo router na nie nie odpowiada, albo laptop ignoruje odpowiedzi.

Wyłącz wifi, podłącz ethernet i z poziomu linii komend wpisz dhclient p3p1. Zobacz czy wtedy zadziała.

Jeżeli zadziała, to usuń WSZYSTKIE wpisy dotyczące p3p1 z /etc/network/interfaces
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 9
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #6 dnia: 2015-04-26, 10:57:24 »
niestety polecenie dhclient p3p1 nie wyswietla absolutnie nic

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2475
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #7 dnia: 2015-04-26, 18:38:12 »
Bo nie wyświetla. CZY NET DZIAŁA?
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 9
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #8 dnia: 2015-04-28, 01:25:18 »
oczywiscie nie dziala, gdyby zadzialalo to raczej bym to napisal...

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 17
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #9 dnia: 2015-04-28, 15:49:50 »
interface p3p1
trzeba zmienić na eth0
cd /etc/udev/rules.d
cp 70-persistent-net.rules 70-persistent-net.rules.bak
nano 70-persistent-net.rules
zmienić
Name="p3p1"
na
Name="eth0"
Nastepnie trzeba edytować plik /etc/network/interfaces
auto eth0
    allow-hotplug eth0
    iface eth0 inet dhcp
restart kompa
Pomogłem??? BTC: 17KaVRX6MhUrxH8bCMTXzaZNwX2nmNZL5M

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 9
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #10 dnia: 2015-04-28, 16:44:16 »
okazalo sie ze wpliku rules.d jest tylko definicja wlan. Dodalem linijke dla eth0 podajac adres sprzetowy z wyswietlanego ifconfig dla p3p1. Potem zmienilem linijki w network/interfaces. Niestey dodanie linii     iface eth0 inet dhcp i ponowne uruchomienie komputera powoduje brak sieci na starcie. Ubuntu wstaje dosc dlugo z komunikatem czekania na konfiguracje ustawien sieciowych, po czym uruchamia sie bez obslugi sieci (network menager tez wylaczony). If config wyswietla tylko lo. Aby przywrocic chociazby wifi musze zakomentowac linijke iface eth0 inet dhcp i ponownie uruchomic system.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 17
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #11 dnia: 2015-04-28, 18:40:19 »
nie miałes nic dodawać do pliku rules.d....
tylko edytować 70-persistent-net.rules
prawidłowa linijka w 70-persistent-net.rules dla eth0:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="TWOJ ADRES SPRZETU ", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
w etc/network/interfaces zmien dodaj  do tego co pisałem wyżej:
auto lo eth0
iface lo inet loopback
restart
Pomogłem??? BTC: 17KaVRX6MhUrxH8bCMTXzaZNwX2nmNZL5M

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 9
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #12 dnia: 2015-04-29, 01:17:15 »
oczywicie chodzilo o plik 70-persistent-net.rules :> Post byl pisany dosyc pozno wiec wybaczcie pomylke :> Tak jak wspomnialem w pliku byla tylko konfiguracja wlan wiec dodalem linie dla eth0 o dokladnie takiej tresci jak wkleil R3likt5. Ale niewiele to dalo bo net ciagle nie dziala, a interfejs ethernetowy ciagle wystepuje pod nazwa p3p1:

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="28:D2:44:2A:7D:5C", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="68:17:29:ee:01:ec", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
if conig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:505 errors:0 dropped:0 overruns:0 frame:0
          TX packets:505 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:52168 (52.1 KB)  TX bytes:52168 (52.1 KB)

p3p1      Link encap:Ethernet  HWaddr 28:d2:44:2a:7d:5c  
          inet6 addr: fe80::2ad2:44ff:fe2a:7d5c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2517 errors:0 dropped:11 overruns:0 frame:0
          TX packets:69 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:152028 (152.0 KB)  TX bytes:15115 (15.1 KB)
          Interrupt:19

wlan0     Link encap:Ethernet  HWaddr 68:17:29:ee:01:ec  
          inet addr:192.168.101.107  Bcast:192.168.101.255  Mask:255.255.254.0
          inet6 addr: fe80::6a17:29ff:feee:1ec/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:928 errors:0 dropped:0 overruns:0 frame:0
          TX packets:608 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:558232 (558.2 KB)  TX bytes:103346 (103.3 KB)
interfaces:
auto lo eth0
#auto eth0
#allow-hotplug eth0
#iface eth0 inet dhcp
#iface p3p1 inet dhcp
iface lo inet loopback
jak napisalem wyzej net ciagle nie dziala po kablu.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 46
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #13 dnia: 2015-04-29, 11:44:32 »
Dodatkowo zmień opcje boot. Edytuj
/etc/default/grub
dodając
biosdevname=0
a następnie w terminalu
sudo update-grub
restart

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 9
    • Zobacz profil
Problem na Ubuntu 14.10 z kartą Qualcome
« Odpowiedź #14 dnia: 2015-04-29, 12:37:27 »
Dodalem linjke biosdevname=0 do GRUB_CMDLINE_LINUX w grub i faktycznie po restarcie interfejs zmienil nazwe na etc0. Niestety nic to nie zmienilo w sprawie braku polaczenia po kablu:
eth0      Link encap:Ethernet  HWaddr 28:d2:44:2a:7d:5c  
          inet6 addr: fe80::2ad2:44ff:fe2a:7d5c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:652 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:49612 (49.6 KB)  TX bytes:6023 (6.0 KB)
          Interrupt:19

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:391 errors:0 dropped:0 overruns:0 frame:0
          TX packets:391 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:35434 (35.4 KB)  TX bytes:35434 (35.4 KB)