Nowe posty

xx Jak usunąć kilka dowiązań twardych jednym poleceniem. (3)
2019-06-14, 12:12:10
xx Skrypt sprawdzający miejsce na dysku (1)
2019-06-13, 13:55:00
xx Samba server (3)
2019-06-10, 17:01:44
xx Skrypt tworzący użytkownika (3)
2019-06-07, 17:11:55
xx Jaki serwis komp. we Wrocławiu (0)
2019-06-06, 12:39:23
xx serwer wydruku (1)
2019-06-04, 13:57:58
xx mod_security i roundcube (0)
2019-05-27, 14:27:03
xx Touchpad po pewnym losowym czasie przestaje reagować (33)
2019-05-27, 10:14:21
xx [ROZWIĄZANY] przygotowanie zeskanowanego pdf do OCR (6)
2019-05-24, 14:46:43
xx Przydatne Linki (1)
2019-05-23, 18:05:04

Autor Wątek: Połączenie PPPoE w Fedorze  (Przeczytany 4325 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 226
    • Zobacz profil
Połączenie PPPoE w Fedorze
« dnia: 2014-10-29, 19:39:49 »
Witam!
Mimo że mój dostawca internetu preferuje połączenie PPPoE ja połączyłem się za pomocą Network Manager'a jako DSL.
Dzisiaj postanowiłem spróbować stworzyć połączenie PPPoE, niestety się nieudało.
[piotrek@localhost ~]$ su -
Hasło:
Ostatnie logowanie: śro paź 29 19:04:29 CET 2014 na pts/0
[root@localhost ~]# pppoe-setup

Welcome to the PPPoE client setup.  First, I will run some checks on
your system to make sure the PPPoE client is installed properly...

LOGIN NAME

Enter your Login Name: (mój login)

INTERFACE

Enter the Ethernet interface connected to the PPPoE modem
For Solaris, this is likely to be something like /dev/hme0.
For Linux, it will be ethX, where 'X' is a number.
(default eth0):

Do you want the link to come up on demand, or stay up continuously?
If you want it to come up on demand, enter the idle time in seconds
after which the link should be dropped.  If you want the link to
stay up permanently, enter 'no' (two letters, lower-case.)
NOTE: Demand-activated links do not interact well with dynamic IP
addresses.  You may have some problems with demand-activated links.
Enter the demand value (default no):

DNS

Please enter the IP address of your ISP's primary DNS server.
If your ISP claims that 'the server will provide dynamic DNS addresses',
enter 'server' (all lower-case) here.
If you just press enter, I will assume you know what you are
doing and not modify your DNS setup.
Enter the DNS information here: server

PASSWORD

Please enter your Password:
Please re-enter your Password:

USERCTRL

Please enter 'yes' (three letters, lower-case.) if you want to allow
normal user to start or stop DSL connection (default yes):

FIREWALLING

Please choose the firewall rules to use.  Note that these rules are
very basic.  You are strongly encouraged to use a more sophisticated
firewall setup; however, these will provide basic security.  If you
are running any servers on your machine, you must choose 'NONE' and
set up firewalling yourself.  Otherwise, the firewall rules will deny
access to all standard servers like Web, e-mail, ftp, etc.  If you
are using SSH, the rules will block outgoing SSH connections which
allocate a privileged source port.

The firewall choices are:
0 - NONE: This script will not set any firewall rules.  You are responsible
          for ensuring the security of your machine.  You are STRONGLY
          recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
                for a LAN
Choose a type of firewall (0-2): 0

Start this connection at boot time

Do you want to start this connection at boot time?
Please enter no or yes (default no):

** Summary of what you entered **

Ethernet Interface: eth0
User name:          7716_PRZECISZOWSKI
Activate-on-demand: No
DNS addresses:      Supplied by ISP's server
Firewalling:        NONE
User Control:       yes
Accept these settings and adjust configuration files (y/n)? y
Adjusting /etc/sysconfig/network-scripts/ifcfg-ppp0
Adjusting /etc/ppp/chap-secrets and /etc/ppp/pap-secrets
  (But first backing it up to /etc/ppp/chap-secrets.bak)
  (But first backing it up to /etc/ppp/pap-secrets.bak)



Congratulations, it should be all set up!

Type '/sbin/ifup ppp0' to bring up your xDSL link and '/sbin/ifdown ppp0'
to bring it down.
Type '/sbin/pppoe-status /etc/sysconfig/network-scripts/ifcfg-ppp0'
to see the link status.

[root@localhost ~]# pppoe-start
/sbin/pppoe-start: line 217:  1830 Terminated              $CONNECT "$@" > /dev/null 2>&1
[root@localhost ~]# ifup ppp0
/sbin/adsl-start: line 217:  2226 Terminated              $CONNECT "$@" > /dev/null 2>&1
Wszędzie wybierałem ustawienia domyślne.
Od dostawcy mam tylko login i hasło.
Proszę o jakieś sugestie.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2156
  • 1709
    • Zobacz profil
Połączenie PPPoE w Fedorze
« Odpowiedź #1 dnia: 2014-10-30, 02:12:23 »
DSL i pppoe moze nie znaczy to samo,
ale w tym przypadku tak to dziala w systemach.
Czyli jak ustawiles przez network manager,
to nie potrzebujesz juz konfigurowac pppoe-setup.
Czyli jak dziala jedno z nich to nie potrzebujesz juz drugiego.
To sa tak jakby dwa rozne programy, ale identycznie lacza Cie z internetem.
Czy jest jakis wazny powod dla ktorego musisz skorzystac z pppoe-setup?
Pochwal się swoją kartą graficzną w tym wątku-->
http://forum.linux.pl/index.php/topic,19841.msg121122.html#msg121122

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 226
    • Zobacz profil
Połączenie PPPoE w Fedorze
« Odpowiedź #2 dnia: 2014-10-30, 11:56:59 »
W sumie nie ma ważnego powodu...
Dzięki za wyjaśnienie.

Offline roobal

  • Users
  • Guru
  • *****
  • Wiadomości: 2052
    • Zobacz profil
Połączenie PPPoE w Fedorze
« Odpowiedź #3 dnia: 2014-10-30, 21:42:14 »
Cytuj
The firewall choices are:
0 - NONE: This script will not set any firewall rules.  You are responsible
          for ensuring the security of your machine.  You are STRONGLY
          recommended to use some kind of firewall rules.
Możliwe, że tu leży problem. Nie jestem pewny, dawno nie używałem Fedory, ale CentOS bazujący na RHEL domyślnie dostarcza reguły zapory. Jeśli masz ustawione domyślne reguły zapory, to prawdopodobnie tu leży problem. Firewall blokuje połączenie.

Co do Network Managera, działa on wolniej, niż konfiguracja sieci w plikach tekstowych. U mnie np. po uśpieniu, muszę odczekać 2 minuty aż NM się połączy z siecią, jak skonfiguruję sobie sieć w plikach tekstowych, zaraz po wybudzeniu mam dostęp do sieci (mowa o WiFi).

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 226
    • Zobacz profil
Połączenie PPPoE w Fedorze
« Odpowiedź #4 dnia: 2014-12-09, 18:31:41 »
The firewall choices are:
0 - NONE: This script will not set any firewall rules.  You are responsible
          for ensuring the security of your machine.  You are STRONGLY
          recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
                for a LAN
Obojętnie czy wybiorę 0, 1 lub 2 nadal nie działa połącznie pppoe.
W wersji Workstation chciałbym utorzyć takie połączenie.

Offline roobal

  • Users
  • Guru
  • *****
  • Wiadomości: 2052
    • Zobacz profil
Połączenie PPPoE w Fedorze
« Odpowiedź #5 dnia: 2014-12-09, 19:42:06 »
Cytat: syngromu88
Obojętnie czy wybiorę 0, 1 lub 2 nadal nie działa połącznie pppoe..
Przeczytaj jeszcze raz to, co napisałem.