Nowe posty

Autor Wątek: jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a  (Przeczytany 3510 razy)

Offline Marcin K

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
Witam
Mam zainstalowanego CUPS\\'a i esp gs\\'a z \\"domowej kompilacji\\" pakietów.
Drukarka to Samsung ML-1440 podłączona pod parallel:/dev/lp0 .Sterowniki: Samsung-ML-1440-spl.ppd

Po uporaniu się z drobnymi błędami utknąłem na czymś co w error_log jest opisane przez linijki:

I [11/Nov/2005:18:58:14 +0100] Started filter /usr/lib/cups/filter/pstops (PID 3
000) for job 13.
I [11/Nov/2005:18:58:14 +0100] Started filter /usr/lib/cups/filter/cupsomatic (P
ID 3001) for job 13.
I [11/Nov/2005:18:58:14 +0100] Started backend /usr/lib/cups/backend/parallel (P
ID 3002) for job 13.
E [11/Nov/2005:18:58:14 +0100] PID 3001 stopped with status 22!
I [11/Nov/2005:18:58:14 +0100] Hint: Try setting the LogLevel to \\"debug\\" to find
 out more.

Wygląda to tak że pakiety zanim dojdą do drukarki \\"wysypują się\\" na filtrach cupsomatic\\'a.

Nie mam pojęcia jak się zabrać za rozwiązanie tego problemu.

Pozdrawiam

Offline Dominik Przyborowski

  • Users
  • Guru
  • *****
  • Wiadomości: 747
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #1 dnia: 2005-11-11, 20:04:23 »
Witam.

Jęzeli drukarka bez buforowania drukuje to problem może leżec w pliku ppd. Na linuxprinting.org mają inny plik dla twojego modelu:
http://linuxprinting.org/show_printer.cgi?recnum=Samsung-ML-1440
Proponowałbym spróbowac na nim.

Pzdr

Offline Marcin K

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #2 dnia: 2005-11-11, 21:35:59 »
Dzięki za odpowiedź.
Drukarka jest buforowana poprostu nie miałem cupsomatic\\'a.
Po dodaniu filtrow cupsomatic dostaje komunikat (error_log):

I [11/Nov/2005:20:15:19 +0100] Started filter /usr/lib/cups/filter/pstops (PID 3
341) for job 14.
I [11/Nov/2005:20:15:19 +0100] Started filter /usr/lib/cups/filter/cupsomatic (P
ID 3342) for job 14.
I [11/Nov/2005:20:15:19 +0100] Started backend /usr/lib/cups/backend/parallel (P
ID 3343) for job 14.
E [11/Nov/2005:20:15:21 +0100] PID 3342 stopped with status 3!

Teraz to juz maprawde się pogubiłem...

Pozdrawiam

Offline Marcin K

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #3 dnia: 2005-11-11, 22:36:02 »
Dołączam bardziej szczegółowe wycinki z listningu  error_log:

D [11/Nov/2005:22:20:48 +0100] [Job 23] 0 %%EOF
D [11/Nov/2005:22:20:48 +0100] [Job 23] Saw EOF!
D [11/Nov/2005:22:20:48 +0100] [Job 23] perl: warning: Setting locale failed.
D [11/Nov/2005:22:20:48 +0100] [Job 23] perl: warning: Please check that your locale settings:
D [11/Nov/2005:22:20:48 +0100] [Job 23] LANGUAGE = (unset),
D [11/Nov/2005:22:20:48 +0100] [Job 23] LC_ALL = (unset),
D [11/Nov/2005:22:20:48 +0100] [Job 23] LANG = \\"en\\"
D [11/Nov/2005:22:20:48 +0100] [Job 23] are supported and installed on your system.
D [11/Nov/2005:22:20:48 +0100] [Job 23] perl: warning: Falling back to the standard locale (\\"C\\").
D [11/Nov/2005:22:20:49 +0100] [Job 23] foomatic-rip version $Revision: 3.43.2.9 $ running...
D [11/Nov/2005:22:20:49 +0100] [Job 23] Parsing PPD file ...
.
.
.
D [11/Nov/2005:22:20:49 +0100] [Job 23] You are using an old Foomatic 2.0 PPD file, consider upgrading
.
D [11/Nov/2005:22:20:49 +0100] [Job 23]
D [11/Nov/2005:22:20:49 +0100] [Job 23] Settings for \\"PageSize\\" and \\"PageRegion\\" are different:
D [11/Nov/2005:22:20:49 +0100] [Job 23] PageSize: Letter
D [11/Nov/2005:22:20:49 +0100] [Job 23] PageRegion:
D [11/Nov/2005:22:20:49 +0100] [Job 23] Using the \\"PageSize\\" value \\"Letter\\", for both.
.
.
.
l -sOutputFile=- -
D [11/Nov/2005:22:20:49 +0100] [Job 23]
D [11/Nov/2005:22:20:49 +0100] [Job 23] Closing renderer
D [11/Nov/2005:22:20:49 +0100] [Job 23] perl: warning: Setting locale failed.
D [11/Nov/2005:22:20:49 +0100] [Job 23] perl: warning: Please check that your locale settings:
D [11/Nov/2005:22:20:49 +0100] [Job 23] LANGUAGE = (unset),
D [11/Nov/2005:22:20:49 +0100] [Job 23] LC_ALL = (unset),
D [11/Nov/2005:22:20:49 +0100] [Job 23] LANG = \\"en\\"
D [11/Nov/2005:22:20:49 +0100] [Job 23] are supported and installed on your system.
D [11/Nov/2005:22:20:49 +0100] [Job 23] perl: warning: Falling back to the standard locale (\\"C\\").
D [11/Nov/2005:22:20:49 +0100] [Job 23] foomatic-gswrapper: gs \\'-dBATCH\\' \\'-dSAFER\\' \\'-dNOPAUSE\\' \\'-sDEVI
CE=qpdl\\' \\'-sOutputFile=/dev/fd/3\\' \\'/dev/fd/0\\' 3>&1 1>&2
D [11/Nov/2005:22:20:49 +0100] [Job 23] ESP Ghostscript 815.01 (2005-09-22)
.
.
.
D [11/Nov/2005:22:20:50 +0100] [Job 23] Unknown device: qpdl
D [11/Nov/2005:22:20:50 +0100] [Job 23] renderer return value: 1
D [11/Nov/2005:22:20:50 +0100] [Job 23] renderer received signal: 1
D [11/Nov/2005:22:20:50 +0100] [Job 23] tail process done writing data to STDOUT
D [11/Nov/2005:22:20:50 +0100] [Job 23] KID4 finished
D [11/Nov/2005:22:20:50 +0100] [Job 23] KID4 exited with status 0
D [11/Nov/2005:22:20:50 +0100] [Job 23] KID3 exited with status 3
D [11/Nov/2005:22:20:50 +0100] [Job 23] Renderer exit stat: 3
D [11/Nov/2005:22:20:50 +0100] [Job 23] Process dying with \\"Possible error on renderer command line or
 PostScript error. Check options.\\", exit stat: 3
D [11/Nov/2005:22:20:50 +0100] [Job 23] error: Illegal seek (29)
D [11/Nov/2005:22:20:50 +0100] [Job 23] Possible error on renderer command line or PostScript error. C
heck options.
D [11/Nov/2005:22:20:50 +0100] [Job 23] Renderer process finished
D [11/Nov/2005:22:20:50 +0100] [Job 23] Killing process 2823 (KID3)
D [11/Nov/2005:22:20:50 +0100] [Job 23] Process dying with \\"Error closing renderer\\", exit stat: 3
D [11/Nov/2005:22:20:50 +0100] [Job 23] error: Bad file descriptor (9)
D [11/Nov/2005:22:20:50 +0100] [Job 23] Error closing renderer
E [11/Nov/2005:22:20:50 +0100] PID 2821 stopped with status 3!
D [11/Nov/2005:22:20:50 +0100] UpdateJob: job 23, file 0 is complete.
D [11/Nov/2005:22:20:50 +0100] CancelJob: id = 23
D [11/Nov/2005:22:20:50 +0100] StopJob: id = 23, force = 0
D [11/Nov/2005:22:20:50 +0100] StopJob: printer state is 3
D [11/Nov/2005:22:21:19 +0100] ReadClient: 7 GET /admin HTTP/1.1

Czy może to być wina przestarzałego foomatic\\'a

Offline Marcin K

  • Users
  • Użytkownik
  • **
  • Wiadomości: 74
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #4 dnia: 2005-11-12, 13:38:48 »
WItam

Zrobione. Przyczyną był zły *.PPD na płycie ze sterownikami dołączonej do druakrki. Wystarczyło ściągnąć skrypt instalacyjny ze strony producenta (www.samsungprinter.com), i zainstalować inne sterownki. Po wyborze sterowników GDI, drukarka działa.

Pozdrwaiam wszystkich forumowiczów.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #5 dnia: 2005-11-11, 16:18:52 »
Witam,
na poczatku chciałbym poprosić osoby które mają cierpliwość i spokój - otóż jestem kompletnym newbie.

Jak już gdzieś czytałem "na windowsie grzebiesz w rejestrze, usuwasz wirusy, znasz podstawowe komendy dos`owskie - myslisz sobie "jestem dobry!" - przechodzi na linuxa i "eee" - poznajesz co to komputer". Byłem co do tego przekonany, ale nie sądziłem, że to 'piekło' może się dla mnie zacząć już na początku...

Ściągnęłem sobie Debiana, SuSE i Ubuntu - nagrałem płytki - nie były to obrazy, tylko archiwa RAR, więc wypakowałem i nagrałem te pliki w Neronie, nazwy płyt w stylu "debian 31r0a-binary1". I nie wiem czy ja już przy nagrywaniu płyt popełniłem błędy?? Otóż którą bym z płyt nie włożył to mi ją 'odrzuca' - "PLEASE INSERT BOOT DISK" - czyta płyty, ale nie startuje... Ja rozumiem, że to jest trudniejesze jak na windowsie, ale poco sobie tak utrudniac zycie i nie udostepniac na serwerach wersji ktora odrazu startuje z płyty, a może się myle??

Mój sprzęt wygląda tak
AMD 64 Sempron 2800+
Płyta Gigabyte GA-K8NE
ATI Radeon x550 PCI-Express
Dysk SATA WD - 160GB
512RAM
Nagrywara NEC

Czy mój sprzęt nie obsługuje linuxa?? W to nie wierze... albo coś schrzaniłem w BIOS`ie, albo...? No właśnie co...

Poza tym szukałem tutaj i wielu innych stronach - (na google wpisałem nawet "instalacja linuxa dla debili" i nic ciekawego mi nie znalazlo - wszedze "ogólnie", a ja już mam ochote kompa wyrzucić... Na każdej ze stron trafiałem na to iż powinienem zrobić "dysk startowy" - fajnie tylko jak... jakieś komendy, ale pod linuxa! Poza tym pisali, o tym, że pliki znajduja sie na plycie - zadnych takich (jak pisali) niema - a odnośników do tych plików w necie niema...

Kombinowałem nawet w taki sposób, że wystartowałem z 'dysku startowego win98' wszystko okay plyte mi odczytało, ale żaden plik nie chce się uruchomić jako instalacja - tak jak to jest w banalnie prostym windowsie...

Ja jestem pewien, że jest to coś banalnie proste, ale ja nie potrafię tego zauważyć.

Jeśli znajdzie się ktoś wyrozumiały to bardzo proszę o pomoc, bo już nie daje rady, a żadnej pomocy w live niemam - jak mówię "Linux" - to wszystkim włos się jeży na głowie... A to co robie to są już Syzyfowe prace...

Albo wkońcu przejdę na Linuxa, albo dalej będę instalował windowsa co 3-4tygodnie - przy stale wlaczonym kompie nie wytrzymuje, zamula strasznie...

Z góry wielce Wam dziękuję!

Pozdrawiam - Skalarpl - Peace&Love

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #6 dnia: 2005-11-11, 17:04:37 »
Zapomniałem jeszcze spytać o jedno: jak już mi ktoś pomoże w tej pierwszej sprawie to mam pytanie: Jakie rozmiary partycji proponujecie?? Ile na systemowa i czy moze ona miec 20GB i czy można na niej przechowywać własne dane??

Z góry dziękuję!

Pozdrawiam - Skalarpl - Peace&Love

Offline Szymek W

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 350
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #7 dnia: 2005-11-11, 17:23:42 »
2005-11-11 17:04:37 Skalarpl napisał:

> Zapomniałem jeszcze spytać o jedno: jak już mi ktoś pomoże w tej pierwszej sprawie to mam
 > pytanie: Jakie rozmiary partycji proponujecie?? Ile na systemowa i czy moze ona miec 20GB i czy
 > można na niej przechowywać własne dane??
 >
 > Z góry dziękuję!
 >
 > Pozdrawiam - Skalarpl - Peace&Love

Skąd miałeś te pliki rar?

http://www.debian.org/CD/http-ftp/

http://dug.net.pl/texty/inst-sarge1.php
http://dug.net.pl/texty/inst-sarge2.php

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #8 dnia: 2005-11-11, 18:24:48 »
> Skąd miałeś te pliki rar?
 >
 > http://www.debian.org/CD/http-ftp/
 >
 > http://dug.net.pl/texty/inst-sarge1.php
 > http://dug.net.pl/texty/inst-sarge2.php

Ja pierdykam... moj WinRAR rozpoznał pliki ISO jako skompresowane archiwa i... ja to wypakowalem i pozniej nagralem 'normalnie' w neronie poprzez "dane" i tyle... no to super... różnica jest rzędu 500KB, ale nie chodzi... nagrałem właśnie te obrazy POPRAWNIE i już mi sie instalator bez problemu zainstalowal... eh... i w ten sposób przez WinRARa (no i można powiedzieć moją nieuwagę) straciłem 2dvd na debiana i 1cd na ubuntu i 5cd na SuSE ;] ale to jest nic... Najważniejsze, że błąd został znaleziony :D

Dziękuję Ci bardzo, chociaż nie bezpośrednio, ale pomogłeś mi :D Inaczej nakierowałeś mnie na mój błąd poprzez te "rar`y" :) których niema :)

Jeszcze raz dziękuję bardzo i... do zobaczenia po drugiej stronie :D Winda leci... a to dlatego, że jakbym ją zostawił to bym do niej wracał ;] a mam nadzieję, że nie będę musiał ;]

P.S.:Dzięki również za te adresy - właśnie oglądam jak zainstalować :)

Dziękuję!
Pozdrawiam - Skalarpl - Peace&Love

Offline Szymek W

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 350
    • Zobacz profil
jak uruchomić instalacje /Debian/SuSE/Ubuntu | jak zrobić boot`a
« Odpowiedź #9 dnia: 2005-11-11, 19:50:37 »
2005-11-11 18:24:48 Skalarpl napisał:

>  > Skąd miałeś te pliki rar?
 >  >
 >  > http://www.debian.org/CD/http-ftp/
 >  >
 >  > http://dug.net.pl/texty/inst-sarge1.php
 >  > http://dug.net.pl/texty/inst-sarge2.php
 >
 > Ja pierdykam... moj WinRAR rozpoznał pliki ISO jako skompresowane archiwa i... ja to
 > wypakowalem i pozniej nagralem 'normalnie' w neronie poprzez "dane" i tyle... no to
 > super... różnica jest rzędu 500KB, ale nie chodzi... nagrałem właśnie te obrazy POPRAWNIE i już
 > mi sie instalator bez problemu zainstalowal... eh... i w ten sposób przez WinRARa (no i można
 > powiedzieć moją nieuwagę) straciłem 2dvd na debiana i 1cd na ubuntu i 5cd na SuSE ;] ale to
 > jest nic... Najważniejsze, że błąd został znaleziony :D
 >
 > Dziękuję Ci bardzo, chociaż nie bezpośrednio, ale pomogłeś mi :D Inaczej nakierowałeś mnie na
 > mój błąd poprzez te "rar`y" :) których niema :)
 >
 > Jeszcze raz dziękuję bardzo i... do zobaczenia po drugiej stronie :D Winda leci... a to
 > dlatego, że jakbym ją zostawił to bym do niej wracał ;] a mam nadzieję, że nie będę musiał ;]
 >
 > P.S.:Dzięki również za te adresy - właśnie oglądam jak zainstalować :)
 >
 > Dziękuję!
 > Pozdrawiam - Skalarpl - Peace&Love

Zapraszam na forum.dug.net.pl
Wsparcie ze strony społeczności jest bardzo ważne zwłaszcza dla newbie.