Nowe posty

Autor Wątek: Kompilacja  (Przeczytany 8449 razy)

Offline paweł gieroba

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 42
    • Zobacz profil
Kompilacja
« dnia: 2005-06-02, 23:56:01 »
mam taki problemo

skompilowałem sobie fluxa 0.9.9 pod fc3
mam xorga z zainstalowanymi fontami iso-8859-2
ale dalej nie mam polskich fontów, w niektóruch programach, to znaczy np.

w psi nie mam ó zamiast tego dwa kwadraciki... podobnie w quanta+,
w atermie działa mi z kolei tylko ó... reszty wogóle nie wyświetla
w gvim też nie najlepiej, w menu mam znaki zapytania zamiast np. ż itd...
pewnie jeszcze kilka aplikacji by sie dało znaleść gdzie ich nie ma...

i teraz moje pytanie, co z tym zrobić? jak to naprawić?

czy to może przez styl fluxa, trzeba jakiś obsługujący iso-8859-2 wrzucić? a jeśli tak to skąd taki można wziąć?
czy może czegoś przy kompilejszyn nie ustawiłem, bo z tego co pamiętam to jak z paczek instalowałem ty chyba były fonty, chociaż moge dobrze nie pamiętać :P
a może to przez qt?

z góry dzięki za jakąś wskazówkę, bo jakoś nic nie mogę znaleść na ten temat :/

Offline Jacek Lehmann

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Kompilacja
« Odpowiedź #1 dnia: 2005-06-05, 01:35:07 »
wpisz w konsoli locale i podaj wynik
sprawdz czy te programy uzywaja czcionek z ogonkami
co do aterma sprawdz czy masz podobny wpis w .Xdefaults
Aterm*font:-xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso8859-2

Offline paweł gieroba

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 42
    • Zobacz profil
Kompilacja
« Odpowiedź #2 dnia: 2005-06-05, 20:06:15 »
2005-06-05 01:35:07 jackkill napisał:

> wpisz w konsoli locale i podaj wynik

LANG=pl_PL.UTF-8
LC_CTYPE=C
LC_NUMERIC=\\"pl_PL.UTF-8\\"
LC_TIME=\\"pl_PL.UTF-8\\"
LC_COLLATE=\\"pl_PL.UTF-8\\"
LC_MONETARY=\\"pl_PL.UTF-8\\"
LC_MESSAGES=\\"pl_PL.UTF-8\\"
LC_PAPER=\\"pl_PL.UTF-8\\"
LC_NAME=\\"pl_PL.UTF-8\\"
LC_ADDRESS=\\"pl_PL.UTF-8\\"
LC_TELEPHONE=\\"pl_PL.UTF-8\\"
LC_MEASUREMENT=\\"pl_PL.UTF-8\\"
LC_IDENTIFICATION=\\"pl_PL.UTF-8\\"
LC_ALL=

więc raczej tak jak powinno być

 > sprawdz czy te programy uzywaja czcionek z ogonkami

raczej używają, wnioskuję to dlatego, iż na kde działają z polskimi znakami

 > co do aterma sprawdz czy masz podobny wpis w .Xdefaults

mam wpis

aterm font:--fixed-medium-r-normal---140-----iso8859-2

 > Aterm*font:-xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso8859-2

i uruchmiam aterma z parametrami

aterm -trsb -tr -fg white -bg black -fn \\"-misc-fixed-medium-r-normal--13120-100-100-c-90-iso8859-2\\" -geometry 85x35 +sb -sh 60 -ls


ps. gdzieś wyczytalem że w stylu trzeba pozmieniać fonty,  np. żeby mieć polskie czcionki na pasku czy gdzieś tam indziej. zrobiłem tak, ale to nie pomoglo, ani na pasek ani na programy, a dodałem do stylu:

font:            -lucidatypewriter-medium-r-normal--10-100-75-75-m-60-iso8859-2
menu.frame.font:      -lucidatypewriter-medium-r-normal--10-100-75-75-m-60-iso8859-2
menu.title.font:      -lucidatypewriter-medium-r-normal--10-100-75-75-m-60-iso8859-2
window.font:         -lucidatypewriter-medium-r-normal--10-100-75-75-m-60-iso8859-2
toolbar.font:            -lucidatypewriter-medium-r-normal--10-100-75-75-m-60-iso8859-2

Offline Jacek Lehmann

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Kompilacja
« Odpowiedź #3 dnia: 2005-06-06, 09:25:51 »
ciężka sprawa,
spróbuj ściągnąć najnowszego fluxboxa (9.13)
ja go używam i nie mam problemów,

co do aterma to sprawdz też czy masz taki
wpis w xorg.conf w sekcji [InputDevice]
Option      \\"XkbLayout\\"  \\"pl\\"

spróbuj zmienić locale z pl_PL..UTF-8 na pl_PL.ISO8859-2

Offline paweł gieroba

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 42
    • Zobacz profil
Kompilacja
« Odpowiedź #4 dnia: 2005-06-06, 18:13:12 »
2005-06-06 09:25:51 jackkill napisał:

> ciężka sprawa,
 > spróbuj ściągnąć najnowszego fluxboxa (9.13)
 > ja go używam i nie mam problemów,
 >

ściągnąłem, skompilowałem, jednak bez rezultatu, wkońcu z rpma zainstalowałem też wersję 0.9.13 ale dalej to samo.

 > co do aterma to sprawdz też czy masz taki
 > wpis w xorg.conf w sekcji [InputDevice]
 > Option      \\"XkbLayout\\"  \\"pl\\"
 >

wpis mam, jednak miałem ustawione na de, więc przestawiłem na pl, przeładowalem serwer, ale atermowi to niesety nie pomogło :/

 > spróbuj zmienić locale z pl_PL..UTF-8 na pl_PL.ISO8859-2
 >
 >
 >

zrobiłem

export LANG=\\"pl_PL.iso88592\\"

bez rezultatu

walnąłem więc

export LANG=\\"pl_PL\\"

też nic

pozatym po wylogowaniu i ponownym zalogowaniu ustawiają mi sie stare locale... powinienem to chyba do /etc/profile gdzieś wrzucić żeby mi przy każdym starcie je exportował, ale nie wiem za bardzo gdzie to wsadzić do tego skryptu...

Offline paweł gieroba

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 42
    • Zobacz profil
Kompilacja
« Odpowiedź #5 dnia: 2005-06-06, 21:47:19 »
z menu sobie poradziłem jako tako, znalazłem w którymś ze styli takie coś

window.tab.font:                     -*-lucida-medium-r-*-*-14-*-*-*-*-60-*-*
toolbar.font:                        -*-lucida-bold-r-*-*-*-100-*-*-*-*-*-*
window.font:                         -*-lucida-medium-r-normal-*-12-*-*-*-*-*-*-*
#menu.title.font:                    -*-lucida-bold-r-*-*-*-100-*-*-*-*-*-*
menu.title.font:                     -*-lucida-bold-r-*-*-*-100-*-*-*-*-*-*
menu.frame.font:                     -*-lucida-medium-r-*-*-14-100-*-*-*-*-*-*

trochę pozmieniałem wielkość czcionki i działa, ale co do reszty to nie za bardzo mam pojęcie co zrobić... gdzieś wyczytałem że trzeba cać konfigure bez czegośtamalias, no i zrobiłm, ale też nic nie dało...
w dodatku wlazlem w qtconfig i tam przejrzalem wszystkie fonty ale żadna nie pokazuje mi ó (dziwne że w mozilli moge napisać ó)
wiem że ten temat był wiele razy poruszany, ale ja przeszukałem już wiele for oraz dokumentacje fluxa i nic co by mi pomogło nie znalazłem... :/

Offline Przemysław Kułakowski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Kompilacja
« Odpowiedź #6 dnia: 2005-10-29, 18:29:58 »
ja rozwiazalem problem w taki sposób
(nadmienie ze w konsoli działały mi polskie fonty. w momencie odpalania iksów fonty nie działały)
plik .Xresources
aterm*font:-*-*-*-*-*-*-14-*-*-*-*-*-iso8859-2
aterm*geometry:90x35
aterm*background:       #0a3f71
aterm*borderWidth:      0
aterm*color0:           Black
aterm*color1:           #b5001e
aterm*color2:           #169302
aterm*color3:           #b5b200
aterm*color4:           #0059ba
aterm*color5:           #a500b5
aterm*color6:           #0078b5
aterm*color7:           AntiqueWhite
aterm*color8:           Grey25
aterm*color9:           #ff6b6b
aterm*color10:          #6bffc8
aterm*color11:          #fff26b
aterm*color12:          #6bb2ff
aterm*color13:          #f76bff
aterm*color14:          #6bd5ff
aterm*color15:          White
aterm*cursorColor:      #aaaaaa
aterm*cursorColor2:     #0059ba
aterm*foreground:       #aaaaaa
aterm*pointerColor:     #6bb2ff
aterm*scrollBar:        false
aterm*tinting:          #4e8dc7
aterm*tintingType:      true
aterm*transparent:      true

najistotniejsza jest ta linijka aterm*font:-*-*-*-*-*-*-14-*-*-*-*-*-iso8859-2

po wszystkim restart iksów
pozdro

Offline Rafał D*******

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 18
    • Zobacz profil
Kompilacja
« Odpowiedź #7 dnia: 2005-06-02, 20:51:57 »
Jak skompilować źródła xorg, gdy make && make install niedziala (i czemu nie dziala). Co musze zrobic? Odrazu zaznaczam, że jestem totalnym niewbie :]

P.S.
Mam slacka 10.0 (zipslack)

Offline Grzegorz L

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
Kompilacja
« Odpowiedź #8 dnia: 2005-06-02, 20:59:42 »
Nie ma gotowej juz skompilowanej paczki dla slacka ?
Co oznacza nie da sie ? Moze jakis blad wypisuje ?

Offline Arek ...

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
Kompilacja
« Odpowiedź #9 dnia: 2005-06-02, 22:03:48 »
Zipslack ma 100MB więc siło rzeczy jest okrojony z pewnych rzeczy, między innymi z narzędzi służących do kompilacji...

Offline Rafał D*******

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 18
    • Zobacz profil
Kompilacja
« Odpowiedź #10 dnia: 2005-06-02, 22:23:55 »
2005-06-02 22:03:48 arkh napisał:

> Zipslack ma 100MB więc siło rzeczy jest okrojony z pewnych rzeczy, między innymi z narzędzi
 > służących do kompilacji...

to by wyjasnialo blad: bash: make: command not found :P

mozecie mi wiec powiedziec jak sie nazywa paczka z narzedziami do kompilacji?

Offline Wojciech Miłkowski

  • Global Moderator
  • Stały bywalec
  • *****
  • Wiadomości: 206
    • Zobacz profil
Kompilacja
« Odpowiedź #11 dnia: 2005-06-02, 23:18:10 »
> mozecie mi wiec powiedziec jak sie nazywa paczka z narzedziami do kompilacji?

Porywasz się z motyką na Księżyc.
Primo konfiguracja X-ów nie jest tak banalna jak zapuszenie configure i make.
Secundo sama paczka z kompilatorem nie wystarczy, potrzebne są jeszcze wszytskie wymagane nagłówki i biblioteki, a tego może być sporo...
Reasumując - ściągnij gotową skompilowanę paczkę i zapomnij o tym pomyśle jeśli naprawdę nie wiesz jak to zrobić.

Wojtek

Offline Rafał D*******

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 18
    • Zobacz profil
Kompilacja
« Odpowiedź #12 dnia: 2005-06-04, 01:14:37 »
hmm..dzieki za rade :P
problem jest taki ze starszymi wersjami mam problemy a najnowszej skompilowanej nie moge nigdzie znalezc :]
Chyba przerzuce sie z zipslacka na normalnego slackware'a na normalnej partycji z normalnym KDE, Xami i wszystkim innym :P

...thx anyway