Nowe posty

Autor Wątek: Instalacja VLC d backports w debian stable wheezy  (Przeczytany 2109 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 42
    • Zobacz profil
Instalacja VLC d backports w debian stable wheezy
« dnia: 2014-08-17, 14:18:04 »
Witam.

W debian wheezy stable 64 bit backports wystepuje problem nie kompatybilności. Znany tez w necie ale nikt nie podał rozwiązania.

Mianowicie normalnie po aktywowaniu architektury i386 w debian wheezy 64 bit mozna instalować programy 32 bitowe a wśród nich np. wine.

Niestety problem w tym, że po zainstalowaniu VLC ale z backports nie można już instalować programów i386 a na pewno nie wine. Mało tego o ile wcześniej przed instalacją VLC można było zainstalować virtualbox najnowszego (deb) to jeśli najpierw instaluje się vlc z backports to potem w virtualbox jest problem kompatybilności bibliotek.

Jedyne rozwiązanie jakie znalazłem to przeinstalować system i instalowac vlc nie z backports albo najpierw instalować wszystko a na końcu VLC z backports ale to nie jest zadne rozwiązanie.

A więc proszę was o pomoc.
Scenariusz jest taki.
Po zainstalowaniu systemu wheezt stable 64bit i uaktywnieniu i386 instaluję vlc
apt-get -t wheezy-backports install vlc
następnie próbuję zainstalować wine i dostaję poniższy błąd. Bardzo chciałbym wiedzieć jak mogę go rozwiązać, jak mogę zrobić porządek z bibliotekami.


root@vbdebian:/home/robert/Downloads# apt-get install wine:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 wine:i386 : Hängt ab von: wine-bin:i386 (>= 1.4.1-4) soll aber nicht installiert werden oder
                            wine64-bin:i386 (>= 1.4.1-4) ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Jestem zaskoczony, że vlc zaleca na swojeje stronie instalować swój program z backports na debiana stable podczas gdy nie jest w pełni kompatybilny.

Kiedy próbuję wykonać
aptitude install wine:i386
dostaję

root@vbdebian:~# aptitude install wine:i386
Die folgenden NEUEN Pakete werden zusätzlich installiert:
  gcc-4.7-base:i386{a} libasound2:i386{a} libc6:i386{a} libc6-i686:i386{a} libdbus-1-3:i386{a} libdrm-intel1:i386{a} libdrm-nouveau1a:i386{a} libdrm-radeon1:i386{a} libdrm2:i386{a} libexpat1:i386{a}
  libffi5:i386{a} libfontconfig1:i386{a} libfreetype6:i386{a} libgcc1:i386{a} libgcrypt11:i386{a} libgl1-mesa-dri:i386{a} libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a} libglu1-mesa:i386{a}
  libgnutls26:i386{a} libgpg-error0:i386{a} libgpm2:i386{a} libgsm1:i386{a} libice6:i386{a} libjbig0:i386 libjpeg8:i386{a} libltdl7:i386{a} liblzma5:i386{a} libmpg123-0:i386{a} libncurses5:i386{a}
  libodbc1:i386{a} libp11-kit0:i386{ab} libpciaccess0:i386{a} libpng12-0:i386{a} libsm6:i386{a} libssl1.0.0:i386{a} libstdc++6:i386{a} libtasn1-3:i386{a} libtiff4:i386{a} libtinfo5:i386{a} libuuid1:i386{a}
  libv4l-0:i386{a} libv4lconvert0:i386{a} libwine:i386{a} libwine-alsa:i386{a} libwine-bin:i386{a} libwine-gecko-1.4{a} libwine-gl:i386{a} libx11-6:i386{a} libx11-xcb1:i386{a} libxau6:i386{a}
  libxcb-glx0:i386{a} libxcb1:i386{a} libxcomposite1:i386{a} libxcursor1:i386{a} libxdamage1:i386{a} libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} libxi6:i386{a} libxinerama1:i386{a} libxml2:i386{a}
  libxrandr2:i386{a} libxrender1:i386{a} libxslt1.1:i386{a} libxxf86vm1:i386{a} uuid-runtime{a} wine:i386{b} wine-bin:i386{ab} zlib1g:i386{a}
Die folgenden Pakete werden aktualisiert:
  libssl1.0.0
1 Pakete aktualisiert, 70 zusätzlich installiert, 0 werden entfernt und 33 nicht aktualisiert.
93,5 MB an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 265 MB zusätzlich belegt sein.
Die folgenden Pakete haben verletzte Abhängigkeiten:
 libp11-kit0 : Beschädigt: libp11-kit0:i386 (!= 0.20.2-1~bpo70+1) aber 0.12-3 soll installiert werden.
 libp11-kit0:i386 : Beschädigt: libp11-kit0 (!= 0.12-3) aber 0.20.2-1~bpo70+1 ist installiert.
 wine-bin:i386 : Kollidiert mit: wine64-bin aber 1.4.1-4 ist installiert.
 wine : Kollidiert mit: wine:i386 aber 1.4.1-4 soll installiert werden.
 wine:i386 : Kollidiert mit: wine aber 1.4.1-4 ist installiert.
 wine64-bin : Kollidiert mit: wine-bin, welches ein virtuelles Paket ist.
              Kollidiert mit: wine-bin:i386 aber 1.4.1-4 soll installiert werden.
offen: 266; geschlossen: 1139; zurückgestellt: 86; Konflikte: 126                                                                                                                                                oDie folgenden Aktionen werden diese Abhängigkeiten auflösen:

       Entfernen der folgenden Pakete:                                                                        
1)       aisleriot                                                                                            
2)       alacarte                                                                                              
3)       ant                                                                                                  
4)       ant-optional                                                                                          
5)       apache2.2-bin                                                                                        
6)       aptdaemon                                                                                            
7)       baobab                                                                                                
8)       bluez-cups                                                                                            
9)       brasero                                                                                              
10)      browser-plugin-gnash                                                                                  
11)      bsd-mailx                                                                                            
12)      ca-certificates-java                                                                                  
13)      caribou                                                                                              
14)      caribou-antler                                                                                        
15)      cheese                                                                                                
16)      cups                                                                                                  
17)      cups-bsd                                                                                              
18)      cups-client                                                                                          
19)      cups-filters                                                                                          
20)      cups-pk-helper                                                                                        
21)      cups-ppdc                                                                                            
22)      dconf-tools                                                                                          
23)      default-jre                                                                                          
24)      default-jre-headless                                                                                  
25)      empathy                                                                                              
26)      eog                                                                                                  
27)      evince                                                                                                
28)      evolution                                                                                            
29)      evolution-data-server                                                                                
30)      evolution-plugins                                                                                    
31)      evolution-webcal                                                                                      
32)      exim4                                                                                                
33)      exim4-daemon-light                                                                                    
34)      file-roller                                                                                          
35)      foomatic-db-engine                                                                                    
36)      gcalctool                                                                                            
37)      gconf-service                                                                                        
38)      gconf2                                                                                                
39)      gcr                                                                                                  
40)      gdebi                                                                                                
41)      gdm3                                                                                                  
42)      geany                                                                                                
43)      gedit                                                                                                
44)      gedit-plugins                                                                                        
45)      geoclue                                                                                              
46)      geoclue-hostip                                                                                        
47)      geoclue-localnet                                                                                      
48)      geoclue-manual                                                                                        
49)      geoclue-yahoo                                                                                        
50)      ghostscript                                                                                          
51)      ghostscript-cups                                                                                      
52)      gimp                                                                                                  
53)      gir1.2-caribou-1.0                                                                                    
54)      gir1.2-clutter-1.0                                                                                    
55)      gir1.2-clutter-gst-1.0                                                                                
56)      gir1.2-evince-3.0                                                                                    
57)      gir1.2-gck-1                                                                                          
58)      gir1.2-gconf-2.0                                                                                      
59)      gir1.2-gcr-3                                                                                          
60)      gir1.2-gdata-0.0                                                                                      
61)      gir1.2-gkbd-3.0                                                                                      
62)      gir1.2-gnomebluetooth-1.0                                                                            
63)      gir1.2-goa-1.0                                                                                        
64)      gir1.2-gtk-3.0                                                                                        
65)      gir1.2-gtkclutter-1.0                                                                                
66)      gir1.2-gtksource-3.0                                                                                  
67)      gir1.2-gucharmap-2.90                                                                                
68)      gir1.2-javascriptcoregtk-3.0                                                                          
69)      gir1.2-mutter-3.0                                                                                    
70)      gir1.2-networkmanager-1.0                                                                            
71)      gir1.2-panelapplet-4.0                                                                                
72)      gir1.2-peas-1.0                                                                                      
73)      gir1.2-rb-3.0                                                                                        
74)      gir1.2-soup-2.4                                                                                      
75)      gir1.2-totem-1.0                                                                                      
76)      gir1.2-totem-plparser-1.0                                                                            
77)      gir1.2-vte-2.90                                                                                      
78)      gir1.2-webkit-3.0                                                                                    
79)      gir1.2-wnck-3.0                                                                                      
80)      git                                                                                                  
81)      gkbd-capplet                                                                                          
82)      gksu                                                                                                  
83)      glchess                                                                                              
84)      glib-networking                                                                                      
85)      glines                                                                                                
86)      gnash                                                                                                
87)      gnash-common                                                                                          
88)      gnect                                                                                                
89)      gnibbles                                                                                              
90)      gnobots2                                                                                              
91)      gnome                                                                                                
92)      gnome-applets                                                                                        
93)      gnome-applets-data                                                                                    
94)      gnome-bluetooth                                                                                      
95)      gnome-color-manager                                                                                  
96)      gnome-contacts                                                                                        
97)      gnome-control-center                                                                                  
98)      gnome-core                                                                                            
99)      gnome-dictionary                                                                                      
100)     gnome-disk-utility                                                                                    
101)     gnome-documents                                                                                      
102)     gnome-font-viewer                                                                                    
103)     gnome-games                                                                                          
104)     gnome-icon-theme                                                                                      
105)     gnome-icon-theme-extras                                                                              
106)     gnome-icon-theme-symbolic                                                                            
107)     gnome-keyring                                                                                        
108)     gnome-mag                                                                                            
109)     gnome-media                                                                                          
110)     gnome-nettool                                                                                        
111)     gnome-online-accounts                                                                                
...............................................
...............................................    
421)     xulrunner-24.0                                                                                        
422)     yelp                                                                                                  
423)     zenity                                                                                                

       Die folgenden Abhängigkeiten unaufgelöst lassen:                                                        
424)     alacarte empfiehlt gnome-panel                                                                        
425)     at empfiehlt default-mta | mail-transport-agent                                                      
426)     bluetooth empfiehlt bluez-cups                                                                        
427)     cron empfiehlt exim4 | postfix | mail-transport-agent                                                
428)     cups empfiehlt printer-driver-gutenprint                                                              
429)     cups empfiehlt ghostscript-cups (>= 9.02~)                                                            
430)     empathy empfiehlt nautilus-sendto-empathy                                                            
431)     empathy-common empfiehlt yelp                                                                        
432)     evolution-common empfiehlt evolution                                                                  
433)     exim4-base empfiehlt mailx                                                                            
434)     libfolks25 empfiehlt libfolks-eds25                                                                  
435)     printer-driver-foo2zjs empfiehlt wget                                                                
436)     printer-driver-foo2zjs empfiehlt cups                                                                
437)     foomatic-db-compressed-ppds empfiehlt foomatic-db-engine                                              
438)     foomatic-db-compressed-ppds empfiehlt ghostscript                                                    
439)     foomatic-db-compressed-ppds empfiehlt cups                                                            
440)     foomatic-db-compressed-ppds empfiehlt cups-client                                                    
441)     openprinting-ppds empfiehlt cups                                                                      
442)     openprinting-ppds empfiehlt cups-client                                                              
443)     foomatic-db-engine empfiehlt cups                                                                    
444)     foomatic-db-engine empfiehlt cups-client                                                              
445)     foomatic-filters empfiehlt cups-client | lpr | lprng | rlpr                                          
446)     foomatic-filters empfiehlt ghostscript                                                                
447)     foomatic-filters empfiehlt cups | enscript | a2ps | mpage                                            
448)     foomatic-filters empfiehlt foomatic-db-engine (>= 4.0)                                                
449)     libgconf-2-4 empfiehlt gconf-service                                                                  
450)     gedit-common empfiehlt gedit                                                                          
451)     gimp empfiehlt ghostscript                                                                            
452)     gimp-data empfiehlt gimp                                                                              
453)     gksu empfiehlt gnome-keyring                                                                          
454)     glib-networking-common empfiehlt glib-networking                                                      
455)     glib-networking-services empfiehlt glib-networking                                                    
456)     gnash-common empfiehlt gstreamer0.10-plugins-bad                                                      
............................................
...........................................              
557)     libwebkitgtk-3.0-0 empfiehlt gstreamer0.10-plugins-good                                              
558)     libwebkitgtk-3.0-0 empfiehlt gstreamer0.10-plugins-bad                                                
559)     acpi-support empfiehlt xscreensaver | gnome-screensaver                                              


Diese Lösung akzeptieren? [Y/n/q/?]
Jeśli zaakceptuję to co proponuje aptitude to aptitude usunię mi dla kompatybilności bibliotek prawie cały system a pozostawi wine i kilka drobnych aplikacji :) co też jest zrozumiałe ale jak to naprawić, w jaki sposó szukać zależności żeby w przyszłości jak natrafię na taki program co będzie niekompatybilny jak vlc z backports to co robić...?

Przepraszam za uniedogodnienia mogące wyniknąc z niemieckiej wersji systemu.

Ten sam problem pojawił się też na forum:

http://www.linuxquestions.org/questions/debian-26/can't-install-wine-on-wheezy-64-bit-4175499221/

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2988
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Instalacja VLC d backports w debian stable wheezy
« Odpowiedź #1 dnia: 2014-08-17, 21:21:58 »
A co jest nie tak z wine:amd64 ? Dlaczego na siłę chcesz zepsuć system?

Przy okazji, przed wklejeniem komunikatów przełącz lokale choć na angielskie, bo jak widzę "Probleme können nicht korrigiert werden" to mi się granaty same odbezpieczają.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 42
    • Zobacz profil
Instalacja VLC d backports w debian stable wheezy
« Odpowiedź #2 dnia: 2014-08-17, 21:56:38 »
Jasne, następnym razem poczytam jak to zrobić i zmienię locale :)

Nie ma wine 64bit na wheezy stable w debian main repo.
Oczywiście, że wolałbym 64 bit (to samo, że skype).
Można wykonać apt-get install wine i wtedy instaluje jakby to nazwać mini część programu wine i po odpaleniu poleceniem "wine" wyświetla się zamiast programu wine informacja, że trzeba dodać architekturę i386 i instalować apt-get install wine:i386.