Nowe posty

Autor Wątek: Błąd w instalacji Neostradyt  (Przeczytany 1658 razy)

stefan2005

  • Gość
Błąd w instalacji Neostradyt
« dnia: 2005-11-07, 20:43:40 »
Mam problem z Mozilla przez przypadek kliknalem chyba cos takiego jak \\"zamknij wszyskie karty\\" aby zamknac wyskakujace okna i od tego czasu jak otwieram kilka okien to przewaznie zamyka mi sie Mozilla probowalem zmiany roznych ustawien ale nic to nie daje.
Zaznaczam, ze Linuxa uzywam dopiero od czterech dni i pewnie moje problemy sa dla Was banalne ale bybym wdzieczny za rade.
Pozdrawiam Wszystkich


Numenor

  • Gość
Błąd w instalacji Neostradyt
« Odpowiedź #1 dnia: 2005-11-07, 20:32:38 »
Witam serdecznie.
Jestem użytkownikiem Mandrake 10.0, posiadam modem Sagem USB F@st800. Po ściągnięciu sterownika eagle-1.0.4, rozpakowaniu go w /tmp (jako root) i poprawce w pliku /etc/fstab, wejściu w katalog eagle-1.0.4 wpisałem następujące komendę: make clean. Wszystko poszło dobrze. Problem pojawia się po przy drugim poleceniu: make . Wyskakują tutaj błędy uniemożliwiające instalację:
-----------------------------------------------------------------------------------
 [root@localhost eagle-1.0.4]# make
make -C driver &&
make -C pppoa &&
make -C scripts
make[1]: Entering directory `/tmp/eagle-1.0.4/driver'
make[2]: Entering directory `/tmp/eagle-1.0.4/driver'
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2 -M *.c > .depend
make[2]: Leaving directory `/tmp/eagle-1.0.4/driver'
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o AdiUsbAdslDriver.o AdiUsbAdslDriver.
c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Boot.o Boot.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Util.o Util.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Pipes.o Pipes.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Me.o Me.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Sm.o Sm.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Msg.o Msg.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Dsp.o Dsp.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Mpoa.o Mpoa.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Uni.o Uni.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Sar.o Sar.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Crc.o Crc.c
gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
e  -mpreferred-stack-boundary=2 -O2   -c -o Oam.o Oam.c
ld -r -o adiusbadsl.o AdiUsbAdslDriver.o Boot.o Util.o Pipes.o Me.o Sm.o Msg.o D
sp.o Mpoa.o Uni.o Sar.o Crc.o Oam.o
make -C ./firmware
make[2]: Entering directory `/tmp/eagle-1.0.4/driver/firmware'
gcc -O2 -pipe -Wall -pedantic builddsp.c -o buildDSP
./buildDSP -d sagem/eagle DSPcode.bin
Reading file sagem/eagle/rtbld0.bnm
Reading file sagem/eagle/rtbld1.bnm
Reading file sagem/eagle/rtbld2.bnm
Reading file sagem/eagle/rtbld3.bnm
Reading file sagem/eagle/rtbld4.bnm
Writing file DSPcode.bin
make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/firmware'
make -C ./user
make[2]: Entering directory `/tmp/eagle-1.0.4/driver/user'
gcc -O2 -pipe -Wall -pedantic -DLINUX -g adictrl.c -o adictrl
adictrl.c:184: error: redefinition of `struct usb_device_descriptor'
make[2]: *** [adictrl] Bł±d 1
make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/user'
make[1]: *** [adiuser] Bł±d 2
make[1]: Leaving directory `/tmp/eagle-1.0.4/driver'
make: *** [build] Bł±d 2
[root@localhost eagle-1.0.4]# make install
other beforeInstall
make[1]: Entering directory `/tmp/eagle-1.0.4/driver'
make -C ./firmware
make[2]: Entering directory `/tmp/eagle-1.0.4/driver/firmware'
make[2]: Nie nic do roboty w `all'.
make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/firmware'
make -C ./firmware install
make[2]: Entering directory `/tmp/eagle-1.0.4/driver/firmware'
gcc -O2 -pipe -Wall -pedantic firmware.c -o buildFirmware
In file included from firmware.c:12:
Firmware8051.h:2509:8: warning: C++ style comments are not allowed in ISO C90
Firmware8051.h:2509:8: warning: (this will be reported only once per input file)
./buildFirmware
mkdir -p /etc/analog
/usr/bin/install -c -m 0664 -o root -g root *.bin /etc/analog
make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/firmware'
make -C ./user
make[2]: Entering directory `/tmp/eagle-1.0.4/driver/user'
gcc -O2 -pipe -Wall -pedantic -DLINUX -g adictrl.c -o adictrl
adictrl.c:184: error: redefinition of `struct usb_device_descriptor'
make[2]: *** [adictrl] Bł±d 1
make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/user'
make[1]: *** [adiuser] Bł±d 2
make[1]: Leaving directory `/tmp/eagle-1.0.4/driver'
make: *** [install] Bł±d 2
[root@localhost eagle-1.0.4]#

 
------------------------------------------------------------------------------
Przyznam się szczerze, że moja wiedza na temat Linuxa nie jest wystarczająca. Dlatego też bardzo proszę o pomoc w tej sprawie. Z góry uprzejmie dziękuję.

                                                Numenor.

Muzzy123

  • Gość
Błąd w instalacji Neostradyt
« Odpowiedź #2 dnia: 2006-04-27, 21:54:44 »
2005-11-07 20:32:38 Numenor napisał:

> Witam serdecznie.
 > Jestem użytkownikiem Mandrake 10.0, posiadam modem Sagem USB F@st800. Po ściągnięciu sterownika
 > eagle-1.0.4, rozpakowaniu go w /tmp (jako root) i poprawce w pliku /etc/fstab, wejściu w katalog
 > eagle-1.0.4 wpisałem następujące komendę: make clean. Wszystko poszło dobrze. Problem pojawia
 > się po przy drugim poleceniu: make . Wyskakują tutaj błędy uniemożliwiające instalację:
 > -----------------------------------------------------------------------------------
 >  [root@localhost eagle-1.0.4]# make
 > make -C driver &&
 > make -C pppoa &&
 > make -C scripts
 > make[1]: Entering directory `/tmp/eagle-1.0.4/driver'
 > make[2]: Entering directory `/tmp/eagle-1.0.4/driver'
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2 -M *.c > .depend
 > make[2]: Leaving directory `/tmp/eagle-1.0.4/driver'
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o AdiUsbAdslDriver.o AdiUsbAdslDriver.
 > c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Boot.o Boot.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Util.o Util.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Pipes.o Pipes.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Me.o Me.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Sm.o Sm.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Msg.o Msg.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Dsp.o Dsp.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Mpoa.o Mpoa.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Uni.o Uni.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Sar.o Sar.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Crc.o Crc.c
 > gcc -DLINUX -D__KERNEL__ -DMODULE -I/usr/src/linux/include '-DADIDRIVERVERSION="
 > 1.0.4"' -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pip
 > e  -mpreferred-stack-boundary=2 -O2   -c -o Oam.o Oam.c
 > ld -r -o adiusbadsl.o AdiUsbAdslDriver.o Boot.o Util.o Pipes.o Me.o Sm.o Msg.o D
 > sp.o Mpoa.o Uni.o Sar.o Crc.o Oam.o
 > make -C ./firmware
 > make[2]: Entering directory `/tmp/eagle-1.0.4/driver/firmware'
 > gcc -O2 -pipe -Wall -pedantic builddsp.c -o buildDSP
 > ./buildDSP -d sagem/eagle DSPcode.bin
 > Reading file sagem/eagle/rtbld0.bnm
 > Reading file sagem/eagle/rtbld1.bnm
 > Reading file sagem/eagle/rtbld2.bnm
 > Reading file sagem/eagle/rtbld3.bnm
 > Reading file sagem/eagle/rtbld4.bnm
 > Writing file DSPcode.bin
 > make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/firmware'
 > make -C ./user
 > make[2]: Entering directory `/tmp/eagle-1.0.4/driver/user'
 > gcc -O2 -pipe -Wall -pedantic -DLINUX -g adictrl.c -o adictrl
 > adictrl.c:184: error: redefinition of `struct usb_device_descriptor'
 > make[2]: *** [adictrl] Bł±d 1
 > make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/user'
 > make[1]: *** [adiuser] Bł±d 2
 > make[1]: Leaving directory `/tmp/eagle-1.0.4/driver'
 > make: *** [build] Bł±d 2
 > [root@localhost eagle-1.0.4]# make install
 > other beforeInstall
 > make[1]: Entering directory `/tmp/eagle-1.0.4/driver'
 > make -C ./firmware
 > make[2]: Entering directory `/tmp/eagle-1.0.4/driver/firmware'
 > make[2]: Nie nic do roboty w `all'.
 > make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/firmware'
 > make -C ./firmware install
 > make[2]: Entering directory `/tmp/eagle-1.0.4/driver/firmware'
 > gcc -O2 -pipe -Wall -pedantic firmware.c -o buildFirmware
 > In file included from firmware.c:12:
 > Firmware8051.h:2509:8: warning: C++ style comments are not allowed in ISO C90
 > Firmware8051.h:2509:8: warning: (this will be reported only once per input file)
 > ./buildFirmware
 > mkdir -p /etc/analog
 > /usr/bin/install -c -m 0664 -o root -g root *.bin /etc/analog
 > make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/firmware'
 > make -C ./user
 > make[2]: Entering directory `/tmp/eagle-1.0.4/driver/user'
 > gcc -O2 -pipe -Wall -pedantic -DLINUX -g adictrl.c -o adictrl
 > adictrl.c:184: error: redefinition of `struct usb_device_descriptor'
 > make[2]: *** [adictrl] Bł±d 1
 > make[2]: Leaving directory `/tmp/eagle-1.0.4/driver/user'
 > make[1]: *** [adiuser] Bł±d 2
 > make[1]: Leaving directory `/tmp/eagle-1.0.4/driver'
 > make: *** [install] Bł±d 2
 > [root@localhost eagle-1.0.4]#
 >
 >  
 > ------------------------------------------------------------------------------
 > Przyznam się szczerze, że moja wiedza na temat Linuxa nie jest wystarczająca. Dlatego też
 > bardzo proszę o pomoc w tej sprawie. Z góry uprzejmie dziękuję.
 >
 >                                                 Numenor.

Moze to
https://newbie.linux.pl/?id=article&kategoria=4&show=146
lub:
https://newbie.linux.pl/?id=article&kategoria=4&show=239
Z tego co widze masz za stare sterowniki eagel.
Pozdrawiam i powodzenia

piotrek22

  • Gość
Błąd w instalacji Neostradyt
« Odpowiedź #3 dnia: 2006-04-27, 22:28:44 »
2006-04-27 21:54:44 Muzzy123 napisał:

> 2005-11-07 20:32:38 Numenor napisał:
 >
 
 >
 > Moze to
 > https://newbie.linux.pl/?id=article&kategoria=4&show=146
 > lub:
 > https://newbie.linux.pl/?id=article&kategoria=4&show=239
 > Z tego co widze masz za stare sterowniki eagel.
 > Pozdrawiam i powodzenia
 

Zdecydowanie, już od dość dawna używam wersji 1.9.9. Zachowuje się bardzo stabilnie, może już są nowsze.