Nowe posty

Autor Wątek: Karta wspierana przez starsza wersje sterownika  (Przeczytany 4670 razy)

wena

  • Gość
Karta wspierana przez starsza wersje sterownika
« dnia: 2013-11-08, 03:21:48 »
Witam.

Przy instalacji nowych dystrybucji na moim laptopie co prawda zostaje wybierany dobry sterownik lub sam moge przez xorg.conf wskazac wlasciwy jednak z wydajnoscia nie jest za dobrze ~60fps przy glxgears (i to w okienku). Problem polega na tym, iz moja karta ATI Mobility FireGL V5250 jest wspierana przez wczesniejsza wersje sterownika te z kolei wymagaja starszej wersji X'ow. Wiem, ze raczej nie jest problemowym wymuszenie starszej wersji pakietu przez downgrade ale jak jest w przypadku czegos tak wielkiego jak serwer X ? Czy przejscie na nizsza wersje wymusza kozystanie ze starszych wersji innych pakietow kozystajacych z serwera graficznego ? Jak zmusic system do wsparcia starszego sprzetu czy jest jakis inny sposob ? Podobny problem spotkalem przy dellu d400 i karcie intela 855 gdzie pozostanie na dostepnych sterownikach powoduje ze  nawet youtube dziala bardzo malo wydajnie gdzie na xp'ku nie bylo problemu. Mile widziane sugestie.
Pozdrawiam.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 3062
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
Karta wspierana przez starsza wersje sterownika
« Odpowiedź #1 dnia: 2013-11-08, 07:10:50 »
Xorg jest powiązany z tyloma kluczowymi bibliotekam systemowymii, że downgrade xów praktycznie jest niewykonalny. Pamiętam zabawy pod Gentoo z utrzymaniem drivera Nvidii w wersji 2xx - blokowało X-y i kernela a przez to wiele innych bibliotek.

Pozostaje zainstalowanie najnowszej wersji systemu posiadającej jeszcze właściwy sterownik. I wysłanie stosownych żali do ATI/AMD.

P.S. Argument "na XPku było ok" jest trochę nietrafiony - XP powstał 12 lat temu... Zainstaluj na tym laptopie Windows 8 to pogadamy o wsparciu do starego sprzętu.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

chmooreck

  • Gość
Karta wspierana przez starsza wersje sterownika
« Odpowiedź #2 dnia: 2013-11-08, 09:36:39 »
Cytat: wena
Witam.

Przy instalacji nowych dystrybucji na moim laptopie co prawda zostaje wybierany dobry sterownik lub sam moge przez xorg.conf wskazac wlasciwy jednak z wydajnoscia nie jest za dobrze ~60fps przy glxgears (i to w okienku).
glxgears jest w tym przypadku synchronizowane do częstotliwości odświeżania ekranu. Ma się nijak do wydajności grafiki.
glxgears to nie jest żaden benchmark.

Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2769
  • 1709
    • Zobacz profil
Karta wspierana przez starsza wersje sterownika
« Odpowiedź #3 dnia: 2013-11-08, 11:07:14 »
Te ~60fps to może pokazywać częstotliwości odświeżania ekranu
jak chmooreck napisał.
( Taki linuxowy zonk :D )
Żebyś zobaczył "coś innego" musiałbyś wyłączyć synchronizację tego z częstotliwością ekranu.
( Nie wiem jak, jesli bylyby to sterowniki producenta to szukałbym w konfiguratorze ATI )

Wniosek:
Te 60 fps nie musi być wyznacznikiem wydajności, trzeba porównać z czymś innym.
Są też testery on-line, ale jak to benchmark kazda troche inaczej pokazuje wyniki,
a dwa ta synchronizacja w testach często przeszkadza bo test jest zafałszowany do 60 fps (odswiezania ekranu).

http://ie.microsoft.com/testdrive/performance/fishIETank/default.html
ja przy 1000 rybek mam 57fps minimum, a jakbym mniej wybrał to zwsze 60fps.
Możesz przetestować w Red Eclipse, głowy urwać sobie nie dam, ale chyba pokazywało tam fps.
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.

wena

  • Gość
Karta wspierana przez starsza wersje sterownika
« Odpowiedź #4 dnia: 2013-11-08, 13:32:08 »
@chmooreck wiem ,ze glxgear nie jest zadnym benchmark ale pokazuje czy akceleracja jest wlaczona. Nie jest to wynik odswiezania monitora bo wtedy wynik polecenia glxgears bylby poprzedzony komunikatem:
 "Running synchronized to the vertical refresh. The framerate should be approximately the same as the monitor refresh rate."

@pkraszewski Petycji do ati chyba nie ma juz co pisac skoro wsparcie dla karty skonczylo ise tak dawno temu. Wlasnie chodzilo mi o sens downgrade takiego duzego pakietu jak xorg i konsekwencji jakie to ze soba niesie. O ile na t60p wsparcie otwartych sterownikow jest na tyle dobre, ze nie odczowam dyskomfortu podczas pracy. To kwestia dell'a wyglada gorzej. Argument z xp'kiem bardziej mial wskazac, ze stary system wspolpracuje bez problemu z nowymi aplikacjami i nie jest wina starosci sprzetu brak plynnosc np przy wyswielaniu yt. Kwestia jak wyglada wsparcie dla dla intel 855gm dla linuksa chyba, ze jedynym wyjsciem jest instalacja starej dystrybucji i wymuszenie braku aktualizacji pakietow.