Nowe posty

Autor Wątek: "kdeinit" coudin't start (Nvidia)  (Przeczytany 6494 razy)

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 268
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« dnia: 2005-11-02, 14:02:59 »
Od nie dawna zacząłem używać iceWM i mam taki problem. Jak umieścić na pulpicie ikony takie jak np. w KDE. Wiem że można tak zrobić bo w CD Linuksie właśnie tak jest. Używam Auroxa 10.0. Dzięki za wszystkie wpisy.
jak podmontowac partycje, zeby pliki mialy 666, a nie 777 ?
a ty co, satanista?

http://www.java-bean.net

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #1 dnia: 2005-11-02, 14:52:43 »
przygladnij sie rox\\'owi...

Offline Maciej Rutecki

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2107
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #2 dnia: 2005-11-02, 19:42:07 »
2005-11-02 14:02:59 axlinux napisał:

> Od nie dawna zacząłem używać iceWM i mam taki problem. Jak umieścić na pulpicie ikony takie jak
 > np. w KDE. Wiem że można tak zrobić bo w CD Linuksie właśnie tak jest. Używam Auroxa 10.0.
 > Dzięki za wszystkie wpisy.

http://icewm.golf-olszewka.home.pl/icewm/faq.php?numer=3

--
Maciek

Offline Tadeusz Gruszczyński

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 173
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #3 dnia: 2005-11-01, 22:29:32 »
Prawie gotowa instalacja Nvidii, ale...

Dotychczas używałem w Slackware-2.6.13 do mojej grafiki NVIDIA RIVA TNT  stery "nv".
Po zainstalowaniu NVIDIA-Linux-7174 i skonfigurowaniu "xorg.conf" i uruchomieniu pokazuje się logo Nvidia właczaja okienka X
i pojawia się taki komunikat:

"kdeinit couldn't start.  Check your installation"

Do tej pory na sterownikach 'nv'  miałaem wszystko w porządku!
W dodatku przywracajać konfigurację z "nv" serwer już się nie uruchamia.
Moje xorg.conf [fragm]:

Section   "ServerLayout"
   Identifier     "Simple Layout"
   Screen         "Screen1" 0 0
   InputDevice    "Mouse1" "CorePointer"
   InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"

   ModulePath "/usr/X11R6/lib/modules"
   RgbPath      "/usr/X11R6/lib/X11/rgb"
   FontPath    ..............
EndSection

Section "Module"
     Load       "dbe"   # Double buffer extension
     Load  "extmod"
     SubSection "extmod"
   Option       "omit xfree86-dga"   # don't initialise the DGA extension
EndSubSection
     Load       "type1"
     Load       "freetype"
     Load     "record"
     Load     "bitmap"
#        Load      "glx"
#        Load     "GLcore"
EndSection
 
Section "Monitor"
   Identifier   "Monitor1"
   HorizSync    31.5 - 50.0
   VertRefresh  40.0 - 90.0
EndSection

Section "Device"
     Identifier  "nVIDIA"
     Driver      "nvidia"
     BoardName   "RIVA TNT"
     Option      "NvAGP"  "1"
     Option      "NoLogo" "false"
     BusID   "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "nVIDIA"
   Monitor    "Monitor1"
   DefaultDepth     24
SubSection "Display"
..........
EndSection

Fragmenty Xorg.log:

Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen1" (0)
(**) |   |-->Monitor "Monitor1"
(**) |   |-->Device "nVIDIA"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(WW) `fonts.dir' not found (or not valid) in "/usr/local/share/fonts".
   Entry deleted from font path.
............................
(II) LoadModule: "bitmap"
(II) LoadModule: "pcidata"
(II) Module pcidata: vendor="X.Org Foundation"
(II) LoadModule: "dbe"
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) LoadModule: "extmod"
(II) LoadModule: "type1"
(II) Loading font FreeType
(II) LoadModule: "record"
(II) LoadModule: "bitmap"
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.7174
   Module class: XFree86 Video Driver
(II) NVIDIA X Driver  1.0-7174  Tue Mar 22 06:48:37 PST 2005
(II) Primary Device is: PCI 01:00:0
(--) Chipset NVIDIA GPU found
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(**) NVIDIA(0): Option "NoLogo" "false"
(**) NVIDIA(0): Option "NvAGP" "1"
......
(II) NVIDIA(0): NVIDIA GPU detected as: RIVA TNT
(--) NVIDIA(0): VideoBIOS: 02.04.20.00.00
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): VideoRAM: 16384 kBytes
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module ddc: vendor="X.Org Foundation"
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) NVIDIA(0): Primary V_BIOS segment is: 0xc000
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
.............................
(II) NVIDIA(0): Setting mode "1024x768"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(II) Loading extension NV-CONTROL
(EE) NVIDIA(0): Failed to load GLX
Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
...........
Proszę o jakieś porady. Za ew. incjatywę Z góry dziękuję.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 46
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #4 dnia: 2005-11-01, 22:54:01 »
Witam
Nie znam sie na tyma za dobrze ale w README.txt z e sterów pisze chyba żeby z Section Module usunąć
"Load "glx"

może zadziała

Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #5 dnia: 2005-11-01, 22:56:28 »
2005-11-01 22:54:01 manve napisał:

> Witam
 > Nie znam sie na tyma za dobrze ale w README.txt z e sterów pisze chyba żeby z Section Module
 > usunąć
 > "Load "glx"
 >
 > może zadziała

Nie usunąć tylko właśnie wstawić (usunąć komentarz) :) Usunąć masz natomiast  DRI.  Ale manve podsunął b. dobry pomysł: przeczytaj README :)
Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 46
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #6 dnia: 2005-11-01, 23:03:12 »
faktycznie mój błąd
 miało być usunąć:
# Load "GLcore"
przepraszam za pomyłkę

Offline Tadeusz Gruszczyński

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 173
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #7 dnia: 2005-11-02, 01:18:07 »
2005-11-01 23:03:12 manve napisał:

* Jak ładuje GLcore to nic się nie zmienia
* jak ładuje glx to system się zawiesza i pozostaje reset

Offline Tadeusz Gruszczyński

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 173
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #8 dnia: 2005-11-02, 12:54:38 »
2005-11-02 01:18:07 Tad napisał:

A może problem leży gdzie indziej. W końcu logo Nvidi pokazuje się system startuje Kde się włacza tylko komunikat: o niemozliwości startowani "kdeinit"
Mogły ulec zniszczeniu jekieś pliki podczas kilkakrotnego restartu PC-ta przyciskiem na obudowie ?

Offline Jakub Zalas

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 534
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #9 dnia: 2005-11-02, 13:31:21 »
Na pewno powinieneś skomentować ładowanie dri oraz GLcore, a dodać ładowanie glx.

Poza tym z doświadczenia wiem, że niektóre stery nvidii nie działają z danym modelem karty. Do rivy tnt Radzę Ci spróbować wersji 6111 lub 6629.

Offline xis

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 1049
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #10 dnia: 2005-11-02, 14:05:56 »
Wygląda na to, że sterownik i X serwer działają OK. Powinieneś w takim razie sprawdzić czy to nie 'wina' KDE. Sprobuj na czas testowego uruchomienia zmienić nazwę katalogu ~/.kde na np. ~/.kde_old i wtedy uruchomić X.
Jeśli ruszy, to przyczyny szukaj w KDE (spróbuj sprawdzić logi itd.).
Everything should be made as simple as possible, but not simpler
-- Albert Einstein

Offline Tomcio Paluch

  • Users
  • Guru
  • *****
  • Wiadomości: 676
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #11 dnia: 2005-11-02, 14:45:05 »
2005-11-02 14:05:56 xis napisał:

> Wygląda na to, że sterownik i X serwer działają OK. Powinieneś w takim razie sprawdzić czy to
 > nie 'wina' KDE. Sprobuj na czas testowego uruchomienia zmienić nazwę katalogu ~/.kde na np.
 > ~/.kde_old i wtedy uruchomić X.
 > Jeśli ruszy, to przyczyny szukaj w KDE (spróbuj sprawdzić logi itd.).
 >

Odpal X'y ze swoim aktualnym konfigiem w ten sposob:
X -config /etc/X11/xorg.conf

Jezeli sie nie powiedzie wykluczysz bledy w managerach okien. Wowczas przyczyn szukaj w samych X'ach.

Offline Tomcio Paluch

  • Users
  • Guru
  • *****
  • Wiadomości: 676
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #12 dnia: 2005-11-02, 14:50:08 »
A poza tym, jezeli poprawiles cos w konfiguracji xorga i nadal nie dziala to wklej tutaj cala zawartosc /var/log/Xorg.0.log. oraz komunikat z jakim sie wysypuje.

Ponad to, jezeli proba odpalenia X'ow, konczy sie powrotem do konsoli, to jest to wina X'ow.

Ktos sugerowal zainstalowanie starszej wersji sterwonikow nvidii, proponuje wyprobowanie tego sladu.

Offline Tadeusz Gruszczyński

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 173
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #13 dnia: 2005-11-02, 16:51:59 »
Xax79 napisał:

> jezeli poprawiles cos w konfiguracji xorga i nadal nie dziala to wklej tutaj
 zwartosc juz wyzej zamieszczona w skrocie
 
 > Ponad to, jezeli proba odpalenia X'ow, konczy sie powrotem do konsoli, to jest to wina X'ow.

wlasnie przeinstalowalem x11-4.6.8-i486.tgz
i teraz niezaleznie od tego czy w xorg.conf
'nvidia', 'nv', 'fb-dev', czy 'vesa'  
ten sam blad;
couldn't start kdeint
i
'could not start network connection
/home/tad/,dcopserver-tad-tad--0'

i wyrzuca spowrotem z trybu graficznbego do konsoli.



Offline Tomcio Paluch

  • Users
  • Guru
  • *****
  • Wiadomości: 676
    • Zobacz profil
"kdeinit" coudin't start (Nvidia)
« Odpowiedź #14 dnia: 2005-11-02, 17:07:07 »
A probowales odpalic X'y tak:
X -config /etc/X11/xorg.conf

Najlepiej sproboj najpierw wygenerowac automatycznie plik konfiguracjny xorga.
Odpal jako root:
Xorg -configure

Poczytaj dobrze co zwraca, glownie czy nie ma tam informacji o bledach. Jezeli wszystko poszlo dobrze, w katalogu roota powinien byc plik xorg.conf.new. Odpal teraz cos takiego:
X -config /etc/X11/xorg.conf.new

Powinno sie odpalic srodowisko graficzne. Jezeli uparcie nie chce, to jedynie wglad do logow xorga moze wniesc cos wiecej informacji. Jezeli juz bedziesz zmuszony je tu wkleic to wstaw komplet.