Nowe posty

Autor Wątek: Kernel patch  (Przeczytany 4832 razy)

  • Gość
Kernel patch
« dnia: 2005-11-01, 19:30:16 »
probuje zainstalowac xmmsa 1.2.10 - zgodnie z tym co pojawilo sie przy jego ./configure sciagnalem atk 1.10.1 glib-2.8.3 gtk+ 2.8.6 i pango 1.10.1

problem w tym ze po instalacji glib cala reszta stwierdza ze wymagana jest wersja co najmniej 2.x.x (pango natomiast ze 2.5.x) oraz czasami ze mozliwe ze zainstalowany jest w innym miejscu i.. nalezy to zmienic ^_^ a ja nie wiem jak bo mam mandrake 10.1 od niecalego tygodnia :)

z gory dziekuje za pomoc!

  • Gość
Kernel patch
« Odpowiedź #1 dnia: 2005-11-01, 19:32:40 »
tu jest log (pongo i atk)..

checking for GLIB - version >= 2.5.7... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

  • Gość
Kernel patch
« Odpowiedź #2 dnia: 2005-11-01, 20:00:31 »
2005-11-01 19:30:16 miii_mako napisał:

> probuje zainstalowac xmmsa 1.2.10 - zgodnie z tym co pojawilo sie przy jego ./configure
 > sciagnalem atk 1.10.1 glib-2.8.3 gtk+ 2.8.6 i pango 1.10.1
 >
 > problem w tym ze po instalacji glib cala reszta stwierdza ze wymagana jest wersja co najmniej
 > 2.x.x (pango natomiast ze 2.5.x) oraz czasami ze mozliwe ze zainstalowany jest w innym miejscu
 > i.. nalezy to zmienic ^_^ a ja nie wiem jak bo mam mandrake 10.1 od niecalego tygodnia :)
 >
 > z gory dziekuje za pomoc!

Może spróbuj ustawić zmienną PKG_CONFIG_PATH tak by zawierała ścieżkę do glib-2.0.pc

np.
export PKG_CONFIG_PATH=\\'/jakis/tam/katalog/glib-2.0.pc\\'

a następnie wykonaj ./configure, ale nie wiem czy to jest to.

oldgoj

  • Gość
Kernel patch
« Odpowiedź #3 dnia: 2005-11-01, 20:29:47 »
2005-11-01 19:30:16 miii_mako napisał:

> probuje zainstalowac xmmsa 1.2.10 - zgodnie z tym co pojawilo sie przy jego ./configure
 > sciagnalem atk 1.10.1 glib-2.8.3 gtk+ 2.8.6 i pango 1.10.1
 >
 > problem w tym ze po instalacji glib cala reszta stwierdza ze wymagana jest wersja co najmniej
 > 2.x.x (pango natomiast ze 2.5.x) oraz czasami ze mozliwe ze zainstalowany jest w innym miejscu
 > i.. nalezy to zmienic ^_^ a ja nie wiem jak bo mam mandrake 10.1 od niecalego tygodnia :)
 >
 > z gory dziekuje za pomoc!

Zainstaluj odpowiednie paczki *devel
Pozdrawiam -
Piotr Kiedrzyński.

  • Gość
Kernel patch
« Odpowiedź #4 dnia: 2005-11-01, 22:13:22 »
jestem bardzo wdzieczny za zainteresowanie prosilbym jednak o jasniejsze wyjasnienie wszystko - ze tak powiem jak narazie \\'trzeba ze mna jak z dzieckiem\\' - z linuxem bawie sie od niecalego tygodnia i oczywiscie pewne rzeczy udalo mi sie juz wywnioskowac z innymi potrzebuje jednak pomocy udzielonej jezykiem najprostszym z mozliwych ^_^

jeszcze raz dziekuje!

Lorenzo

  • Gość
Kernel patch
« Odpowiedź #5 dnia: 2005-11-01, 22:26:35 »
Witam.

Ja bym proponował jednak instalowanie pakietów binarnych, ale skoro bardzo chcesz kompilować źródła, to musisz zainstalować pakiety -devel zawierające pliki nagłówkowe i inne mądre przydatne rzeczy bez których źródeł nie skompilujesz. A skoro ./configure marudził o atk, glib, gtk i pango to zainstaluj paczki glib--devel, etc.

Pozdrawiam
Dominik

pablo222

  • Gość
Kernel patch
« Odpowiedź #6 dnia: 2005-11-01, 18:21:21 »
Witam chciałbym sie dowiedziec
czy gdzies znajde patche na aktualne jadro
lub  odrazu zawierajace takie patche  chodzi mi o
esfq, imq, wrr, ipp2p, grsec itp
   czy za kazdym razem trzeba to recznie patchowac?
bo sam nie znalazlem nic do najnowszych wersji jadra 2.6
  qnet cos stanal, powerpack tez


dzieki za pomoc.

greg000

  • Gość
Kernel patch
« Odpowiedź #7 dnia: 2005-11-01, 18:26:59 »
Jak sie pojawią do najnowszych wersji to wtedy beda dostepne to chyba logiczne ;) Zazwyczaj trzeba recznie patchowac chyba ze ktos zna inna metode .

bizonek

  • Gość
Kernel patch
« Odpowiedź #8 dnia: 2005-11-02, 10:47:13 »
2005-11-01 18:21:21 pablo222 napisał:

> Witam chciałbym sie dowiedziec
 > czy gdzies znajde patche na aktualne jadro
 > lub  odrazu zawierajace takie patche  chodzi mi o
 > esfq, imq, wrr, ipp2p, grsec itp
 >    czy za kazdym razem trzeba to recznie patchowac?
 > bo sam nie znalazlem nic do najnowszych wersji jadra 2.6
 >   qnet cos stanal, powerpack tez
 >
 >
 > dzieki za pomoc.

Jezeli chcesz patcha na jadro 2.6.12.3 wraz z tymi rzeczami (nie bede wymienial), dodalem patcha odrazu do iptables i iproute


http://bizon.informel.pl/download/serwer/

pablo222

  • Gość
Kernel patch
« Odpowiedź #9 dnia: 2005-11-02, 16:36:20 »
>2005-11-02 10:47:13 bizonek napisał:
 > Jezeli chcesz patcha na jadro 2.6.12.3 wraz z tymi rzeczami (nie bede wymienial), dodalem
 > patcha odrazu do iptables i iproute
 >
 >
 > http://bizon.informel.pl/download/serwer/


ja bym chcial na jadro 2.6.14 :) na 2.6.12.3 to mam

pablo222

  • Gość
Kernel patch
« Odpowiedź #10 dnia: 2005-11-02, 16:37:48 »
ale dzieki za pomoc