Nowe posty

Autor Wątek: ifdown - nie działa  (Przeczytany 21007 razy)

Offline Marcin Maćczak

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 235
    • Zobacz profil
ifdown - nie działa
« Odpowiedź #30 dnia: 2005-06-02, 10:17:36 »
dobra od poczatku spojrz na pingi
----------------
Badanie 156.17.227.126 z użyciem 32 bajtów danych:

Odpowiedź z 156.17.227.126: bajtów=32 czas=2552ms TTL=255
Odpowiedź z 156.17.227.126: bajtów=32 czas<1 ms TTL=255
Odpowiedź z 156.17.227.126: bajtów=32 czas=1ms TTL=255
Odpowiedź z 156.17.227.126: bajtów=32 czas=1ms TTL=255
-----------------

pierwszy jest dziwnie duzy, pozniewaz win ma swoja wlasna popier@#%#$ logike wyglada na to, ze podczas pierwszego pinga on automatycznie szuka bramy w danej podsieci, bo przy normalnie skonfigurowanej bramie wszystkie pingi powinny miec ten sam czas. linux Ci nie pozwoli ustawić bramy z innej podsieci niz jestes i tak powinno byc na logike
sproboj ustawic jeszcze brame tego ip co ci admin podal na za pierwszym razem tylko,ze z 1 zamiast 0, czyli 192.168.1.126. jezeli to nie zadziala to bym na twoim miejscu sprobowal brac pokoleji kazde ip z twojej podsieci od 192.168.1.1 do 192.168.1.254 moze cos zadziala :] warto zawsze sprobowac
pozdrawiam
Maciasz

Offline Jakub Zalas

  • Global Moderator
  • Guru
  • *****
  • Wiadomości: 534
    • Zobacz profil
ifdown - nie działa
« Odpowiedź #31 dnia: 2005-06-02, 10:26:37 »
> sproboj ustawic jeszcze brame tego ip co ci admin podal na za pierwszym razem tylko,ze z 1
 > zamiast 0, czyli 192.168.1.126. jezeli to nie zadziala to bym na twoim miejscu sprobowal brac
 > pokoleji kazde ip z twojej podsieci od 192.168.1.1 do 192.168.1.254 moze cos zadziala :] warto

for i in `seq 1 254`; do ping 192.168.1.$i; done  

:P

Offline Marcin Maćczak

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 235
    • Zobacz profil
ifdown - nie działa
« Odpowiedź #32 dnia: 2005-06-02, 10:34:06 »
2005-06-02 10:26:37 gomath napisał:

 > for i in `seq 1 254`; do ping 192.168.1.$i; done  

jak juz to
r i in `seq 1 254`; do ping -c 1 192.168.1.$i; done

:P

Offline Grzegorz Świtkowski

  • Users
  • Guru
  • *****
  • Wiadomości: 516
    • Zobacz profil
ifdown - nie działa
« Odpowiedź #33 dnia: 2005-06-02, 12:51:18 »
> sproboj ustawic jeszcze brame tego ip co ci admin podal na za pierwszym razem tylko,ze z 1
 > zamiast 0, czyli 192.168.1.126.

Ewentualnie zostaw domniemany adres gateway\\'a a tylko zmien swoja maske z 24 bitowej na co najwyzej 23 bitową (255.255.254.0).

Offline Przemek Lisowski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 30
    • Zobacz profil
ifdown - nie działa
« Odpowiedź #34 dnia: 2005-06-01, 12:50:15 »
Witam
Mam taki problem, że po wydaniu komendy
ifdown eth0
i wpisaniu po niej ifconfig pokazuje mi że eth0 jest nadal włączony. Może mi ktoś wytłumaczyć dlaczego tak się dzieje i co zrobić żeby wyłączyć eth0
Dodam że mam Mandrake 10.1
Pozdrawiam

Offline

  • Users
  • Użytkownik
  • **
  • Wiadomości: 76
    • Zobacz profil
ifdown - nie działa
« Odpowiedź #35 dnia: 2005-06-01, 13:31:01 »
Spróbuj:
ifconfig eth0 down