Nowe posty

xx Touchpad po pewnym losowym czasie przestaje reagować (6)
Dzisiaj o 12:54:54
xx badblocks nie sprawdza dalej. (3)
Wczoraj o 20:44:36
xx Automat/scrypt do uruchamiania bootowalnego USB (0)
2019-04-22, 22:15:41
xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (2)
2019-04-22, 20:59:31
xx Uprawnienia (1)
2019-04-22, 14:10:38
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50

Autor Wątek: Update systemu  (Przeczytany 6336 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 17
    • Zobacz profil
Update systemu
« dnia: 2012-07-30, 23:16:31 »
Może mógłby ktoś mi odpisać jak poradzić sobie z tymi błędami?
http://pastebin.com/VbEnFbsS
Próbowałem już zamaskować ten pakiet i pozostałe w ten sposób, ale nadal jest to samo. Czy jest jakiś sposób żeby aktualizacja dalej ruszyła?
echo "sys-auth/polkit" >> /etc/portage/package.mask

Offline vanhelzing

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 313
    • Zobacz profil
Update systemu
« Odpowiedź #1 dnia: 2012-07-31, 00:15:52 »
Cytuj
# Masking the latest version of consolekit as it depends on >=udev-182.
# See b.g.o. 408713
=sys-auth/consolekit-0.4.5_p20120320

...

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).
Dlaczego maskujesz całego polkita? Zamaskuj najnowszą wersję consolekita (dokładnie tak jak masz napisane w informacji), albo użyj parametru --autounmask-write, to Ci sam doda odpowiednią maskę automatycznie.

Maskujesz tylko jedną, konkretną wersję consolekita, żeby udev nie chciał się aktualizować.
echo  "=sys-auth/consolekit-0.4.5_p20120320" >> /etc/portage/package.mask

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 17
    • Zobacz profil
Update systemu
« Odpowiedź #2 dnia: 2012-07-31, 10:21:40 »
Zamaskowałem to w ten sposób jak podałeś. Wcześniej  dodawałem w ten zły sposób
echo  "sys-auth/consolekit" >> /etc/portage/package.mask
Wystarczyło tylko dalej wpisać emerge --sync && emerge -auDN world --autounmask-write , zakaceptować yes. A na sam koniec emerge --sync && emerge -auDN world --autounmask-keep-masks. Teraz aktualizacja systemu ruszyła. Dzięki za pomoc. Mam jeszcze pytanie jakie flagi USE trzeba dopisać do make.conf żeby zainstalować xorg, openbox lub fluxbox oraz operę? Mam Gentoo dopiero drugi dzień więc jeszcze wiem tyle co nic o tym systemie.

Offline mateo86

  • Users
  • Guru
  • *****
  • Wiadomości: 652
    • Zobacz profil
Update systemu
« Odpowiedź #3 dnia: 2012-07-31, 14:28:45 »
http://www.gentoo.org/doc/en/index.xml?catid=desktop

Drugi Punkt...

Jak w adresie zmienisz 'en' na 'pl' będziesz miał to samo po polsku, tylko nie wiem jak z aktualnością polskiej wersji. Zdaje się, że grupa tłumacząca chwilowo wstrzymała tam swoją działalność...

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 17
    • Zobacz profil
Update systemu
« Odpowiedź #4 dnia: 2012-07-31, 17:17:50 »
Czytałem to, mimo to dzięki. Mam teraz inne zmartwienie. Mianowicie nie wykrywa mi eth0 i nie mogę użyc dhcpcd eth0. Pod chrotem jest eth0 i wszystko ładnie działa. Zrobiłem wszystko tak jak w handbooku http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=3.
Może teraz wraz z jądrem 3.5.0 wprowadzili jakieś zmiany w konfiguracji sieci, których nie zdążyli jeszcze dopisać do handbooka?
Moja karta sieciowa to
Atheros Communications Inc. AR8152 v2.0 Fast Ethernet
sterownik atl1c. Jak to rozwiązać?

Offline vanhelzing

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 313
    • Zobacz profil
Update systemu
« Odpowiedź #5 dnia: 2012-07-31, 18:31:06 »
1) Sprawdź czy interfejs jest na liście
ifconfig
2) Jeżeli sterownik masz skompilowany jako moduł, to upewnij się, że jest załadowany. Powinna być jego nazwa na liście z polecenia
lsmod
Jeżeli nie, albo dla pewności, możesz załadować go
modprobe atl1c
(nie mam tej karty, więc piszę na ślepo)

Upewnij się, że moduł się załadował (lsmod)

3) Postaw interfejs.

ifconfig eth0 up
ifconfig
Drugi ifconfig powinien pokazać Ci interfejs z wyzerowanymi wartościami.

4) Uruchom dhcpcd albo inny program, którego używasz do pozyskiwania ustawień.

dhcpcd eth0
ifconfig
Ifconfig powinien pokazać właściwe ustawienia.

5) Jeżeli zadziała, to masz z górki. Jeżeli nie, spróbuj skonfigurować interfejs i trasę ręcznie.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 17
    • Zobacz profil
Update systemu
« Odpowiedź #6 dnia: 2012-07-31, 18:48:59 »
Próbowałem już tego wszystkiego co napisałeś. Ten moduł jest własciwy , ponieważ mi działa w innej dystrybucji. Natomiast polecenie ifconfig pokazuje jedynie lo i nieznaną mi nazwę sit0.  Przekompilowałem też jądro dodając Atheros L2 Fast (wydaje mi się że to jest ta karta)
 [*]   Atheros devices                                                       │ │  
  │ │     <*>     Atheros L2 Fast Ethernet support                                    │ │  
  │ │     < >     Atheros/Attansic L1 Gigabit Ethernet support                        │ │  
  │ │     < >     Atheros L1E Gigabit Ethernet support (EXPERIMENTAL)                 │ │  
  │ │     < >     Atheros L1C Gigabit Ethernet support (EXPERIMENTAL)
Ale nadal się eth0 nie pojawiło. Nie działa również polecenie lspci , lspci -v.
bash: lspci: nie znaleziono polecenia
Wyczytałem też że Gentoo może inaczej nazywać kartę i trzeba ten plik usunąć?
Usuń etc/udev/rules.d/70-persistent-net.rules i rebootuj, bedzie sie nazywac eth0 od tego momentu
Coś jest nie tak. Teraz zauważyłem że polecenie lsmod pod Gentoo nie pokazuje żadnego modułu.
Module                  Size  Used by
Pod chrootem widać wszystkie moduły.

Offline vanhelzing

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 313
    • Zobacz profil
Update systemu
« Odpowiedź #7 dnia: 2012-07-31, 22:14:11 »
Gwiazdka przy nazwie oznacza, że sterownik zostanie wkompilowany w jądro i nie będziesz mieć modułu na liście modułów. Musiałbyś zaznaczyć go jako "" i dopiero wtedy będziesz mógł go sobie ładować. Ale nie sądzę, żeby w tym był problem.

Jeżeli używasz menuconfig do konfiguracji, to opcją "Help" możesz dowiedzieć się jak będzie się nazywać moduł, i z tego, co widzę, to dla "Atheros L2 Fast Ethernet support" jest to atl2, natomiast "atl1c jest dla "Atheros L1C Gigabit Ethernet support", więc może po prostu wybierasz niewłaściwy sterownik.

Udev niewiele zdziała, jeżeli nie zaznaczysz właściwego sterownika. Od biedy możesz skompilować wszystkie Atherosy jako moduły i wtedy powinien się załadować właściwy.

"sit0" to inna bajka i w tym przypadku nie ma znaczenia.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 17
    • Zobacz profil
Update systemu
« Odpowiedź #8 dnia: 2012-07-31, 22:32:44 »
To już nie mam pomysłu jak to naprawić. Dla pewności dodałem wszystkie co widać. A przy ostatnim Atheros L1C pokazuje help mój moduł karty. Jednak nadal nie działa eth0.
[*]   Atheros devices                                                       │ │  
  │ │     <*>     Atheros L2 Fast Ethernet support                                    │ │  
  │ │     <*>     Atheros/Attansic L1 Gigabit Ethernet support                        │ │  
  │ │     <*>     Atheros L1E Gigabit Ethernet support (EXPERIMENTAL)                 │ │  
  │ │     <*>     Atheros L1C Gigabit Ethernet support (EXPERIMENTAL)                 │ │  
  │ │     [*]   Broadcom devices
Może jest jeszcze  inne ustawienie w menuconfig  od tego chipsetu Atheros? Lub mam niepoprawny make.conf i namieszane z flagami USE.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2484
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Update systemu
« Odpowiedź #9 dnia: 2012-08-01, 13:09:47 »
Atherosy wymagają do pracy firmwaru w katalogu /lib/firmware. Skopiuj z działającego systemu.

Off-Topic: Uważasz, że Gentoo jest najlepszym wyborem dla Ciebie?
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 17
    • Zobacz profil
Update systemu
« Odpowiedź #10 dnia: 2012-08-01, 13:21:42 »
Ok dziękuję sprawdzę to. Co do Gentoo to zbierałem się do tego systemu już od kilku lat. Obecnie próbuje z nim sił jako drugi system. A z binarnymi systemami nie mam żadny problemów lub potrafię sobie z nimi poradzić. Jeśli nie dzisiaj mam wybrać i przetestować ten system Gentoo to kiedy? Za miesiąc, rok za 10 lat? Nikt się nie rodzi z wiedzą o Gentoo więc uważam że warto spróbować. Pewnie dużo osób która zaczynała z tym systemem i teraz można o nich powiedzieć specjaliści od Gentoo też miała różne problemy na samym początku. Jak dopiero mam styczność z tym systemem od 3 dni więc.

Rozwiązałem problem. Wystarczyło przekompilować jądro bez załadowanych modułów .