Nowe posty

xx Postfix jako SMTP Proxy (1)
2019-02-13, 17:01:01
xx Zabezpieczenie przed nieautoryzowanym serwerem DHCP (2)
2019-02-13, 16:24:09
xx Programy antywirusowe - gdzie mają zastosowanie (6)
2019-02-10, 23:05:29
xx Kompilacja kernela. (6)
2019-02-07, 12:08:41
xx Od jakiego linuxa zacząć (1)
2019-02-06, 14:53:46
xx Wtyczki Photoshopa w GIMPie, pod Xubuntu. (1)
2019-02-05, 20:03:39
xx Mysql workbranch (0)
2019-02-05, 10:07:33
xx Problem z uruchomieniem skryptu CGI (2)
2019-02-04, 08:37:12
xx Boot manager (22)
2019-02-03, 12:46:18
xx Skrypt (3)
2019-02-03, 12:28:36

Autor Wątek: Problemy z siecią.  (Przeczytany 5465 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Problemy z siecią.
« dnia: 2012-06-04, 15:46:29 »
Po krótce się przedstawię.

*-network
                description: Ethernet interface
                product: RTL8111/8168B PCI Express Gigabit Ethernet controller
                vendor: Realtek Semiconductor Co., Ltd.
                physical id: 0
                bus info: pci@0000:03:00.0
                logical name: eth0
                version: 06
                serial: e8:11:32:92:da:1a
                size: 100Mbit/s
                capacity: 1Gbit/s
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
                configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.0.9 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
                resources: irq:43 ioport:b000(size=256) memory:e2c04000-e2c04fff memory:e2c00000-e2c03fff

               
*-network
                description: Network controller
                product: BCM4313 802.11b/g/n Wireless LAN Controller
                vendor: Broadcom Corporation
                physical id: 0
                bus info: pci@0000:02:00.0
                version: 01
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list
                configuration: driver=bcma-pci-bridge latency=0
                resources: irq:16 memory:f6c00000-f6c03fff

O ile z połączeniem przewodowym problemów brak o tyle z Wifi problem mam straszny. Dla mojej karty sieć. Broadcom wydał sterowniki, które są dostępne w jądrze i tam mam je na stale w jądro wbite, więc teoretycznie powinno działać a tak nie jest. Próbuję się połączyć przez wicd, ale nie wyszukuje mi żadnej sieci bezprzewodowej. Dodam, że przy livecd gentoo i sabayona sytuacja jest podobna. Nie wiem co z tym fantem zrobić. Nie wiem czy to potrzebne ale dodam jeszcze to:

*-network:0
       description: Ethernet interface
       physical id: 2
       logical name: ifb0
       serial: 16:87:07:ba:fa:e6
       capabilities: ethernet physical
       configuration: broadcast=yes
  *-network:1
       description: Ethernet interface
       physical id: 3
       logical name: ifb1
       serial: 62:28:b9:fa:6c:73
       capabilities: ethernet physical
       configuration: broadcast=yes
  *-network:2
       description: Ethernet interface
       physical id: 4
       logical name: bond0
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bonding driverversion=3.7.1 firmware=2 link=no master=yes multicast=yes

Bardzo bym prosił o pomoc. Dodam, że sprzęt na pewno działa poprawnie, bo na tym samym komputerze jest windows 7 i działa ona poprawnie.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 25
    • Zobacz profil
Problemy z siecią.
« Odpowiedź #1 dnia: 2012-06-04, 17:16:33 »
Cytat: davepi
Po krótce się przedstawię.

*-network
                description: Ethernet interface
                product: RTL8111/8168B PCI Express Gigabit Ethernet controller
                vendor: Realtek Semiconductor Co., Ltd.
                physical id: 0
                bus info: pci@0000:03:00.0
                logical name: eth0
                version: 06
                serial: e8:11:32:92:da:1a
                size: 100Mbit/s
                capacity: 1Gbit/s
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
                configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.0.9 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
                resources: irq:43 ioport:b000(size=256) memory:e2c04000-e2c04fff memory:e2c00000-e2c03fff

               
*-network
                description: Network controller
                product: BCM4313 802.11b/g/n Wireless LAN Controller
                vendor: Broadcom Corporation
                physical id: 0
                bus info: pci@0000:02:00.0
                version: 01
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list
                configuration: driver=bcma-pci-bridge latency=0
                resources: irq:16 memory:f6c00000-f6c03fff

O ile z połączeniem przewodowym problemów brak o tyle z Wifi problem mam straszny. Dla mojej karty sieć. Broadcom wydał sterowniki, które są dostępne w jądrze i tam mam je na stale w jądro wbite, więc teoretycznie powinno działać a tak nie jest. Próbuję się połączyć przez wicd, ale nie wyszukuje mi żadnej sieci bezprzewodowej. Dodam, że przy livecd gentoo i sabayona sytuacja jest podobna. Nie wiem co z tym fantem zrobić. Nie wiem czy to potrzebne ale dodam jeszcze to:

*-network:0
       description: Ethernet interface
       physical id: 2
       logical name: ifb0
       serial: 16:87:07:ba:fa:e6
       capabilities: ethernet physical
       configuration: broadcast=yes
  *-network:1
       description: Ethernet interface
       physical id: 3
       logical name: ifb1
       serial: 62:28:b9:fa:6c:73
       capabilities: ethernet physical
       configuration: broadcast=yes
  *-network:2
       description: Ethernet interface
       physical id: 4
       logical name: bond0
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bonding driverversion=3.7.1 firmware=2 link=no master=yes multicast=yes

Bardzo bym prosił o pomoc. Dodam, że sprzęt na pewno działa poprawnie, bo na tym samym komputerze jest windows 7 i działa ona poprawnie.
Cytat: silva2007
Tak mi przychodzi na myśl rzecz następująca: sprawdzić czy przypadkiem zapora czegoś nie blokuje.
+SILVA2007+

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2461
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Problemy z siecią.
« Odpowiedź #2 dnia: 2012-06-04, 18:05:20 »
Cytat: silva2007
Tak mi przychodzi na myśl rzecz następująca: sprawdzić czy przypadkiem zapora czegoś nie blokuje.
A co ma zapora do wykrycia APów?

Do davepi: odpal komputer i wklej w tagach code (albo daj na pastebina) wynik działania polecenia dmesg. Może jest problem z firmwarem do karty (sam sterownik to za mało).
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Problemy z siecią.
« Odpowiedź #3 dnia: 2012-06-04, 19:23:58 »
http://pastebin.com/LShY691F

Tutaj jest odpowiedź na polecenie dmesg. Z góry dzięki za zaangażowanie w ten temat :)

Offline vanhelzing

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 313
    • Zobacz profil
Problemy z siecią.
« Odpowiedź #4 dnia: 2012-06-04, 21:18:19 »
Według wireless.kernel.org, Twoja karta nie jest obsługiwana przez sterownik b43 i powinieneś użyć własnościowego wl albo otwartego brcm80211.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2461
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
Problemy z siecią.
« Odpowiedź #5 dnia: 2012-06-04, 21:26:27 »
Z tego co widzę, to BCM4313 jest nie wspierany (jeszcze) przez drivery b43 (tzw WIP - Work In Progress).

Śledź ich stronę sterownika B43, który docelowo ma obsługiwać ten chipset. W chwili obecnej logika jest wykryta, ale driver nie obsługuje samego nadajnika (tzw PHY):

b43-phy0: Broadcom 4313 WLAN found (core revision 24)
b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 10, Type 8, Revision 1)
b43: probe of bcma0:0 failed with error -95

Pomóc może jeden z dwóch innych sterowników: wl albo brcmsmac.

Pierwszy jest w pakiecie net-wireless/broadcom-sta.
Drugi z nich jest w kernelu w drzewie Device Drivers/Network Device Support/Wireless LAN/Broadcom IEEE(...)SoftMAC adapter (to jest opcja CONFIG_BRCMSMAC, mój kernel to 3.2.16-gentoo-ck1, jest to standardowe 3.2.16-gentoo z łatkami BFS+BFQ, więc niewiele nowsze od Twojego).

Któryś pewnie zadziała...

P.S. Z ilości "śmieciowych" driverów wnioskuję, że chyba używasz genkernel (konfiguracja NUMA, LEDy, pomiar temperatury procków VIA, drivery do pilotów video, drivery 1-wire, LEgo USB tower i inne). Poświęć trochę czasu na poczytanie dmesg-a, lspci -k i sam zrób sobie konfigurację pod swój przęt. Będzie szybciej wstawać system i mniejsze prawdopodobieństwo konfliktów sterowników.
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 11
    • Zobacz profil
Problemy z siecią.
« Odpowiedź #6 dnia: 2012-06-08, 20:40:54 »
Odświeżam, gdyż niestety nic nie pomogło. Musiałem zaktualizować jądro, żebby móc w niego wepchnąć brcmsmac (3.4.0). Wicd łączy się z siecią przewodową. Działa także przycisk włącz wyłącz wifi (wcześniej nie działo się nic po jego naciśnięciu).

http://pastebin.com/1P2dJNSU <- kod z dmesg jeśli ktoś chce.

ifconfig -a wyświetla eth0, sit0 i lo.

Kernel skonfigurowany na szybko, żeby zobaczyć, czy działa. brcmsmac obłusługuje podobno moją kartę (wiadomość ze strony http://linuxwireless.org/en/usershttp://pastebin.com/1P2dJNSU/Drivers/brcm80211 ). Wl próbowałem, ale nie było skutku. Ale mimo wszystko wolę brcmsmac, skoro jest otwarty i obsługuje moją kartę.
______________
edit:
http://www.gentoo.org/doc/pl/handbook/handbook-amd64.xml?part=4&chap=4 według tego podręcznika nic nie konfigurowałem specjalnie dla połączeń bezprzewodowych. jedynie usunąłem net.eth0 ze skryptów startowych.
w /etc/rc.conf dodałem rc_hotplug="!net.*" tak jak wicd przy instalacji kazał.

_______________
edit2:
problem podobny do mojego. Ten sam komunikat błędu w dmesg na archu.
https://bbs.archlinux.org/viewtopic.php?id=142655
jednak niestety u mnie /usr/lib/firmware nie istnieje o usr/lib/firmware/brcm nie wspominając.

Po skompilowaniu sterownika jako moduł modprobe brcmsmac działa i nie wyrzuca błędu. lsmod pokazuje brmscmac i brmscutil. Jednak nie mogę znaleźć żadnego połączenia bezprzewodowego. Nie mam już pojęcia za bardzo co robić...
________________

ciekawostka z rfkill:

gentoo gentoo # rfkill list all
0: samsung-wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: samsung-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no

więc to tak jakby widział jednak kartę...