Nowe posty

Autor Wątek: czarny obraz i kreseczka  (Przeczytany 5417 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
czarny obraz i kreseczka
« dnia: 2012-04-25, 12:24:40 »
zainstalowalem ubuntu 11.04 obok windowsa xp , wszystko się zainstalowalo i pojawił się pulpit zainstalowanego ubuntu. wpisuje login i hasło choć wpisalem podczas instalacji aby pamiętał hasło i wyrzucilo że zle hasło. wylaczylem ubuntu, chciałem poszukać na windowsie jak odzyskać hasło - wylaczam bootowanie płyty jako pierwszej . ustawienia się zachowały - komputer uruchamia się ponownie czyli wszystko ok do tego momentu. zamiast gruba jest czarny obraz z kreseczka gdzie nic nie można wpisać.
widać że nie chce się bootowac żaden system.

POMOCY!

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1258
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #1 dnia: 2012-04-25, 14:45:41 »
Cytat: eska97
hasło - wylaczam bootowanie płyty jako pierwszej . ustawienia się zachowały -

POMOCY!
hmmm.. Jesteś pewien, że ustawienia się zachowały?
Ustawiłeś też boot'owanie z dysku twardego?
Bios zadał Ci pytanie o zachowanie zmian, a Ty je potwierdziłeś?
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #2 dnia: 2012-04-25, 15:05:04 »
tak, w ustawieniach jako 1 jest hard drive a 2 cd . gdy zamieniam miejscami pokazuje sie livecd - tam wszystko dobrze działa. na tym samym komputerze ale w połączeniu ubuntu 10.10 + vista wszystko dobrze działało.

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1258
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #3 dnia: 2012-04-25, 17:44:22 »
Coś mi się wydaje, że albo nie zainstalowałeś Grub'a lub namieszałeś coś z partycjami ( instalacja z automatu czy sam stawiałeś partycje ).
Dziwna też kwestia tego hasła.
Wielkość liter/znaków wziąłeś pod uwagę?
Płyta wypalona poprawnie?
Sumy się zgadzają?
Prędkość wypalania nie za wysoka?
Może spróbuj przywrócić Gruba.

---edit
Zerknij z poziomu Live CD co masz i obecnie na twardym dysku.
Tzn. jak wyglądają partycje.
Tak czy siak spróbowałbym za pomocą nośnika jednak przywrócić Grub'a
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #4 dnia: 2012-04-25, 18:07:28 »
Cytat: Lord Darius
Coś mi się wydaje, że albo nie zainstalowałeś Grub'a lub namieszałeś coś z partycjami ( instalacja z automatu czy sam stawiałeś partycje ).
wybrałem aby się sam zainstalował obok win xp

 
Cytat: Lord Darius
Dziwna też kwestia tego hasła.
Wielkość liter/znaków wziąłeś pod uwagę?
tak było tam 7cyfr i jedna mała litera

 
Cytat: Lord Darius
Płyta wypalona poprawnie?
tak

 
Cytat: Lord Darius
Sumy się zgadzają?
sumy czego ?

Cytat: Lord Darius
Prędkość wypalania nie za wysoka?
8x
 
Cytat: Lord Darius
Może spróbuj przywrócić Gruba.
jak?

 
Cytat: Lord Darius
---edit
Zerknij z poziomu Live CD co masz i obecnie na twardym dysku.
Tzn. jak wyglądają partycje.
Tak czy siak spróbowałbym za pomocą nośnika jednak przywrócić Grub'a
jak, jestem dość początkujący ;) ?

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1258
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #5 dnia: 2012-04-25, 20:07:13 »
1. Sumy kontrolne ( checksum ) - mówiąc po ludzku ciąg cyfr/znaków podany najczęściej przy linku do pobierania ISO.
Wynik musi być taki sam po ściągnięciu, a można to sprawdzić np w programie do wypalania.
To musisz sprawdzić od razu, skoro nie wiesz co i jak, a tym bardziej, że dzieją się takie cyrki u Ciebie.
Jeśli sumy się nie zgadzają to kicha.
Musisz ściągnąć ISO od nowa,  przejrzeć ponownie sumy i poprawnie wypalić z obrazu ISO - to ostanie ma też znaczenie, bo nagranie obrazu ISO a nagranie Z Obrazu ISO to dwie różne rzeczy, ale to tak na marginesie.
2. Przywracanie Gruba - proste jak drut:
http://www.ubuntu-pomoc.org/przywracanie-gruba-2-z-livecd/
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #6 dnia: 2012-04-25, 20:16:56 »
płytę dawno wypalalem, nie miałem czAsu na komputer przez jakiś czas - iso usunięte

pobawie się o tym grubie

====== EDIT ====================================


ubuntu@ubuntu:~/Desktop$ sudo fdisk -l

Dysk /dev/sda: 120.0 GB, bajtów: 120034123776
głowic: 255, sektorów/ścieżkę: 63, cylindrów: 14593
Jednostka = cylindrów, czyli 16065 * 512 = 8225280 bajtów
Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512
Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512
Identyfikator dysku: 0xbbc58b91

Urządzenie Rozruch   Początek      Koniec   Bloków   ID  System
/dev/sda1   *           1        5230    42008699    7  HPFS/NTFS
/dev/sda2            5230       14594    75209713    f  W95 Rozsz. (LBA)
Partycja 2 nie kończy się na granicy cylindra.
/dev/sda5            7012       13386    51200320+   7  HPFS/NTFS
/dev/sda6           13386       14594     9698944+   7  HPFS/NTFS
/dev/sda7            5230        6882    13262848   83  Linux
/dev/sda8            6882        7012     1042432   82  Linux swap / Solaris

Wpisy w tablicy partycji nie są w tej kolejności, co na dysku
ubuntu@ubuntu:~/Desktop$


To chyba źle, co ?

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 214
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #7 dnia: 2012-04-25, 21:26:47 »
Czemu źle?
Robisz po kolei tak:
- logowanie na konto roota z poziomu livecd:
sudo su [Enter]
mount /dev/sda7 /mnt
mount -o bind /proc /mnt/proc
mount -o bind /sys /mnt/sys
mount -o bind /dev /mnt/dev
Chroot-owanie:
chroot /mnt /bin/bash
Instalacja Gruba:
grub-install --no-floppy /dev/sda
Opuszczenie systemu, do którego zalogowałeś się w trybie chroot:
exit
Następnie odmontuj wszystko po kolei tak jak było montowane, a potem reboot - polecenie:
umount /mnt/dev
i kolejne analogicznie.
========
Przed instalacją Gruba możesz jeszcze upewnić się, że system Windows został wykryty - sprawdzisz to poleceniem:
os-prober
========
Generalnie Lord Darius ma rację, że nie jest tak jak być powinno (granice partycji), ale zawsze możesz spróbować zainstalować tego Gruba.
Dystrybucja: $ lsb_release -a

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1258
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #8 dnia: 2012-04-25, 21:33:49 »
---- jakieś zamieszanie się robi :D
Widocznie coś się kisi przy wspólnym zatwierdzaniu wpisów .

Powtórzę:

Trochę bryndza Ci wyszła.
Podobny problem masz tu:
http://debian.linux.pl/threads/19921-Podział-dysku-pod-Debiana-i-Windowsa

Może i dasz radę, a i widzę, że marcin dobrze podpowiada.
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #9 dnia: 2012-04-25, 22:04:31 »
ciekawi mnie czy te granice są błędem czy informacją. wszystkie moje pliki które miałem na windowsie - partycje c,d,e - są ok. linux wydaje mi się ze też bo też wszystkie katalogi można wyczytać. jutro dam znać jak poszlo z grubym ;)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #10 dnia: 2012-04-26, 08:36:08 »
wyrzucilo że grub poprawnie zainstalowany. owszem jest, ale:

 http://imgur.com/uPRQu.jpg

Offline Tomasz Frydrych

  • Users
  • Guru
  • *****
  • Wiadomości: 529
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #11 dnia: 2012-04-26, 17:45:06 »
wygenerowałeś poprawny grub.cfg, inne cfg? było #update-grub chociaż?
Gdyby głupota była lżejsza od powietrza to unosilibyśmy się pod sufitem.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 34
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #12 dnia: 2012-04-26, 17:57:27 »
wpisywalem wszystko co napisał marcin.
jak mogę zaktualizowac gruba z livecd

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1258
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #13 dnia: 2012-04-26, 18:14:48 »
Cytat: eska97
jak mogę zaktualizowac gruba z livecd
Podam bardziej łopatologiczny link - już chyba bardziej zrozumiale nie da się tego przedstawić:
http://dug.net.pl/tekst/77/przywracanie_grub2_za_pomoca_chroot/

Zwróć uwagę na występującą tam różnicę między /dev/hda, a Twoim /dev/sda - o czym zresztą jest tam wspomniane.

Jeszcze jedna rzecz....
Cytat: eska97
jak mogę zaktualizowac gruba z livecd
To samo można zawsze wpisać w google, otrzymując wiele, konkretnych i zrozumiałych wyników...
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

Offline ultr

  • Users
  • Guru
  • *****
  • Wiadomości: 1186
    • Zobacz profil
czarny obraz i kreseczka
« Odpowiedź #14 dnia: 2012-04-26, 23:59:49 »
Kiedyś też miałem problem z GRUBem: http://forum.linux.pl/viewtopic.php?pid=88625

Okazało się, że dane dla GRUBa (partycja zawierająca /boot) były za daleko od początku dysku i po prostu GRUB opierając się na tym co widzi BIOS nie mógł ich odczytać.
Widzę, że ty masz dysk tylko 120GB, ale nigdy nic nie wiadomo.