Nowe posty

xx Touchpad po pewnym losowym czasie przestaje reagować (7)
Wczoraj o 13:28:28
xx badblocks nie sprawdza dalej. (3)
2019-04-23, 20:44:36
xx Automat/scrypt do uruchamiania bootowalnego USB (0)
2019-04-22, 22:15:41
xx Zdalne polaczenie z posrednikiem pod Ubuntu bez GUI (2)
2019-04-22, 20:59:31
xx Uprawnienia (1)
2019-04-22, 14:10:38
xx bład krytyczny na dysku, dysk jest w LVM (2)
2019-04-19, 06:38:20
xx Przekierowanie na bezpieczną stronę z SSL (1)
2019-04-16, 19:52:43
xx bootloader (4)
2019-04-13, 18:31:03
xx Ubuntu i Bluetooth (1)
2019-04-12, 10:12:18
clip Opera - odtwarzanie niektórych filmów nie działa (1)
2019-04-12, 00:41:50

Autor Wątek: Brak uprawnień dostępu do katalogu na serwerze Apache.  (Przeczytany 8376 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 30
    • Zobacz profil
Cześć,
Jak zwykle zainstalowałem sobie php i mysql (mam na myśli instalacje kilka pakietów). Instalowałem je tak samo jak zwykle. Zrobiłem sobie alians na nazwe użytkownika i na adresie
http://127.0.0.1/
wszystko działa a na:
http://127.0.0.1/drraven/
Dostaję 403:
Forbidden

You don't have permission to access /drraven/ on this server.
Apache/2.2.17 (Ubuntu) Server at 127.0.0.1 Port 80
Powiem, że reinstalacja nie pomaga. Jakiego mam linuxa widzicie na górze.

Offline Paweł Smoliński

  • Administrator
  • Guru
  • *****
  • Wiadomości: 593
    • Zobacz profil
Brak uprawnień dostępu do katalogu na serwerze Apache.
« Odpowiedź #1 dnia: 2011-10-15, 09:42:18 »
1) Jak wygląda konfiguracja Apache'a?
2) Masz w katalogu przypisanym do /drraven/ jakieś pliki (a zwłaszcza index.php/index.html)? Jakie pliki widnieją w dyrektywie DirectoryIndex?
3) Jeżeli chcesz mieć dostęp do listingu plików w katalogu, spróbuj opcji Options Indexes w konfiguracji Apache'a
4) Mówi się alias, nie alians :)
Gutta cavat lapidem non vi, sed saepe cadendo / sic homo doctus fit non vi sed saepe studendo

Offline Tomasz Frydrych

  • Users
  • Guru
  • *****
  • Wiadomości: 529
    • Zobacz profil
Brak uprawnień dostępu do katalogu na serwerze Apache.
« Odpowiedź #2 dnia: 2011-10-19, 10:04:22 »
sprawdź, czy zasoby należą do grupy lub użytkownika apache, jeśli nie to dodaj apache do grupy właściciela.
Gdyby głupota była lżejsza od powietrza to unosilibyśmy się pod sufitem.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Brak uprawnień dostępu do katalogu na serwerze Apache.
« Odpowiedź #3 dnia: 2012-03-17, 16:28:44 »
chmod 777 /var/www/twoj_katalog

Offline Grzegorz Świtkowski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 516
    • Zobacz profil
Brak uprawnień dostępu do katalogu na serwerze Apache.
« Odpowiedź #4 dnia: 2012-03-19, 15:17:34 »
Cytat: rootka
chmod 777 /var/www/twoj_katalog
Nie zalecam:)
Zalecam to o czym pisał ZipoKing czyli przejrzenie konfiguracji Apache'a pod kątem katalogu z DocumentRoot.