Nowe posty

xx Migracja GRUB2 (0)
2019-08-24, 12:30:46
xx Przydatne Linki (4)
2019-08-23, 14:13:00
xx Awstat (0)
2019-08-22, 14:55:15
xx SMB - Access denied z Windows (9)
2019-08-19, 11:27:24
xx Kali Linux - książka. (0)
2019-08-19, 00:20:25
xx Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera (6)
2019-08-18, 14:37:04
xx Nie moge urchmomic laptopa - grub rescue. (1)
2019-08-17, 18:24:00
xx Po aktualizacji zniknęły niektóre funkcje (45)
2019-08-14, 06:39:01
xx Operacje na bitach. (4)
2019-08-10, 21:44:36
xx Pblem z montowaniem dysku sieciowego (1)
2019-08-09, 23:36:45

Autor Wątek: brak biblioteki libGL.so.1 po instalacji sterowników  (Przeczytany 5092 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
witam, instalowałem dzisiaj sterowniki do mojej karty graficznej (geforce4 mx 440). Sterowniki to
NVIDIA-Linux-x86-96.43.19-pkg1
mój system to ubuntu 11.04. instalacja przebiegała pomyślnie lecz po instalacji nie wstawały X'y wyskakiwał błąd
no screens found
więc pierwsze co zrobiłem to wykonałem polecenie
nvidia-xconfig
niestety bez rezultatów. przeszukałem google, także bez rezultatów więc dałem sobie spokój i odinstalowałem te sterowniki i przywróciłem stary plik xorg.conf.
 następnie z folderu /etc/modprobe.d usunąłem plik "nvidia-noveau-blocking" czy jakoś tak w każdym razie plik dodawał stary sterownik do blacklist. następnie zrestartowałem system i wszystko zdawało się być jak wcześniej niestety przy próbie odpalenia jakiejkolwiek gry dostaje komunikat
error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
poszperałem i dowiedziałem się, że jest to część mesa'y, ale jestem kompletnym laikiem i nie mam pojęcia co powinienem usunąć i co zainstalować. dodam tylko, że w folderze /usr/lib/mesa znajdują się pliki
ld.so.conf  libGL.so  libGL.so.1  libGL.so.1.2
plik libGL.so.1 i libGL.so są dowiązaniami do (chyba) nieistniejących plików.
z góry dzięki za jakąkolwiek pomoc.

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 214
    • Zobacz profil
brak biblioteki libGL.so.1 po instalacji sterowników
« Odpowiedź #1 dnia: 2011-09-24, 15:31:54 »
Cytat: llaik
mój system to ubuntu 11.04. instalacja przebiegała pomyślnie lecz po instalacji nie wstawały X'y wyskakiwał błąd
Po instalacji sterowników zrestartuj komputer i wygeneruj nowy plik xorg.conf
Najpiew kopia starego:
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.oldie
Następnie tworzymy nowy plik:
X -configure
i umieszczamy go na swoim miejscu:
sudo mv /root/xorg.conf.new /etc/X11/xorg.conf
Plik xorg.conf generujemy z poziomu runlevel 3 (konsola bez X), czyli ... podczas uruchamiania komputera wciśnij Shift aby zatrzymać odliczanie Gruba, potem wciśnij "e", przejdź na koniec linii z wyrażeniem /boot/vmlinuz i dopisz na końcu:
single
Aby uruchomić jądro ze zmodyfikowanymi opcjami wciśnij:
Ctrl+X
Bluescreen'a na pewno nie zobaczysz :P
Dystrybucja: $ lsb_release -a

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
brak biblioteki libGL.so.1 po instalacji sterowników
« Odpowiedź #2 dnia: 2011-09-24, 15:39:22 »
Ale X'y i te Nvidiowskie sterowniki już nie są problemem. Po wywaleniu sterowników nvidii po prostu usunąłem plik /etc/X11/xorg.conf i zrestartowałem komputer (doszukałem się żeby tak zrobić na jakiejś stronie) i system działa jak działał przed mieszaniem z tymi sterownikami.
 teraz problemem jest brak możliwości odpalenia jakiejkolwiek gry. 3/4 mojego poprzedniego posta można olać opisałem tylko jak to wszystko popsułem na razie i tak nie będę już instalował tych sterowników nvidii, bo nie mam sprawnej nagrywarki, a boję się, że coś znowu popsuję.

@edit tak spojrzałem na mój pierwszy post i bardzo chaotycznie napisałem z czym w ogóle mam problem. w każdym razie nie mogę odpalić żadnej gry, bo nie można znaleźć biblioteki współdzielonej libGL.so.1

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
brak biblioteki libGL.so.1 po instalacji sterowników
« Odpowiedź #3 dnia: 2011-09-24, 20:58:31 »
o ile się nie mylę powinna pomóc ponowna instalacja biblioteki mesa

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
brak biblioteki libGL.so.1 po instalacji sterowników
« Odpowiedź #4 dnia: 2011-09-25, 12:06:33 »
też tak pomyślałem, ale mesa ciągnie za sobą dużo innych rzeczy

jak bym to wszystko usunął to by to się dobrze dla systemu nie skończyło.

Offline Piotr Chmura

  • Administrator
  • Guru
  • *****
  • Wiadomości: 5060
    • Zobacz profil
brak biblioteki libGL.so.1 po instalacji sterowników
« Odpowiedź #5 dnia: 2011-09-26, 07:35:03 »
ale nie masz usuwać, tylko zainstalować

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
brak biblioteki libGL.so.1 po instalacji sterowników
« Odpowiedź #6 dnia: 2011-09-26, 18:38:40 »
myślałem, że masz na myśli odinstalowanie i ponowne zainstalowanie wszystkich składników mesa'y. doinstalowałem libglw1-mesa i wszystko śmiga, dzięki za pomoc :)