Nowe posty

Autor Wątek: Problem z autostartem emulatora na Raspberry Pi  (Przeczytany 93 razy)

Offline divupiko

  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Problem z autostartem emulatora na Raspberry Pi
« dnia: Wczoraj o 19:40:22 »
Witam. Proszę o radę, mam problem ze skonfigurowaniem Raspberry Pi 4B - OS Lite tak, aby automatycznie po włączeniu maliny następowało uruchomienie zainstalowanego emulatora Atari.

Wszystko śmiga, oprócz autostartu. Próbowałem systemd, ale nie działa. Czy trzeba napisać jakiś dodatkowy skrypt do którego będzie odnosić się "nazwa".service? Może jest jakieś prostsze rozwiązanie?


Offline 1709

  • Users
  • Guru
  • *****
  • Wiadomości: 2612
  • 1709
    • Zobacz profil
Odp: Problem z autostartem emulatora na Raspberry Pi
« Odpowiedź #1 dnia: Wczoraj o 21:49:11 »
1. Nie napisałeś jak to dokładnie zrobiłeś.

2. Generalnie możesz to zrobić na kilka sposobów
https://wiki.archlinux.org/title/Autostarting

Z tego najpopularniejsze to
- cron ,
- systemd/Timers ,
- $HOME/.config/autostart/ (z menadzera okien)

3. Należy mieć na względzie czy emulator Atari jest aplikacją graficzną.
Jeśli tak, to czasami np. w cronie
- trzeba dać kilkusekundowe opóźnienie, tak aby usługa wystartowała po uruchomieniu się środowiska graficznego
- trzeba wskazać ekran
- trzeba przypilnować aby usługa startująca miała uprawnienia uruchomić aplikację graficzną.

Tu masz przykład z cronem + notify-send + smartctl
https://forums.linuxmint.com/viewtopic.php?f=49&t=331950&p=1900455&hilit=cron#p1900455

4. Do tego można się pobawić
skrypt > /home/nazwa_użytkownika/skrypt.log
skrypt >> /var/log/mydebug.cron.log 2>&1

Nawet są komendy do logowania
logger https://www.networkworld.com/article/3274570/using-logger-on-linux.html
systemd-cat  https://www.freedesktop.org/software/systemd/man/systemd-cat.html
« Ostatnia zmiana: Wczoraj o 21:52:26 wysłana przez 1709 »
PS: Brak polskiej czcionki, nie jest to brak lenistwa, a jej brak w systemie i brak czasu na reczne poprawki.