Nowe posty

xx Przy uploadzie przerywane są wszystkie połączenia (9)
2020-06-01, 20:13:01
xx Apache2 i twarde https (3)
2020-05-25, 15:53:43
xx Czy istnieje emulator terminala który zapamieta komendy na jakiejś liście? (9)
2020-05-23, 17:04:57
xx RTLinux wybór dystrybucji (0)
2020-05-23, 15:42:54
xx Problem z instalacją Ubuntu na bootowalnym pendrajwie (9)
2020-05-22, 15:08:12
xx Ubuntudde 20.04 LTS nie działa Lightdm (8)
2020-05-22, 09:16:42
xx [Gra za darmo] GTA5 (1)
2020-05-20, 21:49:26
xx Marketing (1)
2020-05-13, 08:00:41
xx Polecenia Debian (1)
2020-05-10, 19:58:54
xx Uruchamianie pliku z każdego katlogu (2)
2020-05-10, 19:23:33

Autor Wątek: Problem z przepisywaniem adresów pod apache na suse  (Przeczytany 4028 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Problem z przepisywaniem adresów pod apache na suse
« dnia: 2011-07-27, 14:09:01 »
Witam, zadaje tu to pytanie bo juz odchodzę od zmysłów z przemęczenia a możliwe ze to tylko jakiś kruczek, którego nie znam.

Opisze problem dokładnie aby uniknąć niepotrzebnych opowiedzi.
Korzystam z Suse 11.4

Ogólnie chodzi o Zend Framework i to , że nie działają kontrolery inne niż index, zakładam że chodzi o rewrite ale

- Wszystko co trzeba jest zainstalowane ( tj apache, php, mysql, zend framework itp itd )
- W konfiguracji apacha rewrite jest właczony ( modyfikowałem zarówno w http.conf a jak to nie przynosiło skutku, pomimo że rewite wygladał na właczony - zainstalowałem obsługe serwera apache za pomocą Yasta i tu tez wszystko jest ustawione jak należy mam na myśli rewrite)
- z forów wszedzie rozwiązaniem problemu była zmiana z Override None na All ale ze jako mam to już zmienione problem leży gdzie indziej.


Ogólnie wina nie leży też w zend frameworku bo to samo pod windowsem działa jak należy oczywiście po uruchomieniu rewrite i zmianie Override None na All ( oczywiscie w http.conf)

Sytuacja wygląda mniej wiecej tak że jak wyłaczam rewrite to z folderu projektu znika public.
Jak włączam rewite to pojawia się ponownie public. Ale htaccess nijak nie wpływa na działanie aplikacji.  Katalog projektu jest w public_html

Linkowanie przez localhost/user/katalogprojektu/public
działa
localhost/user/katalogprojektu/public
localhost/user/katalogprojektu/public/index
nie działa (nie widzi strony)
localhost/user/katalogprojektu/public/innykontroler

Ogólnie nie bawiłem się jeszcze w wirtualne hosty bo musiałbym to przerobić ale wątpie czy dodanie wirtualnego hosta cokolwiek zmieni jesli nie działa normalnie.

Myślę że przyczyną jest coś powiązanego z suse. Ale po przeczytaniu wszystkiego, ustawieniu wszystkiego nic nie przynosi efektu.

To co pomoże ktoś :D   ?  ?