Nowe posty

xx GMail w KDE (15)
Dzisiaj o 08:58:12
xx Zmiana Nazwy użytkownika (1)
Wczoraj o 23:39:05
xx Dostęp zewnętrzny do sprzętu. (4)
Wczoraj o 22:29:25
xx Modem komórkowy z GPS - komendy AT (5)
2018-10-17, 17:58:39
xx Jak pobierać dodatki do kde? (6)
2018-10-17, 14:06:19
xx [ROZWIĄZANY] LO Writer - jak rozsunąć tekst do lewa i prawa w jednym wierszu (4)
2018-10-17, 11:57:05
xx skrypty wykonywane w crontab-ie [SElinux] (2)
2018-10-17, 10:33:12
xx Jak zmienić domyślny emulator terminala ? (4)
2018-10-14, 20:51:52
xx Javascript pasjans (1)
2018-10-14, 13:10:22
xx Problem ze słuchawkami (3)
2018-10-10, 18:34:36

Autor Wątek: Problem z przepisywaniem adresów pod apache na suse  (Przeczytany 3768 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Problem z przepisywaniem adresów pod apache na suse
« dnia: 2011-07-27, 14:09:01 »
Witam, zadaje tu to pytanie bo juz odchodzę od zmysłów z przemęczenia a możliwe ze to tylko jakiś kruczek, którego nie znam.

Opisze problem dokładnie aby uniknąć niepotrzebnych opowiedzi.
Korzystam z Suse 11.4

Ogólnie chodzi o Zend Framework i to , że nie działają kontrolery inne niż index, zakładam że chodzi o rewrite ale

- Wszystko co trzeba jest zainstalowane ( tj apache, php, mysql, zend framework itp itd )
- W konfiguracji apacha rewrite jest właczony ( modyfikowałem zarówno w http.conf a jak to nie przynosiło skutku, pomimo że rewite wygladał na właczony - zainstalowałem obsługe serwera apache za pomocą Yasta i tu tez wszystko jest ustawione jak należy mam na myśli rewrite)
- z forów wszedzie rozwiązaniem problemu była zmiana z Override None na All ale ze jako mam to już zmienione problem leży gdzie indziej.


Ogólnie wina nie leży też w zend frameworku bo to samo pod windowsem działa jak należy oczywiście po uruchomieniu rewrite i zmianie Override None na All ( oczywiscie w http.conf)

Sytuacja wygląda mniej wiecej tak że jak wyłaczam rewrite to z folderu projektu znika public.
Jak włączam rewite to pojawia się ponownie public. Ale htaccess nijak nie wpływa na działanie aplikacji.  Katalog projektu jest w public_html

Linkowanie przez localhost/user/katalogprojektu/public
działa
localhost/user/katalogprojektu/public
localhost/user/katalogprojektu/public/index
nie działa (nie widzi strony)
localhost/user/katalogprojektu/public/innykontroler

Ogólnie nie bawiłem się jeszcze w wirtualne hosty bo musiałbym to przerobić ale wątpie czy dodanie wirtualnego hosta cokolwiek zmieni jesli nie działa normalnie.

Myślę że przyczyną jest coś powiązanego z suse. Ale po przeczytaniu wszystkiego, ustawieniu wszystkiego nic nie przynosi efektu.

To co pomoże ktoś :D   ?  ?