Nowe posty

Autor Wątek: Mysz USB - dziwny problem  (Przeczytany 6332 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Mysz USB - dziwny problem
« dnia: 2011-02-20, 15:23:41 »
Posiadam laptopa asus f3sg i mysz usb Trust GM-4200, nie jest jakaś luksusowa, do tej pory działała idealnie.
Ostatnio jednak po przejściu na sabayona 5.5 zaczęły dziać się dziwne rzeczy. Przez chwilę wszystko działa ok. Przykładowo włączam Operę lub FF i przeglądam strony, chcę zminimalizować lub zamknąć i nie mogę. Wskaźnik reaguje na ruch myszy, jednak klikać mogę tylko w obrębie aktywnego okna (nie mogę nawet przesunąć okna). Dzieje się to pod każdym środowiskiem graficznym i niestety z ciekawości sprawdziłem dziś linux mint z live CD i jest to samo.
Początkowo myślałem, że źle wykrywana jest mysz i męczyłem się z xorg.conf, jednak myślę, że problem jest inny. Mianowicie touchpad działa prawidłowo do puki oczywiście nie podłącze myszy. Jak już dojdzie do tego, że nie mogę klikać poza aktywnym oknem, wystarczy, że odłącze mysz i touchpad działa prawidłowo.
Pod KDE mogłem ustawić, by touchpad wyłączał się gdy podłącze mysz - nic nie pomogło.
W MINT działają dodatkowe przyciski asusa i mogę wyłączyć touchpada - nic nie daje.
Szukałem dość długo w google informacji na temat podobnego problemu, jednak nie znalazłem nic co mogło by mi pomóc. Zazwyczaj wszystkim pomaga ręczne ustawienie wszystkiego w xorg.conf

Dodam jeszcze, że używam jakiegoś tam kursora z gnome, jednak po wejściu do FF lub opery lub czegokolwiek, w obszarze aktywnego okna kursor zmienia się na czarny z białą obwódką, jednak po wyjechaniu na zewnątrz wygląda normalnie.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Mysz USB - dziwny problem
« Odpowiedź #1 dnia: 2011-03-01, 18:58:29 »
Mam podobny problem co kolega wyżej, lecz na komputerze stacjonarnym, również z myszką USB. Problemy zaczęły się wiele tygodni temu na systemie ubuntu 10.04, prawdopodobnie po którejś aktualizacji, bo ponad pół roku działał bez problemu. Z systemu nie dało się korzystać, gdyż nie zawsze reagował na kliknięcia myszy, ciężko stwierdzić, od czego to zależało. Działało dobrze tylko jedno okno, reszta nie, łącznie z paskiem systemowym. Problem był również w innym środowisku graficznym – lxde. Nie miałem czasu się tym zająć, więc korzystałem z systemu windows, na którym nie było żadnych problemów, co wyklucza uszkodzenie sprzętu.
Teraz postanowiłem zainstalować na czysto ubuntu 10.10 i ku mojemu zaskoczeniu problem jest nadal. Odpalałem też live fedory z kde i jest to samo. Dobrze działa tylko slax, którego miałem na pendrive od dłuższego czasu, jeszcze zanim wystąpiły problemy na ubuntu. Pożyczyłem więc na chwilę i podłączyłem mysz PS/2 zamiast tej usb i co ciekawe wszystko było dobrze. Gdy podłączam dwie myszy i korzystam z tej pod PS/2 to problem znów występuje.
Czy ktoś wie, co muszę zrobić by znów wszystko działało tak dobrze jak kiedyś? Nie chciałbym rezygnować przez to z systemów linux, gdyż poza tym nie mam im nic do zarzucenia.

majt

  • Gość
Mysz USB - dziwny problem
« Odpowiedź #2 dnia: 2011-03-02, 13:02:53 »
Witam!
1. Sprawdzaliscie inna mysz?
2. Sprawdzaliscie mysz na innym komputerze.
3.Sprawdzcie czy ktorys przycisk na klawiaturze lub myszy sie nie zablokowal.
na klawiaturze naprosciej to sprawdzic otwierajac jakis edytor tekstu i wciskajac po kolei wszystkie klawisze patrzec co wychodzi w edytorze. czasem zblokuje sie np. alt+ctrl co moze powodac dziwnie zachowanie. Na myszy patrz pt 1 i 2.
4. Napisz 'cat  /var/log/Xorg.0.log' i wklej tutaj
Cytat: Davidcc
więc korzystałem z systemu windows, na którym nie było żadnych problemów, co wyklucza uszkodzenie sprzętu.
Nieprawda, windows bardzo czesto dziala nawet z uszkodzonym sprzetem, np ja w moim laptopie mam wylamany port usb, ktory oprocz tego ze jest luzny, pod windowsem pozwala podlaczyc mi sprzet peryferyjny, a pod linuxem juz nie, nie roumie do konca dlaczego ale prawdopodobnie chodzi o jakies przepiecia w hubie usb.

pozdrawiam!

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Mysz USB - dziwny problem
« Odpowiedź #3 dnia: 2011-03-02, 16:21:51 »
Dziękuję za odpowiedź.

Ad. 1
Nie mam innej myszy usb.

Ad. 2
Tak, wyniki:
inny_komputer+moja_mysz_usb - najnowszy ubuntu (gnome) 10.10, fedora (kde) 14, starszy slax (kde, kernel 2.6.27.27) - wszystko działało idealnie
mój_komputer+moja_mysz_usb - jedynie slax działa dobrze
mój_komputer+inna_mysz_PS/2 - wszystko dobrze

Ad. 3
Klawiatura jest w porządku

Ad. 4
Cytat: MyszUSB
[    13.043]
X.Org X Server 1.9.0
Release Date: 2010-08-20
[    13.043] X Protocol Version 11, Revision 0
[    13.044] Build Operating System: Linux 2.6.24-28-server x86_64 Ubuntu
[    13.044] Current Operating System: Linux CompLinux 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64
[    13.044] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-25-generic root=UUID=dff6e494-fbed-4311-a488-bbc33dc49ad9 ro quiet splash
[    13.044] Build Date: 09 January 2011  12:14:27PM
[    13.044] xorg-server 2:1.9.0-0ubuntu7.3 (For technical support please see http://www.ubuntu.com/support)
[    13.044] Current version of pixman: 0.18.4
[    13.044]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    13.044] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    13.044] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar  2 15:41:54 2011
[    13.044] (==) Using config file: "/etc/X11/xorg.conf"
[    13.044] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    13.052] (==) No Layout section.  Using the first Screen section.
[    13.052] (**) |-->Screen "Default Screen" (0)
[    13.052] (**) |   |-->Monitor ""
[    13.052] (==) No device specified for screen "Default Screen".
   Using the first device section listed.
[    13.052] (**) |   |-->Device "Default Device"
[    13.052] (==) No monitor specified for screen "Default Screen".
   Using a default monitor configuration.
[    13.052] (==) Automatically adding devices
[    13.052] (==) Automatically enabling devices
[    13.052] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    13.052]    Entry deleted from font path.
[    13.052] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
[    13.052] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    13.052] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    13.052] (II) Loader magic: 0x7d17a0
[    13.052] (II) Module ABI versions:
[    13.052]    X.Org ANSI C Emulation: 0.4
[    13.052]    X.Org Video Driver: 8.0
[    13.052]    X.Org XInput driver : 11.0
[    13.052]    X.Org Server Extension : 4.0
[    13.053] (--) PCI:*(0:1:0:0) 10de:02e1:0000:0000 rev 162, Mem @ 0xf3000000/16777216, 0xe0000000/268435456, 0xf2000000/16777216, BIOS @ 0x????????/131072
[    13.054] (II) Open ACPI successful (/var/run/acpid.socket)
[    13.054] (II) "extmod" will be loaded by default.
[    13.054] (II) "dbe" will be loaded by default.
[    13.054] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    13.054] (II) "record" will be loaded by default.
[    13.054] (II) "dri" will be loaded by default.
[    13.054] (II) "dri2" will be loaded by default.
[    13.054] (II) LoadModule: "glx"
[    13.081] (II) Loading /usr/lib/xorg/extra-modules/libglx.so
[    14.075] (II) Module glx: vendor="NVIDIA Corporation"
[    14.075]    compiled for 4.0.2, module version = 1.0.0
[    14.075]    Module class: X.Org Server Extension
[    14.075] (II) NVIDIA GLX Module  173.14.28  Wed Sep 29 10:19:01 PDT 2010
[    14.075] (II) Loading extension GLX
[    14.075] (II) LoadModule: "extmod"
[    14.076] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    14.076] (II) Module extmod: vendor="X.Org Foundation"
[    14.076]    compiled for 1.9.0, module version = 1.0.0
[    14.076]    Module class: X.Org Server Extension
[    14.076]    ABI class: X.Org Server Extension, version 4.0
[    14.076] (II) Loading extension MIT-SCREEN-SAVER
[    14.076] (II) Loading extension XFree86-VidModeExtension
[    14.076] (II) Loading extension XFree86-DGA
[    14.076] (II) Loading extension DPMS
[    14.076] (II) Loading extension XVideo
[    14.076] (II) Loading extension XVideo-MotionCompensation
[    14.076] (II) Loading extension X-Resource
[    14.076] (II) LoadModule: "dbe"
[    14.076] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    14.076] (II) Module dbe: vendor="X.Org Foundation"
[    14.076]    compiled for 1.9.0, module version = 1.0.0
[    14.076]    Module class: X.Org Server Extension
[    14.076]    ABI class: X.Org Server Extension, version 4.0
[    14.076] (II) Loading extension DOUBLE-BUFFER
[    14.076] (II) LoadModule: "record"
[    14.077] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    14.077] (II) Module record: vendor="X.Org Foundation"
[    14.077]    compiled for 1.9.0, module version = 1.13.0
[    14.077]    Module class: X.Org Server Extension
[    14.077]    ABI class: X.Org Server Extension, version 4.0
[    14.077] (II) Loading extension RECORD
[    14.077] (II) LoadModule: "dri"
[    14.077] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    14.077] (II) Module dri: vendor="X.Org Foundation"
[    14.077]    compiled for 1.9.0, module version = 1.0.0
[    14.077]    ABI class: X.Org Server Extension, version 4.0
[    14.077] (II) Loading extension XFree86-DRI
[    14.077] (II) LoadModule: "dri2"
[    14.077] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    14.078] (II) Module dri2: vendor="X.Org Foundation"
[    14.078]    compiled for 1.9.0, module version = 1.2.0
[    14.078]    ABI class: X.Org Server Extension, version 4.0
[    14.078] (II) Loading extension DRI2
[    14.078] (II) LoadModule: "nvidia"
[    14.078] (II) Loading /usr/lib/xorg/extra-modules/nvidia_drv.so
[    14.952] (II) Module nvidia: vendor="NVIDIA Corporation"
[    14.952]    compiled for 4.0.2, module version = 1.0.0
[    14.952]    Module class: X.Org Video Driver
[    15.000] (II) NVIDIA dlloader X Driver  173.14.28  Wed Sep 29 10:00:06 PDT 2010
[    15.009] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    15.009] (++) using VT number 7

[    15.020] (II) Loading sub module "fb"
[    15.020] (II) LoadModule: "fb"
[    15.020] (II) Loading /usr/lib/xorg/modules/libfb.so
[    15.020] (II) Module fb: vendor="X.Org Foundation"
[    15.020]    compiled for 1.9.0, module version = 1.0.0
[    15.020]    ABI class: X.Org ANSI C Emulation, version 0.4
[    15.020] (II) Loading sub module "wfb"
[    15.020] (II) LoadModule: "wfb"
[    15.020] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    15.032] (II) Module wfb: vendor="X.Org Foundation"
[    15.032]    compiled for 1.9.0, module version = 1.0.0
[    15.032]    ABI class: X.Org ANSI C Emulation, version 0.4
[    15.032] (II) Loading sub module "ramdac"
[    15.032] (II) LoadModule: "ramdac"
[    15.032] (II) Module "ramdac" already built-in
[    15.055] (II) NVIDIA(0): Creating default Display subsection in Screen section
   "Default Screen" for depth/fbbpp 24/32
[    15.055] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    15.055] (==) NVIDIA(0): RGB weight 888
[    15.055] (==) NVIDIA(0): Default visual is TrueColor
[    15.055] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    15.055] (**) NVIDIA(0): Option "NoLogo" "True"
[    15.056] (**) NVIDIA(0): Enabling RENDER acceleration
[    15.062] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[    15.062] (II) NVIDIA(0):     enabled.
[    16.172] (II) NVIDIA(0): NVIDIA GPU GeForce 7600 GS (G73) at PCI:1:0:0 (GPU-0)
[    16.172] (--) NVIDIA(0): Memory: 262144 kBytes
[    16.172] (--) NVIDIA(0): VideoBIOS: 05.73.22.33.00
[    16.172] (II) NVIDIA(0): Detected AGP rate: 8X
[    16.172] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    16.172] (--) NVIDIA(0): Connected display device(s) on GeForce 7600 GS at PCI:1:0:0:
[    16.172] (--) NVIDIA(0):     LG W2343 (DFP-0)
[    16.172] (--) NVIDIA(0): LG W2343 (DFP-0): 330.0 MHz maximum pixel clock
[    16.172] (--) NVIDIA(0): LG W2343 (DFP-0): Internal Dual Link TMDS
[    16.173] (II) NVIDIA(0): Assigned Display Device: DFP-0
[    16.173] (==) NVIDIA(0):
[    16.173] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    16.173] (==) NVIDIA(0):     will be used as the requested mode.
[    16.173] (==) NVIDIA(0):
[    16.173] (II) NVIDIA(0): Validated modes:
[    16.173] (II) NVIDIA(0):     "nvidia-auto-select"
[    16.173] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[    16.174] (--) NVIDIA(0): DPI set to (95, 94); computed from "UseEdidDpi" X config
[    16.174] (--) NVIDIA(0):     option
[    16.174] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[    16.175] (--) Depth 24 pixmap format is 32 bpp
[    16.178] (II) NVIDIA(0): Initialized AGP GART.
[    16.184] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[    16.384] (II) Loading extension NV-GLX
[    16.455] (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
[    16.460] (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
[    16.460] (==) NVIDIA(0): Backing store disabled
[    16.460] (==) NVIDIA(0): Silken mouse enabled
[    16.461] (==) NVIDIA(0): DPMS enabled
[    16.461] (II) Loading extension NV-CONTROL
[    16.461] (==) RandR enabled
[    16.461] (II) Initializing built-in extension Generic Event Extension
[    16.461] (II) Initializing built-in extension SHAPE
[    16.461] (II) Initializing built-in extension MIT-SHM
[    16.461] (II) Initializing built-in extension XInputExtension
[    16.461] (II) Initializing built-in extension XTEST
[    16.461] (II) Initializing built-in extension BIG-REQUESTS
[    16.461] (II) Initializing built-in extension SYNC
[    16.461] (II) Initializing built-in extension XKEYBOARD
[    16.461] (II) Initializing built-in extension XC-MISC
[    16.461] (II) Initializing built-in extension SECURITY
[    16.461] (II) Initializing built-in extension XINERAMA
[    16.461] (II) Initializing built-in extension XFIXES
[    16.461] (II) Initializing built-in extension RENDER
[    16.461] (II) Initializing built-in extension RANDR
[    16.461] (II) Initializing built-in extension COMPOSITE
[    16.461] (II) Initializing built-in extension DAMAGE
[    16.461] (II) Initializing built-in extension GESTURE
[    16.461] (II) Initializing extension GLX
[    16.620] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[    16.628] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    16.629] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    16.629] (II) LoadModule: "evdev"
[    16.629] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    16.629] (II) Module evdev: vendor="X.Org Foundation"
[    16.629]    compiled for 1.9.0, module version = 2.3.2
[    16.629]    Module class: X.Org XInput Driver
[    16.629]    ABI class: X.Org XInput driver, version 11.0
[    16.629] (**) Power Button: always reports core events
[    16.629] (**) Power Button: Device: "/dev/input/event1"
[    16.660] (II) Power Button: Found keys
[    16.660] (II) Power Button: Configuring as keyboard
[    16.660] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    16.660] (**) Option "xkb_rules" "evdev"
[    16.660] (**) Option "xkb_model" "pc105"
[    16.660] (**) Option "xkb_layout" "pl"
[    16.662] (II) XKB: reuse xkmfile /var/lib/xkb/server-61818C6B46DD4F01AE1F641F27B555591612208F.xkm
[    16.664] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    16.664] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    16.664] (**) Power Button: always reports core events
[    16.664] (**) Power Button: Device: "/dev/input/event0"
[    16.710] (II) Power Button: Found keys
[    16.710] (II) Power Button: Configuring as keyboard
[    16.710] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[    16.710] (**) Option "xkb_rules" "evdev"
[    16.710] (**) Option "xkb_model" "pc105"
[    16.710] (**) Option "xkb_layout" "pl"
[    16.711] (II) config/udev: Adding input device A4Tech PS/2+USB Mouse (/dev/input/event3)
[    16.711] (**) A4Tech PS/2+USB Mouse: Applying InputClass "evdev pointer catchall"
[    16.711] (**) A4Tech PS/2+USB Mouse: always reports core events
[    16.711] (**) A4Tech PS/2+USB Mouse: Device: "/dev/input/event3"
[    16.750] (II) A4Tech PS/2+USB Mouse: Found 12 mouse buttons
[    16.750] (II) A4Tech PS/2+USB Mouse: Found scroll wheel(s)
[    16.750] (II) A4Tech PS/2+USB Mouse: Found relative axes
[    16.750] (II) A4Tech PS/2+USB Mouse: Found x and y relative axes
[    16.750] (II) A4Tech PS/2+USB Mouse: Configuring as mouse
[    16.750] (**) A4Tech PS/2+USB Mouse: YAxisMapping: buttons 4 and 5
[    16.750] (**) A4Tech PS/2+USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    16.750] (II) XINPUT: Adding extended input device "A4Tech PS/2+USB Mouse" (type: MOUSE)
[    16.750] (II) A4Tech PS/2+USB Mouse: initialized for relative axes.
[    16.750] (II) config/udev: Adding input device A4Tech PS/2+USB Mouse (/dev/input/mouse0)
[    16.750] (II) No input driver/identifier specified (ignoring)
[    16.755] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[    16.755] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    16.755] (**) AT Translated Set 2 keyboard: always reports core events
[    16.755] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[    16.790] (II) AT Translated Set 2 keyboard: Found keys
[    16.790] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[    16.790] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[    16.790] (**) Option "xkb_rules" "evdev"
[    16.790] (**) Option "xkb_model" "pc105"
[    16.790] (**) Option "xkb_layout" "pl"
Cytat: MyszPS/2_różnica
[    16.525] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[    16.525] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    16.525] (**) AT Translated Set 2 keyboard: always reports core events
[    16.525] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[    16.560] (II) AT Translated Set 2 keyboard: Found keys
[    16.560] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[    16.560] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[    16.560] (**) Option "xkb_rules" "evdev"
[    16.560] (**) Option "xkb_model" "pc105"
[    16.560] (**) Option "xkb_layout" "pl"
[    16.560] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/event3)
[    16.560] (**) ImPS/2 Generic Wheel Mouse: Applying InputClass "evdev pointer catchall"
[    16.560] (**) ImPS/2 Generic Wheel Mouse: always reports core events
[    16.560] (**) ImPS/2 Generic Wheel Mouse: Device: "/dev/input/event3"
[    16.560] (II) ImPS/2 Generic Wheel Mouse: Found 3 mouse buttons
[    16.560] (II) ImPS/2 Generic Wheel Mouse: Found scroll wheel(s)
[    16.560] (II) ImPS/2 Generic Wheel Mouse: Found relative axes
[    16.560] (II) ImPS/2 Generic Wheel Mouse: Found x and y relative axes
[    16.560] (II) ImPS/2 Generic Wheel Mouse: Configuring as mouse
[    16.560] (**) ImPS/2 Generic Wheel Mouse: YAxisMapping: buttons 4 and 5
[    16.560] (**) ImPS/2 Generic Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    16.561] (II) XINPUT: Adding extended input device "ImPS/2 Generic Wheel Mouse" (type: MOUSE)
[    16.561] (II) ImPS/2 Generic Wheel Mouse: initialized for relative axes.
[    16.561] (II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/mouse0)
[    16.561] (II) No input driver/identifier specified (ignoring)
Wstawiam link na youtube, w którym ukazana jest istota problemu
http://www.youtube.com/watch?v=NnF4FE2h6Rk

Jak widać na początku wszystko działa dobrze, system reaguje na kliknięcia. Gdy uruchamiam trzeci program, ten już nie reaguje, podobnie jak pasek z menu. Żadnego z tych programów nie da się wtedy wyłączyć klikając w "X" . Skróty klawiszowe działają, podobnie jak jeden z tych programów - w tym przypadku firefox. Terminal też się nie reagował, dopiero gdy wyłączyłem pozostałe programy.

Bardzo proszę o pomoc, gdyż sam się nawet nie domyślam co zrobić, by z systemu dało się komfortowo korzystać.

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
Mysz USB - dziwny problem
« Odpowiedź #4 dnia: 2011-03-13, 14:04:33 »
W moim przypadku niestety myliłem się i pomogła edycja xorg.conf

Cytuj
Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mouse1"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection
Cytuj
Section "ServerLayout"
    Identifier   "Main Layout"
    Screen 0    "Screen 0"
    InputDevice "Configured Mouse" "CorePointer"
    InputDevice "Synaptics Touchpad" "SendCoreEvents"
EndSection
Oczywiście mysz to /dev/input/mouse1 i tu jest ok, polecenie:
sudo cat /dev/input/mouse1
Pokazuje, że faktycznie mysz to mouse1, ale z touchpadem jest dziwnie bo nigdzie go nie ma, w /dev/input napewno, a /dev/psaux wpisałem bo kilka osób tak miało, ale jak wpisuje cat /dev/psaux nic nie widzę.

Dodatkowo tylko ja miałem problemy z tą myszką (kolega pod linuxem nie miał).
Kolejna niedogodność to teraz touchpad jest dużo czulszy od myszy, ale w sumie da się do tego przyzwyczaić.
Klawiatura USB, której zazwyczaj używam przy laptopie nie sprawiała żadnych problemów.

PS. Radzę uważać z wklejaniem moich fragmentów xorg.conf do swojego pliku.