Nowe posty

Autor Wątek: System często zawiesza się  (Przeczytany 1531 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
System często zawiesza się
« dnia: 2010-11-12, 17:26:37 »
Mam problem z systemem Arch Linux. Dodam, że jestem dość początkującym użytkownikiem.
Często system aktualizuję i praktycznie cały czas mam najnowsze pakiety. System jednak po włączeniu się i po kilkunastu/kilkudziesięciu minutach pracy zawiesza się. Nie można ruszyć myszą, przełączyć się na konsolę etc. W zasadzie nie można zrobić nic. Może pokażę logi systemu, by Ci, którzy znają te wiadomości może zrozumieli i pomogli mi o co w tym chodzi:

Jedna taka zawieszka:

Nov 10 19:07:02 localhost ntfs-3g[969]: ntfs_mst_post_read_fixup: magic: 0x0000
0002  size: 1024  usa_ofs: 0  usa_count: 65535: Invalid argument
Nov 10 19:07:02 localhost ntfs-3g[969]: ntfs_mst_post_read_fixup: magic: 0x0000
0002  size: 1024  usa_ofs: 0  usa_count: 65535: Invalid argument








�D�Fh�D$�V`���E�~K�GD9E�r"�Uԉ���V$N(�M�+E�G@�O�G^L�-���+EԋO@�D�Eԉ^L$��D$�P����G
$��Ґ��&--Więcej--W<�U�W���$--Więcej--
���E�LJ���ÜE��E���E��N����
�����FD�M�N^L)N�D$^L�F@�D�Gh�<$�D$�W`�M���~a����G$W(�V@�EȉV^L�UċVDȉV--������������U�����]��ɦ���Ö--Więcej----Więcej--j--
�E����������$����멍������D�D$�Ƥ���Ó--Więcej--
               ����F^L�U��UЃ���$������E��D$
$�W`�������F9�r)ЉщF��W$O(������N)ЉD�U���D$�^L$�}����F�U��ȍ�H����D�D�]��u��}���]�f��U��t��U�
��u��-Więcej---Więcej--���]��u��}���]Ít&$^L--Więcej--�����$^L--Więcej--
+M����cej----
��������Vl��9O�9U�|8�EԋU؉D�T$^L�Fh�4$�D$�V`��~q����F$V(�@�����Fl��뿐��+E؉U��D$
�Więcej--
�����[^]�1���--

��$膁��������Í�&roup subsys cpuset
Nov 10 19:16:04 localhost kernel: Initializing cgroup subsys cpu
Inna mająca identyczne objawy:
Nov 12 14:43:42 localhost kernel: eth0: link down
Nov 12 14:43:45 localhost kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x45
E1
Nov 12 14:44:07 localhost kernel: eth0: link down
Nov 12 14:44:09 localhost kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x45
E1








����E�f��}ЋU؋E�Uȅ��U�H��
^L�]��u���P�������E��D$--Więcej--
]����������U�����]��������~����$�X����D$
����]��u��}���]��ظ���Uԉu��$�|�������T$�*�������t\\�E��D$�4$�5�����uA�E��D$���[^_]Ë���U��l����U��J��#����ɍ�)���E��D$������$�U�� ����U��s����B �D$��=����$�����U�����
�!E������������$�E��������tM���������$�E��������t6���������$�E��������t��.������$�E��l����
����4$�������L[^_]�f���^L$�5����D$^L�E^L�D�MԉL$��$�H����D�Mԉ4$�L$����������D$^L
����~�N��u�9N r��w�����C����F1҅�t����T$�$�Զ���V������--Więcej--
t�D$��$�ĭ���F,�$�^����F��t6Nov 12 14:47:04 localhost kernel: Initializing cgroup subsys cpuse
t
Nov 12 14:47:04 localhost kernel: Initializing cgroup subsys cpu
Dzieje się tak przy korzystaniu z przeróżnych procesów, nie ma reguły. Czasem przy przeglądaniu internetu, czasem przy przeglądaniu plików, czasem przy tworzeniu dokumentów. To samo jeśli chodzi o obciążenie systemu raz procesor jest mocno obciążony innym razem mniej.
Po moich poszukiwaniach przyczyny pierwszym rozwiązaniem była pamięć. Oczywiście ściągnąłem memtesta i okazało się, że pamięć jest ok (2 kości, jedna 512 a druga 256) przynajmniej memtest tak mówi. Myślę, że warto dodać, że jeszcze nigdy owej zawieszki nie było gdy raz się pojawiła, zresetowałem komputer i znów włączyłem archa. Wtedy można było korzystać i korzystać ale znów powiedzmy wyłączenie komputera lub reboot na windowsa, powtórne odpalenie archa, kilkadziesiąt minut pracy i znów dzieją się wyżej opisane rzeczy.
Dodam jeszcze, że komputer nie jest nowy, swój wiek ma ale na poprzednio zainstalowanym debianie takich rzeczy nie było.
Czekam na wszelkie sugestie, ja nie znam się dobrze na tym wszystkim dlatego nie jestem pewien jakie informacje mogą się przydać, dlatego napiszcie ew. co podać, jakie parametry, zawartość jakich plików lub co wypluje dana komenda.

Z góry dziękuję za pomoc.

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
System często zawiesza się
« Odpowiedź #1 dnia: 2010-11-12, 18:05:37 »
Może by standardowo zacząć, tzn. odpalić go na poziomie uruchamiania "1" (czyli w tzw. trybie single)? Zobacz najpierw czy po jakimś czasie padnie bez uruchamiania dodatkowych programów lub usług. Warto też odpalić sshd i łapać komunikaty na zdalną maszynę, póki Twoja działa.

Nie wiem co mówi komunikat od ntfs-3g, ale może zakomentuj testowo w /etc/fstab wpis na temat tego systemu plików (chyba że montujesz go innym sposobem). Potem odmontuj go lub uruchom system od nowa.

Na razie nie piszę jak to robić - mam nadzieję, że nawet jeśli nie do końca wiesz, to doszukasz się sposobów w aktualnych w miarę poradnikach dla początkujących.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam