Nowe posty

Autor Wątek: INstalacja sterowników ati  (Przeczytany 7358 razy)

Offline Mariusz Jotek

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 46
    • Zobacz profil
INstalacja sterowników ati
« dnia: 2005-05-29, 15:11:54 »
Niewiem co temu Linuksowi mojemu odbiło. Mam 3 partycje windowsowe. Postanowiłem że na jednej będe ściągać pliki. Wsadziłem tam edonkeya i od pewnego czasu jak n.p prubuje cos dodac do sciagania to pokazuje takie cos
Couldn\\'t create Temp File Read-only file system
I niewiem co mu odbiło... tak jest na całej partycji. Niewiem co mu odbiło patrzyłem i partycja NIE jest ustawiona jako tylko do odczuty ( patrzyłem w Konfiguracji Komputera)
Co mam zrobic zeby przestał wkońcu to pokazywać?? Wielkie dzieki za odpowiedz
Pozdro

Offline jan karwowski

  • Users
  • Guru
  • *****
  • Wiadomości: 844
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #1 dnia: 2005-05-29, 15:55:37 »
Chodzi o partycje fat, tak?
A wiec, musze Ci powiedziec,
ze nie jastes pierwsza osoba, ktora
ma taki problem.
Poszukaj na tym forum \\"umask\\"

pozdrawiam

Offline Tomcio Paluch

  • Users
  • Guru
  • *****
  • Wiadomości: 676
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #2 dnia: 2005-05-29, 18:53:09 »
W jaki sposob montujesz te partycje, recznie, przez fstab (jezeli tak, to go pokaz jezeli mozesz).

Jaki to system plikow ? Za malo danych :)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #3 dnia: 2005-05-29, 13:22:44 »
Jak zainstalowaći skonfigurowac stery do ati.Z góry dzięki

Offline Krzysztof Plucinski

  • Users
  • Guru
  • *****
  • Wiadomości: 829
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #4 dnia: 2005-05-29, 13:33:18 »
2005-05-29 13:22:44 thecoreofdarknes napisał:

> Jak zainstalowaći skonfigurowac stery do ati.Z góry dzięki


Kolejny...... Najpierw czytać, potem pytać.... Czy myślisz, że jesteś jedyny z ATI pod linuxem?

http://rtfm.bsdzine.org/
http://ag.bocznica.org/

Offline Sebastian Kazimierski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 26
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #5 dnia: 2005-06-16, 17:41:42 »
2005-05-29 13:33:18 kmp napisał:

> 2005-05-29 13:22:44 thecoreofdarknes napisał:
 >
 > > Jak zainstalowaći skonfigurowac stery do ati.Z góry dzięki
 >
 >
 > Kolejny...... Najpierw czytać, potem pytać.... Czy myślisz, że jesteś jedyny z ATI pod
 > linuxem?
 >
 > http://rtfm.bsdzine.org/
 > http://ag.bocznica.org/
 >
    Ja z zainstalowaniem sterów ATI dla mojego Radeona (9550 Speedy Edition) walczę już ok. 2 miesiące. Pewnie za mało się staram. Przeca styknie zapytać Google'a i przejżeć jakieś 300-400 odpowiedzi i już. A jak jeszcze nie, to zmienić zapytanie i przeczytać następne 400! Najlepiej zaś trafić na 'mądrego' co zamiast pisać o rozwiązaniu poleci 'najpierw czytać, potem pytać' ;D Ja np. odnalazłem info krok po kroku - jak przepis na zupę. Tyle, że nie działa. Ale to już drobiażdżek ;) Głowa do góry: rok, dwa i Ty będziesz newbie jechał na funty i kazał im 'najpierw czytać'. A tak na marginesie - jak znajdziesz sensowne (w sensie 'sensowne') info, to daj znać, pls. Pozdro Khaz

Offline Grzegorz L

  • Users
  • Guru
  • *****
  • Wiadomości: 594
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #6 dnia: 2005-06-16, 19:09:37 »
Dla posiadaczy kernela 2.6 polecam wylaczyc DRI w jadrze, bo gryzie sie to z fglrx. Zreszta obsluga DRI jest zawarta w sterownikach ati.

Offline Sebastian Kazimierski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 26
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #7 dnia: 2005-06-25, 21:51:47 »
2005-05-29 13:22:44 thecoreofdarknes napisał:

> Jak zainstalowaći skonfigurowac stery do ati.Z góry dzięki
Oto jak:
Wyobraź sobie, że po bardzo długich bojach udało mi się zainstalować sterowniki do mojej karty ATI - mam teraz wsparcie dla OpenGL. Jak udało mi się zdobyć info na ten temat? Po prostu NIE UDAŁO! Więc co zrobiłem? Naczytałem się wszelkich tipsów i przepisów na zupę, już byłem przekonany, że bez rekompilacji jajka się nie da, że, jeżeli już coś się zmienia ze sterami do grafy, to trzeba to robić w trybie tekstowym, itp. itd. No i co? Wszystko g. warte! Pomyślałem sobie: a czy ATI nie przygotowało gotowego rozwiązania do tak powszechnego problemu? No i poczytałem (zgodnie z zasadą 'najpierw czytać'). No i dotarłem do informacji o instalatorze sterów ATI: ładne zrzuty ekranu, wszystko pięknie, bez bólu - ściągnąłem rpm'a ze sterownikami a w przepisie było coś o pliku instalatora (ati-driver-installer-8.14.13.run). Tyle, że ja go nie miałem. Myślałem, że może jest zaszyty w rpm'ie. Szukam, szukam i nic. Więc wpisałem bezczelnie nazwę pliku do Googl'a i dostałem link. Google wskazał link do adresu: 'http://www2.ati.com/drivers/linux/ati-driver-installer-8.14.13.run'. Kliknąłem i zaczął mi ściągać ten plik - najpierw był tekst skryptu, potem krzaki - pomślałem 'binarki' i wkleiłem adres do KGet. Ściągnąłem plik 'ati-driver-installer-8.14.13.run' (32.5 MB) a wcześniej rpm'a ze sterami ('fglrx_6_8_0-8.14.13-1.i386.rpm' - w moim przypadku) - wszystko było w jednym katalogu. Zalogowałem się jako root - na wszelki wypadek (i chyba dobrze) i uruchomiłem plik. Odpalił się instalator jak w opisie ATI - bombastic. To było w sumie najprostrze. Po instalacji uruchomiłem tylko plik /usr/X11R6/bin/fglrxconfig w celu skonfigurowania sterownika (większość opcji wybrałem domyślnych). I to by było wszystko - sterownik gra i buczy. Ale musiałem sprawdzić. Odpaliłem na początek wygaszacz ekranu 'sztuczne ognie' bo on wykorzystuje OpenGL. Bez sterowników ATI się ciął. A teraz... Bajka. Dalej Chromium. Miodzio. I in. Jednym słowem DZIAŁA! Bez rekompilacji, bez zmiany runlevel'u. Bombastic! Więc w skrócie, jeszcze raz, przepis na zupę:
1. Ściągnąć sterowniki ATI (u mnie 'fglrx_6_8_0-8.14.13-1.i386.rpm').
2. Ściągnąć instalator 'ati-driver-installer-8.14.13.run' (przynajmniej jak dla mojej konfiguracji).
3. Zalogować się jako root.
4. Odpalić instalator (./ati-driver-installer-8.14.13.run).
5. Podziwiać ekrany jak na http://www2.ati.com/drivers/linux/linux_8.14.13-inst.html#176980.
6. Uruchomić /usr/X11R6/bin/fglrxconfig i skonfigurować driver.
7. Nie grać cały czas w gierki a z przerwami :D
I wszystko. Bez bólu i gładko.
Moja konfiguracja: Mandriva 2005 LE, Athlon 1,2 GHz, GeCube Radeon 9550 Speedy Edition.
Pozdro Khaz

Offline Wojciech Miłkowski

  • Global Moderator
  • Stały bywalec
  • *****
  • Wiadomości: 206
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #8 dnia: 2005-06-26, 13:08:10 »
2005-06-25 21:51:47 khaz napisał:

[...]

I brawo tak trzymać - grunt to inicjatywa!
Można się dużo nauczyć i być z siebie zadowolonym :)

Wojtek

Offline Maciek Kędzierski

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #9 dnia: 2005-07-13, 15:36:41 »
a ja, jak chce zainstalowac, to mi wywala "Permission denied" zalogowalem sie jako root i to samo. Pomozcie, bo ja totalny n00b
moja konfiguracja to:
Linux mandrake 10.0 offical, Athlon XP 2000+. 512 ram, Radeon 9550 SE

Offline marcin bortel

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 14
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #10 dnia: 2005-07-21, 22:40:14 »
ja mialem podobne przejscia do khaza, ale w moim przypadku nie jest tak rozowo, wlaczam gierke wygaszacz itd i wszystko chodzi... ale przerazliwie wolno :( help...

Offline max couler

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 24
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #11 dnia: 2005-07-23, 21:14:45 »
2005-07-13 15:36:41 kedziek napisa?:

> a ja, jak chce zainstalowac, to mi wywala "Permission denied" zalogowalem sie jako
 > root i to samo. Pomozcie, bo ja totalny n00b
 > moja konfiguracja to:
 > Linux mandrake 10.0 offical, Athlon XP 2000+. 512 ram, Radeon 9550 SE
Nadaj prawa plikowi- "chmod +x belebleblecostam.costam"

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 2
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #12 dnia: 2005-07-26, 08:50:16 »
2005-06-25 21:51:47 khaz napisał:

> 2005-05-29 13:22:44 thecoreofdarknes napisał:
 >
 > > Jak zainstalowaći skonfigurowac stery do ati.Z góry dzięki
 > Oto jak:
 > Wyobraź sobie, że po bardzo długich bojach udało mi się zainstalować sterowniki do mojej karty
 > ATI - mam teraz wsparcie dla OpenGL. Jak udało mi się zdobyć info na ten temat? Po prostu NIE
 > UDAŁO! Więc co zrobiłem? Naczytałem się wszelkich tipsów i przepisów na zupę, już byłem
 > przekonany, że bez rekompilacji jajka się nie da, że, jeżeli już coś się zmienia ze sterami do
 > grafy, to trzeba to robić w trybie tekstowym, itp. itd. No i co? Wszystko g. warte! Pomyślałem
 > sobie: a czy ATI nie przygotowało gotowego rozwiązania do tak powszechnego problemu? No i
 > poczytałem (zgodnie z zasadą 'najpierw czytać'). No i dotarłem do informacji o instalatorze
 > sterów ATI: ładne zrzuty ekranu, wszystko pięknie, bez bólu - ściągnąłem rpm'a ze sterownikami
 > a w przepisie było coś o pliku instalatora (ati-driver-installer-8.14.13.run). Tyle, że ja go
 > nie miałem. Myślałem, że może jest zaszyty w rpm'ie. Szukam, szukam i nic. Więc wpisałem
 > bezczelnie nazwę pliku do Googl'a i dostałem link. Google wskazał link do adresu:
 > 'http://www2.ati.com/drivers/linux/ati-driver-installer-8.14.13.run'. Kliknąłem i zaczął mi
 > ściągać ten plik - najpierw był tekst skryptu, potem krzaki - pomślałem 'binarki' i wkleiłem
 > adres do KGet. Ściągnąłem plik 'ati-driver-installer-8.14.13.run' (32.5 MB) a wcześniej rpm'a
 > ze sterami ('fglrx_6_8_0-8.14.13-1.i386.rpm' - w moim przypadku) - wszystko było w jednym
 > katalogu. Zalogowałem się jako root - na wszelki wypadek (i chyba dobrze) i uruchomiłem plik.
 > Odpalił się instalator jak w opisie ATI - bombastic. To było w sumie najprostrze. Po instalacji
 > uruchomiłem tylko plik /usr/X11R6/bin/fglrxconfig w celu skonfigurowania sterownika (większość
 > opcji wybrałem domyślnych). I to by było wszystko - sterownik gra i buczy. Ale musiałem
 > sprawdzić. Odpaliłem na początek wygaszacz ekranu 'sztuczne ognie' bo on wykorzystuje OpenGL.
 > Bez sterowników ATI się ciął. A teraz... Bajka. Dalej Chromium. Miodzio. I in. Jednym słowem
 > DZIAŁA! Bez rekompilacji, bez zmiany runlevel'u. Bombastic! Więc w skrócie, jeszcze raz,
 > przepis na zupę:
 > 1. Ściągnąć sterowniki ATI (u mnie 'fglrx_6_8_0-8.14.13-1.i386.rpm').
 > 2. Ściągnąć instalator 'ati-driver-installer-8.14.13.run' (przynajmniej jak dla mojej
 > konfiguracji).
 > 3. Zalogować się jako root.
 > 4. Odpalić instalator (./ati-driver-installer-8.14.13.run).
 > 5. Podziwiać ekrany jak na http://www2.ati.com/drivers/linux/linux_8.14.13-inst.html#176980.
 > 6. Uruchomić /usr/X11R6/bin/fglrxconfig i skonfigurować driver.
 > 7. Nie grać cały czas w gierki a z przerwami :D
 > I wszystko. Bez bólu i gładko.
 > Moja konfiguracja: Mandriva 2005 LE, Athlon 1,2 GHz, GeCube Radeon 9550 Speedy Edition.
 > Pozdro Khaz
Witam, zrobiłem jak napisałeś i jest problem bo mi sie te koorowe okna instalatora nie pojawiaja tylko w konsoli kilka pytań w ramkach na niebieskim tle, jak juz dobrne do końca zaczyna instalowac przesówa sie pasek stanu i na końcu error juz nawet nie pamietam jaki (Knoppix 3.9)


Offline Kyoji Bayer

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #13 dnia: 2005-08-05, 08:51:40 »
Wszystko zrobilem wedlug instrukcji khaza lecz nic to nie pomoglo nadal nie mam akceleracji a nie wiedziec czemu fglrxconfig nie wykrywa mojej karty zwraca nastepujacy komunikat po zapisywaniu xorg.conf:

Probing PCI bus for a supported graphics device...
unable to find any of the subsequent graphics boards:

         - ATI Radeon 8500 / 9100
         - ATI FireGL 8700 / 8800
         - ATI FireGL E1
         - ATI FireGL T2
         - ATI Radeon 9000
         - ATI Radeon 9200
         - ATI Radeon 9500
         - ATI Radeon 9600
         - ATI Radeon 9700
         - ATI Radeon 9800
         - ATI FireGL Z1 / X1 / X2
         - ATI FireGL V3100
         - ATI FireGL V5100
         - ATI FireGL V7100
         - ATI Mobility M9
         - ATI Mobility FireGL 9000
         - ATI Mobility M9PLUS

After starting X11, auto-detection will take place.

If you want to forcefully bind to a specific PCI bus slot at a later time
then you have to edit the fglrx-BusID entry in your xorg.conf file.

Czy to normalne? Karta po zainstalowaniu sterownikow nadal dziala na MESA nawet po zamianie parametru Option "UseInternalAGPGART" z "yes" na "no" nie ma zadnej poprawy. W ATi Control pisze Card name i Chip type, Unknow. Wie ktos jak moglbym uzyskac akceleracje w mojej karcie?
ATI Gigabyte R9550 128bit 128MR Ram @ Ubuntu 5.04 kernel 2.6.10

Offline Kyoji Bayer

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 16
    • Zobacz profil
INstalacja sterowników ati
« Odpowiedź #14 dnia: 2005-08-05, 09:11:21 »
Dodam jeszcze jak wyglada moj konfig (na terazniejsza chwile bo ciagle cos proboje dlubac):

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
   FontPath   "unix/:7100"         # local font server
   # if the local font server has problems, we can fall back on these
   FontPath   "/usr/lib/X11/fonts/misc"
   FontPath   "/usr/lib/X11/fonts/cyrillic"
   FontPath   "/usr/lib/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/lib/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/lib/X11/fonts/Type1"
   FontPath   "/usr/lib/X11/fonts/CID"
   FontPath   "/usr/lib/X11/fonts/100dpi"
   FontPath   "/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
   Load   "GLcore"
   Load   "bitmap"
   Load   "dbe"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "record"
   Load   "type1"
   Load   "vbe"
   SubSection "extmod"
       Option "omit xfree86-dga"
   EndSubSection
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "keyboard"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "pl"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
   Option      "ZAxisMapping"      "4 5"
EndSection

Section "Device"
   Identifier   "ATI Technologies, Inc. Radeon 9600 (RV350 AS)"
   Driver      "fglrx"
   BusID      "PCI:1:0:0"
   Option "VideoOverlay" "on"
   Option "OpenGLOverlay" "off"
   Option "UseInternalAGPGART" "no"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies, Inc. Radeon 9600 (RV350 AS)"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x1024" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
EndSection

Section "DRI"
   Mode   0666
EndSection

Jesli ktos moglby mi go poprawic chodzi tylko by miec wsparcie dla OpenGL gdyz nie wiedziec czemu co bym nie robic zawsze jest MESA a jak jeszcze do tego doloze config zrobiony fglrxconfig'iem to kompletna padaka (te trybiki do testow chodza kilka razy wolniej niz na tym xorg.conf co mam teraz)