Nowe posty

xx Migracja GRUB2 (0)
Wczoraj o 12:30:46
xx Przydatne Linki (4)
2019-08-23, 14:13:00
xx Awstat (0)
2019-08-22, 14:55:15
xx SMB - Access denied z Windows (9)
2019-08-19, 11:27:24
xx Kali Linux - książka. (0)
2019-08-19, 00:20:25
xx Arch - startx dla uruchomienia GNOME powoduje wyłączenie komputera (6)
2019-08-18, 14:37:04
xx Nie moge urchmomic laptopa - grub rescue. (1)
2019-08-17, 18:24:00
xx Po aktualizacji zniknęły niektóre funkcje (45)
2019-08-14, 06:39:01
xx Operacje na bitach. (4)
2019-08-10, 21:44:36
xx Pblem z montowaniem dysku sieciowego (1)
2019-08-09, 23:36:45

Autor Wątek: Ubuntu nie może zamontować partycji Windows i nie włącza się  (Przeczytany 5877 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 30
    • Zobacz profil
Witam serdecznie, mam problem z zamontowaniem jednej partycji Windows w Ubuntu 10.04 Gnome, przez co system nie chce się uruchomić.
Do automatycznego montowania używam aplikacji ntfs-config, no już zapomniałem jej nazwę z trybu graficznego. Coś tam Narzędzie konfiguracji dla trybu zapisu, yy jakoś tak, ale to nie ważne.
Na Windowsie 7 uczę się obsługi programu TrueCrypt. Kiedy pierwszy raz go użyłem, oczywiście przed tym zrobiłem sobie kopie zapasową danych. Po zaszyfrowaniu partycji nie systemowej tym programem, oczywiście nie można jej całkowicie odszyfrować bez sformatowania. Dobra, no więc od montowałem wolumen i sformatowałem, po czym wszystkie skopiowane wcześniej dane z tej partycji zgrałem na nią z powrotem.

Jednak teraz nie mogę uruchomić Linuksa. Jak niektórzy wiedzą, to aplikacja ntfs-config montuje partycje po dodaniu im odpowiednich ścieżek. Ja partycję D nazwałem partycjad i oczywiście jej lokalizacja jest następująca: /media/partycjad

Podczas uruchomienia Ubuntu na ekranie boot screen (logo Ubuntu gdzie jest ładowanie) jest napisane po angielsku (przetłumaczę na polski):

Nie można odczytać /media/partycjad lub napęd nie jest obecny.
Kontynuuj czekanie; albo naciśnij S, aby pominąć montowanie, lub M aby ręcznie przywrócić.

Czekałem z 3 godziny i nic się nie dzieje. Kiedy nacisnę S to system się wiesza, a jak M to włącza się terminal i nie wiem jakiego polecenia użyć.

W internecie jest mnóstwo poleceń do montowania, ale boję się, że coś bardziej namieszam. Przede wszystkim z tego względu, że do montowania użyłem ntfs-config i partycje Windows mają końcówkę ścieżki podaną przeze mnie.
Proszę o pomoc, nie chcę robić formatu Linuksa.

Offline kenpo

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 202
    • Zobacz profil
Ubuntu nie może zamontować partycji Windows i nie włącza się
« Odpowiedź #1 dnia: 2010-08-06, 18:17:26 »
Ja do montowania na linux używam pmount i nakładkę graficzną mount-gtk. Ale to raczej do płyt, czy bo z tym mam problemy. A do montowania partycji potrzebny jest wpis w fstab.

Jak się da uruchomić w jakimś trybie awaryjnym żebyś miał dostęp do konsoli możesz wpisać
gksudo gedit /etc/fstab
i zobaczyć czy jest tam wpis o tej partycji.

Przeczytaj:
http://manual.sidux.com/pl/part-uuid-pl.htm
http://www.tuxfiles.org/linuxhelp/fstab.html
http://newbie.linux.pl/wydruk.php?wydruk=234&show=artykul
http://ubuntuforums.org/showthread.php?t=283131
http://faq.pcformat.pl/index.php/Fstab
Są tam odpowiednie informacje o edycji fstab, przede wszystkim o dodaniu informacji o dysku/partycji wraz z informacją o jego UUID do fstab.

Jak się nie da od razu otworzyć możesz przeedytować albo uruchamiając z płyty instalacyjnej livecd - o ile poprawnie  zobaczy ci tą partycję, albo z płytki parted magic, gdzie są odpowiednie narzędzia.

Ja po formacie i zmianie systemu plików miałem podobną sytuację.

Offline roobal

  • Users
  • Guru
  • *****
  • Wiadomości: 2052
    • Zobacz profil
Ubuntu nie może zamontować partycji Windows i nie włącza się
« Odpowiedź #2 dnia: 2010-08-06, 22:48:20 »
Uruchom Ubuntu w trybie awaryjnym i w /etc/fstab usuń wpisy dotyczące tej partycji albo zmień na:

/dev/xxxx /media/partycjad ntfs rw 0 0
za /dev/xxxx podstawiasz odpowiednią partycję:

Uruchom ponownie komputer i zobacz czy system wstaje.

Pozdrawiam!

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 30
    • Zobacz profil
Ubuntu nie może zamontować partycji Windows i nie włącza się
« Odpowiedź #3 dnia: 2010-08-07, 14:22:38 »
Jak najbardziej, pomogło, a zrobiłem to bardziej na swój sposób, szybszy :P. Taka myśl mnie naszła, ponieważ ta metoda się nieraz sprawdza. Przed zastosowaniem zrobiłem kopię pliku fstab.
Wykasowałem mu wszystkie wpisy oprócz tych dotyczących partycji Linuksowej. System się uruchomił, ale nadal był błąd, partycje zamontowane nie chciały się od montować, nawet po restarcie. A więc musiałem włączyć ntfs-config i usunąć z niego te partycje które mu dodałem. Jeszcze dla pewności odinstalowałem ten programik.
Ponownie zajrzałem w plik fstab i stworzyły się wpisy z programu. Wywaliłem znowu oprócz Linuksowej partycji, przelogowałem się, zainstalowałem ntfs-config, ustawiłem od nowa sobie automatyczne montowanie i działa wszystko dobrze, również po restarcie :D.

Dziękuję bardzo :)