Nowe posty

Autor Wątek: cdrom zmienilem na kablu, jak teraz to skonfigurowac?  (Przeczytany 2417 razy)

^robert^

  • Gość
od jakeigos czesu zaczynam sie zalamywac...

chcialem cos tam nowego zainstalowac no i niby wszystko ok, ale pojawia sie pewien problem, nie maly. mam nowy package *.deb i podczas inst wyskakuje ze on zalezy od czegos, a ja mam starsza wersje... tak zwykle pare typow do update program mi podaje. no zaczynam updateowac te co sa podane i tam znowu po pare bibliotek/dupereli do updatu wyskakuje... no i tak chyba w nieskonczonocsc bedzie :( jest na to jakis sposob?

Pozdr,
Robert

kamikaze

  • Gość
cdrom zmienilem na kablu, jak teraz to skonfigurowac?
« Odpowiedź #1 dnia: 2005-10-06, 12:49:11 »
2005-10-06 12:30:30 ^robert^ napisał:

> od jakeigos czesu zaczynam sie zalamywac...
 >
 > chcialem cos tam nowego zainstalowac no i niby wszystko ok, ale pojawia sie pewien problem, nie
 > maly. mam nowy package *.deb i podczas inst wyskakuje ze on zalezy od czegos, a ja mam starsza
 > wersje... tak zwykle pare typow do update program mi podaje. no zaczynam updateowac te co sa
 > podane i tam znowu po pare bibliotek/dupereli do updatu wyskakuje... no i tak chyba w
 > nieskonczonocsc bedzie :( jest na to jakis sposob?
 >
 > Pozdr,
 > Robert

Użuj apt-get żeby zainstalować ten program. Apt rozwiązuje automatycznie zalezności uaktualniając lub doinstaliowując wymagane do instalacji paczki.

^robert^

  • Gość
cdrom zmienilem na kablu, jak teraz to skonfigurowac?
« Odpowiedź #2 dnia: 2005-10-06, 12:55:13 »
2005-10-06 12:49:11 kamikaze napisał:

> 2005-10-06 12:30:30 ^robert^ napisał:
 >
 > > od jakeigos czesu zaczynam sie zalamywac...
 >  >
 >  > chcialem cos tam nowego zainstalowac no i niby wszystko ok, ale pojawia sie pewien
 > problem, nie
 >  > maly. mam nowy package *.deb i podczas inst wyskakuje ze on zalezy od czegos, a ja mam
 > starsza
 >  > wersje... tak zwykle pare typow do update program mi podaje. no zaczynam updateowac te co
 > sa
 >  > podane i tam znowu po pare bibliotek/dupereli do updatu wyskakuje... no i tak chyba w
 >  > nieskonczonocsc bedzie :( jest na to jakis sposob?
 >  >
 >  > Pozdr,
 >  > Robert
 >
 > Użuj apt-get żeby zainstalować ten program. Apt rozwiązuje automatycznie zalezności
 > uaktualniając lub doinstaliowując wymagane do instalacji paczki.
 >



wiec uruchomilem apta chcac instalowac swierza mozille. pojaiwly sie bledy i program napisal zeby sprobowac to rozwiazac przez apt-get -f install. pojawilo sie to [cala operacja], ale wyglada koncowk agroznie. co robic?

root@box:/home/rob# apt-get install mozilla
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install\\' to correct these:
The following packages have unmet dependencies:
  gftp-gtk: Depends: libatk1.0-0 (>= 1.7.2) but 1.6.1-3 is to be installed
            Depends: libgtk2.0-0 (>= 2.6.0) but 2.4.4-2 is to be installed
            Depends: libpango1.0-0 (>= 1.8.1) but 1.4.1-1 is to be installed
            Depends: gftp-common (= 2.0.18-5) but it is not going to be installed
  gftp-text: Depends: gftp-common (= 2.0.18-5) but it is not going to be installed
  kmencoder: Depends: mplayer but it is not installable
             Depends: libpng3 but it is not going to be installed
             Depends: libqt3-mt (>= 2:3.0.5-1) but it is not going to be installed
  libapache-mod-ssl: Depends: apache-common (< 1.3.32) but 1.3.33-6sarge1 is to be installed
  libc6-dev: Depends: libc6 (= 2.3.2.ds1-16) but 2.3.2.ds1-22 is to be installed
  libexpat1-dev: Depends: libexpat1 (= 1.95.6-8) but 1.95.8-3 is to be installed
  libfontconfig1-dev: Depends: libfontconfig1 (= 2.2.3-1) but 2.3.1-2 is to be installed
  libglib2.0-data: Depends: libglib2.0-0 (= 2.4.6-1) but 2.6.4-1 is to be installed
  libglib2.0-dev: Depends: libglib2.0-0 (= 2.4.6-1) but 2.6.4-1 is to be installed
  libqt3-mt-dev: Depends: libqt3c102-mt (= 3:3.2.3-4) but 3:3.3.4-3 is to be installed
  libqt3c102-mt: Depends: libpng12-0 (>= 1.2.8rel) but 1.2.5.0-7 is to be installed
  libtse3-0.2.7: Depends: artsbuilder (>= 4:3.2.3) but it is not going to be installed
  libwine-print: Depends: libwine (= 0.0.20040615-1) but 0.0.20050310-1.1 is to be installed
  libwine-twain: Depends: libwine (= 0.0.20040615-1) but 0.0.20050310-1.1 is to be installed
  locales: Depends: glibc-2.3.2.ds1-16 but it is not installable
  mozilla: Depends: mozilla-browser (= 2:1.7.11-1) but 2:1.7.2-4 is to be installed
           Depends: mozilla-mailnews (= 2:1.7.11-1) but 2:1.7.2-4 is to be installed
           Depends: mozilla-psm (= 2:1.7.11-1) but 2:1.7.8-1sarge2 is to be installed
  mozilla-psm: Depends: mozilla-browser (= 2:1.7.8-1sarge2) but 2:1.7.2-4 is to be installed
  wine-utils: Depends: libwine (= 0.0.20040615-1) but 0.0.20050310-1.1 is to be installed
W: Couldn\\'t stat source package list http://ftp.de.debian.org ./ Packages (/var/lib/apt/lists/ftp.de.debian.org_debian_._Packages) - stat (2 No such file or directory)
W: Couldn\\'t stat source package list http://ftp.de.debian.org ./ Packages (/var/lib/apt/lists/ftp.de.debian.org_debian_._Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Unmet dependencies. Try \\'apt-get -f install\\' with no packages (or specify a solution).
root@box:/home/rob# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  artsbuilder gcc-4.0-base gftp gftp-common gftp-gtk gftp-text kdelibs-bin
  kdelibs-data kdelibs4 libapache-mod-ssl libarts1 libarts1-dev libartsc0
  libartsc0-dev libasound2 libasound2-dev libaspell15 libatk1.0-0 libc6
  libc6-dev libcupsys2 libcupsys2-gnutls10 libexpat1-dev libfontconfig1
  libfontconfig1-dev libgcc1 libglib2.0-0 libglib2.0-data libglib2.0-dev
  libgnutls12 libgpg-error-dev libgpg-error0 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libidn11 libidn11-dev libjack0.80.0-0 libjack0.80.0-dev
  libncurses5 libncurses5-dev libogg-dev libogg0 libopencdk8 libopenexr2
  libpango1.0-0 libpango1.0-common libpng12-0 libpng12-dev libpng3
  libqt3-compat-headers libqt3-headers libqt3-mt-dev libreadline5 libstdc++6
  libtasn1-2 libtasn1-2-dev libusb-0.1-4 libusb-dev libvorbis-dev libvorbis0a
  libvorbisenc2 libvorbisfile3 libwine libwine-print libwine-twain
  libxinerama1 libxml2 libxrender-dev libxrender1 libxslt1.1 linux-wlan-ng
  locales qt3-dev-tools render-dev wine wine-utils
Suggested packages:
  ca-certificates libapache-mod-ssl-doc libasound2-plugins alsa-base
  libasound2-doc aspell aspell-bin libglib2.0-doc gnutls-bin ttf-kochi-gothic
  ttf-kochi-mincho ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp
  ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp libqt3-i18n
  qt3-doc wine-doc libwine-gl msttcorefonts binfmt-support
Recommended packages:
  akode libatk1.0-data jackd linux-wlan-ng-doc linux-wlan-ng-0.2.2-modules
  apt-src
The following packages will be REMOVED:
  alsa-headers bluez-utils console-common console-data console-tools cupsys
  e2fsprogs euro-support-console ftape-util hostap-modules-2.4.27
  initrd-tools ipw2100-modules-2.4.27 ipw2100-modules-2.6.7 kdebase
  kdelibs4-dev kmencoder knoppix-terminalserver knx-installer libcupsys2-dev
  libgnutls10-dev libopencdk8-dev madwifi-modules-2.4.27
  madwifi-modules-2.6.7 modutils mozilla mozilla-psm nfs-common
  nfs-kernel-server nis sysvinit
The following NEW packages will be installed:
  artsbuilder gcc-4.0-base gftp-common libcupsys2 libgnutls12 libidn11-dev
  libjack0.80.0-0 libjack0.80.0-dev libopenexr2 libpng3 libreadline5
  libstdc++6 libxinerama1
The following held packages will be changed:
  kdelibs-data kdelibs4-dev libqt3-mt-dev
The following packages will be upgraded:
  gftp gftp-gtk gftp-text kdelibs-bin kdelibs-data kdelibs4 libapache-mod-ssl
  libarts1 libarts1-dev libartsc0 libartsc0-dev libasound2 libasound2-dev
  libaspell15 libatk1.0-0 libc6 libc6-dev libcupsys2-gnutls10 libexpat1-dev
  libfontconfig1 libfontconfig1-dev libgcc1 libglib2.0-0 libglib2.0-data
  libglib2.0-dev libgpg-error-dev libgpg-error0 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libidn11 libncurses5 libncurses5-dev libogg-dev libogg0
  libopencdk8 libpango1.0-0 libpango1.0-common libpng12-0 libpng12-dev
  libqt3-compat-headers libqt3-headers libqt3-mt-dev libtasn1-2
  libtasn1-2-dev libusb-0.1-4 libusb-dev libvorbis-dev libvorbis0a
  libvorbisenc2 libvorbisfile3 libwine libwine-print libwine-twain libxml2
  libxrender-dev libxrender1 libxslt1.1 linux-wlan-ng locales qt3-dev-tools
  render-dev wine wine-utils
WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
  e2fsprogs sysvinit
64 upgraded, 13 newly installed, 30 to remove and 862 not upgraded.
9 not fully installed or removed.
Need to get 68.3MB of archives.
After unpacking 880kB of additional disk space will be used.
You are about to do something potentially harmful
To continue type in the phrase \\'Yes, do as I say!\\'
 ?]

^robert^

  • Gość
cdrom zmienilem na kablu, jak teraz to skonfigurowac?
« Odpowiedź #3 dnia: 2005-10-06, 14:04:38 »
czy nikt nie potrafi mi pomoc ? :(

kamikaze

  • Gość
cdrom zmienilem na kablu, jak teraz to skonfigurowac?
« Odpowiedź #4 dnia: 2005-10-06, 16:50:10 »
2005-10-06 14:04:38 ^robert^ napisał:

> czy nikt nie potrafi mi pomoc ? :(

apt-get update daj najpierw. Albo naucz sie korzystać z apt. Skorzystaj z pomocy na debianusers.pl.

Rabarbar

  • Gość
cdrom zmienilem na kablu, jak teraz to skonfigurowac?
« Odpowiedź #5 dnia: 2005-10-06, 01:17:55 »
Tak jak w temacie. jak teraz mam skonfigurowac cdrom aby mozna bylo montowac?(obecnie nie moge gdyz go nie znajduje)
fstab:
/dev/cdrom   /mnt/cdrom     iso9660    noauto,owner,ro   0   0

difrost

  • Gość
cdrom zmienilem na kablu, jak teraz to skonfigurowac?
« Odpowiedź #6 dnia: 2005-10-06, 01:44:41 »
2005-10-06 01:17:55 Rabarbar napisał:

> Tak jak w temacie. jak teraz mam skonfigurowac cdrom aby mozna bylo montowac?(obecnie nie moge
 > gdyz go nie znajduje)
 > fstab:
 > /dev/cdrom   /mnt/cdrom     iso9660    noauto,owner,ro   0   0

Zmien dowiazanie w klatalogu /dev tak aby wskazywalo ono odpowiedni kanal do ktorego jest teraz podlaczony cdrom:
# cd /dev
# ln -sf hdx cdrom
gdzie: x =
a - primary master
b - primary slave
c - secondary master
d - secondary slave

POZDRAWIAM