Nowe posty

xx W Grubie nie pokazuje ubuntu (0)
2020-09-18, 15:49:34
question Połączenie się z OEL 8 >> MS SQL (0)
2020-09-16, 12:05:25
xx PORADNIK ! [Poszukiwanie bledow] (2)
2020-09-15, 08:24:56
xx Po instalacji minta i tak startuje windows ... (8)
2020-09-13, 00:48:13
xx DHCP i Virtualbox (2)
2020-09-08, 20:56:37
xx Brak macierzy RAID w Ubuntu (3)
2020-09-08, 19:10:24
xx Edycja plików w lokalizacji /sys/class/net/eth0/statistics (1)
2020-09-04, 08:43:34
xx ikona uruchamiająca (chyba) skrypt w ubuntu 16 (4)
2020-09-02, 22:57:36
xx Postfix (2)
2020-09-01, 18:58:16
xx Nie mogę naprawić dzwięku w Ubuntu 18.04 LTS (15)
2020-08-31, 22:48:26

Autor Wątek: apache2 virtualhosty - ucze sie  (Przeczytany 3203 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 4
    • Zobacz profil
apache2 virtualhosty - ucze sie
« dnia: 2010-04-11, 20:52:14 »
Co robie zle:

Zrobilem VirtualHosty

subdomena1 i subdomena2

I dziwo jest takie, ze co nie wpisze w przegladarce to wyskakuje ZAWSZE strona z subdomena2

Konfiguracja domyslna, zmienilem tak:

 cat /etc/apache2/sites-enabled/000-default


        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
       
                Options FollowSymLinks
                AllowOverride None
       

       
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
       


        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
       
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
       


        ErrorLog /var/log/apache2/error.log
        LogLevel warn
        CustomLog /var/log/apache2/access.log combined
    Alias /doc/ "/usr/share/doc/"
   
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
   





        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/katalog2/
       
                Options FollowSymLinks
                AllowOverride None
       

       
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
       


        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
       
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
       


        ErrorLog /var/log/apache2/error.log

        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
   
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
   





cat /etc/apache2/ports.conf

NameVirtualHost subdomena1.domena.pl:80
Listen 80


    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
---------------------
Proszę stosować znaczniki przy wklejaniu tego typu treści.
Inaczej będą się tworzyć "tasiemce", a chodzi przecież o poprawną czytelność.
W związku z powyższym poprawiłem post, wprowadzając znaczniki w edycji.
 - Lord Darius

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 19
    • Zobacz profil
apache2 virtualhosty - ucze sie
« Odpowiedź #1 dnia: 2010-04-13, 15:10:36 »
Wyszukiwanie dlaczego jest nie tak w tym bagienku to tragedia. Przykład konfiguracji dla jednego IP:
 NameVirtualHost 88.888.888.8

ServerAdmin admin@domena.net
DocumentRoot /var/www/str
ServerName str.domena.net
ServerAlias str.domena.net

        Options -Indexes FollowSymLinks
        AllowOverride NONe
        Order allow,deny
        Allow from all

Dodajesz analogiczny wpis dla każdej strony.
PS. Czasem ( a nawet często) łatwiej jest napisać konfiga krok po kroku niż wyszukać błąd przy X zbędnych wpisów.


---------------------
Proszę stosować znaczniki przy wklejaniu tego typu treści.
Inaczej będą się tworzyć "tasiemce", a chodzi przecież o poprawną czytelność.
W związku z powyższym poprawiłem post, wprowadzając znaczniki w edycji.
- Lord Darius

Offline Rafi X

  • Users
  • Guru
  • *****
  • Wiadomości: 758
  • Nie ufaj nikomu w internecie. Nawet mi..
    • Zobacz profil
    • Google+ / Tech
apache2 virtualhosty - ucze sie
« Odpowiedź #2 dnia: 2010-04-13, 18:29:16 »
Wersja skrócona każdego wpisu u mnie wygląda tak i działa

    ServerAdmin root@localhost
    DocumentRoot /var/www/html/domena.www/
    ServerName domena-local.pl
    ErrorLog /var/log/httpd/domena-local.pl
PC: AsRock, AMD FX-6300, 8GB DDR3, Palit GTX 680, SanDisk Ultra II 240GB, Seagate 500GB, openSUSE 42.1
Laptop: C2D T7300, 4GB DDR2, GeForce 8600 GS, Samsung 500 GB, openSUSE 42.1
Mobilnie: Moto G 1gen (Android 5.1), Lumia 625 (Windows 10), iPhone 4 (iOS 7.1.2), Nokia 6310i