Nowe posty

Autor Wątek: zmiana uprawnien. Redhat, centOS  (Przeczytany 12243 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
zmiana uprawnien. Redhat, centOS
« dnia: 2010-03-20, 17:33:44 »
Witam, Mam problem ze zmiana uprawnien plikow.
Mam centOS, system plikow reiserf.
loguje sie jako root,
polecenie
chmod 777 plik daje mi taka odpowiedz

chmod: changing permissions of `plik': Read-only file system

Jakeis sugestje?

Offline Robert

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2495
    • Zobacz profil
zmiana uprawnien. Redhat, centOS
« Odpowiedź #1 dnia: 2010-03-20, 18:30:19 »
Masz zamontowaną partycją w trybie odczytu [read only, w srócie ro], bez praw zapisu, dlatego system nie pozwala CI zmienić uprawnień do pliku.

Może to być spowodowane:
1. Parametrem ro w pliku /etc/fstab
2. Błędem systemu plików
Zanim popełnisz grafomaństwo: 1 | 2 | 3
Baza RPM Jak szukać informacji

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
zmiana uprawnien. Redhat, centOS
« Odpowiedź #2 dnia: 2010-03-20, 23:23:58 »
Mój plik fstab:
root@s1 [~]# cat /etc/fstab
#  
/dev/md3        /       reiserfs        defaults        1       2
/dev/md1        /boot   reiserfs        defaults        1       2
/dev/sda2       swap    swap    defaults        0       0
/dev/sdb2       swap    swap    defaults        0       0
proc            /proc   proc    defaults                0       0
sysfs           /sys    sysfs   defaults                0       0
tmpfs           /dev/shm        tmpfs   defaults        0       0
devpts          /dev/pts        devpts  defaults        0       0
/usr/tmpDSK             /tmp                    ext3    defaults,noauto        0 0

Jak można to rozwiązać? Proszę o podpowiedź i wyrozumiałość, nie zjeb*kę. Dopiero zaczynam zabawę z linuxem. Dziękuję z góry.

Offline Rafi X

  • Users
  • Guru
  • *****
  • Wiadomości: 758
  • Nie ufaj nikomu w internecie. Nawet mi..
    • Zobacz profil
    • Google+ / Tech
zmiana uprawnien. Redhat, centOS
« Odpowiedź #3 dnia: 2010-03-21, 10:04:32 »
I teraz pytanie gdzie leży ten plik, na jakiej partycji?

Oto przykład poniżej jak wymusić montowanie w trybie do odczytu i zapisu
/dev/md3 / reiserfs defaults,rw 1 2
PC: AsRock, AMD FX-6300, 8GB DDR3, Palit GTX 680, SanDisk Ultra II 240GB, Seagate 500GB, openSUSE 42.1
Laptop: C2D T7300, 4GB DDR2, GeForce 8600 GS, Samsung 500 GB, openSUSE 42.1
Mobilnie: Moto G 1gen (Android 5.1), Lumia 625 (Windows 10), iPhone 4 (iOS 7.1.2), Nokia 6310i

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
zmiana uprawnien. Redhat, centOS
« Odpowiedź #4 dnia: 2010-03-21, 11:45:46 »
Przy edycji pliku mam:
E45: 'readonly' option is set (add ! to override)

Offline Rafi X

  • Users
  • Guru
  • *****
  • Wiadomości: 758
  • Nie ufaj nikomu w internecie. Nawet mi..
    • Zobacz profil
    • Google+ / Tech
zmiana uprawnien. Redhat, centOS
« Odpowiedź #5 dnia: 2010-03-21, 13:36:34 »
Ta informacja to przy edycji fstab?
chmod o+w /etc/fstab
chown root.root  /etc/fstab
I tak z każdym plikiem konfiguracyjnym  - można też w miarę możliwości hurtowo to zrobić, tylko trzeba uważać.
PC: AsRock, AMD FX-6300, 8GB DDR3, Palit GTX 680, SanDisk Ultra II 240GB, Seagate 500GB, openSUSE 42.1
Laptop: C2D T7300, 4GB DDR2, GeForce 8600 GS, Samsung 500 GB, openSUSE 42.1
Mobilnie: Moto G 1gen (Android 5.1), Lumia 625 (Windows 10), iPhone 4 (iOS 7.1.2), Nokia 6310i

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
zmiana uprawnien. Redhat, centOS
« Odpowiedź #6 dnia: 2010-03-21, 16:07:18 »
Dostaje poniższe komunikaty:

root@s1 [~]# chmod o+w /etc/fstab
chmod: changing permissions of `/etc/fstab': Read-only file system
root@s1 [~]# chown root.root /etc/fstab
chown: changing ownership of `/etc/fstab': Read-only file system

moze uruchamia sie w init 1 zamiast init 3?

plik lilo.conf:
prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
lba32
append=""
#serial=0,9600n8

image=/boot/bzImage-2.6.32.2-xxxx-grs-ipv4-64
        label=linux
        read-only
        root=/dev/hda1

czy to "read-only" jest tu poprawnie umieszczone?

Offline Rafi X

  • Users
  • Guru
  • *****
  • Wiadomości: 758
  • Nie ufaj nikomu w internecie. Nawet mi..
    • Zobacz profil
    • Google+ / Tech
zmiana uprawnien. Redhat, centOS
« Odpowiedź #7 dnia: 2010-03-21, 19:32:31 »
Cytuj
czy to "read-only" jest tu poprawnie umieszczone?
tak

Heh, wychodzi na to że trzeba się wbić z zewnątrz tj. jakiegoś LiveCD i wyedytować plik jak wyżej podałem. A inna sprawa - czy ty czasem nie masz skompilowanego ReiserFS ale z opcją tylko do odczytu a nie do odczytu i zapisu?
PC: AsRock, AMD FX-6300, 8GB DDR3, Palit GTX 680, SanDisk Ultra II 240GB, Seagate 500GB, openSUSE 42.1
Laptop: C2D T7300, 4GB DDR2, GeForce 8600 GS, Samsung 500 GB, openSUSE 42.1
Mobilnie: Moto G 1gen (Android 5.1), Lumia 625 (Windows 10), iPhone 4 (iOS 7.1.2), Nokia 6310i

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 6
    • Zobacz profil
zmiana uprawnien. Redhat, centOS
« Odpowiedź #8 dnia: 2010-03-21, 23:31:47 »
Cytat: ra-v
A inna sprawa - czy ty czasem nie masz skompilowanego ReiserFS ale z opcją tylko do odczytu a nie do odczytu i zapisu
Nie wiem, jak mozna to sprawdzic i zmienic?

Online Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2473
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
    • Linuxpedia.PL
zmiana uprawnien. Redhat, centOS
« Odpowiedź #9 dnia: 2010-03-22, 17:40:48 »
/dev/mdXX to RAID-y. Jaką masz strukturę dysków? Błędy wyglądają tak, jakby samo urządzenie było tylko-do-odczytu (np w sytuacji rozjechanego mirrora).
Paweł Kraszewski
~Gentoo/FreeBSD/OpenBSD/Specjalizowane customy