Nowe posty

Autor Wątek: Kubuntu 9.10 - Open Office nagle przestał działać  (Przeczytany 3735 razy)

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 30
    • Zobacz profil
Kubuntu 9.10 - Open Office nagle przestał działać
« dnia: 2010-02-06, 22:48:39 »
Witam serdecznie.
Zainstalowałem Kubuntu, wszystko ok, inaczej się w ogóle na tym pracuje niż w GNOME i gdzie indziej są opcje. Ale obczaiłem już co nieco, jednak mam problem. Nagle z niczego sobie przestał mi działać Open Office. Gdy go włączam to nic się nie dzieje, nie pojawia się ten ekran początkowy ładowania itd. Pomiga tylko na pasku narzędzi przez 5 sekund i znika. Wszedłem w menedżer pakietów i usunąłem wszystko co związane z open office i zresetowałem komputer. Pobrałem z oficjalnjen strony open office dla Linuksa i zainstalowałem. Instalacja przebiegła bezbłędnie, jednak dalej się nie włącza.
Patrzyłem w monitorze systemu czy nie ma za wielu procesów Open office które mogłyby blokować, nic takiego nie zauważyłem.

Nie uruchamia się żaden OO, czy to Writer, Base, Draw, Math itd.

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
Kubuntu 9.10 - Open Office nagle przestał działać
« Odpowiedź #1 dnia: 2010-02-07, 00:02:01 »
Cytuj
You are upgrading from a version which might have corrupted
 service/component registry files (*.rdb), especially
 /var/lib/openoffice/basis3.1/program/services.rdb and the rdb files
 in /var/spool/openoffice/uno_packages/cache for installed extensions.
If you experience problems with the component manager or segmentation faults
 in either unopkg or OOo which involve store, please check those
 (and eventually cleanly reinstall the packages and/or use a clean user profile)
Dziś podczas aktualizacji dostałem mniej więcej taki tekścik. Nie sprawdzałem co stanie się z uruchomieniem OO, gdy usuniesz wymienione w /var pliki (po zrobieniu kopii) lub katalog z profilem użytkownika (~/.openoffice.org/). To czy odpalenie kończy się segfaultem, najłatwiej chyba sprawdzić, odpalając soffice z powłoki.
Użytkownik: Ib5sXfcCkvYR
Hasło: adam

Offline

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 30
    • Zobacz profil
Kubuntu 9.10 - Open Office nagle przestał działać
« Odpowiedź #2 dnia: 2010-02-07, 02:05:53 »
Dziękuję ci bardzo, wprawdzie nie zrobiłem tego co napisałeś, ale to mnie naprowadziło na dobry trop. Otóż po zastosowaniu twoich metod Open Office dalej nie działał. A więc pomyślałem sobie, a to wywalę wszystko. Zainstalowałem menedzer pakietów Synaptic i zaznaczyłem doszczętnie wszystko co związane z open office na status (zaznacz do całkowitego usunięcia, wraz z plikami konfiguracyjnymi). Po zakończeniu usuwania jeszcze włączyłem wyszukiwanie nazwy open office w całym systemie i resztki usunąłem, oczywiście oprócz czcionek itp.
Przelogowałem się, zainstalowałem na nowo i działa :).