Nowe posty

Autor Wątek: System halted  (Przeczytany 8217 razy)

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1162
    • Zobacz profil
System halted
« dnia: 2010-02-05, 13:26:37 »
Mandriva 2010, uruchamianie z Gruba.
Po ostatniej aktualizacji system nie wyłacza się.
Dokładnie niby słychać wyłączanie kompa, ale dysk działa nadal.
Po przejściu Esc nie widać żadnych procesów oprócz komunikatu "System halted".
Kombinowanie z ACPI nic nie wnosi.

Kiedyś miałem podobny problem, ale rozwiązałem go w Lilo.conf
Teraz nic to też nie wnosi.

Jakieś pomysły?

Pozdrawiam
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 432
    • Zobacz profil
System halted
« Odpowiedź #1 dnia: 2010-02-05, 18:15:43 »
Żeby to był chociaż pomarańczowy napis: "Można teraz bezpiecznie wyłączyć komputer"... Ale to?

Pamiętasz może, co mogło śmignąć w aktualizacjach? jakaś aktualizacja jądra? To może nie być problem stricte z ACPI, a np. z demonem...

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1162
    • Zobacz profil
System halted
« Odpowiedź #2 dnia: 2010-02-05, 18:58:05 »
Mówiąc szczerze też mi coś tym jajkiem zajeżdża ;)
Nie zwracałem uwagi na pakiety przy aktualizacji - mój błąd, ale z drugiej strony, czego miałem się obawiać? ;)
Pokombinuję jeszcze z tym.
Pozdrawiam
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

Brix

  • Gość
System halted
« Odpowiedź #3 dnia: 2010-02-06, 22:48:57 »
Jeżeli zaktualizowało się jądro, powinieneś mieć chyba dodane w grubie wpisy ze startem systemu na starszym jądrze... (przynajmniej dotąd tak było, bo jak na złość, może wreszcie dopiero jutro uda mi się zainstalować M2010 ;) ). A jak instalowałeś stery 3D, automatycznie czy ręcznie? (ręczna instalacja to bardzo popularna przyczyna niestartowania systemu po aktualizacji).

Edit: no chyba, że aktualizacja z pewnych przyczyn nie udała się, wtedy najprościej np. próbować zrobić "downgrade" z płyty i jeszcze raz zaktualizować...

Offline Lord Darius

  • Guru
  • *****
  • Wiadomości: 1162
    • Zobacz profil
System halted
« Odpowiedź #4 dnia: 2010-02-06, 23:14:50 »
Problem rozwiązany - jak dla mnie ;)
Zanim wyjaśnię jak to zrobiłem, odpowię na sugestię kolegi/ów

Co do wpisów w Grub-ie fakt istnieją starsze wersje jądra.
Jednak coś się tak popieprz&*o, ze efekt był taki sam dla wszystkich opcji.
3D konfigurowałem ręcznie - to fakt i być może miało to wpływ na całe te zamieszanie.

Jednak uparłem się, wychodząc z mojego założenia, że "Linux to Linux i nie ma bata" ;) i musi się on w końcu poddać logicznemu myśleniu.

Nie myliłem się ;)

Zdecydowałem wypierniczyć Gruba, a w jego miejsce dać Lilo.
Wymagało to jeszcze pewnych zmian i manipulacji w Lilo.conf, których nie każcie mi tu przytaczać ;), bo cały dzień przy tym kombinowałem, aż się udało i nie chcę już dłuzej się na tym rozwodzić.
Jak odpocznę to może wkleję tu następnym razem treść lilo, ale teraz to mnie muli jak miałbym go znowu otwierać ;)

Sumując:
Lilo okazuje się być bardziej elastycznym niż Grub i to w pełnym tego słowa znaczeniu.
System startuje i zamyka się bez najmniejszych problemów.

Dzięk wszystkimi za wskazówki.
Temat zamykam.

Pozdrawiam

p.s i dla bezpieczeństwa jadę nobecnie na starszym jajku ;)
Spójrz bez strachu na rzecz budzącą strach, a straszność sama zniknie.
cat /etc/debian_version

arctgx

  • Gość
System halted
« Odpowiedź #5 dnia: 2010-02-06, 23:48:35 »
Sam fakt, że użyłeś LILO, nie jest jeszcze logicznym wyjaśnieniem, mimo że po tym problem zniknął ;)

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 432
    • Zobacz profil
System halted
« Odpowiedź #6 dnia: 2010-02-07, 02:12:29 »
Pewnie chodziło o jakiś domyślny wpis w grubie, pozornie bez znaczenia...
Więc Lordzie, zbierz się w wolnej chwili do kupy, i zarzuć nas logami ;)