Nowe posty

xx Przy uploadzie przerywane są wszystkie połączenia (9)
2020-06-01, 20:13:01
xx Apache2 i twarde https (3)
2020-05-25, 15:53:43
xx Czy istnieje emulator terminala który zapamieta komendy na jakiejś liście? (9)
2020-05-23, 17:04:57
xx RTLinux wybór dystrybucji (0)
2020-05-23, 15:42:54
xx Problem z instalacją Ubuntu na bootowalnym pendrajwie (9)
2020-05-22, 15:08:12
xx Ubuntudde 20.04 LTS nie działa Lightdm (8)
2020-05-22, 09:16:42
xx [Gra za darmo] GTA5 (1)
2020-05-20, 21:49:26
xx Marketing (1)
2020-05-13, 08:00:41
xx Polecenia Debian (1)
2020-05-10, 19:58:54
xx Uruchamianie pliku z każdego katlogu (2)
2020-05-10, 19:23:33

Autor Wątek: Problem z Eclipse pod Linuxem  (Przeczytany 7328 razy)

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 268
    • Zobacz profil
Problem z Eclipse pod Linuxem
« dnia: 2010-02-02, 12:06:36 »
Witam

Mam problem z wyśmienitym środowiskiem IDE - Eclipse pod Ubuntu 9.10.

Mianowicie buttony nie działają właściwie. Np. Klikam sobie w nowy projekt, wybieram typ projektu klikam w Next i nic się nie dzieje. Dziwna sprawa bo, gdy najadę kursorem myszy na button to zachowuje się on tak jak bym go kliknął :/ ale zawartość okna się nie zmienia. Tak samo miałem z RadRails. Czy ktoś może ma, lub miał taki problem i wie jak to rozwiązać.

Byłbym wdzięczny. Wiem że pod takim dziwnym systemem operacyjnym aczkolwiek dość popularnym Eclipse działa normalnie. THX
jak podmontowac partycje, zeby pliki mialy 666, a nie 777 ?
a ty co, satanista?

http://www.java-bean.net

Offline Kamil Leduchowski

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 152
    • Zobacz profil
Problem z Eclipse pod Linuxem
« Odpowiedź #1 dnia: 2010-02-02, 13:07:28 »
Bug w wersji 3.5 eclipse, więcej tutaj : https://bugs.eclipse.org/bugs/show_bug.cgi?id=287307
Rozwiązaniem jest uruchomienie eclipse ze zmienną środowiskową GDK_NATIVE_WINDOWS=1, np. za pomocą skryptu :
#!/bin/sh
export GDK_NATIVE_WINDOWS=1
/home/kamil/eclipse/eclipse

Offline John Doe

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Problem z Eclipse pod Linuxem
« Odpowiedź #2 dnia: 2010-02-02, 23:04:26 »
Albo plik 'eclipse.sh' o takiej zawartości wrzuć do katalogu eclipsa i nim odpalaj

#!/bin/sh

export GDK_NATIVE_WINDOWS=1
`dirname $0`/eclipse