Nowe posty

xx Debian 9 Stretch, linuxcnc i restart przy uruchamianiu (2)
2019-10-19, 21:54:36
xx Zakup sprzętu bez preinstalowanego windowsa (8)
2019-10-17, 16:50:51
xx Problem z pocztą Dovecot+Postfix+MySQL (3)
2019-10-16, 14:43:41
xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
2019-10-15, 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36
xx Problem z instalacją sterowników TL-WN821N (4)
2019-10-11, 23:15:00
xx Sprzet z Linuxem (1)
2019-10-11, 10:06:24
xx nadpisanie partycji domowej (6)
2019-10-03, 03:27:28
xx Screen flickering Deepin (4)
2019-10-02, 20:32:56

Autor Wątek: Problem z Eclipse pod Linuxem  (Przeczytany 7230 razy)

Offline

  • Users
  • Prawie jak Guru
  • ****
  • Wiadomości: 268
    • Zobacz profil
Problem z Eclipse pod Linuxem
« dnia: 2010-02-02, 12:06:36 »
Witam

Mam problem z wyśmienitym środowiskiem IDE - Eclipse pod Ubuntu 9.10.

Mianowicie buttony nie działają właściwie. Np. Klikam sobie w nowy projekt, wybieram typ projektu klikam w Next i nic się nie dzieje. Dziwna sprawa bo, gdy najadę kursorem myszy na button to zachowuje się on tak jak bym go kliknął :/ ale zawartość okna się nie zmienia. Tak samo miałem z RadRails. Czy ktoś może ma, lub miał taki problem i wie jak to rozwiązać.

Byłbym wdzięczny. Wiem że pod takim dziwnym systemem operacyjnym aczkolwiek dość popularnym Eclipse działa normalnie. THX
jak podmontowac partycje, zeby pliki mialy 666, a nie 777 ?
a ty co, satanista?

http://www.java-bean.net

Offline Kamil Leduchowski

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 152
    • Zobacz profil
Problem z Eclipse pod Linuxem
« Odpowiedź #1 dnia: 2010-02-02, 13:07:28 »
Bug w wersji 3.5 eclipse, więcej tutaj : https://bugs.eclipse.org/bugs/show_bug.cgi?id=287307
Rozwiązaniem jest uruchomienie eclipse ze zmienną środowiskową GDK_NATIVE_WINDOWS=1, np. za pomocą skryptu :
#!/bin/sh
export GDK_NATIVE_WINDOWS=1
/home/kamil/eclipse/eclipse

Offline John Doe

  • Users
  • Nowy na forum
  • *
  • Wiadomości: 1
    • Zobacz profil
Problem z Eclipse pod Linuxem
« Odpowiedź #2 dnia: 2010-02-02, 23:04:26 »
Albo plik 'eclipse.sh' o takiej zawartości wrzuć do katalogu eclipsa i nim odpalaj

#!/bin/sh

export GDK_NATIVE_WINDOWS=1
`dirname $0`/eclipse