Nowe posty

xx Instalacja Debian10 problem z instalacją GRUBa na RAID5 (5)
Wczoraj o 17:58:57
xx AMD Ryzen 5 3500U (11)
2019-10-14, 18:29:46
xx Konfiguracja directadmina (0)
2019-10-13, 03:18:36
xx Problem z instalacją sterowników TL-WN821N (4)
2019-10-11, 23:15:00
xx Sprzet z Linuxem (1)
2019-10-11, 10:06:24
xx nadpisanie partycji domowej (6)
2019-10-03, 03:27:28
xx Screen flickering Deepin (4)
2019-10-02, 20:32:56
xx Pisanie bezpiecznych skryptow. (0)
2019-10-01, 19:42:01
xx Ciągle pojawiają się nowe wpisy w auth.log (1)
2019-09-27, 21:09:45
xx Pblem z montowaniem dysku sieciowego (3)
2019-09-22, 22:05:08

Autor Wątek: 2 sekundy w GRUB inaczej sie odliczają w 2 mieszkaniach  (Przeczytany 4419 razy)

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 129
    • Zobacz profil
Bardzo dziwna sprawa dotyczy komputera dosyć nowego (PC stacjonarny) na którym jest Windows XP + GRUB. Ustawiłem w GRUB 2 sekundy i domyślnie Windows XP. Jeżeli ten komputer stoi u mnie w mieszkaniu (tutaj wszystko instalowałem) to wszystko jest OK:

Włączam komputer, za chwilę pojawia się GRUB, widać go przez 2 sekundy, które ładnie się odliczają. Ponieważ Windows XP jest domyślnie zaznaczony więc po tych 2 sekundach uruchamia się właśnie on.

Tak jest u mnie w mieszkaniu. Natomiast po przeniesieniu tego komputera do mieszkania gdzie ma stać sytuacja wygląda identycznie jak u mnie z jednym wyjątkiem:

GRUB jedynie tylko mignie w trybie ekspresowym i od razu uruchamia się Windows XP. Jedyna sposobność uruchomienia Kubuntu to pełne skupienie przed i podczas wyświetlania napisu GRUB loading (czy jak to tam jest?) i szybkie naciskanie klawiszy strzałka do góry żeby załapał jeszcze przed menu.

Najpierw myślałem, że to coś mogło się namieszać poprzez jakąś paczkę i sprawdziłem menu GRUBa. Ale w pliku jest wszystko OK - 2 sekundy. Na razie zignorowaliśmy to bo nie miałem wtedy czasu na to. Ponieważ jednak Windows XP z jakiś względów zachowywał się mocno niestabilnie w związku z modułem sieci bezprzewodowej (na USB) zabrałem PC do siebie na kilka dni testów (bo to było losowe i nie chciałem tego testować u tej osoby). Zdziwiłem się, że u mnie GRUB się "sam naprawił" tzn. normalnie odliczał te 2 sekundy. Więc myślę sobie - kurcze co jest? No ale naprawiło się, to dobrze....i zapomniałem o tym. Po kilku dniach testów okazało się, że rzeczywiście ten moduł na USB losowo wykładał Windowsa. Zamontowaliśmy WiFi na PCI do środka komputera i zawieźliśmy go znowu do mieszkania właściciela PC. Podłączyłem kable, włączyłem komputer i co widzę? GRUB znowu w trybie ułamka sekundy sam akceptuje Windows XP i go uruchamia.

Spotkał się ktoś z was z czymś podobnym?

Offline mateo86

  • Users
  • Guru
  • *****
  • Wiadomości: 652
    • Zobacz profil
2 sekundy w GRUB inaczej sie odliczają w 2 mieszkaniach
« Odpowiedź #1 dnia: 2009-12-07, 10:53:33 »
Bierzesz cały komputer (tj. jednostka centralna, monitor, klawiatura itp.) Czy tylko samą jednostkę do swojego mieszkania?

Otóż jak bierzesz samą jednostkę to rozwiązanie jest bardzo proste: Monitor u tej osoby dłużej zmienia tryby graficzne niż u Ciebie. Dlatego Ty widzisz normalnie ekran GRUBA a w drugim mieszkaniu tylko on mignie. Daj jeszcze kilka sekund na wybór.

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 129
    • Zobacz profil
2 sekundy w GRUB inaczej sie odliczają w 2 mieszkaniach
« Odpowiedź #2 dnia: 2009-12-07, 15:54:29 »
Zgadza się. To kwestia monitora :) Wpisanie 5 sekund powoduje odliczanie od 3 sekundy.
Zasugerowałem się dodaniem KMS ale przecież ten komputer ma kartę GeForce a te nie maja tego jeszcze.

Temat można zamknąć.

Dzięki za podpowiedź/

Offline Rafi X

  • Users
  • Guru
  • *****
  • Wiadomości: 758
  • Nie ufaj nikomu w internecie. Nawet mi..
    • Zobacz profil
    • Google+ / Tech
2 sekundy w GRUB inaczej sie odliczają w 2 mieszkaniach
« Odpowiedź #3 dnia: 2009-12-07, 18:06:20 »
Ja mam 1 sekundę po której w >95% przypadkach odpalam Linuksa, i na zimnym monitorze CRT tylko słychać tykanie, że coś się przełącza, a obrazu nie widać. LCD mają gdzieś 0.5-2 sekundy reakcji i kalibracji obrazu więc przedziały są podobne, pewnie niezależne od temperatury monitora.
PC: AsRock, AMD FX-6300, 8GB DDR3, Palit GTX 680, SanDisk Ultra II 240GB, Seagate 500GB, openSUSE 42.1
Laptop: C2D T7300, 4GB DDR2, GeForce 8600 GS, Samsung 500 GB, openSUSE 42.1
Mobilnie: Moto G 1gen (Android 5.1), Lumia 625 (Windows 10), iPhone 4 (iOS 7.1.2), Nokia 6310i

Offline arctgx

  • Users
  • Guru
  • *****
  • Wiadomości: 2753
    • Zobacz profil
2 sekundy w GRUB inaczej sie odliczają w 2 mieszkaniach
« Odpowiedź #4 dnia: 2009-12-07, 20:20:01 »
Cytat: addos2
Zasugerowałem się dodaniem KMS ale przecież ten komputer ma kartę GeForce a te nie maja tego jeszcze.
KMS, z samej choćby definicji, jest obsługiwany przez jądro, a nie program rozruchowy ;).
Użytkownik: Ib5sXfcCkvYR
Hasło: adam

Offline ultr

  • Users
  • Guru
  • *****
  • Wiadomości: 1186
    • Zobacz profil
2 sekundy w GRUB inaczej sie odliczają w 2 mieszkaniach
« Odpowiedź #5 dnia: 2009-12-07, 23:25:33 »
Miałem podobny problem, ale monitorem nie da się go wyjaśnić :)

Mianowicie LILO w Debianie 3.0 na komputerku wbudowanym TS-5600 odlicza czas wielokrotnie szybciej niż powinien. Ale już zegar w systemie chodzi dobrze.

Ten sam system zainstalowany na VirtualBoxie działa całkowicie poprawnie.

Offline

  • Users
  • Stały bywalec
  • ***
  • Wiadomości: 129
    • Zobacz profil
2 sekundy w GRUB inaczej sie odliczają w 2 mieszkaniach
« Odpowiedź #6 dnia: 2009-12-08, 08:30:56 »
Hmmm.... czyli w moim przypadku problemem był monitor ale widzę, że niekoniecznie tak musi być w każdym przypadku.... dobrze wiedzieć w razie czego :)

Mój monitor jest podłączony złączem DVI i działa dosyć szybko przy przełączaniu. A tamten powolny podłączony jest przez D-SUB. Aha... tylko, że DVI to ja mam na swoim sprzęcie a używam LILO (Slackware) ale gdy podpinałem tamten komputer to podpiąłem go pod moje D-SUB - przełączam się wtedy w monitorze przyciskiem pomiędzy 2 komputerami... tak robię sprzęty innym czasami . To już nie wiem czy DVI / D-SUB ma jakieś znaczenie :)

KMS - no w sumie faktycznie ... nazwa mówi sama za siebie... nie skojarzyłem tego - dzięki za naprowadzenie mnie :)