Nowe posty

Autor Wątek: KDE 4.3.2 Problem z polską strefą czasową  (Przeczytany 8141 razy)

vckbarth

  • Gość
KDE 4.3.2 Problem z polską strefą czasową
« dnia: 2009-11-05, 20:24:54 »
Witam wszystkich znachorów :)

Od jakiegoś czasu borykam się z problemem poprawnego działania czasu systemowego.
W momencie ustawienia polskiej strefy czasowej (czas warszawski), zegar systemowy pokazuje 1 godzinę później niż jest w rzeczywistości (w czasie letnim przesunięcie sięga 2 h).
Posiadam dystrybucję Fedora w wersji po angielsku (ale oczywiście jest obsługa polskiego, polska klawiatura, strefa czasowa). Jeśli sztucznie przestawię godzinę na poprawną, to w biosie zostaje za bardzo cofnięta i wtedy w WinXp jest blędna wartość.
Do tej pory rozwiązaniem pośrednim okazało się być ustawienie strefy czasowej "Dakar" (wtedy nawet czas zimowy/letni działają poprawnie).

Jeśli ktoś wie co mam zrobić aby po ustawieniu polskiej strefy czasowej otrzymac poprawny czas systemowy (zimowy i letni) to proszę o informację.
Pozdrawiam.

Offline Paweł Kraszewski

  • Administrator
  • Guru
  • *****
  • Wiadomości: 2840
  • Lenistwo jest matką potrzeby = babcią wynalazku
    • Zobacz profil
KDE 4.3.2 Problem z polską strefą czasową
« Odpowiedź #1 dnia: 2009-11-05, 23:02:12 »
Rozwiązanie jest proste:
* Linux (tak jak większość systemów wywodzących się od serwerowych) spodziewa się, że zegar na płycie głównej pracuje w strefie UTC/GMT. Przy odczycie sprzętu uwzględniana jest strefa czasowa.
* Windows spodziewa się, że na płycie głównej zegar pokazuje czas lokalny.
Stąd przy przełączeniach WIndows-Linux występuje szamotanie zagara w przód i tył. Poszukaj w konfiguracji Fedory ustawienia nazywającego się mniej więcej "System clock/RTC in local timezone" i je włącz albo "System clock/RTC in UTC" i je wyłącz. Wtedy i Linux i Windows będą traktowały zegar na płycie jako lokalny.
Angielski przepis jest taki (nie mam Fedory, więc nie podam tłumaczenia):
Cytuj
Click on System --> Administration --> Date & Time, sign in as root --> clock comes up, click on Time Zone tab, then uncheck next to "System clock uses UTC", then click on OK and everything should be fine.
Paweł Kraszewski
~Arch/Void/Gentoo/FreeBSD/OpenBSD/Specjalizowane customy

ra-v

  • Gość
KDE 4.3.2 Problem z polską strefą czasową
« Odpowiedź #2 dnia: 2009-11-08, 02:10:36 »
We Fedorze były cyrki z tym czasem.

Niestety nie pamiętam co która opcja powodowała - wyłączenie "System clock/RTC in UTC" powodowało że co uruchomienie linuksa dodawał mi godzinę a włączenie tej opcji powodowało to co pisze @vckbarth  - lub odwrotnie (wolałem wybrać wariant przesunięcia godziny w WInXP.

Teraz mam W7 i FC10  - problem ten nie występuje.