Nowe posty

Autor Wątek: 2.6.13.2 i IP_CONNTRACK  (Przeczytany 9968 razy)

s4

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #15 dnia: 2005-09-27, 22:43:39 »
2005-09-27 22:24:28 xis napisał:

> Jeśli masz zintegrowaną kartę muz.
> na płycie, to zadbaj o jej wyłączenie w biosie - byc może cały galimatias przez to, że się gryzą.
> Inne pytanie: czy masz alsamixer?

1. kartę mam wyłączoną w BIOSie od lat,
2. nie mam alsamixera.

xis

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #16 dnia: 2005-09-27, 22:52:34 »
Ok. Zatem nasz jedyny problem to brak urządzenia w katalogu /dev.
Na stronie http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Creative+Labs&card=Sound+Blaster+Audigy2+ZS+Value.&chip=CA0108&module=emu10k1 w komentarzach użytkowników znalazłem podobny problem do Twojego; tam użytkownik fedory poradził sobie uruchamiając skrypt snddevices dodawany do ALSY (powinieneś znaleźć go w katalogu z alsa-driver).
Po prostu wejdź (jako root) do /usr/src/alsa-driver- i wklep:
./snddevices

Po tym mikser powinien znaleźć kartę muzyczną (jesli używasz miksera graficznego w KDE, albo w Gnome, to pomóc może restart środowiska - przeloguj się).

Jak to nie zadziała to ja już nie wiem :)
Powodzenia

s4

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #17 dnia: 2005-09-27, 23:10:07 »
2005-09-27 22:52:34 xis napisał:

 > Po prostu wejdź (jako root) do /usr/src/alsa-driver- i wklep:
 > ./snddevices
 >
 > Po tym mikser powinien znaleźć kartę muzyczną (jesli używasz miksera graficznego w KDE, albo w
 > Gnome, to pomóc może restart środowiska - przeloguj się).
 >
 > Jak to nie zadziała to ja już nie wiem :)
 > Powodzenia

rezultat:

./snddevices
Creating /dev/mixer?... done
Creating /dev/sequencer... done
Creating /dev/midi0?... done
Creating /dev/dsp?... done
Creating /dev/audio?... done
Creating /dev/sndstat... done
Creating /dev/music... done
Creating /dev/dmmidi?... done
Creating /dev/dmfm?... done
Creating /dev/amixer?... done
Creating /dev/adsp?... done
Creating /dev/amidi?... done
Creating /dev/admmidi?... done
tworzenie dowiązania symbolicznego `/dev/mixer\\' do `/dev/mixer0\\'
tworzenie dowiązania symbolicznego `/dev/midi\\' do `/dev/midi00\\'
tworzenie dowiązania symbolicznego `/dev/dsp\\' do `/dev/dsp0\\'
tworzenie dowiązania symbolicznego `/dev/audio\\' do `/dev/audio0\\'
tworzenie dowiązania symbolicznego `/dev/sequencer2\\' do `/dev/music\\'
tworzenie dowiązania symbolicznego `/dev/adsp\\' do `/dev/adsp0\\'
tworzenie dowiązania symbolicznego `/dev/amidi\\' do `/dev/amidi0\\'
rm: nie można usunąć `/dev/snd\\': Jest katalogiem
Creating /dev/snd/control?... done
Creating /dev/snd/seq... done
Creating /dev/snd/timer... done
Creating /dev/snd/hw??... done
Creating /dev/snd/midi??... done
Creating /dev/snd/pcm??p... done
Creating /dev/snd/pcm??c... done
ALSA loader devices
Creating /dev/aload?... done
Creating /dev/aloadSEQ... done


następnie z ciekawości sprawdziłem, czy mogę uruchomić alsamixer i zobaczyłem coś takiego:
alsamixer: function snd_ctl_open failed for default: No such device

s4

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #18 dnia: 2005-09-27, 23:15:08 »
dorzucam jeszcze skrina tego błędu:

http://img275.imageshack.us/img275/25/blad7ba.jpg

xis

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #19 dnia: 2005-09-27, 23:31:06 »
Przyznam się, że teraz nie mam pomysłu co może być nie tak :(
Mogę jedynie powiedzieć co ja bym zrobił na Twoim miejscu:
Zrestartowałbym komputer, żeby \\'oczyścić\\' go z załadowanych modułów itd. (restart wydaje się bys najprostszym wyjściem).
Następnie - posługując się informacjami na stronie http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Creative+Labs&card=Sound+Blaster+Audigy2+ZS+Value.&chip=CA0108&module=emu10k1 wykonywałbym wszystkie czynności poza kompilacją i instalacją sterownika (który de facto jest już w Twoim systemie). Czyli ignorowałbym wszystkie bloczki zaczynające się od \\'./configure\\', a kończące się na \\'make install\\'. Resztę czynności wykonywałbym dokładnie w tej kolejności, jaka jest tam opisana.
Dopiero po tym konfrontowałbym efekty z komentarzami użytkowników (które i tak warto wziąć pod rozwagę już w trakcie instalacji).

Jesli problem się powtórzy, to niestety chyba zostaje google i grzebanie...

W każdym razie powodzenia

s4

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #20 dnia: 2005-11-20, 13:38:10 »
na początek chciałem podziękować za pomoc, dobrze było być przywitanym w tym stylu :)

dzięki także za zainteresowanie i chociaż nie rozwiązałem wówczas problemu, teraz mam wreszcie moje ubuntu i dźwięk płynący z głośników :)

co zrobiłem? posadziłem ubuntu 5.10 (zamówiłem sobie nowe płytki ;)) i tyle :) ALSA sama zastartowała bez zająknięcia.

czas odkrywać linuksa i rozkoszować się dźwiękiem :)

pozdrawiam!

llol

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #21 dnia: 2005-09-25, 18:20:39 »
Zainstalowalem kernel 2.6.13.2. Wszystko by bylo dobrze, gdyby nie to, ze nie moge znalezc m.in. modulu ip_conntrack... Dla pewnosci podczas kompilacji pozaznaczalem praktycznie wszystko, co odnosi sie do netfilter etc. Mimo to bez skutku:( Wie ktos moze w jaki sposob zalatwic sprawe modulow netfilter?

amdfanatyk

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #22 dnia: 2005-09-25, 18:44:52 »
moze wkompilowales w kernel albo nie dales make modules_install, chociaz wtedy nie powinno wystartowac jajo.

maciasz

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #23 dnia: 2005-09-25, 19:13:12 »
2005-09-25 18:44:52 amdfanatyk napisał:

> chociaz wtedy nie powinno wystartowac jajo.

jajo wystaruje ale bedzie duuuuzo bledow :]

llol

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #24 dnia: 2005-09-25, 20:18:23 »
2005-09-25 19:13:12 maciasz napisał:

> 2005-09-25 18:44:52 amdfanatyk napisał:
 >
 > > chociaz wtedy nie powinno wystartowac jajo.
 >
 > jajo wystaruje ale bedzie duuuuzo bledow :]

Nie jestem pewny, ale chyba wkompilowalem w jajko:) A czy to robi jakas roznice? I mam takie pytanie - czy w takich sytuacjach nie wykorzystuje sie jakichs patchy tak jak w przypadku kernela 2.4?

llol

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #25 dnia: 2005-09-25, 20:19:44 »
Aaa i na koniec wpisalem make modules_install po czym make install :)

amdfanatyk

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #26 dnia: 2005-09-25, 20:48:13 »
robi taka, ze kernel jest wiekszy i nie masz tego jako modul; pytania o pacze nie rozumiem.

llol

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #27 dnia: 2005-09-25, 21:14:13 »
2005-09-25 20:48:13 amdfanatyk napisał:

> robi taka, ze kernel jest wiekszy i nie masz tego jako modul; pytania o pacze nie rozumiem.
 >

llol

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #28 dnia: 2005-09-25, 21:17:25 »
Skoro wspomniales o wkompilowaniu modulow, myslalem, ze w tym problem. A jesli chodzi o patchowanie, to np. to: http://newbie.linux.pl/?id=article&kategoria=4&show=247  ... nie znam sie zbytnio na tym, bo wlasnie niedawno rozpoczalem zabawe z kompilacja jajka

amdfanatyk

  • Gość
2.6.13.2 i IP_CONNTRACK
« Odpowiedź #29 dnia: 2005-09-25, 21:37:25 »
pacze poprawiaja bledy i/lub dodaja nowa funkcjonalnosc.